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Chapter 1: About the Sage Construction 
Management Integration Guide

If you use Sage Construction Management, you can transfer estimate information directly into your job costing 
application. This enables you to access budget and transaction data without reentering the information. This 
guide covers the interface between Sage Estimating and Sage Construction Management Job Cost, which 
enables the information transfer.

Read the Supporting Documentation Before You Begin
 l The Installation and Administration Guide includes an overview of this release, installation instructions, 

system requirements, and contact information.

 l The Release Notes  provide details about new features, database changes, known issues, and fixes. 

 l The Getting Started Guide provides an operational overview of the Sage Estimating software. 

 l The SQL Server Guide gives you an overview of the significant differences between the new 
SQL Server databases and the Pervasive databases used in previous Sage Estimating releases. 

Conventions Used in this Guide
This guide uses the following conventions:

 l Information you type into the software is shown in bold font. For example: Type Miscellaneous in the 
box.

 l The names of screens, windows, fields, and other features displayed by the software are shown in bold 
font.

 l Names of keys are also shown in bold font. For example: Enter or Tab. A plus sign (+) between two key 
names indicates you should press the keys simultaneously.

 l The names of buttons you can click are shown in bold font and enclosed in brackets. For example: [OK] 
or [Post].

 l Variable names or names that are specific to your installation may appear in italics and brackets. For 
example: [Drive]\\[Server].

Menu Paths

In this document, menu paths show you the steps required to start a task. Menu paths appear in bold font with 
square brackets around buttons. For example:
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"If the program does not automatically start, click [Start] > Run."

Need help?
Use Sage Estimating Help or a variety of self-help resources to get answers to your questions. 

The Help System

Sage Estimating Help provides more efficient access to information than most manuals. With a click of the 
mouse or a keystroke, you can easily get Help for a command, a field, a window, or a procedure.

Sage Estimating displays Help in your default browser. If you have an Internet connection, it displays the most 
current Help for your version of Sage Estimating from the Sage Estimating Help website. If you have no 
connection (you are working offline), it displays Help that was current when the software was released and 
installed on your computer when you install Sage Estimating.

Important!  Because the Microsoft Edge browser does not display locally installed help properly, we 
recommend that you select a different default when working offline.

To get Help on a window option

To display Help for an option in a window, do one of the following:

 l Click  What's This? on the toolbar or on the title bar, and then click the option.

 l Select What’s This? from the Help menu, and then click the option.

 l Select the option, and then press F1.

To get Help for the whole window

For information about the window, such as the window's purpose and what tasks you can perform in it, click 
[Help] at the bottom of the window.

To use Help to learn how to do tasks

 1.  Click [Help] on the toolbar, or select the Home tab > Help group > Help (or select Help menu > Help 
topics in classic view). 
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The Help Window

 2. Use the navigation pane to begin looking for a topic. 

 l Help subjects are organized under headings. Select the heading for the type of task you want to 
perform to view a list of topics.

When you see the topic you want, double-click it to display it.

 l Select the Glossary heading to view an alphabetical list of definitions of terms used throughout the 
Sage Estimating software.

 3. Use the Search box to find articles that match the keywords you enter.

Additional self-help resources

The Help menu available from on the ribbon also provides convenient links to a variety of self-help resources.

 The Help menu in Ribbon view
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Get help by: Recommendation* To access:

Reading product 
documentation  

View documents and reference material from the 
Estimating Product Documents website.   

Visit the Sage Estimating 
Product Documents page.

Searching the 
Knowledgebase

Search the Sage Knowledgebase, which provides 
24/7 access to support articles as well as the latest 
software downloads and updates.

Visit the Knowledgebase at 
Sage Knowledgebase.

Asking the 
community

Join industry peers, certified partners, and Sage 
pros online 24/7 at the Sage Community Hub—the 
best place to ask questions and share product 
experiences, tips, and tricks.

Visit the Sage Estimating 
General Discussion forum.

Checking the 
latest product 
alerts

Keep up with the latest product information with 
Sage Estimating Announcements at the Sage 
Community Hub forum.

See Sage Estimating 
Announcements.

Submitting a 
web ticket 

Submit your issue directly to our support team using 
Online Case submission.

Visit the Sage Customer Portal.

Exploring 
training options

Learn how to harness the full power of your software 
through videos and classes at Sage University.

Visit Sage University.
You can also get access to Sage 
University from the Estimating 
File menu by selecting Help  > 
Sage University.

* Customer Service hours vary by product line. Access to some resources require an active Sage 
Business Care support plan.

How to Get Additional Help
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Submitting Enhancement Requests
We want to hear your suggestions for improving the software. To send us your comments, click the File menu 
button  and then select Help >  Submit Product Idea.
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Sage Construction Management Integration Guide

Chapter 2: Sage Construction 
Management Integration

If you use Sage Construction Management, you can export estimates directly from Sage Estimating to a 
lead in that program, where you can work with the estimate without having to reenter or import the 
information.  

Overview   
There are 2 parts to the integration process:

 1. Setup in Sage Construction Management. You need to perform some setup steps in  Sage 
Construction Management before you can select integration settings for a standard database or 
an estimate in Sage Estimating.

 2. Setup in Sage Estimating. With setup information from Sage Construction Management, you 
integrate an estimate or a standard database with a Sage Construction Management account.

Note: This guide covers the interface between Sage Estimating and Sage Construction 
Management, which enables the information transfer. For detailed information about Sage 
Construction Management, see theSage Construction Management in-product Help.

Setting up the integration with  Sage Construction 
Management  
To help ensure a smooth data transfer between Sage Estimating and Sage Construction Management, 
follow the guidelines in this section.

Setting up the integration in Sage Construction Management

Before you start:

 l Make sure you have administrator permission in Sage Construction Management.

 l Sage Estimating sends estimates to a target lead or project in Sage Construction Management. 
If the leads to which you will send estimates do not exist in Sage Construction Management, add 
them. (To find out about setting up leads, see Add a lead manually in the Sage Construction 
Management help.)
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Chapter 2

In Sage Construction Management:

 1. Sign into Sage Construction Management as an Admin.

 2. Select the Settings icon .

 3. On the Settings panel, select Developer Mode.

 4. On the Developer Mode Settings page, do the following:

 a. For the Do you wish to use developer mode option, select Yes. 

 b. Click [Save].

 c. Refresh the page by selecting Return to the Application, and then re-enter the Developer 
Mode Settings page, where the developer options will now be visible.

 d. Copy the following numbers and paste them into a text document: 

 l Account Key

 l Integration Key/Client Id

 e. Select [Add New Apps and Keys], and then fill in the Add Apps and Integration Keys page, 
as follows:

 i. For the App Name, enter Sage Estimating.

 ii. In the Select Features section, select:

 l Leads

 l Projects

 l Estimates

 l Job Cost Codes

 iii. For the Authentication Type, select Client Credentials.

Sage Construction Management generates a secret key.

 iv. Copy the Secret Key immediately and paste it into the same text document where 
you pasted the other keys. 

Important! Do not select [Save] or leave this page before copying and pasting this 
number. The secret key is only visible once—ensure it is securely stored for all 
users who will need it. It will not be available again!

 v. Store the text document where you recorded the keys in a secure, accessible 
location for all estimators, as it will be needed for future sign-ins. 

 f. In the Scopes section, select Add, Edit, and Read.
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Sage Construction Management Integration Guide

 g. For the State, type Sage.

 h. Select [Save].

Setting up the integration in Sage Estimating 
You can integrate a standard database or an individual estimate with Sage Construction Management.

These instructions describe how to integrate a standard database. To integrate an estimate, you use the 
Estimate Information window and follow the same steps, except that you can also identify a lead from 
Sage Construction Management, as indicated.

Before you start

Make sure you have the Account Id, Integration Key, and Client Secret key you copied from Sage 
Construction Management handy.

To integrate a standard database:

 1. In the Estimating Management Console, click the Standard Databases tab.

 2. From the list in the Standard Database Catalog pane, select the standard database you want to 
integrate with Sage Construction Management.

 3. In the  Job Cost Information section of the detail pane, select Sage Construction Management as 
the job cost interface .

 4. Click [Setup] to open the Sage Construction Management Sign in window.

 5. In the Sign in window:

 a. Enter the Account Id, Integration Key, and Client Secret key.

 b. Select Save sign-in information, so that you do not have to keep entering this information 
when connecting to Sage Construction Management

 c. Click [Sign in].

The  Job Cost Integrator window opens.

Note: Sage CM Cost Types are preselected for each Labor, Material, Subcontractor, Equipment, 
and Other category in Sage Estimating. You will need to map these cost types to each item in 
your estimates before exporting the estimates.

 6. In the Sage Construction ManagementIntegration window: 
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Chapter 2

 a. To add Sage Construction Management cost type information automatically to existing 
items in your standard database, select the Add   cost types to items checkbox. You only 
need to do this once for each standard database you integrate.

Tip: This step can save you time when you match items to Sage Construction 
Management cost types in your standard database.

 b. Click [OK] to return to the Estimating Management Console.

 7. If you are integrating an estimate, rather than a standard database:

 a. Click the [Browse] button for the Job Number.

 b. Select the lead or project to which you will send the estimate. 

 c. Click [OK].

 8. Click [Save].
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Chapter 3: Exporting Data to Sage 
Construction Management 

After performing the integration steps in Sage Construction Management and Sage Estimating, you can export 
an estimate to Sage Construction Management as a Lead.

When you export an estimate to Sage Construction Management, each exported line includes the description, 
unit, and quantity, which you map when you set up the integration. Any item amounts not assigned to a job cost 
category and job cost code are not exported to Sage Construction Management. 

Note: Addons are exported as a single consolidated line to Sage Construction Management and only 
addons with assigned cost codes and categories are exported.

Before you start

For the estimate you plan to export:

 1. In the Estimate Information window, make sure the estimate is integrated with Sage Construction 
Management. (If you integrated the open standard database, the estimate will be integrated by 
default.) 

 2. Assign a lead to the estimate, if one is not already assigned. Use the Job Number Browse button to 
open a list where you can select a  lead from Sage Construction Management.

 3. In the estimate spreadsheet, if the current layout does not already include them, display the job cost 
categories and job cost phases for each estimating cost code. Then, make sure that a job cost 
category and job cost phase have been assigned to each cost code for which the estimate has an 
amount. (Note that Estimating exports cost codes as phases to Sage Construction Management.)

To assign a job cost category from Sage Construction Management to an item:

On the estimate item line, in the select job cost category column (for example, Sub JC Cat), select the 
ellipsis icon , select the appropriate Cost Type ID from the list of Sage Construction Management Cost 
Type IDs, and then click [OK]..

To assign a job cost phase from Sage Construction Management to an item:

On the estimate item line, in the select job cost phase column, select the ellipsis icon , select the 
appropriate Cost Type ID from the list of Sage Construction Management Cost Code Types, and then click 
[OK]..
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To export estimate data to Sage Construction Management:

 1. In Sage Estimating, on the Advanced tab, select Export to Sage CM. 

 2. On the introductory screen of the Sage Construction Management Export wizard, click [Next].

 3. Enter lead and estimate information.

 a. Beside the Lead # field, select the list icon, and then select a lead.

 b. In the Estimate # field, type the code to identify the estimate in Sage Construction Management.

 c. In the Estimate Title field, type a unique name for the estimate. 

 d. Click [Next].

 4. In the Rounding Options screen, if you want to round quantities, select Round Accumulated Item 
Quantities, and then click [Next]..

 5. Optionally, specify a destination for the export report, and then click [Finish].
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