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Introduction

Sage welcomes you to Sage Estimating.

Read the supporting documentation carefully to make sure you understand the process before you install and
configure Sage Estimating.

This Installation and Administration Guide includes a system overview, installation and configuration
instructions, and information about managing your Sage Estimating license.

The Release Notes provide details about new features, database changes, known issues, and fixes.
The Getting Started Guide provides an operational overview of the Sage Estimating software.

The SQL Server Guide gives you an overview of the significant differences between the SQL Server
databases and the Pervasive databases used in previous Sage Estimating releases.

The Sage 100 Contractor Integration Guide describes how to integrate Sage Estimating with Sage 100
Contractor, making certain data in that program available in Sage Estimating, and it explains how to use
the interface wizards to send proposals, budgets, and change orders you create in Sage Estimating to
Sage 100 Contractor.

The Sage 300 Job Cost Integration Guide provides installation, setup, and operating instructions for Sage
300 Job Cost integration.

The Means Integration Guide provides installation, setup, and operating instructions for Means
Integrator.

The On-Screen Takeoff Integration Guide provides installation, setup, and operating instructions for Sage
300 Construction and Real Estate.

Notes:

« For current information about supported operating systems, Internet browsers, Microsoft®
SQL Server®, and other software, and about system requirements for servers and client
workstations, refer to our Knowledgebase article System Requirements for Estimating v25.1.The
system requirements are the minimum for a computer running Estimating with one SQL Server
instance. Running several other business programs with multiple SQL Server instances may
affect the performance of your system.

« Documentation for all supported versions of Sage Estimating (SQL) is available at
http://cdn.na.sage.com/Docs/en/customer/estimating/Documentation.htm.

« Documentation for all supported versions of Sage 100 Contractor is available at
http://cdn.na.sage.com/docs/en/customer/100contractor/Documentation.htm.
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Conventions Used in this Guide

This guide uses the following conventions:

 Information you type into the software is shown in bold font. For example: Type Miscellaneous in the
box.

e The names of screens, windows, fields, and other features displayed by the software are shown in bold
font.

» Names of keys are also shown in bold font. For example: Enter or Tab. A plus sign (+) between two key
names indicates you should press the keys simultaneously.

e The names of buttons you can click are shown in bold font and enclosed in brackets. For example: [OK]
or [Post].

» Variable names or names that are specific to your installation may appear in italics and brackets. For
example: [Drive]\[Serven.

Notes, Tips, and Cautions

. Note: A Note indicates that the information supplements the adjacent text.

. Tip: A Tip indicates helpful points about using the software.

. Caution! A Caution indicates important information to help you avoid a loss of critical data.

Important! An Important note indicates critical information that you need to understand or important
steps you need to take.

Menu Paths

In this document, menu paths show you the steps required to start a task. Menu paths appear in bold font with
square brackets around buttons. For example:

"If the program does not automatically start, click [Start] > Run."

Need help?

Use Sage Estimating Help or a variety of self-help resources to get answers to your questions.
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The Help System

Sage Estimating Help provides more efficient access to information than most manuals. With a click of the
mouse or a keystroke, you can easily get Help for a command, a field, a window, or a procedure.

Sage Estimating displays Help in your default browser. If you have an Internet connection, it displays the most
current Help for your version of Sage Estimating available from a hosted Help server. If you have no
connection (you are working offline), it displays Help that was current when the software was released, and is
installed on your computer when you install Sage Estimating.

Important! Because the Microsoft Edge browser does not display locally installed help properly, we
recommend that you select a different default browser when working offline.

To get Help on a window option
To display Help for an option in a window, do one of the following:

» Click What's This? on the toolbar or on the title bar, and then click the option.
» Select What'’s This? from the Help menu, and then click the option.

» Select the option, and then press F1.

To get Help for the whole window

For information about the window, such as the window's purpose and what tasks you can performin it, click
[Help] at the bottom of the window.

To use Help to learn how to do tasks

1. Click [Help] on the toolbar, or select the Home tab > Help group > Help (or select Help menu > Help
topics in classic view).
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The Help Window
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2. Use the navigation pane to begin looking for a topic.

» Help subjects are organized under headings. Select the heading for the type of task you want to
perform to view a list of topics.

When you see the topic you want, double-click it to display it.

» Select the Glossary heading to view an alphabetical list of definitions of terms used throughout the
Sage Estimating software.

3. Use the Search box to find articles that match the keywords you enter.

Additional self-help resources

The Help menu available from on the ribbon also provides convenient links to a variety of self-help resources.
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The Help menu in Ribbon view
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Learn how to harness the full power of your software
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Remote Support Session

To access:

Visit the Sage Estimating
Product Documents page.

Visit the Knowledgebase at
Sage Knowledgebase.

Visit the Sage Estimating
General Discussion forum.

See Sage Estimating
Announcements.

Visit the Sage Customer Portal.

Visit Sage University.

You can also get access to Sage
University from the Estimating
File menu by selecting Help >
Sage University.

* Customer Service hours vary by product line. Access to some resources require an active Sage

Business Care support plan.
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Submitting Enhancement Requests

We want to hear your suggestions for improving the software. To send us your comments, click the File menu
button and then select Help > Submit Product Idea.
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Chapter 1: System Overview

Before you can run Sage Estimating, you need to activate your license, and install and configure the

components on which the Estimating system relies.

This chapter provides an overview of the Sage Estimating system, including:

 Installed components
» Tools you use to configure your system after installation

» The Sage online licensing system

Sage Estimating Components

Internet
Communication

Sage License Server )
> .-—

sage -

‘Web-based licensing &
entitlemeant system

— o

SQL Instance &
Databases

r Sage Estimating Machina(s) \,

Network — _
Communication

License Service J T
¥
7
SQL Server /

Network
Communication

Your On-Premise System

Sage
Estimating

/

Communication

License Service

- Retrieves licensing information from Sage's Web-based
licensing & entitlemant system.

- Provides license uses to the Sage Estimating application.

SqAL Server
- Stores & serves your data to the Sage Estimating
application.
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Your On-Premise Sage Components
Your Sage Estimating system includes these components:

» Your purchased Sage Estimating applications
* Your Sage license server

e Your SQL Server instance

You can set up these components on a single machine or on multiple machines. You choose the configuration
that best meets your needs.

Sage Estimating must be able to communicate with both your license server and your SQL Server Instance.

The Sage Estimating application

The Sage Estimating application is the main component of the Sage Estimating suite of programs. It includes
the Sage Estimating Configuration Wizard, which you use to connect Sage Estimating from each workstation
to your license server and to your SQL Server instance.

When it is connected to your Sage license server, Sage Estimating:
» Acquires a license use while you have it open.
Sage Estimating must maintain a connection to your Sage license server.

* Releases the license use when it is closed.

Your License Server
Your Sage license server communicates with the Sage online licensing system. It performs the following tasks:

« [t obtains licenses from Sage for your purchased products based on your registered Company name
and Sage Client ID, which must exactly match the Company name and Sage Client ID in your account.

It provides available license uses to your networked Sage Estimating computers.

Because it attempts to connect periodically to Sage, the license server must have continuous Internet access.

Your SQL Server Instance

Your SQL Server instance serves up, stores, and processes Sage Estimating data (including estimates,
standard databases, address book, and so on).

The Sage Online Licensing System
Sage Estimating uses a convenient online system to activate and verify your Estimating license.

The Sage online licensing system resides at Sage, and it:

Sage Estimating (SQL) v25.1Installation and Administration Guide 8



e Maintains a list of your purchased modules and number of license uses.

* Provides information to your Sage license server (at your company) about the modules and license

uses to which your company is entitled.

You use the License Administration window to connect to the Sage online licensing system. When you submit
your registered Company name and Sage Client ID to Sage, the Sage online licensing system determines the
number of license uses and the features that your purchased license provides, and it allocates the licenses to

your license server for use in your environment.

Configuration Tools in Sage Estimating

After installation, you use the following configuration tools to set up Sage Estimating:

* License Administration. You use the License Administration window to allocate your product licenses
and license uses to your designated Sage license server. For more information, see "Activate your
license on the Sage license server" (page 19) and "Managing Your License" (page 41).

» Configuration Wizard. You use the Configuration Wizard to connect each workstation to the designated
Sage license server and SQL Server instance. For more information, see "D. Connect Workstations to
Your License Server (Configuration Wizard)" (page 20) and "D. Connect Workstations to Your License
Server (Configuration Wizard)" (page 20) in Chapter 3—Installing and Configuring Sage Estimating.

« Estimating Management Console. You use the Estimating Management Console to manage your SQL
databases, estimates, custom reports, contacts, and security.
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Chapter 2: System and Other
Requirements

Before you install Sage Estimating, you should:
« Confirm your registration information:
1. Log into the Sage Customer Portal at:
https://customers.sagenorthamerica.com/

2. Confirm that the Company name used to register your Sage Estimating software exactly matches
the Company name used to activate your standard database.

3. Ifthese names do not match, contact Customer Support before you install and activate Sage
Estimating.

Important! This step is particularly important if you are upgrading from a version prior to version
17.11, when the registration information may have been slightly different. If these names do not
match, you will not be able to reactivate your database.

» Ensure that your system meets the minimum hardware and software requirements.

As with any software, as we continue to enhance Sage Estimating, you will realize optimal system
performance by using up-to-date computer hardware (memory as well as overall hardware
specifications).

For current information about supported operating systems, Internet browsers, Microsoft®
SQL Server®, and other software, and about system requirements for servers and client workstations,
refer to our Knowledgebase article System Requirements for Estimating v25.1.

Note: The system requirements are the minimum for a computer running Estimating with one SQL
Server instance. Running several other business programs with multiple SQL Server instances may
affect the performance of your system.

For help in selecting the right business-class computers for your business-class software, contact your
authorized business partner.

« Ensure that you have sufficient Windows permissions to install the software.
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If you are upgrading from an earlier version of Sage Estimating, or you plan to use an existing SQL
Server instance, you also need sufficient permissions on the SQL Server instance.

For more information, see "Access Rights" (page 11), later in this chapter.

« If you are upgrading from an earlier version of Sage Estimating, make sure you are upgrading from a
supported version of the product.

For more information, see "Supported Upgrade Path from Estimating (Pervasive)" (page 13), later in this
chapter.

Access Rights

The following sections describe the access rights you need to install and use Sage Estimating.

Elevate Permissions

During installation, you may be prompted to elevate your privileges. If you do not acknowledge each message
within two minutes, the installation process will quit the task. If this occurs, you may receive a separate
message asking you to retry the task. To retry the task, click [Retry] and then elevate your privileges when
prompted.

SQL Server Permissions

Always use the Security feature in the Estimating Management Console to configure security for Sage
Estimating.

. Important! Do not use SQL Server Management Studio to modify security settings.

For more information on setting up SQL Server security for Sage Estimating, see "Installing and Configuring
Sage Estimating " (page 14).

Full Control of Specific Files and Folders Required

To use Sage Estimating, you need to have full control of the following files and folders on your file server,
terminal server, and workstations that have Sage Estimating installed. Make sure that your system
administrator also gives you full control of all the subfolders and files.

Caution! Incorrectly modifying Microsoft Windows security may severely impair your system operations.
Sage is not responsible for operation problems caused by incorrectly modifying your Microsoft Windows
security settings. To set permissions on your network or Windows operating system, you need advanced
knowledge of your network. Contact your system administrator for assistance.

Sage Estimating (SQL) v25.1Installation and Administration Guide 11



Folders and Files Requiring Operator Control

Product Operating Required Folders and Files Location and Specifications
Systems
This folder is located on the file server,
terminal server, and workstations where you
64-bit installed Sage Estimating. It is the default
Sage Windows [Drive]\Program Files\Sage\ | installation location for Sage Estimating.
Estimating Svstems Estimating However, depending on your system
y configuration, your company may have
renamed this folder or installed it to a different
location.
[Drive]\Users\Public\Sage\ These folders are located on the workstation
) Estimatin or terminal server where you use Sage
Sage Windows 8.1 g o . y . 9
L . -and- Estimating. Sage Estimating installs
Estimating Windows 10 . . .
[Drivel\ProgramData\Sage\ | necessary files to these folders and requires
Estimating that the user has full control of them.

Note: Some of these folders may be hidden.

To view them, open Windows Explorer, click the View tab, and then select the Hidden items checkbox in
the Show/hide group.

Full Control and Read Access to Specific Registry Keys Required

To use Sage Estimating, you need to have full control of the following Windows registry key on your file server,
terminal server, and workstations that have Sage Estimating installed. Make sure that your system
administrator also gives you full control of all subkeys.

« HKEY_CURRENT_USER
You should also have read access to the following registry keys and associated subkeys:

e HKEY_Local_Machine\Software\ODBC
e HKEY_Local_Machine\Software\Wow6432Node\Sage

Caution! Incorrectly editing the Microsoft Windows registry may severely damage your system. Sage is
not responsible for damage to your system caused by editing the registry. Before making changes to the
registry, contact your system administrator for assistance and make a backup copy of all valued data.
System administrators, see Microsoft Registry Editor Help topics for detailed instructions.

Sage Estimating (SQL) v25.1 Installation and Administration Guide 12



Supported Upgrade Path from Estimating (Pervasive)

If you have been using a Pervasive-based version of Sage Estimating, you need to:
1. Migrate (transfer) your existing Pervasive-based data to Estimating (SQL) v20.1.
2. Upgrade your database from v20.1 to this release.

For information about migrating your Pervasive-based data to Estimating (SQL), see the v20.1 Installation and
Administration Guide.

Sage Estimating (SQL) v25.1Installation and Administration Guide 13



Chapter 3: Installing and Configuring Sage
Estimating

You can set up Sage Estimating in any of the following configurations:
e On a server/workstation domain
* In aworkgroup environment

* On a standalone computer

The server/workstation configuration is a common setup where multiple Sage Estimating workstations access

the same SQL Server instance and Sage license server. The next sections step you through the installation
and configuration of a Sage Estimating system in a server/workstation domain, highlighting the distinct
components of the system. However, you are not limited to this configuration.

Tip: For information on the other supported configurations of Sage Estimating, see "I. Other Installation
Scenarios" (page 28).

Before You Install or Upgrade Sage Estimating
» Read and understand the information in this guide.

 If you are currently using a previous version of Sage Estimating, create a complete backup copy of all
Sage Estimating data and program files before installing this version.

« Install the appropriate operating system service pack, make sure that there is sufficient hard disk space
available, and ensure that your server and workstations meet all other hardware and software
requirements.

For current information about supported operating systems, Internet browsers, Microsoft®
SQL Server®, and other software, and about system requirements for servers and client workstations,
refer to our Knowledgebase article System Requirements for Estimating v25.1.

Note: The system requirements are the minimum for a computer running Estimating with one SQL
Server instance. Running several other business programs with multiple SQL Server instances may
affect the performance of your system.

e Make sure that you have full control of the necessary folders, files, and registry keys on your file server,
terminal server, and workstations that will have Sage Estimating installed.

Sage Estimating (SQL) v25.1 Installation and Administration Guide
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For a list of the required folders, files, and registry keys for your operating system, see the chapter on
"System and Other Requirements" (page 10).

e Close all programs and services for the duration of the installation. This includes programs that may be
running in the background such as antivirus, email, and backup programs.

e Decide which installation scenario to follow.
See "Configuration Tools in Sage Estimating" (page 9).

* You need to have the appropriate permissions to perform certain tasks described in this chapter.
Contact your Sage Estimating administrator if you require additional permissions.

Installing on a Server / Workstation (Example)

A server/workstation configuration uses separate machines for:

» The SQL Server (which hosts Estimating databases)
» The Sage license server (from which you administer licenses)

* One or more Sage Estimating workstations (where you use the Estimating programs to create estimates
and do related processing)

To install and configure Sage Estimating on a server/workstation setup, you perform the following general
steps:

. Note: For details on each step, refer to the associated sections indicated in parentheses for each step.

1. Atthe SQL Server machine, install and configure the SQL Server Instance (Section B)

2. Atthe license server machine:

a. Install Sage Estimating (Section A)
b. Configure your license server (Section C)

3. Atthe workstation or server where you will host your Sage Estimating data:

a. Install Sage Estimating (Section A)
b. Connect to the Sage license server (Section D)
c. Connectto SQL Server (Section E)

d. Install standard databases or upgrade your data (Section F)
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Note: You only do this step once, from a single workstation, because the data is hosted on the
SQL Server instance and shared by all workstations.

€. Set up roles and permissions (Section G)

4. At each Sage Estimating workstation:

a. Install Sage Estimating (Section A)

b. Open Sage Estimating to verify that the workstation can connect to the license server and SQL
Server instance.

Installing Training Data Using the Configuration Wizard

If you create a SQL Server instance outside of the Estimating installation, you can install training data directly
from the Configuration Wizard.

In Step E, if no estimates database exists in your SQL Server instance when you try to connect your
workstation, you can create a new one "on the fly" using the Create Estimate Database window. After naming
the new database, select the Install training data check box.

Note: This option is not available if you use the option to install SQL Server Express when you install
Estimating.

Providing no address book exists when you install training data, Estimating creates 2 address book databases:
an address book for training data and an empty one to use when you finish using the training data. (If an
address book exists, Estimating does not create an empty one.)

A. Install Sage Estimating

If you have not already done so, download the Sage Estimating installation files according to the instructions
provided in the software notice. If you are installing Sage Estimating on a server, ensure you save the
installation files in a location that all workstations can access. Then copy the installation files to each
workstation where you want to install Sage Estimating.

Note:

¢ The installation process may restart your computer during the installation. Ensure you close all
programs and applications before starting the installation to avoid losing any data. If your
computer restarts, log on to your computer again.

 If you choose to upgrade data from a previous version of Sage Estimating, the process may take
up to four hours, depending on the size of your databases. Plan accordingly.
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Important!

« Do not install Sage Estimating unless you have sufficient hard disk space available.

» For current information about supported operating systems, Internet browsers, Microsoft®
SQL Server®, and other software, and about system requirements for servers and client
workstations, refer to our Knowledgebase article System Requirements for Estimating v25.1.The
system requirements are the minimum for a computer running Estimating with one SQL Server
instance. Running several other business programs with multiple SQL Server instances may
affect the performance of your system..

« Do notinstall previous releases of Sage 300 Construction and Real Estate after installing Sage
Estimating. The new licensing system is incompatible with previous releases.

1. At the workstation or server, log on with full administrative rights.

Full administrative rights means write access to the Windows registry and all folders on the computer
(including rights to the root of all hard drives). If you are unsure whether you have full administrative
rights, ask your network administrator for assistance.

2. Double-click the SetMeUp.exe file in your local Sage Estimating Install folder.

The Sage Estimating Install folder is at the location you specified during the Sage Estimating download
process. For example, if you downloaded the installation files to C:\Users\Public\Public
Documents\Sage Estimating, look in this folder for the SetMeUp.exe file.

3. When prompted by the User Account Control dialog box, click [Yes] to allow the program to make
changes to the computer.

4. Read the terms of the Sage License Agreement, and then click [Accept] to accept them.
5. Onthe Sage Estimating installation window that appears, select Install Sage Estimating.

Selecting this option alone installs the Sage Estimating software and support components.

If you are installing Sage Estimating only for demonstration or trial purposes, or if you are configuring
Sage Estimating for a single user, SQL Server Express may be adequate. However, for large databases
and multi-user configurations, Sage strongly recommends implementing your Sage Estimating system
with a standard version of SQL Server.

6. Follow the remaining steps as prompted by the installation process, which guides you through the
installation of Sage Estimating products and required support software.

7. Repeat steps 1 through 6 for each workstation or server where you want to install Sage Estimating.

B. Install and Configure SQL Server

If you are installing Sage Estimating for the first time or if you want to create a new SQL Server Instance, install
or configure a supported version of SQL Server on the computer on which you installed Sage Estimating.
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Refer to the Sage Estimating SQL Server Guide for information about installation and the SQL Server settings
that Sage Estimating requires.

If you want to use an existing installation of SQL Server, refer to "Configuring SQL Server" (page 32) for
settings for creating and configuring a new instance.

If you need to create a new SQL Server instance, you can select the Create a new local SQL Server instance
option during installation. This option will install a new instance of SQL Server Express 2017. If you choose this
option, however, you will not have the option to install training data through the Configuration Wizard.

Important! If you are using Sage Estimating in a multi-user environment, Sage recommends that you use
the standard SQL Server product. Although SQL Server Express is a reasonable choice for smaller-
scale implementations, it does not support databases larger than 10 GB and can only use 1 GB of RAM
(among other limitations), so we do not recommend that you use it for a shared SQL Server instance.

If you are operating in a workstation/server environment (see "Installing and Configuring Sage Estimating "
(page 14)), you do not need to install SQL Server on the workstations.

Important! To allow communication with a remote SQL Server instance, you may need to set firewall
exceptions for the SQL Server Database Engine and the SQL Server browser services. If your firewall
blocks network traffic between your computer and the SQL Server instance, you will not be able to
connect workstations to the server. For information about setting these exceptions, see Setting Firewall

Exceptions.

Notes:

» Atthe instance name prompt, type a name for the new SQL Server instance (database server) in
the box, and then click [OK].

The default instance name is SAGE_ESTIMATING, but you can give the instance any name you
want provided you do not give it the same name as any existing SQL Server instance on the
computer.

e SQL Server allows an unlimited database size. However, SQL Server Express limits the database
size to 10 gigabytes (GB). Sage Estimating warns you if your database size nears the limit.

If you select the option to create a new SQL Server instance in the Select installation options for
Sage Estimating window, the installation process automatically configures a new Sage
Estimating-compatible instance for you.

e The installation process may restart your computer. If your computer restarts, log back onto your
computer at the prompt.

¢ You can install an approved instance of SQL Server side by side on a computer where other
versions of SQL Server are installed. Be aware that installing Sage Estimating may result in an
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"Install completed with errors" message. However, the resulting Sage Estimating installation
operates correctly.

Caution! Sage recommends againstinstalling SQL Server on a domain controller. Installing SQL Server
on a domain controller is a security risk, and not recommended or supported by Microsoft.

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and
other software, and about system requirements for servers and client workstations, refer to our
Knowledgebase article System Requirements for Estimating v25.1.

Note: The system requirements are the minimum for a computer running Estimating with one SQL
Server instance. Running several other business programs with multiple SQL Server instances may
affect the performance of your system.

C. Configure Your License Server (License Administration)

Before configuring your license server

Make sure you have an active Internet connection.

Activate your license on the Sage license server

To activate your license:
1. Onthe machine designated as your license server, open the License Administration window.
Click Start > All Apps > Sage Estimating > License Administration.
2. Check that computer named in the License server box is the designated license server.

If License Administration is not pointing to the correct server, click Change server, and then enter the
correct computer name or IP address of your license server.

3. Inthe Registration Information section, submit your registration details as follows:
a. Click the Edit registration information link.

b. Inthe Sage client ID box, type your client number.

o

In the Registration name box, type your registered company name exactly as provided by Sage.

o

Click [OK]
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If the activation was successful, the Licensed Modules grid displays the modules and number of
uses that you have purchased. Your license server is now ready to serve licenses to your Sage
Estimating (SQL) users.

If the activation was successful, the Licensed Modules grid displays the modules that you have
purchased.

For more information, see "Managing Your License" (page 41).

D. Connect Workstations to Your License Server
(Configuration Wizard)

. Note: You perform these steps on each workstation that will run Sage Estimating.

The Configuration wizard is installed automatically during Sage Estimating installation.

To connect to your Sage license server

1. To start the Configuration wizard, click the Configuration Wizard tile on the Start menu, or right-click
outside the tile area, and then click All apps > Sage > Configuration Wizard.

Important! Depending on your version of Windows, you may need to elevate your permissions before
starting the Configuration wizard. On the Start menu, right-click Configuration Wizard, and then select
Run as administrator.

2. Inthe navigation pane of the Configuration Wizard, click Licensing.
3. In the right-hand pane, choose a licensing option:

 Ifyour license server is installed on a different computer on your network, select Connect to a
remote license server , and then click [Specify remote server].

Tip: If your computer is already connect to a license server, the current server name is displayed
beside this option.

The Specify License Server window opens.

 Ifyour license server is installed on the same machine you are working on, select Use a local
server, and then click [Set up local server].

The Set Up Local License Server window opens.

4. If you selected the remote server option, in the Specify License Server window:
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a. Inthe Server box, enter the name of the computer running the license server.
b. Inthe Port box, ensure that the port is set to 48650.

c. Click [OK].

If you selected the local server option, in the Set Up Local License Server window:

a. Enter your company's registration name and your client ID exactly as they appear for your
account in the Sage Customer Portal at https://customers.sagenorthamerica.com/.

b. Inthe Port box, ensure that the port is set to 48650.

c. Click [OK].

Note: A green check mark appears beside the Licensing item in the navigation pane if you connected to
the license server successfully.

For more information, see "Managing Your License" (page 41).

E. Connect Workstations to Your SQL Server Instance
(Configuration Wizard)

Note: Before connecting workstations to your SQL Server instance, make sure that the SQL Server
instance and your browser can communicate with other machines on your network. If your firewall
settings are blocking communication with your server, the Configuration Wizard cannot find the SQL
Server instance. For more information, see Configuring SQL Server.

As a final step in configuring the workstation, connect to the SQL Server instance ("server"), as follows:
1. Start the Configuration wizard.

Click the Configuration Wizard tile on the Start menu, or right-click outside the tile area, and then click All apps
> Sage > Configuration Wizard.

2. In the navigation pane of the Configuration wizard, click Data Server.
3. Beside the Server box, click [Select] (or click [Change] to select a different instance).
The Select a SQL Server window appears.

4. Inthe Server box, type the name of the computer that is hosting your SQL Server instance.

. Tip: If you are not sure of the name, click [Search], and then select the server from the list.

5. Click [Verify].
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If you have not set up an estimates database, Estimating displays a message telling you that the SQL
Server instance does not contain an estimates database.

a. If the message appears, click [OK].

Estimating displays the Create an Estimates Database, where you can create a new database or
restore an existing one.

b. To create a new estimates database:
i. Select Create a new database.

ii. Inthe New database name box, accept Estimates as the new database name or type a
different name.

iii. If you want to install training data at the same time, select the Install training data
checkbox.

iv. Click [Create].
To restore an estimates database from a backup:
i. Select Restore a database.

ii. Inthe Select the folder that contains the backed-up database box, type or select the path to
your backup folder.

iii. Inthe grid, in the Restore column, select the check mark for the databases you want to
restore.

iv. Click [Restore].

A green check mark beside the Data Server item in the navigation pane indicates a successful
connection to your SQL Server Instance.

6. Click [Close] to exit the Configuration wizard.

For more information, see "Configuring SQL Server" (page 32).

F. Install Standard Databases and Upgrade Your Data

If you are upgrading from an earlier version of Sage Estimating (SQL), you need to upgrade your data before
you can work with it in the current version. You can also install any standard (industry) databases that you
have purchased.

If you have existing Pervasive-based estimate data, you need to migrate your data to version 20.1 before you
can upgrade to this version.
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If you have been maintaining your own items list that you want to continue to use, you can install a “shell”
database that comes with Sage Estimating so that you don’t have to set up your own database from scratch.
These databases contain CSl industry phases codes, but no items. After installing a shell database, you enter
an item list manually, or you can import items from an Excel spreadsheet.

You can perform these processes from any computer that has access to the SQL Server instance where you
plan to store your estimate data.
Install standard databases

If you have purchased standard databases, you can install and activate them when you finish setting up Sage
Estimating (SQL). You install Standard databases using the Estimating Management Console.

1. In the Estimating Management Console, click the Standard DB tab.
2. On the toolbar, click Install Databases.

3. From the dropdown list, select Optional Databases, and then double-click each standard database you
want to install from the Available Databases pane.

Alternatively, if you want to install one of the shell databases (with no items, only phases), select Shell
Databases from the dropdown list.

4. Inthe Databases to install box, type the activation code for each standard database. (The activation
code must match your registration name exactly.)

. Note: Shell databases that come with Sage Estimating do not have activation codes.

5. Click [Install].

Migrate your data from Sage Estimating (Pervasive)

If you are upgrading from Sage Estimating (Pervasive) version, see "Data Migration to Estimating v20.1" (page
31) for instructions.

Upgrade your data from an earlier version of Sage Estimating (SQL)

If you are upgrading from an earlier version of Sage Estimating (SQL), the Configuration Wizard will prompt
you to upgrade your data when you start that application. Follow the steps in the wizard to complete the
upgrade.

G. Set Up Estimating Security

There are two aspects to security in Sage Estimating: feature security and estimate security.
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As a Sage Estimating administrator, you manage security by maintaining users, roles, and permissions on the
Security tab of the Estimating Management Console.

Note: At least one operator must be assigned to the administrator role at all times. Typically, the person
who Installs SQL Server is the first Sage Estimating administrator. That person can then assign roles and
permissions to others.

 Ifyou install SQL Server as part of the Sage Estimating installation, you are automatically
assigned the administrator role.

 Ifyou install SQL Server outside the Sage Estimating installation process, you should assign
yourself or another user to the sysadmin role for the instance.

User authentication methods

In addition to feature and estimate security, there are two methods for authenticating users who log into your
Estimating system: Windows Authentication and SQL Server Authentication.

If you are using Estimating in a non-domain environment, but you want to use Estimating in a networked way,
you can set up Estimating users with SQL Server authentication. This way, you need to set up each user only
once for the instance, but they can log in to the instance from different machines.

Notes:
« If you have set up Estimating on a domain, do not use SQL authentication.

* You need to create new users for SQL authentication in the Estimating Management Console, to
ensure that they are set up properly. You will not be able to select existing SQL users in the Add
User window.

About feature security

. Important! Only a Sage Estimating administrator can set up and manage roles and permissions.

In the Security window, you use the Users tab to add Estimating users and the Roles tab to assign predefined
roles to those users. Each role is associated with certain types of permissions. By assigning different roles to
users, you control who can:

» Change estimate security
» Create estimates

« Edit a shared catalog

» Edit a standard database

e Manage custom reports
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e Manage shared layouts
* Run the Management Console

* View databases and allow takeoff

About estimate security

Important! Only administrators and users who have Change estimate security permission can modify
estimate security.

You can allow all users to view or edit all estimates, allow existing users to view or edit new estimates by
default, or ensure that view and edit permissions are assigned on an estimate-by-estimate basis. Select the
following options on the Estimates tab as follows:

» Allow all users to view all estimates. This option allows any user, regardless of their role, to view any
estimate.

. Note: You cannot turn off this option for individual estimates.

If you do not select this option, you can choose to select the new Default allow existing users to view
new estimates option. This option gives viewing permission automatically to all existing users when you
create a new estimate, but you can remove viewing permission for individual users on specific
estimates. You will need to give viewing rights manually to new users, later, if they need it.

If you do not select either option, you need to assign permissions to specific users for each and every
estimate.

» Allow all users to edit all estimates. This option allows any user, regardless of their role, to edit any
estimate. Selecting this option automatically confers permission to view all estimates.

. Note: You cannot turn off this option for individual estimates.

If you do not select this option, you can choose to select the new Default allow existing users to view
new estimates option. This option gives editing permission automatically to all existing users when you
create a new estimate, but you can remove editing permission for individual users on specific estimates.
You will need to give editing rights manually to new users, later, if they need it.

If you do not select either option, you need to assign View and Edit access to specific users for each and
every estimate.

Setting up roles and permissions

Setting up roles and permissions involves the following general steps:
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1. Adding roles and assigning features.

2. Adding users and assigning roles.

To add roles and assign features:

Important! Make sure users log off Estimating Management Console before you change their
permissions.

1. Start the Estimating Management Console in one of these ways.

« On the Start menu, click the Estimating Management Console tile.

¢ Right-click outside the tile area, and then click All apps > Sage Estimating Management Console.

2. Inthe Estimating Management Console, click [Security].
3. Inthe Security window, click the Roles tab.
4. Click [Add] to open the Add Role window.
5. Inthe Add Role window:
a. Inthe Name and Description boxes, type a name and description for the new role.
b. Inthe Select Features for Role box, select feature permissions that comes with this role.
6. Click [OK].

To add users and assign roles:
1. Start the Estimating Management Console.

¢ On the Start menu, click the Estimating Management Console tile.

¢ Right-click outside the tile area, and then click All apps > Sage Estimating Management Console.

In the Estimating Management Console, click [Security].

2
3. Inthe Security window, click the Users tab.
4

. On the Users tab, click [Add] to open the Add User window.

o

To set up users with Windows authentication, on the Windows Authentication tab of the Add User
window:

a. (Optional) Select a role to associate with the user. You can assign the role later using the Users
tab.

b. If you know the user or group ID you want to add, type it in the User or Group ID box, and then
click the [Verify user or group] button.
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d.

If you don't know the ID, click the[ Select user or group] button , and then:

In the Select User or Group window, click the [Advanced] button, and then click [Find Now]
to generate a list of all the user IDs and group IDs on the network to which the Estimating
Management Console is connected.

Select a network user ID or group ID from the resulting list, and then click [OK].

The program adds the ID to the Enter the object hame to select box.

. Note: Depending on your domain user count, the search method could take some time.

Click [OK] again.

Click the Verify user or group | button.

Estimating Management Console adds the user to the Users to Add grid on the tab. If you entered

or selected a group ID, Estimating Management Console adds all the users in the group, as well
as users from any subgroups within that group.

In the Users to Add grid, select the checkbox beside each user you want to add.

Tip: A checkbox in the header of the Users to Add grid indicates whether any users are selected.
You can select or clear all the user selections quickly just by selecting or clearing this checkbox.

6. To set up users with SQL Server authentication, select the SQL Server Authentication tab and then:

a.

b.

o

o

From the Role list, select the role to assign to the user.

In the User ID box, type the name or ID of the user.

In the Password box, enter the user's new SQL password.

In the Confirm password box, enter the same password again.

Select local security options that you want to enforce for the user:

Select Enforce password policy to make sure that the user's password meets criteria
specified in Microsoft Windows Security Policy.

Select Enforce password expiration to make sure that the user changes their password
after a period of time specified in Microsoft Windows Security Policy.

If you select User must change password at next login, the next time the user tries to log on,
they are prompted to change their password.

7. Click [OK] in the Add User window.
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The user or users associated with the selected user or group ID appear in the Users grid of the Users
tab.
Managing Security

You can manage the user / role relationship using either the User tab or the Role tab. Changes you make on
one tab are reflected on the other tab .

You can manage estimate security permissions from the Estimates tab, as well as the Estimate Info window if
you have Change estimate security permission.

H. After You Complete Your Setup

Restart all programs and services that you shut down for the installation.

The Sage Estimating software performs a series of checks the first time you start it. If the Sage Estimating
software notifies you of any error conditions, correct the condition before continuing.

Supporting documentation for Sage Estimating is available at
http://cdn.na.sage.com/Docs/en/customer/estimating/Documentation.htm, or by clicking Help > Product
Documents on the ribbon in Sage Estimating. These documents are in Adobe Acrobat (PDF) format. If you do
not already have Adobe Acrobat or Acrobat Reader, you can download Adobe Acrobat from www.adobe.com.

Important! For performance reasons, if you plan to run a virus scanner on the machine that hosts the
SQL Server instance, you should exclude files that have MDF, LDF, NDF, BAK, TRN, and TRC
extensions. You should also exclude additional processes for the version of SQL Server that you are
running.

For more information about the files and processes to exclude, see Knowledgebase article
240423134750620, Antivirus software and SQL Server.

|. Other Installation Scenarios

Workgroup environment (multiple workstations connected to one computer that
stores Estimating data and acts as License Server)

At the server machine:
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1. At the server machine:
a. Install Sage Estimating (Section A)
b. Install and configure the SQL Server Instance (Section B)
c. Configure your license server (Section C)

2. Ateach Sage Estimating workstation:

a. Install Sage Estimating (Section A)
b. Connect to the Sage license server (Section D)
c. Connectto SQL Server (Section E)

d. Install and upgrade your data (Section F)

Note: You only do this step once, from a single workstation or on the server machine, because
the data is hosted on the SQL Server instance and shared by all workstations.

€. Set up roles and permissions (Section G)

Standalone workstation environment (a single workstation that stores Estimating

data and acts as License Server)
At the standalone workstation:
1. Install Sage Estimating (Section A)
Install and configure the SQL Server Instance (Section B)
Configure your license server (Section C)
Connect to the Sage license server (Section D)

Connect to SQL Server (Section E)

o o &~ b

Install and upgrade your data (Section F)

7. Set up roles and permissions as needed (Section G)

Terminal Server

Follow the steps for "Workgroup environment (multiple workstations connected to one computer that stores
Estimating data and acts as License Server)" (page 28), with these exceptions:
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» Always use Add or Remove Programs to start an installation to a terminal server.

 If you use another server to host Sage Estimating databases, install only Sage Estimating products to
the terminal server.

Technical note about the Common Language Runtime in SQL
Server

Beginning with version 18.11, Sage Estimating no longer uses the Common Language Runtime (CLR)
integration feature in the Microsoft SQL Server instance, resulting in improved security and performance, and
a more future-proof application. For this reason, the CLR integration feature is not automatically turned on for
new installations of Sage Estimating.

When you upgrade from earlier versions of Sage Estimating, however, the upgrade process does not turn off
the CLR integration feature. This means that the CLR integration remains turned on for your SQL Server
instance. If you do not use the CLR integration feature in SQL Server and you have database security
concerns, you should consider turning off this feature.

For instructions on turning on or turning off CLR integration for Microsoft SQL Server, see Enabling CLR
Integration in the Microsoft developer’s library at https://technet.microsoft.com/en-us/library/ms131048
(v=sqgl.105).aspx.
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Chapter 4: Data Migration to
Estimating v20.1

The migration path from Estimating (Pervasive) to this release is not direct.
If you have been using a Pervasive-based version of Sage Estimating, you need to:

1. Migrate (transfer) your existing Pervasive-based data to Estimating (SQL) v20.1.

Important! Sage recommends that you first migrate your data to a test environment to ensure that the
migration proceeds smoothly. For example, if there are errors in your Pervasive-based data, you have
an opportunity to correct them in that version before migrating the data to a live environment.

2. Upgrade your database from v20.1 to this release.

For information about migrating your Pervasive-based data to Estimating (SQL), see the v20.1 Installation and

Administration Guide.

Tip: You can continue to operate v20.1 alongside this current release. If you have a large nhumber of
estimates, you can export them, later, from version 20.1 and then import them into this version, as
needed.
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Chapter 5: Configuring SQL Server

Follow the instructions in this section to install and configure a SQL Server instance manually for use with
Sage Estimating.

Important! If you are using Sage Estimating in a multi-user environment, Sage recommends that you use
the standard SQL Server product. Although SQL Server Express is a reasonable choice for smaller-
scale implementations, it does not support databases larger than 10 GB and can only use 1 GB of RAM
(among other limitations), so we do not recommend that you use it for a shared SQL Server instance.

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and
other software, and about system requirements for servers and client workstations, refer to our
Knowledgebase article System Requirements for Estimating v25.1.The system requirements are the minimum
for a computer running Estimating with one SQL Server instance. Running several other business programs
with multiple SQL Server instances may affect the performance of your system.

Setting Up a SQL Server Instance for Use with Sage
Estimating

If you already use a supported version of Microsoft SQL Server, you can set up another instance to work with
Sage Estimating. (Options described in this section may vary slightly depending on the version you are
installing.)

Note: If you choose to uninstall your existing instance first, restart your server before reinstalling to avoid
problems with the new installation.

. Caution! Do not change the owner of any databases in the Sage Estimating instance.

Configure your new SQL Server instance using the settings outlined in the following sections.
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Instance Configuration: Named Instance

Instance Configuration Settings

Instance Configuration

License Terms

Global Rules

Product Updates

Install Setup Files

Install Rules

Feature Selection

Feature Rules

Instance Configuration
Server Configuration
Database Engine Configuration
Feature Configuration Rules
Installation Progress

Complete

You need to use a named instance. You can give the instance any name you want. However, if you have

Specify the name and instance ID for the instance of SQL Server. Instance ID becomes part of the installation path,

(©) Default instance

@ Named instance: | SAGE_ESTIMATING

Instance ID; SAGEEST

SQL Server directory:  C:\Program Files\Microsoft SQL Server\MSSQL12.SAGEEST

Installed instances:

| Instance Name Instance ID Festures Edition Version
| <5Shared Compone... Tools, Tools\Tools.. 9.4.5000
< Back ] [ Next > ] [ Cancel ] [ Help

installed a previous version of Sage Estimating (such as version 11.2), give the new instance a different name
that is easily recognizable (such as SAGE_EST_19_12).
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Authentication Mode

Authentication Mode Settings
—

—

14 SQL Server 2014 Setup

Database Engine Configuration

Specify Database Engine authentication security mode, administrators and data directories.

License Terms Server Configuration | Data Directories | User Instances | FILESTREAM
Global Rules

Product Updates Specify the authentication mode and administrators for the Database Engine.

Install Setup Files Authentication Mode
=Elds ©) Windows authentication mede

Feature Selection _
@ Mixed Mode (SQL Server authentication and Windows authentication)
Feature Rules

Instance Configuration Specify the password for the SQL Server system administrater (sa) account.
Server Configuration

Database Engine Configuration

Enter password:

Feature Configuration Rules Conpppsss

Installation Progress Specify SQL Server administrators

Complete BEST\glah=01 (Glavina, Helen) SQL Server administrators
have unrestricted access
to the Database Engine.

AddCurrentUserH Add... H Remove]
[ <pack || wet> |[ conca ][ nep

The instance must support Mixed Mode authentication (Windows Authentication and SQL Server
Authentication). This means either Windows authentication or SQL Server authentication can be used to
access the database information.

When you use Windows authentication, the operator requires permission to use SQL Server or be a member
of a group that has permission. In Windows authentication mode, SQL Server validates the account name and
password using information from the Windows operating system.

When you use SQL Server authentication, the operator requires system administrator (sysadmin) rights in SQL
Server. SQL Server authentication is used for backwards compatibility and requires a strong password.
Collation Settings

Collation settings must be Latin1_General, case-sensitive, and accent-sensitive (Latin1_General_CS_AS).

You customize the collation settings during the server configuration portion of the SQL Server installation. In
the SQL Server collation customization window, make the following selections:

1. Select the Windows collation designator and sort order option (instead of SQL collation, which is the
default):
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¢ Latin1_General (for the collation designator)
¢ Case-sensitive
¢ Accent-sensitive

2. Clear all other options.

Setting Up Security

You use the Security feature in the Estimating Management Console to set up user access to your estimates
and standard databases.

For more information on setting up SQL Server security for Sage Estimating, see "Installing and Configuring
Sage Estimating " (page 14).

Setting Firewall Exceptions

If you experience communication issues with a remote SQL Server instance, you may be using a firewall that is
set up to block network traffic between your computer and the SQL Server instance. To allow communication,
you need to set two firewall exceptions:

e The SQL Server Database Engine service. (You need to set a SQL Server Database Engine exception
for each instance of SQL Server you use with Sage Estimating.)

+ The SQL Server browser service

Notes:

« The following instructions apply to Windows Firewall. If you are using another firewall for your
system, contact the firewall manufacturer for instructions on setting service exceptions.

« If you are using SQL Server on a workgroup server, you need to set separate firewall exceptions
to allow your workstations to communicate with the SQL Server instance. Refer to Setting the
Firewall for Workgroups instructions.

e Sage recommends contacting your system administrator if you need to change firewall settings.

Setting the SQL Server Database Engine exception

1. Determine the path to your SQL Server computer.
2. Onthe computer or server where SQL Server is installed, open the SQL Server Configuration Manager.

3. Start the SQL Server Configuration Manager.

Click Start > All apps > Microsoft SQL Server > SQL Server Configuration Manager.
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The SQL Server Configuration Manager opens.

In the left-hand pane of the SQL Server Configuration Manager, select SQL Server Services.

In the right-hand pane, right-click on SQL Server (INSTANCE), where (INSTANCE) is the SQL Server
instance for which you are creating the firewall exception, and select Properties.

In the SQL Server Properties window, click the Service tab.

In the Binary Path entry, note or record the path described within the quotation marks. This is the file
path to the SQL Server instance binary files (the path is contained only within the quotation marks—
ignore the text outside the quotes).

Open Windows Firewall by clicking Start > All apps > Windows System > Control Panel > System and
Security > Administrative Tools > Windows Firewall > Advanced Settings. Then:

a. Inthe left-hand pane of the Windows Firewall with Advanced Security window, right-click Inbound
Rules, and then select New Rule.

b. Inthe New Inbound Rule wizard, select the Program option, and then click [Next].
c. Select the This program path option.

d. Click [Browse] and locate the sqlservr.exe file at the binary file path you recorded in step 1, and
then click [Open].

e. Select the Allow the connection option, and then click [Next].

—h

Select the Domain, Public, and Private checkboxes, and then click [Next].

Type the name of your SQL Server instance in the Name box.

> @

Click [Finish] to create the firewall exception for the SQL Server Database Engine service.

The Windows Firewall with Advanced Security window opens.

Setting the SQL Server browser service exception

1.

© N o 0o~ W

Open Windows Firewall by clicking Start > All apps > Windows System > Control Panel > System and
Security > Administrative Tools > Windows Firewall > Advanced Settings.

In the left-hand pane of the Windows Firewall with Advanced Security window, right-click Inbound Rules,
and then select New Rule.

In the New Inbound Rule wizard, select the Port option, and then click [Next].
Select UDP as the protocol type.

Select the Specific local ports option, and then type 1434 in the corresponding box.
Click [Next].

Select the Allow the connection option, and then click [Next].

Select the Domain, Public, and Private checkboxes, and then click [Next].
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9. Type sQL Server Browser Exception inthe Name box.
10. Click [Finish] to create the firewall exception for the SQL Server browser service.

Setting the Firewall for Workgroups

If you are using SQL Server with a workgroup, you need to set the firewall on the workgroup server to allow
workstation computers to connect to the instance.

Note: If you are using SQL Server on a domain-based server, you may still need to configure your
firewall to allow remote communication. Refer to the SQL Server Guide for instructions.

Firewall Settings (Windows 8.1 and Windows 10)
1. Open Windows Firewall.

» Click Start > Windows System > Control Panel > System and Security > Windows Firewall
> Advanced Settings.

2. Setrules forinbound and outbound TCP connections:
a. Right-click Inbound Rules, and then select New Rule.
b. Inthe Inbound Rule wizard, select Port, and then click [Next].
. Select TCP, and then select Specific local ports.

c
d. Inthe Specific local ports box, type 8005, 49385, and then click [Next].

®

Select Allow the connection, and then click [Next].

—h

Select the Domain, Private, and Public checkboxes, and then click [Next].

g. Inthe Name box, type Sage Estimating Service (or other appropriate name), and then click
[Finish].

h. Repeat steps a through g for outbound TCP connections, selecting Outbound Rules in step a.
3. Setrules for inbound and outbound UDP connections:

Right-click Inbound Rules, and then select New Rule.

o o

In the Inbound Rule wizard, select Port, and then click [Next].

Select UDP, and then select Specific local ports.

e o

In the Specific local ports box, type 1433, 1434, and then click [Next].

e. Select Allow the connection, and then click [Next].

—h

Select the Domain, Private, and Public checkboxes, and then click [Next].

g. Inthe Name box, type Sage Estimating Service (or other appropriate name), and then click
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[Finish].

h. Repeat steps a through g for outbound UDP connections, selecting Outbound Rules in step a.

Additional Recommendations

To ensure accurate performance, Sage strongly recommends making changes and verifications to the
following settings in SQL Server Management Studio and SQL Server Configuration Manager. Failure to make
these changes may result in poor Sage Estimating performance or communication difficulties between Sage
Estimating and your SQL Server instance.

Memory

Determine the amount of available memory on the server or workstation where SQL Server is installed. To
prevent SQL Server from consuming all available memory, use SQL Server Management Studio to set the
maximum amount of memory (in the instance properties) to a reasonable limit (such as 4 GB ) as follows:

1. Right-click the SQL Server instance, and then select Properties.
2. Inthe Server Properties window, click Memory (left-hand pane).

3. Set the Maximum server memory amount to 4000 (or whatever limit you determine).

Recovery Model
Sage recommends that you use the Simple recovery model for your Estimating database.

During the upgrade process, the program now shrinks the existing log file, which can become very large, and it
removes invalid estimates. However, it does so only if the database recovery model is set to Simple in the SQL
Server software. We do not recommend that you change the recovery model unless your business requires
features available only in a different model.

Communication Protocol
Set the communication protocol settings for the Sage Estimating SQL Server instance as follows:
1. Start the SQL Server Configuration Manager.
Click Start > All apps > Microsoft SQL Server > SQL Server Configuration Manager.

2. Inthe left-hand pane of the SQL Server Configuration Manager window, click the arrow next to
SQL Server Network Configuration to display all local SQL Server instances.

3. Select the instance associated with Sage Estimating (SAGE_ESTIMATING, by default).
4. Inthe right-hand pane right-click a communication protocol, and then select Disable.

5. Repeat step 4 for all communication protocols except TCP/IP. Leave this protocol Enabled.
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6. Inthe left-hand pane of the SQL Server Configuration Manager window, click the arrow next to
SQL Native Client 10.0 Configuration.

7. Click Client Protocols (left-hand pane).

8. In the right-hand pane right-click a communication protocol, and then select Disable.

9. Repeat step 8 for all communication protocols except TCP/IP. Leave this protocol Enabled.

10. Close the SQL Server Configuration Manager and restart the service.

Copying Databases from Other Instances

Sage Estimating allows the use of just one active SQL Server instance at a time. This instance is a "closed"
SQL Server instance. Sage Estimating does not recognize databases (Address Book or standard databases)
transferred or copied from other SQL Server instances unless they are added by way of the Search For feature
in the Estimating Management Console.

For example, if you have two Sage Estimating installs, Install A and Install B, you cannot copy Address Book
databases by copying them from Install A's SQL Server instance to Install B's SQL Server instance alone
(using SQL Server Management Studio's built-in Copy Databases wizard, for example). You also need to open
the Estimating Management Console and use the Search For ~ button in the Address Book
Companies/Contacts toolbar.

Copying Databases From One SQL Server Instance to Another

You must use the Search For
feaureX for instance B to
recognize databases copied

/ from instance A.

Sage Estimating
SQL Server instance B

Databases Sage Estimating
SOL Server instance A

Any database you add to an instance must have the same Sage Estimating version as the other operating
databases. For example, if you are using Sage Estimating 25.1, and you want to add a standard database from
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a previous Sage Estimating installation, upgrade the standard database to version 25.1 before adding it to the
new instance. Refer to the Estimating Management Console in-product Help for instructions on using the
Search For feature.

You can switch active SQL Server instances at any time for Sage Estimating by starting the Configuration
wizard, selecting Server from the left-hand pane, and clicking [Change] from the right-hand pane.
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Chapter 6: Managing Your License

This chapter provides detailed information about the Sage online licensing system.

About the License Server and the Sage Online Licensing
System

When you activate your product license on the license server, your Sage products and features are registered
on and managed from that computer. As you purchase or remove licenses, the Sage online licensing system
updates this information on your License Server.

The license server communicates with Sage daily, keeping your licenses up to date automatically.

You can view your licenses and (if necessary) update registration information manually using the License
Administration window. The License Administration window displays the number of license uses for the CORE
Estimating product, and it lists any additional modules and features you have purchased.

By default, all license uses are allocated to your Sage license server. The Sage license server then provides
license uses to individual computers on your network.

Sage Estimating and the Sage License Server

You need a license to use Sage Estimating. You acquire a license use from the license server when you start
Sage Estimating on your workstation. Therefore, the computers running Sage Estimating software need to be
connected to the Sage license server

The license server keeps track of the products, features, and number of license uses that are available to you
and other users, and will make a license available to you, unless all the licenses are currently being used.

If you need to use Sage Estimating while you are not connected to the Internet (for example, when you are
away from the office), you can check out a license for offline use. For more information, see "Checking Out a
License for Offline Use" (page 50).

Note: In previous versions of Sage Estimating, licenses were managed using a physical dongle. This
hardware is no longer required.
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Estimating Modules and License Uses

Used as a standalone application, the CORE Sage Estimating (SQL) is a powerful, flexible tool for estimating
all types of construction projects.

You can also purchase the following add-on modules to extend the functionality of Sage Estimating to suit the
needs of your business:

e Crews
¢ Models

e Advanced Reporting, which includes the Comparison Report, the Variance Report, and Custom
Reports.

o eTakeoff

Note: These modules are licensed separately from the CORE Sage Estimating product. Certain
capabilities, menus, and icons described in help are available only if you have purchased the associated
module. Contact your Sage sales representative for more information about modules and feature
bundles.

General Licensing Steps

After installing Sage Estimating (SQL) on a server and individual workstations, you:
1. Configure your License Server using the License Administration window.
e Designate a computer on your network or workgroup as the Sage license server.

* Onthe License Server, enter and send registration information to Sage to activate the licenses for
the products and features you have purchased.

2. Connect individual workstations that will run Sage Estimating (SQL) to the Sage license server using the
Configuration Wizard.

The following sections describe these steps in more detail.

Designating a Sage License Server

One of your first tasks when setting up your Sage Estimating system is to designate a computer on your
network to act as your Sage license server.

When deciding which computer to use as the Sage license server, keep in mind that the Sage license server
must:
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¢ Remain connected to the Internet for daily validation of licenses.

» Be available continuously to other network computers running Sage Estimating, so that they can
acquire licenses for your Sage Estimating products.

Tip: In some situations, you may need to designate more than one computer as a license server. For
information about allocating licenses to multiple servers, see "Multiserver Licensing" (page 47).

When you designate a computer as a license server, you need to supply the full name of the computer you
want to use as the license server. (Alternatively, you can supply its IP address.)

To determine the computer name of the server:
1. Open the Windows Control Panel.
On the Start menu, click All Apps > Windows System > Control Panel.
2. From the Control Panel, click System and Security > System to display the System Properties window.

3. Under Computer name, domain, and workgroup settings, locate Full computer name, and then make a
note of the name.

4. Close the Control Panel.

To designate the Sage license server:

Important! License uses are allocated to the designated computer when you submit your registration
and activate your licenses. If you need to move your Sage Estimating (SQL) server to a different server,
later, you need to deauthorize the licenses on the License Information tab on the old server before you
can activate them on a new server.

1. On the computer where you plan to activate your license, start License Administration.

2. Click Change server.

3. In the Specify License Server window:

a. Inthe Computer box, enter the name of the computer running the license server.

b. Inthe Port number box, type 48650 if that is not the port number displayed in the box.
4. Click [OK].
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Registering the Software and Activating Licenses

To activate your license:
1. On the machine designated as your license server, open the License Administration window.
Click Start > All Apps > Sage Estimating > License Administration.
2. Check that computer named in the License server box is the designated license server.

If License Administration is not pointing to the correct server, click Change server, and then enter the
correct computer name or IP address of your license server.

3. Inthe Registration Information section, submit your registration details as follows:
a. Click the Edit registration information link.
b. Inthe Sage client ID box, type your client number.
c. Inthe Registration name box, type your registered company name exactly as provided by Sage.
d. Click [OK]

If the activation was successful, the Licensed Modules grid displays the modules and number of
uses that you have purchased. Your license server is now ready to serve licenses to your Sage
Estimating (SQL) users.

If the activation was successful, the Licensed Modules grid displays the modules that you have
purchased.

Connecting to the License Server from Sage Estimating

Before you can use Sage Estimating on a client workstation, you need to connect the workstation to your Sage
license server. Then, when you start Sage Estimating, the program automatically acquires a license use for the

workstation.

To connect to the license server:

1. On your workstation, open the Specify License Server window:

a. Start the Estimating Configuration Wizard.

b. Inthe navigation pane, click Licensing.
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c. Inthe right-hand panel, select the Connect to a remote license server option.
d. Click [Specify remote server].
2. Inthe Specify License Server window:
a. Inthe Server box, enter the name of the computer running the license server.
b. Inthe Port box, type 48650 if that is not the port number displayed in the box.

3. Click [OK].

Updating License Information

The Sage license server automatically retrieves license information from Sage every day. The licenses give
you access to the various modules of Sage Estimating (SQL). As you purchase or remove license activations,
the license server automatically updates this information in your system.

You can also update the licensing information manually, as follows:

1. Open License Administration.

2. Ensure that License Administration tool is pointing to your designated License Server machine.
3. On the License information tab, click the Update license information link.

Your Sage license server then contacts the Sage online licensing system to update your license
information, as needed.

Deauthorizing a License Server

When you set up your Sage license server, the Sage online licensing system allocates the licenses for your
purchased Sage Estimating modules and license uses to that computer.

At some point in the future, you might need to designate a different computer as the license server (for
example, if you want to upgrade the server to a new computer) or change your registered company name.
However, you cannot allocate licenses to a new computer or a new company while they are allocated to the
original server.

Before you can reallocate your licenses to a different license server, you need to release the allocated licenses
to the Sage online licensing system. You do so by deauthorizing the original license server, enabling you to
configure the new license server and register the licenses to that machine.

Caution! Do not deauthorize your license server if any users are working with Sage Estimating programs
or have license uses checked out. Doing so can lock the licenses, requiring Sage Customer Support to
resolve.
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To deauthorize your Sage license server:
1. Check your current license server information:
a. Start License Administration.

b. Ensure that the License server box contains the name of the computer you want to deauthorize.

2. Deauthorize your current license server:

a. Ensure that no other users are working with Sage Estimating.

b. Click Deauthorize license server.

You should receive a message saying that deauthorization was successful.

Changing Your Company's Registration Information

Caution! Do not change registration information if any users are working with Sage Estimating programs
or have license uses checked out. Doing so can lock the licenses, requiring Sage Customer Support to

resolve.

To change your registration information:

1. Deauthorize your current license server.

Important! This step is crucial. You need to release your allocated licenses to the Sage online licensing
system so that they are available to reallocate to the "new" company. Make sure you receive a
message saying that deauthorization was successful before you proceed.

2. Change your company's registration name:

a. Click Edit registration information.

b. Enter your new registration information in the Sage client ID and Registration name boxes.

c. Click [OK].

If the new registration is successful, the Licensed Modules grid displays your licensed modules and
license uses with your new registration information.

Note: If you are using licensed standard databases, you need to obtain new activation codes for these
databases after changing your registration information.
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Moving Your Sage License Server to Another Computer

Caution! Do not try to change your license server if any users are working with Sage Estimating
programs or have license uses checked out. Doing so can lock the licenses, requiring Sage Customer
Support to resolve.

To move your license server to another computer.
1. Verify the full computer name of the computer you want to use as the new license server.

2. Deauthorize your current license server.

Important! This step is crucial. You need to release your allocated licenses to the Sage online licensing
system so that they are available to reallocate to the server. Make sure you receive a message saying
that deauthorization was successful before you proceed.

3. Click Change server, and then, in the Specify License Server window:

a. Inthe Computer box, type the full name of the computer you want to use as the license server.

b. Click [OK].

Important! Entering a new computer name in the Specify License Server window points the License
Administration window to a different machine, enabling you to administer licenses on that license
server.

4. To update your registration information, click Edit registration information, type your Sage client ID and
registration name in the boxes provided, and then click [OK].

If the new server is authorized successfully, the Licensed Modules grid displays your licensed modules
and license uses with your new registration information.

Note: After changing the license server, you will need to reconfigure each Estimating workstation to point
to the new license server.

Multiserver Licensing

If you need to administer your company's licenses from two or more license servers, you can allocate licenses
manually to different computers.

Allocating licenses to multiple servers involves two main tasks:
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1.

You reduce the total number of license uses allocated to the original license server, releasing some

license uses.

2. You point to a second license server, and then allocate the remaining license uses to that server.

You use the Multi-Server License Administration window to reallocate license uses to secondary license
servers.

Example: Your company has purchased a license for Sage Estimating with 10 license uses. You want to

allocate 8 of those uses to your main server and 2 uses to a server at your satellite office.

The following steps assume that you have an active license server with 10 uses.

To reduce the license uses allocated to the original license server:

1.
2.

5.
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Start License Administration.

Ensure that the License server box contains the name of your designated license server.

On the License information tab, click Multi-server licensing.

The Multi-Server License Administration window appears, with the total number of license uses allocated to

this server by default.

Select Manually specify license allocations for this server.

This step enables you to change the number of license uses for the current license server.

Multi-5erver License Administration

() Mlocate all available licenses to this server (default)

(@ Manually specify license allocations for this server in the "Uses for

" column below:

Module name Total uses Awailable uses Uses for
Core 100 0 0 |
Advanced Reporting unlimited unlimited unlimited
Crews unlimited unlimited unlimited
ePlan Takeoff unlimited unlimited unlimited
Models unlimited unlimited unlimited
Cancel Help

In the Uses for <machine name> box, type the number of uses you want to allocate to the current server.
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In our example, allocating eight license uses to the current server releases two uses that can be allocated to a
second server.

6. Click [OK].

. Note: You need to have access to the secondary license server and connect to it in the following task.

To allocate residual licenses to a different server:
1. In the License Administration window, connect to the secondary license server:
a. Click Change server.
b. Inthe Specify License Server window, type the full computer name (or IP address) of that server.

2. Click Edit registration information.

3. Inthe Registration Information window, enter the same Sage client ID and registration name used on
the original server.

4. Click [OK].

The Licensed Modules grid displays your purchased modules, and shows the residual license uses that
allocated to this server.

Monitoring License Use

You use the License Administration window to view license uses, the users who are logged on to Sage
Estimating, and the licensing events for the current license server—that is, the computer specified in the
License server box.

» To view which users are logged on to Sage Estimating, click the Active users tab.
» To view checked-out licenses, click the License information tab.
» To view the results of license update attempts, click the Event log tab.

* Click Clear event log if you no longer need the information.

Viewing licenses for a different license server

Initially, the current license server is the one on which you activated your licenses. If you allocated license uses
to another Sage license server and you want to view activity for that server, you "point" the License
Administration window to that server, as follows:
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1. Inthe License Administration window, click Change server.

2. Inthe Specify License Server window, enter the computer name and port number for the secondary
server.

Checking Out a License for Offline Use

If you anticipate a need to use Sage Estimating when your computer cannot communicate with the license
server, you can check out a license use from the Sage license server while you are still connected.

Important! Checking out a product license use removes it from the license server's pool of available
license uses and places it directly on the computer checking out the license. Because checking out a
license may prevent other users' access to Sage Estimating, you should check out a license only when
necessary, and check it back in promptly when you are reconnected to your network.

Before checking out a license

To work offline, you need to take additional steps besides checking out a license. For example, you need to
have a local SQL Server instance that contains an estimates database, as well as copies of your standard
database and address book if needed.

You also require a backup copy of any estimates (exported from your server) that you plan to work with while
you are offline. You import those estimates into your local estimates database.

Also, if you are using Sage Estimating in a workgroup environment, you need to change the Sage Estimating
Licensing Service to run under your local system account. For more information, see the section, "Running
the Sage Estimating Licensing Service under Your Local User Account” (page 51).

To check out a license use:
1. Inthe Sage Estimating main window, click File > Check Out License.

2. Click[Yes].

Note: If you check out a license use, it remains checked out on this computer until you check in the
license using Check In License from the File menu.

To check in a license use:
1. Inthe Sage Estimating main window, click File > Check In License.

2. Click [Yes].
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Running the Sage Estimating Licensing Service under Your Local User Account
Sage Estimating operates in two kinds of environments:

» Domain-controlled, which uses a secure and centralized network authentication protocol.

» Workgroups, which use an older type of authentication that is not centralized. (This includes hosted
environments, such as Azure, with multiple machines networked in the cloud).

In a domain environment, checking out a licenses works automatically. You do not need to change the Sage
Estimating Licensing Service before you check out a license.

However, in a workgroup environment, checking out a license is not automatic because the default security
protocol does not work in a decentralized environment with anonymous users. Therefore, when configuring
Sage Estimating to run in a workgroup environment, you need to set up the Sage Estimating Licensing Service
to run under your local user account on your computer:

To set up the licensing service to run under your local user account:

1. In Windows Services, right-click Sage Estimating Licensing Service 4.6, then click Properties.

2. Click the Log On tab.

3. Inthe This account box, type your user account ID for your local machine .

4. Inthe Password and Confirm Password boxes, type the password for your local account.
5. Click [Apply].

6. Click [OK].

7.

Restart the Sage Estimating Licensing Service.

Troubleshooting License Server Issues

This section provides suggestions to resolve some of the common issues that can occur with your Sage Sage
Estimating (SQL) licenses.

The Registration Information Does Not Match

The Sage client ID and Registration Name on the License Administration window must match the information
on the Sage license server. Ensure the information is entered correctly here.

You Exceeded Your License Activations

You do not have enough licenses to support everyone attempting to use Sage Estimating. You may want to
purchase more licenses.
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Tip: The Number of requests which exceeded use count box on the License information tab of the
License Administration window displays the number of times in the last three months that requests for
licenses have exceeded the number of licenses available.

Disconnection from the Network

Note: This information does not apply if you are running Sage Estimating and the Sage license server on
one computer as a stand-alone installation.

If a workstation is disconnected from the Sage license server while you are using the License Administration
window or the Configuration Wizard, the system displays a Disconnected from the License Server message.

Since our products run on your company's network, it is important to maintain the network connection between
workstations and the Sage license server. When your workstation is disconnected from the Sage license
server, you cannot connect the workstation to the license server or perform license administration functions
from the workstation.

To reconnect to the license server:

1. Wait a few minutes, and then try again to use the Configuration Wizard.
2. Ifthe workstation is still disconnected, check whether the network cable is unplugged.
3. If the workstation remains disconnected, check whether a network drive is disconnected.

4. Contact your network administrator.
When you have restored your connection to the Sage license server, you can use the License Administration
window and the Configuration Wizard to perform licensing tasks.

Connectivity across Your Network

To run Sage Estimating, client workstations must be connected to the Sage license server and to the computer
that hosts the SQL Server instance you are using for Sage Estimating.

If only one user sees the “Sage Estimating (SQL) can’t communicate with the designated Sage license server”
message when all other users are connected, you know that the connectivity problem is limited to that one
person.

If you encounter a hardware failure with your license server, no one can run Sage Estimating.

Disconnected Network Drive

When your workstation is disconnected from the network drive for the Sage license server, you cannot perform
license administration functions from the workstation.
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To check whether a network drive is disconnected:
1. Click [Start] > My Computer.
2. Inthe Network Drives section, check the Type column for the network drive for the Sage license server.

3. Ifthe Type is Disconnected Network Drive, select the network drive and then select another network
drive.

4. Ifthe Type changes to Network Drive, try to use the Configuration Wizard.

5. Ifthe Type remains Disconnected Network Drive, contact your network administrator.

Network Cable Unplugged
When the network cable is unplugged from your workstation, you cannot perform license administration
functions using the License Administration tool.
To check whether a network cable is unplugged:
1. Check the notification area, at the far right of the taskbar, for the message A network cable is unplugged.
« If you see this message, reconnect the network cable to the workstation.
« If you do not see this message, check the network connections:

a. Click [Start > Control Panel > Network Connections.

b. Inthe LAN or High-Speed Internet section, check the Status of the Local Area Connection.

* Ifthe Status is Network cable unplugged, reconnect the network cable to the
workstation.

 [f the Status is Connected, the network cable is connected to the workstation.

2. Tryto use the License Administration tool.

Windows "Sleep Mode" Prevents Computers from Obtaining a
License Use

If the computer you are using as your license server goes into sleep mode, other computers on the network
cannot obtain a license.

Set Sleep Mode on your license server computer to Never.
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To set the Sleep Mode to “Never”:

1. Start > All apps > Control Panel > System and Security > Power Options.
2. Select Change when computer sleeps.

3. From the Put computer to sleep list, select Never.
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