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About the On-Screen Takeoff Integration 
Guide

If you use On-Screen Takeoff (OST) estimating software, you can set OST to interface with Sage 
Estimating through the On-Screen Takeoff Integrator. The OST Integrator lets you perform takeoff to 
estimates in Sage Estimating from drawings you create and store in OST.

Note: This feature is available only if you have a license to use ePlan Takeoff.

Read the Supporting Documentation Before You Begin
This On-Screen Takeoff Integration Guide provides installation, setup, and operating instructions for On-
Screen Takeoff Integrator . Be sure to read it, as well as the following supporting documentation, before 
you install and configure Sage Estimating: 

 l The Installation and Administration Guide includes an overview of this release, installation 
instructions, system requirements, and contact information.

 l The Release Notes  provide details about new features, database changes, known issues, and fixes. 

 l The Getting Started Guide provides an operational overview of the Sage Estimating software. 

 l The SQL Server Guide gives you an overview of the significant differences between the new 
SQL Server databases and the Pervasive databases used in previous Sage Estimating releases. 

Conventions Used in this Document
This document uses the following conventions:

 l Information you type into the software is shown in bold font. For example: Type Miscellaneous in the 
box.

 l The names of screens, windows, fields, and other features displayed by the software are shown in 
bold font.

 l Names of keys are also shown in bold font. For example: Enter or Tab. A plus sign (+) between two 
key names indicates you should press the keys simultaneously.
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 l The names of buttons you can click are shown in bold font and enclosed in brackets. For example: 
[OK] or [Post].

 l Variable names or names that are specific to your installation may appear in italics and brackets. For 
example: [Drive]\\[Server].

Notes, Tips, and Cautions

Note: A Note indicates that the information supplements the adjacent text.

Tip: A Tip indicates helpful points about using the software.

Caution! A Caution indicates important information to help you avoid a loss of critical data.

Important! An Important note indicates critical information that you need to understand or important 
steps you need to take.

Menu Paths

In this document, menu paths show you the steps required to start a task. Menu paths appear in bold font 
with square brackets around buttons. For example:

"If the program does not automatically start, click [Start] > Run."

Ways to Get Help
Use Sage Estimating Help or a variety of self-help resources to get answers to your questions. You can 
also call Customer Support.

The Help System

Sage Estimating Help provides more efficient access to information than most manuals. With a click of the 
mouse or a keystroke, you can easily get Help for a command, a field, a window, or a procedure.
(missing or bad snippet)

To get Help on a window option

To display Help for an option in a window, do one of the following:

 l Click  What's This? on the toolbar or on the title bar, and then click the option.

 l Select What’s This? from the Help menu, and then click the option.
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 l Select the option, and then press F1.

To get Help for the whole window

For information about the window, such as the window's purpose and what tasks you can perform in it, click 
[Help] at the bottom of the window.

The Window Help Button
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To use Help to learn how to do tasks

 1.  Click [Help] on the toolbar, or select the Home tab > Help group > Help (or select Help menu > 
Help topics in classic view). 

The Help Window

 2. Use one of these tabs on the navigation pane to begin looking for a topic. 

 a. Contents contains Help subjects organized within books.

 b. Click the Glossary heading on the Contents tab to view an alphabetical list of definitions of 
terms used throughout the Sage Estimating software.

 c. Index contains an alphabetical list of Help subjects.

When you see the topic you want, double-click it to display it.

 3. Use the Search box to find articles that match the keywords you enter.
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About Integration with Sage Estimating

The On-Screen Takeoff (OST) Integrator lets you perform item and assembly takeoff in Sage Estimating 
from drawings you create in On-Screen Takeoff.

The OST software organizes parts and materials required for a job into collections known as conditions. 
However, Sage Estimating organizes materials in its databases into individual items and collections called 
assemblies. You must convert or integrate OST conditions into items and assemblies before you can 
create estimates in Sage Estimating through OST takeoff.

Integration involves three primary steps:

 1. Select a condition for takeoff in OST.

 2. In the OST Integrator, select a Sage Estimating item or assembly that is comparable to, or the 
equivalent of, the OST condition. 

For example, if you select "Drywall sheeting" for takeoff in OST, find a Sage Estimating item or 
assembly that most closely matches the selected drywall sheeting.

 3. Note the physical properties of the selected OST condition, such as length or height, and type any 
conversion factors as necessary to equate it with the assigned Sage Estimating item or assembly. 

For example, if the drywall board length in OST is measured in meters, and the assigned Sage 
Estimating item measures length in feet, type the conversion factor required to equate the two.

Illustration of the Integration Principle

On-Screen Takeoff Integrator Features

The On-Screen Takeoff Integrator Main Window

The main window of the On-Screen Takeoff Integrator is divided into three separate panes.
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Condition Assignment Pane

The Condition Assignment pane provides a list from which you can  match or assign items or assemblies in 
Sage Estimating with conditions in an OST database.

For example, if you are working with an OST project or drawing that has a condition for 30 square feet of 
ceramic floor tile, and the closest equivalent in a Sage Estimating database is the 04-00-10 Masonry, Tile 

assembly, select the ceramic floor condition in the list, click the Assign Assembly button , and select the 
04-00-10 assembly to assign it to the ceramic floor condition.

Sage Estimating items and assemblies appear in the list beneath the OST conditions to which they are 
assigned.

Condition Properties Pane

The Condition Properties pane displays the physical qualities of any OST condition  selected in the 
Condition Assignment pane, such as depth, height, or count (number). You must "map" these properties to 
their Sage Estimating equivalents in the Integration grid when you assign an item or assembly  to an OST 
condition. 

For example, if the selected OST condition has a length of 30 meters as a physical property or dimension, 
and the Sage Estimating assembly you assign to it measures length in feet, you must map the 
OST condition's length (using the Integration grid) to the assigned assembly's length and indicate the 
conversion factor from meters to feet.
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Mapping condition properties enables the OST Integrator to create accurate estimates when performing 
takeoff from an OST condition.

Integration Grid

Use the Integration grid to "map" or convert the properties of an OST condition to the variable equivalent of 
its assigned Sage Estimating item or assembly.

For example, if you are working with a "drywall ceiling" condition from an OST drawing that has a length of 
30 meters, and you assign the 09-00-10 Drywall assembly from Sage Estimating to it, you must ensure the 
Sage Estimating assembly has a variable  equivalent for length in meters.

To begin mapping, select any condition from the Condition Assignment pane that already has a Sage 
Estimating item or assembly assigned to it. The grid displays the estimating variables and OST condition 
properties associated with the selected condition.

Refer to the OST Integrator in-product Help for  information about specific columns in the grid.
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Performing Integration

Before you start

Before integrating OST items and conditions with Sage Estimating items and assemblies:

 1. Start the OST Integrator from Sage Estimating.

To start the OST Integrator:

 l On the ribbon, from the On-Screen Takeoff group on the Advanced tab,, click On-Screen 
Takeoff Integrator .

 l In classic view, click Interface > Open OST Integrator.

 2. Open an OST database.

You can open either a Microsoft Access-based OST database or a Microsoft® SQL Server®-based 
OST database for integration. See the OST Integrator Help for more information.

 3. Select both the OST database and the Sage Estimating database you want to use for the 
integration and takeoff  processes. 

Integrating OST conditions with Sage Estimating items and 
assemblies

To integrate OST conditions with Sage Estimating items and assemblies:

 1. Select a condition for takeoff in OST.

 2. In the OST Integrator, click the Goto button   to view the selected condition and its associated 
items in the Condition Assignment pane of the OST Integrator. 

 3. In the Condition Assignment pane, expand the OST condition to view any items or assemblies 
already assigned to it.

Note: You can right-click on any condition and select Expand condition to expand it.
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 4. Click the assign item button  to open the Item List window or the assign assembly button  to 
open the Assembly List window.

This window lists all available Sage Estimating items or assemblies in the selected Sage Estimating 
standard database.

 5. Select an item from the list in the Item List window  or an assembly from the Assembly List window 
and click [OK].

The assigned item or assembly then appears in the Condition Assignment pane beneath the 
condition to which you assigned it. 

 6. The variables  associated with the assigned Sage Estimating item or assembly appear in the 
Integration grid.  The properties associated with the selected OST condition appear in the Condition 
Properties pane. You must "map" or match one or more condition properties to a Sage Estimating 
variable:

 a. For the first variable listed in the Estimating Variable column, select an equivalent condition 
property from the list in the Condition Property column.

For example, if the first Sage Estimating variable is Width, select a width-based condition 
property from the Condition Property list.

 b. You can also select a condition property by clicking on a property in the Property column of 
the Condition Properties pane and "dragging" it to the Condition Property column of the 
Integration grid.

Mapping Properties

If no equivalent condition property is available, leave the Condition Property column blank.

 c. If you select a condition property, and a conversion factor is required, type it in the Conversion 
Factor column. 

For example, if the Sage Estimating variable Length is measured in Inches but the condition 
property Length is measured in Feet, the conversion factor is 12/1 or 12.
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If you did not select an equivalent condition property in step a, specify the Sage Estimating 
variable's value by typing directly in the Value column.

 d. Repeat steps a-c for each Sage Estimating variable in the grid.

 7. Repeat steps 1-6 for each OST condition you expect to use during takeoff.

 8. Click [Save] to save your changes.

Performing One-Time Integration
You can integrate values from an OST condition property with an item or assembly dimension in Sage 
Estimating on a one-time basis. You can do this by dragging the OST condition into the dimension grid of 
the Item Takeoff window, Assembly Takeoff window, or Quick Takeoff window in the Sage Estimating 
software.

For example, if you are taking off an assembly in Sage Estimating that requires the Single Ply Roof 
condition from OST to be added to it, you can select each associated property Value from the Condition 
Property pane in the OST Integrator and "drag" it to the Assembly Takeoff window in Sage Estimating. The 
Single Ply Roof condition properties are then added to the assembly.

The Sage Estimating items and assemblies retain the OST condition value integration for one takeoff only. 
If you want to integrate OST conditions and Sage Estimating items and assemblies for more than one 
takeoff, you must perform the integration in the OST Integrator using the procedure in "Performing 
Integration" (page 8). 

To perform a one-time integration with a Sage Estimating estimate:

 1. In Sage Estimating, open the Item Takeoff, Assembly Takeoff, or Quick Takeoff window.

 2. In the OST Integrator, open the OST project containing the condition or conditions you want to add 
to the estimate.

 3. Select the condition you want to add from the Condition Assignment pane of the OST Integrator.

 4. From the Condition Properties pane, select the condition property Value that you want to add to the 
estimate—for example, the values associated with the "width," "height," or "quantity"—and "drag" it to 
the dimension grid of the Item Takeoff window, Assembly Takeoff window, or Quick Takeoff window 
in Sage Estimating.

Selecting a Value for Integration

10Sage Estimating (SQL) v20.1 On-Screen Takeoff Integration Guide



 5. Repeat steps 2-4 to integrate all desired OST conditions with the estimate.

Performing Takeoff to Estimates
After you integrate OST conditions with Sage Estimating items and variables, the OST Integrator allows 
you to create estimates in Sage Estimating using conditions and items you take off from OST projects.

To take off OST items and conditions to an estimate:

 1. Select an OST project from the list in the Condition Assignment pane.

 2. Click the new estimate button to create a new estimate. 

Alternatively, you can open an existing estimate by clicking the update estimate button. 

 l If you are creating a new estimate: Type a name for the new estimate in the New Estimate 
window; then specify an estimate database for storing it, a standard database to associate with 
it (optional), and the estimate "branch" where you want it displayed then click [OK] to create 
the new estimate.

 l If you are opening an existing estimate: Select the existing Sage Estimating estimate from the 
estimate list then click [Open] to open it.

The OST Integrator adds items and assemblies already assigned to conditions in the 
OST project to the new or existing estimate. If desired, you  open the estimate immediately 
after creating it.

Note: For existing estimates only: If you previously generated items and assemblies from the OST 
project to the selected estimate, the OST Integrator deletes the items and assemblies before adding 
new ones.
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Using Condition Style Libraries
Using the OST software, you can create a library of condition styles that you can then use in more than one 
project.  A corresponding condition style library appears in the Condition Assignment pane of the OST 
Integrator.

If, for example, you create a condition in an OST project for right-hand doors called RH Door, you can 
choose to save the condition in the OST style library for use in other projects. In the OST Integrator, the 
RH Door condition automatically appears in the Style Library of the Condition Assignment pane. 

Condition Styles in the Condition Assignment Pane

After saving conditions as styles in the condition style library, you can assign Sage Estimating items and 
assemblies to them in the OST Integrator (see "Performing Integration" (page 8) for instructions). 

You can then use the integrated condition styles in future projects whenever they are required.

You can create and edit condition style libraries only in On-Screen Takeoff. 

Note: Each OST database has only one condition style library.
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Importing and Exporting Condition 
Assignments

You can import and export integrated condition assignments in extensible markup language (XML) files. 
Use this feature when you want to transfer integrated condition assignments from a Sage Estimating 
standard database in one location to a standard database in another location.

For example, if you assign OST conditions to  Sage Estimating items and assemblies in a standard 
database on your local computer, and you want to integrate those same assignments into another 
standard database (such as a shared standard database on a server, for example), export the integrated 
conditions to file then import them into the shared database.

To export assignments to a file:

 1. In the OST Integrator, open the standard database containing the assignments you want to export.

 2. Select Import/Export group > Export the assignments to a file (in classic view, select File > Export).

 3. Type a file name for the export file in the File Name box and browse to the location where you want 
the file saved.

 4. Click [Save].

The OST Integrator saves the condition assignments to an XML file (.osti extension) that you can import 
later.

To import assignments to a file

 1. In the OST Integrator, open the standard database where you want the condition assignments 
imported.

The target standard database you select must have the same items and assemblies as those in the 
.osti file or an error results during import.

 2. Select Import/Export group > Import an assignments file (in classic view, select File > Import).

 3. Select the import file containing the assignments you want to import (.osti extension).

 4. Click [Yes] at the prompt.

The OST Integrator overwrites all current condition assignments in the  standard database when you 
import the assignments from file.
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 5. Right-click on the OST database in the Condition Assignment pane and select Change the Database 
Path.

 6. Browse to the location of the OST database containing the integrated conditions click [Open] to 
update its location relative to the imported condition assignments.
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