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Creating Sage Estimating Reports with the
SAP Crystal Reports Designer

This booklet describes how to use SAPCrystal Reports® to create a report that will print data for a selected
estimate in Sage Estimating. It was designed to help users of all versions of Sage Estimating (SQL). Tables
and views that were introduced after the initial release of Sage Estimating are indicated in "Appendix:
Using Sage Estimating Data on Reports" (page 8).

Note: This booklet assumes that you have a Report Designer role and that you understand how to use
Crystal Reports Designer.

Overview
You use Report Manager in the Estimating Management Console to create estimate reports based on
Crystal Reports designs.

In Report Manager, you specify a Crystal Reports (RPT) file on which to base the estimate report. Report
Manager creates a copy of the report design in a custom reports database, and uses this copy for all
subsequent modifications to the report. Whenever you edit the report design, you check it out from the
custom reports database. (You do not use the original report design file again.)

Before you can create report designs, you must also use Report Manager to generate report sample data.
Report Manager creates tables for the sample data in a separate custom reports database based on one
or more representative estimates that you select. You use the tables and the fields contained in this
sample database when you set up your Crystal Reports design.

Note: An Estimates database can contain many estimates with a mix of features, but you print a report
for one estimate at a time. Therefore, you need to set up your report designs to extract data from a
single estimate.

Before you start

Before you can create a report design in Crystal Reports, you must:

1. Create a blank RPT file.

2. Generate sample data for the custom reports database.
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Creating a blank Crystal Report (RPT) file

3. Identify the EstimateId for a representative estimate that you will use when designing the report.

Creating a blank Crystal Report (RPT) file

Note: This step is required only if no other reports exist in Report Manager. If you have existing reports,
open the Estimating Management Console, select any report, and then skip to step 4 under "Generating
sample data for the custom reports database" (page 2)

One of the steps in the "Using the Standard Report CreationWizard to Create an Estimate Report" (page
4) section requires you to select a blank Crystal Report (RPT) file.

If you do not already have a report file, create one as follows:

1. Start SAP Crystal Reports.

2. On the Start Page tab, click Blank report.

3. In the Database Expert window that appears, click [Cancel].

4. On the main menu, click File > Save.

5. In the File name text box, type blank.rpt.

6. Navigate to an easy-to-access folder.

7. Click [Save].

8. Exit the program.

You will select this file, later, in the Report Manager.

Generating sample data for the custom reports database

Use the Estimating Management Console to create sample data for your report designs:

1. Click [Report Manager] on the toolbar.

2. Click New Report > Crystal Report.

3. In the New Report window:

a. In the Report box, type a name for the report you want to create.

b. From the Filename box, browse to and select the report design file (.RPT) that you saved
earlier.

c. Click [OK].
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Creating a blank Crystal Report (RPT) file

4. Select one or more estimates from the grid (lower right-hand pane) to use for sample data, and then
click [Generate Data].

5. When prompted to select options for the report working data, click OK to accept the default
selection.

Report Manager stores the sample data in a custom reports database, where it is available to use
when you are designing reports.

6. Click [Check In].

Identifying a representative estimate in the custom reports database

When creating a Crystal Reports design, you must identify a single estimate that has the characteristics
you want to report on. When you run an estimate report, Sage Estimating uses the EstimateId of the
estimate displayed at run time. However, when designing the report, you need to supply the EstimateId for
a specific estimate that you will use to lay out the report elements.

To find the EstimateId values that are available in the custom reports database, query the
values using SQL Management Studio, as follows:

1. Start Microsoft SQL Server Management Studio.

2. In the Connect to Server window, connect to the SQL database.

3. For Server type, select Database Engine.

4. For Server name, select your Sage Estimating server.

5. In the Object Explorer:

a. Expand the Databases node.

b. Expand the *ReportDesign* database.

c. Expand the Tables node.

d. Right-click the Report.Estimate_v1 line on the table.

e. Click Select top 1000 rows.

The Results tab displays the estimates available in the custom reports database, including the
EstimateIds and the names of the estimates.

Write down the EstimateId for the estimate that you want to work with when you design the report.
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Using the Standard Report CreationWizard to Create an Estimate Report

Using the Standard Report Creation Wizard
to Create an Estimate Report

Note: These instructions assume that you are using Crystal Reports 2013 with Support Pack 2. If you
use a different version, the workflow may be different.

All of the steps and parameters in this section are required to report on a Sage estimate.

Step 1: Create a report and connect it to the custom reports database

1. Start Crystal Reports.

2. Select File > New > StandardReport.

3. Using the Standard Report Creation Wizard:

a. Expand Create New Connection.

b. Expand OLE DB (ADO).

c. In the OLE DB (ADO) Fields OLEDB Provider window:

i. Select SQL Server Native Client 10.0.

ii. If you are using Microsoft SQL Server 2014, select SQL Server Native Client 11.0.

iii. Click [Next]

d. In the OLE DB (ADO) Connection Information window:

i. In the Server field, enter your SQL instance. For example, enter (local)\SAGE_
ESTIMATING.

ii. Select the Integrated Security check box.

iii. For the Database option, select your custom reports database.

iv. Click [Finish] to return to the Standard Report Creation Wizard.

Step 2: Select the tables you want the report to use

Tip: For a list of the tables you can link to a report, see "Appendix: Using Sage Estimating Data on
Reports" (page 8)
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Using the Standard Report CreationWizard to Create an Estimate Report

1. On the Data tab:

a. Expand the database node you just added.

b. Expand the Report schema node.

c. Select the Estimate_v1 table.

Important! You must select Estimate_v1 or you will not be able to complete Step 4..

d. If you want to include additional tables, select other tables, such as Item_v1.

e. Click [Next].

2. On the Link tab, click [Next].

Step 3: Select the fields to include in the report

Tip: You can use the SQL Server Management Studio or the Crystal Reports Designer to view the
names of fields in each table. For more information, see "Appendix: Using Sage Estimating Data on
Reports" (page 8)

1. On the Field tab, select fields (columns from the tables)—for example:

l Estimate_v1.Name

l Item_v1.PhaseCode

l Item_v1.ItemCode

l Item_v1.Description

l Item_v1.TakeoffQuantity

l Item_v1.TakeoffUnitName

2. Click [Finish]

You return to the main Crystal Reports window, in previewmode.

Step 4: Set up the EstimateId parameter to target a single estimate

Note: For steps on querying the custom reports database to identify valid EstimateId values, see "Before
you start" on "Creating Sage Estimating Reports with the SAP Crystal Reports Designer" (page 1).

1. In the Field Explorer pane:

a. Right click Parameter Fields, and then click New.

b. In the Name field, enter EstimateId.
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Using the Standard Report CreationWizard to Create an Estimate Report

This field is case-sensitive.

c. For the Type option, select Number.

d. For the Value Field option, select Estimate_v1.EstimateId.

e. Click [OK] to return to the preview.

2. With the EstimateId parameter selected, on the Report menu, click Select Expert > Record.

3. In the Select Expert — Record window:

a. On the Estimate_v1.EstimateId tab, in the first drop-down list, select is equal to.

b. In the drop-down list that appears next, select EstimateId.

c. Click [OK].

4. In the Enter Values window that appears, type the EstimateId you wrote down for the representative
estimate from the custom reports database, and then click [OK].

5. On the Report menu, click Refresh Report Data, or press F5.

6. If you entered a valid EstimateId, preview data appears.

Step 5: Save the Crystal report

1. On the main menu:

a. Click File.

b. If the Save Data with Report option is selected, clear it.

This step removes the ID for the estimate you used to create the report. The report can then
take on the ID of the current estimate when you run the report in Estimating.

c. Click Save As.

2. In the Save As window:

a. Navigate to an easy-to-find folder.

b. Enter the report file name.

c. Click [Save]

Step 6: Add the report to Sage Estimating

1. Open the Estimating Management Console.

2. On the toolbar, click [Report Manager].

3. Click New Report > Crystal Report.
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Using the Standard Report CreationWizard to Create an Estimate Report

4. In the New Report window:

a. In the Report box, type the name to use for the new report in the Sage Estimating.

b. From the Filename box, browse to and select the new report design file that you saved in
"Step 5: Save the Crystal report."

c. Click [OK].

5. If this is the first report you have created for Sage Estimating, delete the blank report (which is no
longer needed) from the Report Manager:

a. In the Reports Catalog pane, expand the All Reports folder.

b. Right-click the blank report, and then click Delete.
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Appendix: Using Sage Estimating Data on Reports

Appendix: Using Sage Estimating Data on
Reports

Report Manager can report data from the following tables (in the Report Design database) and views (in
the Estimates database):

l Report.Addon_v1

l Report.AddonBasis_v1

l Report.Address_v1

l Report.Alternate_v1

l Report.AlternateStatus_v1

l Report.Assembly_v1

l Report.AssemblyDetail_v1

l Report.BidGroup_v1

l Report.CityCostIndex_v1

l Report.CityCostIndexDetail_v1

l Report.Company_v1

l Report.Crew_v1

l Report.CrewDetail_v1

l Report.CrewResource_v1

l Report.Estimate_v1

l Report.GroupAssembly_v1

l Report.GroupCrew_v1

l Report.GroupModel_v1

l Report.GroupPhase_v1

l Report.Item_v1

l Report.ItemAddonAllocation_v1

l Report.ItemWbsValue_v1

l Report.MaterialClass_v1
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Viewing table fields

l Report.Model_v1

l Report.ModelLine_v1 (new in v17.12)

l Report.Overline_v1

l Report.Person_v1

l Report.Phase_v1

l Report.ProjectInfo_v1

l Report.RateTable_v1

l Report.RateTableColumnHeading_v1

l Report.RateTableDetail_v1

l Report.Subcategory_v1

l Report.SubcontractorBid_v1

l Report.Unit_v1

l Report.WbsDefinition_v1

l Report.WbsValue_v1

Viewing table fields
You can use SQL Server Management Studio to view the names of fields in each table in the custom
reports database.

To view tables and fields (columns) using SQL Server Management Studio:

1. Start Microsoft SQL Server Management Studio.

2. In the Connect to Server window, connect to the SQL database.

3. For the Server type, select Database Engine.

4. For the Server name, select your Sage Estimating server.

5. In the Object Explorer:

a. Expand the Databases node.

b. Expand the *ReportDesign* database.

This custom reports database is a copy of your data that you use exclusively for creating
reports.
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Viewing table fields

c. Expand Tables.

The Object Explorer window displays a list of tables from the custom reports database.

To view a list of the fields available in a table:

1. Expand the table.

2. Expand the Columns folder.
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