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Version 17.12 Release Notes

This document provides important information regarding new features and changes in your Sage
Estimating 17.12 software. Read these release notes carefully before installing Sage
Estimating 17.12.
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Installation Notes

System Requirements
For current information about supported operating systems, Internet browsers, Microsoft®

SQL Server®, and other software, and about system requirements for servers and client
workstations, refer to our Knowledgebase article ID 86064, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=86064.

Note:While Sage Estimating continues to support 32-bit Microsoft SQL Server, the installation
package includes only the 64-bit Microsoft SQL Server Express application.

Installing Sage Estimating
Refer to the Installation and Administration Guide for complete instructions on installing the software,
and migrating or upgrading your data.

Before Upgrading

Important!
If you are upgrading to version 17.12 and you are using third-party software that integrates with
Sage Estimating, check with the third-party software vendor to ensure that their software is
compatible with version 17.12 before you upgrade.

Installation Notes
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New Features and Enhancements

Sage Estimating version 17.12 includes:

l Expanded Copy Assembly functionality

l Automatic overline quantity calculations

l New, modernized selection windows

l Extended data connector functionality

l Synchronization with source lists

l Spreadsheet enhancements

l Improved Report Manager

l Expanded field widths

l Improved performance

l Refined license administration

l Security changes

l Miscellaneous improvements

The following sections describe these changes in more detail.

Expanded Copy Assembly functionality
Previous versions of Sage Estimating enabled you to copy an assembly within an estimate to avoid
repeating assembly takeoff. This feature, designed to boost your productivity, is especially valuable
for projects where assemblies are distributed across common systems—for example, multiple hotel
bathrooms that require the same assemblies on each floor.

Now, version 17.12 allows you to copy assemblies between estimates, saving you considerable time
and effort. You no longer face the tedium of matching takeoff variable inputs or customizing the
generated items—nor do you have to settle for copying a collection of items, losing valuable review
assembly information in the process.

New Features and Enhancements
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As with copying items, you simply select an assembly overline from the estimate spreadsheet, and
then drag it to the target estimate.

When you drop the assembly, the assembly and all its details appear in the new estimate.

New Features and Enhancements
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Note: This feature is currently available from any spreadsheet sequence where Assembly is
defined as the parent grouping level.

For more information about copying assemblies, see the Estimating help.

Automatic overline quantity calculations
Any estimator who has needed to summarize an estimate’s material quantities knows that it is a
labor-intensive process that often requires either a lot of calculator work or the manipulation of
exported item data.

In earlier versions, you had to enter static overline quantities, updating them manually as the scope
of the estimate changed.

Version 17.12 spares you this tedious work. Now you can rely on the overline quantities to provide
this critical information.

Automatic overline quantity calculations

Release Notes 5



Now, when you select the new Automatically calculate quantities check box (available on the
Miscellaneous tab of the Estimate Settings window), the program calculates summary quantities
based on units of measure and displays them in the overline quantity cells of the spreadsheet.

New Features and Enhancements
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Matching units are summarized in overline totals

Overline summary quantities are derived by comparing the unit value of a given overline to the
takeoff units of the corresponding estimate items.

The takeoff quantities of each matching item are aggregated, with the result appearing in the
overline quantity cell. Because the calculation depends on an exact, case-sensitive match, you can
add or remove item quantities from the aggregate amount simply by altering the Unit. This example
shows how you can exclude the quantity for an added item by using an uppercase "EA":

Automatic overline quantity calculations
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As you add items to the estimate or change existing item quantities, the program recalculates
overline quantities automatically.

Overriding overline quantities

You can also enter an overline quantity manually, overriding the calculated quantity. The overridden
values are highlighted and use the same formatting as category amounts you enter elsewhere in the
estimate spreadsheet.

Should you want to restore the automatic calculation, you can easily do so by right-clicking the cell,
and then clicking Remove Fixed Quantity from the shortcut menu.

New, modernized selection windows
Continuing to modernize common workflows, we have updated the following Select and Edit windows
as we did for WBS values in version 17.11:

l Units

l Locations

l Subcategories

It is now easier to view both the estimate and database lists and to assign values to estimate items
and other records. The Edit windows provide a modern grid that enables you to edit existing records
more efficiently. In addition, when you rename values, you can also choose to propagate the
renamed values to all the estimate assignments, which was not possible with previous versions.

New Features and Enhancements
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Unit description exposed

Respecting the significance of unit values in estimating, we have now added a new Unit Description
field to the Unit table. This description can provide additional information about how to apply the unit
value.

Tip: You can view a unit description by hovering over an assigned unit in the estimate
spreadsheet.

New data connector functionality
Version 17.11 introduced the ability to import and export lists of WBS values to and from Microsoft
Excel. In version 17.12, we have extended this integration to the following additional lists:

l Units

l Locations

New data connector functionality
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l Subcategories

After you export values to an Excel workbook, you can easily edit the values in the workbook, and
then import your changes into the same estimate or, in template fashion, into other estimates. You
can also import data from a fixed-format file.

Import and export processes are straightforward and consistent. As for WBS values, data is validated
and highlighted during the import operation. The import and export processes also create log files
that list the changes to your estimate or database and capture any exceptions.

For more details about this feature, see the help associated with each Import or Export window.

Synchronization with source lists
Besides the efficient management and selection of list values (such as locations, WBS values, and
alternate statuses), version 17.12 also reconciles lists when you change the estimate.

For example, in previous releases, you could remove a value from the estimate WBS value list even if
it was assigned to an estimate item. Now, if a WBS, Alternate, Alternate Status, Unit, Location, or
Subcategory value is assigned to an estimate item, it will always exist in the estimate's value list.

Before you can remove an assigned value from the estimate's value list, you must remove or
reassign the value from any estimate item assignments.

Spreadsheet enhancements
In version 17.12, spreadsheet enhancements continue to improve estimators' productivity.

Clearing a value in the estimate spreadsheet is now as easy as clicking the [Delete] key, consistent
with Microsoft Excel behavior.

Alternatively, you can right-click the value, and then click Remove Values from the shortcut menu.
When you use the shortcut menu to remove a value, you remove the value from all assignments on
the current estimate. You can also chose to remove the value from the corresponding source
estimate’s value list.

Improved Report Manager
Custom reporting is improved in Report Manager in version 17.12.

Report designer databases are no longer created automatically for all users. These databases are
created only when a report developer generates sample design data in the Estimating Management

New Features and Enhancements
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Console. The result is a less cluttered set of report designer databases in your SQL instance, making
database administration easier.

You will also notice the following additions to the reportable views:

l New Allocated Addons fields for each of the cost categories in the Estimate Item table.

l New plain text equivalent fields for all rich text notes fields.

l A newModel Line table.

l The Unit table now includes a Unit Description field.

Expanded field widths
In response to development partner requests, version 17.12 includes technical improvements. For
example, we have expanded the WBSValue field so that you can store more detailed item-level
information.

The following table lists specific changes:

Type Field Old length New length

Addon Description 30 50

Addon Number 2 6

Alternate Description 150 260

Alternate Name 20 50

Alternate Status Name 20 50

Assembly Description 70 260

Company Email Address 50 254

Item BOMDescription 50 260

Item Description 150 260

Item Table Name 20 70

Location Name 15 50

Material Class Name 20 50

Person Email Address 50 254

Expanded field widths
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Type Field Old length New length

Phase Description 150 260

Unit Name 4 8

WBS Value Description 70 260

WBS Value Value 20 50

Improved performance
Sage Estimating continues to reduce processing times, particularly when accessing database
information. In addition:

l We have optimized the Review Assembly function for large estimates.

l You can select estimates more quickly when using the Merge Estimates function.

l The Delete Estimate function is more efficient.

l Displaying the price book report is faster.

Refined license administration
Version 17.12 includes several improvements to the License Administration program.

You now receive a warning before you deauthorize the license server to avoid accidentally locking
licenses.

The License Administration log now includes more information to track license check-ins and check-
outs and for tracing licensing errors.

You may also notice performance improvements when checking out a license for offline use.

Security changes
For new installations of Sage Estimating, users can now view and edit all estimates by default.

In contrast with previous versions, to apply security to individual estimates, the administrator must
now clear Allow all users to view and edit all estimates in the Estimating Management Console.

There is no change to existing installations, where the existing security setting continues to apply.

New Features and Enhancements
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Miscellaneous improvements
Version 17.12 includes the following additional improvements:

l Means Integrator accepts factors (such as *2 or /3) applied to surrogate keys and item codes
when you enter price update codes.

l For new installations only, windows that you can dock below the estimate spreadsheet now
float, by default, when you first open them. This new behavior affects the Totals, Estimate
Details, Default Values, Alternate Summary, and Output windows. You can dock the windows,
if you prefer.

l Items in the Takeoff Order spreadsheet sequence are no longer grouped by Assembly Name.
This change enables you to see all items ordered by takeoff date and time, regardless of their
affiliation with assemblies.

Miscellaneous improvements
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Fixes Since the Previous Version

Version 17.12 includes the following fixes:

l When migrating data from Estimating (Pervasive), the program now resolves Registration
Names longer than 30 characters.

l You no longer receive an error message saying "Index and length must refer to a location
within the string" when you migrate an Options file from Estimating (Pervasive).

l We removed the SQL Server setting from the Settings panel in Data Migration. This setting is
no longer required during migration, and occasionally caused an issue when switching
address books.

l If you are running Estimating in a workgroup, the program now includes the domain or
machine name portion when evaluating your SQL user ID. This enables Estimating to
differentiate between similar IDs when you restore data from different domains.

l When you start Sage Estimating, you are automatically enrolled as a user for the SQL Server
instance, providing Security is not turned on.

l When you delete a user in the Estimating Management Console, their associated report
design database is also deleted.

l When OST is not installed, the OST icon no longer appears on the ribbon (and in classic view,
the OST item does not appear on the menu).

l Items are now listed correctly when you sort items by Group Phase only.

l The shortcut menu on the spreadsheet no longer provides an item for editing the cost index on
an estimate. Now, to edit a cost index for an open estimate, you click Data tab >Miscellaneous
> Cost Indexes.

l You no longer receive a foreign key error when you type a unit in the Phase, Formula, or
Variable window for a standard database, and then press [Enter].

l You no longer receive an out-of-bounds array error that causes the Review Assembly function
to stop working.

l The Estimating spreadsheet is updated automatically when you edit a WBSDescription for an
estimate.

l On the Totals Page, if you use alternates for an estimate, the "Total with included alternates"

Fixes Since the Previous Version
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statement now uses one line that wraps, if necessary.

l You can now see all price code categories in the Price Update by Price Code window.

l Address book data is now generated properly when you run a custom report in Estimating and
when you data generate for report design in the Estimating Management Console.

l In the Estimating Management Console, the [Edit] buttons for the client, architect, and
engineer companies and contacts are available only when you specify the company or
contact.

l Merge Estimates no longer adds duplicate group assemblies to an estimate.

l You no longer receive a communication error when you launch Estimating from the Estimating
Management Console.

l In the Database Editor, you can open a Standard database that is integrated with Sage 100
Contractor.

Fixes Since the Previous Version
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Known Issues

You cannot browse to a desired location in the Standard
Database Catalog when creating a new standard database
The Create New Standard Database window prevents you from using the Browse feature to select a
desired location for the new database.

However, you can type the branch path to enter the location manually while you are creating the
database, or you can move the branch to the desired location after you create the database.

You cannot install Microsoft SQL Server from a folder that
has a long path
If you start the Sage Estimating installer from a path that is longer than 100 characters, you will
receive the error “Exit Code 9 The storage control block address is invalid” in the log file when you
install the software.

To avoid this error, move the Install folder higher up in the tree (closer to the root folder).

Checking in a Standard Database from the Database Editor
Closes the Database for Concurrent Users
You can work on a Standard database in the Estimating Database Editor while other users perform
takeoff using the same database in the Sage Estimating program.

When you try to check in the Standard database while other users have the database open, you
receive a warning that if you continue to check the file in, there may be unpredictable results for the
concurrent users.

If you continue to check the file in despite the warning, the Estimating program stops working for the
other users. However, the data is not corrupted and the Estimating program is not damaged.

Known Issues
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Further Assistance

Sage provides you with the following resources for obtaining assistance with Sage Estimating.

Online Help
The Sage Estimating software includes online Help, which provides answers to your questions about
procedures as well as items in the windows.

To view Help in the Sage Estimating software, click the Help button or icon, or press [F1] to display
the Help topic for that window.

For more information about using the online Help, see the Sage Estimating Help.

Training
Sage University offers online and classroom training sessions to help you get the most out of your
Sage Estimating software. To access Sage University, visitwww.sageu.com.

You can also get access to Sage University from the File menu by selecting Help > Sage University.

Technical Assistance
When you need assistance, refer to the Knowledgebase article How do I get technical support for
Sage Estimating? to determine which service works best for you.

Submitting Enhancement Requests
We want to hear your suggestions for improving the software. To send us your comments, click on
the File menu button and select Help > Submit Product Idea.

Further Assistance
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