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Version 17.11 Release Notes

This document provides important information regarding new features and changes in your Sage
Estimating 17.11 software. Read these release notes carefully before installing Sage Estimating 17.11.

Restructured license packages
In keeping with the expanded functionality available in version 17.11 and to provide greater flexibility to our
customers, Sage is restructuring the license packages offered for Sage Estimating (SQL). With this
version, we are introducing a modular approach to licensing.

Used as a standalone application, the core Sage Estimating (SQL) is a powerful, flexible tool for estimating
all types of construction products.

You can also purchase the following add-on modules to extend the functionality of Sage Estimating to suit
the needs of your business:

l Advanced Reporting, which includes the Comparison Report, the Variance Report, and Custom
Reports.

l Crews

l ePlan Takeoff (OST integration)

l Models

Note: These modules are licensed separately from the Core Sage Estimating product. Certain
capabilities, menus, and icons described in help are available only if you have purchased the associated
module.

When you activate your product license on your license server, your Sage products and features are
registered on and managed from that computer. The [[[Undefined variable Doc_Variables.LicenseAdmin]]]
window displays the number of license uses (or concurrent users) for the Core product, and it lists any
additional modules you have purchased.
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Installation Notes

System Requirements
For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®,
and other software, and about system requirements for servers and client workstations, refer to our
Knowledgebase article ID 82105, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=82105.

Note:While Sage Estimating continues to support 32-bit Microsoft SQL Server, the installation package
includes only the 64-bit Microsoft SQL Server Express application.

Update or Migrate Your Data?
Sage Estimating 17.11 uses a Microsoft® SQL Server®-based database platform. If you are migrating from
Pervasive-based Sage Estimating (versions 9.6 and later), you must migrate your data before you can use
it in Sage Estimating 17.11. Refer to the Installation and Administration Guide in the Documents folder of
your Sage Estimating installation files for migration instructions.

However, if you previously installed SQL-based Sage Estimating version 11.1 or later, you are only
required to upgrade your data prior to using it with Sage Estimating 17.11.

To upgrade your data:

1. Install Sage Estimating 17.11 following the instructions in the Installation and Administration Guide.

2. Start the Configuration wizard by selecting Start > All Programs > Sage Estimating 17.11
> Configuration Wizard, or by clicking the desktop icon.

In Windows 8.1 and Windows 10, select the Configuration Wizard tile on the Desktop, or right-click
outside the tile area, and then click All apps > Sage Estimating 17.11 > Configuration Wizard.

3. Follow the Configuration Wizard's on-screen instructions, and then upgrade your data when
prompted.

Refer to the Installation and Administration Guide for more information about migrating and upgrading
your data.
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New Features and Enhancements

Sage Estimating version 17.11 includes:

l Alternates

l Integration with Sage 100 Contractor (SQL)

l New data connector

l RevisedWBS selection workflow

l Ribbon refinements

l Shortcut refinements for spreadsheet functions

l Other spreadsheet usability enhancements

l Estimate Information window enhancement

l Additional database and estimate reports

l Simplified Copy Estimate processes

l Support for non-unique estimate names

l Address book enhancements

l Performance improvements

l User assistance enhancements

l New license administration system

The following sections describe these changes in more detail.

Alternates that enable you to tailor estimates for customers
Version 17.11 enables you to prepare more versatile estimates that include optional pricing packages. The
ability to define alternates enables you to tailor each estimate in response to specific financial concerns—a
necessity for a competitive bid in today's construction environment.

A new Advanced tab on the Sage Estimating ribbon provides access to new windows you use to set up
alternates for an estimate and to present the results to your customer.
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l Click the Alternates icon on the Advanced tab to open the Edit Alternates window.

You use the Edit Alternates window to define alternate packages that you want to provide to a
customer.

l Click the Statuses icon to open the Edit Alternate Statuses window.

You use the new Edit Alternate Statuses window to define the state of your customer's commitment
to include alternates in a job. For example, you might use "Proposed" to indicate that you or your
customer has suggested an alternate, and "Accepted" to indicate that your customer has agreed to
use this item for the job.

When defining a status, you can designate an Include? attribute, which determines whether
alternates assigned that status are included in estimate totals. It also enables you to present
different views of an estimate. For example, when you prepare an estimate analysis for your
customer, if you select the Show Excluded Alternates option (also on the Advanced tab), all
alternate items are included in the estimate spreadsheet, regardless of whether they are associated
with one of the Included statuses. If you do not select the option, only items that are included in
estimate grand totals are displayed in the summary.

Note: The Show Excluded Alternates option is not available until you add alternates to the
estimate.

l Click the Summary icon to display totals for alternate items in a summary pane (the example shown
here uses simple, unassigned alternates):
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The amounts displayed in this pane can vary depending on whether the alternates have an Included
status type, and whether you selected the Show Excluded Alternates option on the Advanced tab.

Note: The Summary icon and pane are not available until you add alternates to the estimate.

l You can export the Alternate Summary totals to an Excel spreadsheet that you can print for your
customer.

To export the Alternate Summary for the current estimate, you click the Export to Excel icon in
the Alternate Summary pane.

Integration with Sage 100 Contractor (SQL)
Sage Estimating is now fully integrated with Sage 100 Contractor (SQL), enabling you to exchange Sage
Estimating data with your Sage 100 Contractor accounting applications.

The Sage 100 Contractor Application Program Interface (API), which is installed automatically with your
Sage 100 Contractor software, serves as the bridge between the two applications.

You must be a member of the API security group in Sage 100 Contractor to set up or use the integration
between Sage Estimating and Sage 100 Contractor. (Security groups are assigned under Company
Security in Sage 100 Contractor.)

Important! To change user security settings in Sage 100 Contractor, you must be a company
administrator for the company you are integrating with Sage Estimating.

When you integrate a Sage Estimating database with a Sage 100 Contractor company, jobs, cost codes,
cost types, and vendors are imported into your Sage Estimating system, where they are available when
you create estimates.

Integration also enables you to create proposals, budgets, and change orders from estimate data using
Sage Estimating (SQL).

For details about how to integrate your Sage 100 Contractor and Sage Estimating applications, see the
Sage Estimating – Sage 100 Contractor (SQL) Integration Guide.

New data connector
As part of an ongoing effort to integrate Sage Estimating more closely with Microsoft Excel, new import
functions enable you to import information from an Excel file.
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You can also use new export functions to export data to an Excel file, where you can edit it using common
Excel functions, and then import it back into an estimate. These capabilities enable you to share data
between estimates and estimators within your company.

The following windows provide [Import] and [Export] buttons for importing and exporting WBS code values,
alternates, or statuses:

l Edit Estimate WBS Values and Edit Database WBS Values (use to import and export WBS code
values).

l Edit Alternates (use to import and export lists of alternates).

l Edit Alternate Statuses (use to import and export lists of alternate statuses).

Both processes are straightforward and consistent. Also, both processes create log files that capture
information about the changes to your estimate or database effected by the export or import. (For more
information, see the respective windows.)

RevisedWBS selection workflow
Redesigned WBSValues windows improve the process of viewing and selecting WBS values, and provide
a streamlined process for editing existing lists of WBS values.

New Select Estimate WBS Values and Select Database WBS Values windows include a convenient grid
that lists all the values that are defined for a selected estimate or database WBS code.

To select a value, you select it, and then press the Enter key or click the [Select] button--or you can simply
double-click the value on the grid.

The selection windows provide an [Edit] button that you use to access the edit mode for the window, rather
than launching a separate window, as in previous versions. In edit mode, you can easily add, delete, or
rename WBS code values, or export them to or import them from an Excel file.

Tip: The ability to export and import database and estimate WBS values can facilitate the sharing of
WBS values between estimators, databases, and estimates.

To display the Edit WBS Values or the Select WBS Values window (depending on where in the program
you are working), you right-click in a WBS cell, and then click the Edit <WBS Code> Values or Select
<WBS Code> Values option from the shortcut menu:
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Ribbon refinements
In version 17.11, we reorganized items on the ribbon into logical groupings on tabs whose functions are
more obvious. For example, all takeoff-related functions are now located on a new Takeoff tab.

We have also added Expand All and Collapse All icons for viewing all the items in the current spreadsheet
or summarizing them respectively.

If you were used to the ribbon in earlier versions, the Finding your way using the new ribbon help topic can
assist you in navigating to windows, tools, and options from their new positions on the ribbon.

Tip:We suggest that you print the chart in this topic as a handy reference until you become familiar with
the new ribbon.

In addition, the Quick Access toolbar now includes a list of commonly used icons, enabling you to
customize the toolbar easily, as shown here:
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Shortcut refinements for spreadsheet functions
Redesigned shortcut (right-click) menus opened from the spreadsheet are nowmore closely associated
with the context in which you display them, making common functions easier to find and use.

Example: Right-click a column heading to perform column adjustments

Example: Right-click the row header for an item to display item-specific functions

Example: Right-click a cell to viewmenu options related to that cell
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Example: Right-click a range of columns that includes a hidden column if you want to display the hidden
column

Other spreadsheet usability enhancements
l A new Insert Columns dialog box, which is accessible directly from the spreadsheet, lets you quickly
modify the current layout. In previous versions, you had to use the Unhide shortcut option (assuming
you knew the current position of the field) or open the Edit Layout window from the ribbon to view
and position item fields.

Now, you can simply right-click a column header on the spreadsheet, and then click Insert from the
shortcut menu to open a new Insert Columns window. You can then select the columns you want to
add to the spreadsheet from a list of available fields. For example, you can easily add the Allocated
Addon field immediately to left of the Grand Total Amount field.

Tip: You can either double-click a field to add a single field immediately to the spreadsheet, or
click several fields (one at a time), and then click [OK] to add multiple fields to the spreadsheet.
The new columns are inserted to the left of the current column.

l You can easily change the appearance of a spreadsheet column by double-clicking the column
heading, and then adjusting the column properties in the Column Properties window.
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Estimate Information window enhancement
With version 17.11, new Expand All and Collapse All buttons enable you to display or shrink sections of the
Estimate Information window, making it easier for you to find the sections you want to view or edit.

Additional database and estimate reports
Sage Estimating includes more reports, including the following Estimate reports and Database reports:

Report type Report name

Takeoff Unit Costs and
Unit Price reports

l Takeoff Unit Costs

l Unit Price Review

BOM and audit reports l Quote Sheet report

l Detail Audit by Item

Price and Quantity reports l Field report

l Bill of Quantities

l Unit Price Analysis

Estimate reports
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Report type Report name

Bid Grid reports l Selected Subcontractor

l Who's Doing What Work

Report type Report name

Pricebook reports l Price Book

Assembly reports l Assembly Summary

l Assembly Detail

l Assembly Item Tables

Crew reports l Crew Detail

l Crew Summary

l Crew Resource Rate Tables

Database reports

Simplified Copy Estimate processes
We have simplified the process of copying estimates.

In the Copy Estimate window (opened by clicking File > Copy Estimate in the Estimating program), we
have reorganized the fields in a logical order. Now, you specify:

1. ASource Estimate name. (If an estimate is open, the program displays the current estimate name in
this box, but you can change it.)

2. A Target Branch.

3. The New Estimate name.

In the Estimate Catalog (available in the Estimating Management Console or the Manage Estimates
window), you can now use a shortcut menu to create a copy of an existing estimate. In the tree view, right-
click the estimate you want to copy, and then click Copy from the menu. Navigate to the location where you
want to save the copied estimate, right-click the target folder, and then click Paste.
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Support for non-unique estimate names
Multiple estimates can now have the same names—providing they exist in different locations in the Estimate
Catalog. This means that when you copy an estimate to a different branch, you can preserve the
recognizable estimate name without having to append "Copy" to the name, unless the estimate is a
duplicate of an estimate on the same branch in the Estimate catalog.

Address book enhancements
l You can add an email address to a person record.

l You can add a primary Estimating contact for a company. The primary Estimating contact is used on
some subcontractor reports.

l Trades subtypes for estimate subcontractor are migrated from Sage Estimating (Pervasive) and
added to the master trade list in Sage Estimating.

l When adding a vendor on the fly, you no longer need to leave the keyboard and use the mouse to
save the record. When you finish entering the information, simply press [Enter] to save your
changes.

Tip: Help for the Address Book is nowmore easily accessible from the Help Contents panel, where it has
a main heading.

Performance improvements
With version 17.11, Sage Estimating continues to reduce processing times. You should notice
considerable improvements when performing Move/Copy and Copy/Paste operations. Also, Sage
Estimating retrieves data more efficiently, resulting in faster processing.

User assistance enhancements

Restyled online Help with improved search capabilities

Beginning with version 17.11, Sage Estimating displays Help in your default browser. If you have an
Internet connection, it displays the most current Help for your version of Sage Estimating available on our
Sage Help server. Hosting help on a server enables Sage to update help without requiring you to update
your software.
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If you have no connection (you are working offline), it displays the Help that was current when the software
was released. It is installed on your computer when you install Sage Estimating.

Important! Because the Microsoft Edge browser does not display locally installed help properly, we
recommend that you select a different default browser when working offline.

Help for all Sage Estimating modules is available from a single convenient Contents panel. Once you
display help for a module in your browser, you can easily find articles about any other module by using the
new Search box at the top of the screen, or by using the Help Contents panel.

In addition, the new clean style of Help and PDF guides is designed to be easier for you to read.

Redesigned Helpmenus with quick access tomore self-help resources

We have redesigned the Help options available from the ribbon and the File menu in the Sage Estimating
program. You are only a couple of clicks away to an array of self-help resources. These are the Help links
you will find on the File menu in version 17.11:

New license administration system
Licensing for Sage Estimating no longer relies on a Sentinel USB device or the SafeNet/Gemalto License
Manager.

Sage Estimating has implemented a new web-based licensing and entitlement system. The new licensing
system uses your Sage client ID and registration information, rather than USB keys or other devices used
in earlier versions, to verify your entitlement to the software.

13Sage Estimating (SQL) v17.11 Release Notes (Controlled Release)



Important! Any version of Sage Estimating earlier than version 16.12 (a limited pre-release version) will
not work with the License Administration program described here.

To manage your licenses, you use a new License Administration program, which is installed automatically
with the Sage Estimating software. After installation, you can use the Sage Estimating Configuration
Wizard, which has been updated to take advantage of the new licensing features, to acquire licenses for
individual workstations.

After installing Sage Estimating on a server and individual workstations:

1. On the server, use the License Administration window to designate a computer on your network as
the Sage license server, which will regulate and monitor license uses. The license server should
maintain a constant connection to the Internet so that Sage Estimating users can acquire license
uses when they need them.

You also enter and send registration information to Sage to activate the licenses for the products
you have purchased.

2. On workstations, individual users connect their Sage Estimating installations to the Sage license
server using the Configuration Wizard.

Sage Estimating users must either acquire a license through the Sage license server or use Demo
Mode before they can use the software.

Demo Mode is a limited license that is valid for a short period of time so that you can try out the
software. This option is available in the Configuration Wizard until you activate a license.

Tip: If a user will be offline for a time, they can also check out a license use. Checking out a license
reduces the number of license uses available to other Sage Estimating users until the license is
checked back in. (In Sage Estimating, you click File > Check Out License Use or File > Check in
License Use.) For detailed information about checking out a license for offline use, see the
Installation and Administration Guide.

For more detailed information on installing and configuring Sage Estimating version 17.11, see the
Installation and Administration Guide.
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Fixes Since the Previous Version

Version 17.11 includes the following fixes:

l You can connect to a SQL Server instance using a Microsoft account.

l You can copy and paste a row into Microsoft Excel.

l Shared layouts created on one machine are displayed correctly on other machines.

l You can run custom reports on upgraded estimates.

l When you review passes for a merged or copied estimate that contains multiple passes, only the
pass you select is highlighted in the list pane.
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Known Issues

You cannot install Microsoft SQL Server from a folder that has a
long path
If you start the Sage Estimating installer from a path that is longer than 100 characters, you will receive the
error “Exit Code 9 The storage control block address is invalid” in the log file when you install the software.

To avoid this error, move the Install folder higher up in the tree (closer to the root folder).

Checking in a Standard Database from the Database Editor
Closes the Database for Concurrent Users
You can work on a Standard database in the Estimating Database Editor while other users perform takeoff
using the same database in the Sage Estimating program.

When you try to check in the Standard database while other users have the database open, you receive a
warning that if you continue to check the file in, there may be unpredictable results for the concurrent
users.

If you continue to check the file in despite the warning, the Estimating program stops working for the other
users. However, the data is not corrupted and the Estimating program is not damaged.
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Further Assistance

Sage provides you with the following resources for obtaining assistance with Sage Estimating.

Online Help
The Sage Estimating software includes online Help, which provides answers to your questions about
procedures as well as items in the windows.

To view Help in the Sage Estimating software, click the Help button or icon, or press [F1] to display the Help
topic for that window.

For more information about using the online Help, see the Sage Estimating Help.

Training
Sage University offers online and classroom training sessions to help you get the most out of your Sage
Estimating software. To access Sage University, visitwww.sageu.com.

You can also get access to Sage University from the File menu by selecting Help > Sage University.

Technical Assistance
When you need assistance, refer to the Knowledgebase article How do I get technical support for Sage
Estimating? to determine which service works best for you.

Submitting Enhancement Requests
We want to hear your suggestions for improving the software. To send us your comments, click on the File
menu button and select Help > Submit Product Idea.

17Sage Estimating (SQL) v17.11 Release Notes (Controlled Release)

http://www.sageu.com/
https://support.na.sage.com/selfservice/viewdocument.do?externalId=32077
https://support.na.sage.com/selfservice/viewdocument.do?externalId=32077

	Version 17.11 Release Notes
	Restructured license packages

	Installation Notes
	System Requirements
	Update or Migrate Your Data?

	New Features and Enhancements
	Alternates that enable you to tailor estimates for customers
	Integration with Sage 100 Contractor (SQL)
	New data connector
	Revised WBS selection workflow
	Ribbon refinements
	Shortcut refinements for spreadsheet functions
	Other spreadsheet usability enhancements
	Estimate Information window enhancement
	Additional database and estimate reports
	Simplified Copy Estimate processes
	Support for non-unique estimate names
	Address book enhancements
	Performance improvements
	User assistance enhancements
	New license administration system

	Fixes Since the Previous Version
	Known Issues
	You cannot install Microsoft SQL Server from a folder that has a long path
	Checking in a Standard Database from the Database Editor Closes the Database ...

	Further Assistance
	Online Help
	Training
	Technical Assistance
	Submitting Enhancement Requests




