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Chapter 1—Microsoft SQL Server and
Sage Estimating
Sage is pleased to provide you with this guide to understandingMicrosoft® SQL Server®. Read this guide
carefully to learn the basic principles of SQL Server and how it supports Sage Estimating operation.

Sage Estimating uses SQL Server as its database platform. Previous releases used Pervasive as the
database platform for storing Sage Estimating data. This database platform change is intended to offer you
increased security, performance, and flexibility for your reports, queries, and daily operations.

This document provides information on the impact of these changes. It is important to understand these
differences so that you can effectively manage and protect your Sage Estimating data.

Although this document is current at the time of its distribution, a newer versionmay be available. For the
most recent version, visit  http://cdn.na.sage.com/Docs/en/customer/estimating/SageEstimatingDocs.htm,
and then click Sage Estimating (SQL) > Version 16.11 > Sage Estimating SQL Server Guide.

Microsoft SQL Server and Pervasive
Microsoft SQL Server represents a change from the Pervasive database platform used in previous Sage
Estimating releases. It is important to understand how the new SQLServer database platform is structured.

SQL Server stores database information in database (.mdf) and log (.ldf) files. Previously, Sage Timberline
Office Estimating created separate estimate files that you could store in any desiredWindows file structure.
With the new SQL Server database, Sage Estimating stores all your estimates in the same .mdf database file
on a single server known as an instance.

Figure 1: Comparison of Pervasive and SQL Server

A Sage Estimating instance (sometimes referred to as a "server") consists of three primary components:

SQL Server Guide 5
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n An Address Book database

n An estimate database

n One ormore standard databases

You configure security for the instance and apply it to all contents, including the Address Book, all standard
databases, and all estimates within the estimate database.

Estimates are stored entirely within the estimate database. With the new Sage Estimating, you can use the
EstimatingManagement Console feature to arrange your estimates in a hierarchy of tiers or "branches." The
branches you create in the EstimatingManagement Console are for organizational purposes only. They do not
change the structure of your database.

The location of your SQL Server database files (.mdf and .ldf files) depends in part on your operating system.
See “SQL Server Express Installation” on page 12 for more information.

SQL Server allows an unlimited database size. However, SQL Server Express limits the database size to 10
gigabytes (GB). Sage Estimating warns you if your database size nears the limit.

If you select the option to create a new SQL Server instance in theSelect installation options for Sage
Estimatingwindow, the installation process automatically configures a new Sage Estimating-compatible
instance for you. The default name for the instance is SAGE_ESTIMATING. However, you can name the
instance anything you want.

If you do not select the option to create a new SQL Server instance in theSelect installation options for
Sage Estimatingwindow, you can create your own instance using an existing SQL Server installation. The
new instancemust meet the requirements stipulated in “Modified Installation” on page 13.”

The SAGE_ESTIMATING Instance
Sage Estimating allows the use of just one active SQL Server instance at a time. The active instance is a
"closed" SQL Server instance. Sage Estimating does not recognize databases (Address Book or standard
databases) transferred or copied from other SQL Server instances unless they are added by way of the
Search For feature in the EstimatingManagement Console.

For example, if you have two Sage Estimating installations, Install A and Install B, you cannot copy Address
Book databases by copying them from Install A's SQL Server instance to Install B's SQL Server instance
alone (using SQL Server Management Studio's built-in Copy Databases wizard, for example). Youmust also
open the EstimatingManagement Console and use theSearch For button in the Address Book
Companies/Contacts toolbar.

Chapter 1—Microsoft SQL Server and Sage Estimating
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Figure 2: Copying Databases From One SQL Server Instance to Another

Any database you add to an instancemust have the same Sage Estimating version as the other operating
databases. For example, if you are using Sage Estimating 16.11, and you want to add a standard database
from a previous Sage Estimating installation, upgrade the standard database to version 16.11 before adding it
to the new instance. Refer to the EstimatingManagement Console in-product Help for instructions on adding
databases using theSearch For feature.

SQL Server allows an unlimited database size. However, SQL Server Express limits the database size to 10
gigabytes (GB). Sage Estimating warns you if your database size nears the limit.

If you select the option to create a new SQL Server instance in theSelect installation options for Sage
Estimatingwindow, the installation process automatically configures a new Sage Estimating-compatible
instance for you. The default name for the instance is SAGE_ESTIMATING. However, you can give the
instance any name you want, provided it is not the same as an existing SQL Server instance on the computer.

If you do not select the option to create a new SQL Server instance in theSelect installation options for
Sage Estimatingwindow, you can create your own instance using an existing SQL Server installation. The
new instancemust meet the requirements stipulated in “Modified Installation” on page 13.”

Microsoft SQL Server Files
Every SQL Server database has at least two files associated with it:

n A file that stores the actual data (.mdf)

n A transaction log file (.ldf)

SQL Server stores your Sage Estimating data in the database file (.mdf). For details, see “SQL Server
Express Installation” on page 12.

Microsoft SQL Server Files
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The transaction log (.ldf) records all changes to the data in the database. This log ensures data integrity by
keeping track of data that has changed and can be used to roll the data back to a previous state in the event of
a database failure.

It is important to make regular backups of these files. For more information, see “Backing Up SQL Server
Databases” on page 33.

Collation settings for use with Sage Estimating
Sage Estimating requires a special collation setting. Collation settings in SQL Server must be set to:

n Latin1_General

n Case-sensitive

n Accent-sensitive

See “Collation Settings,” on page 30 for more information.

SQL Database Permissions and Access
Youmust give each Sage Estimating operator permissions to the Sage Estimating features that they are
expected to use. Assign database and feature permissions using the security feature of the Estimating
Management Console. For more information, see the EstimatingManagement Console in-product Help.

CAUTION: Do not change the owner of any databases in the Sage Estimating instance.

Read the Supporting Documentation Before You Begin
Be sure to read the supporting documentation before you begin. The following guides are available at
http://cdn.na.sage.com/Docs/en/customer/estimating/SageEstimatingDocs.htm for each supported version:

n This SQL Server Guide gives you an overview of the significant differences between the new SQL Server
databases and the Pervasive databases used in previous Sage Estimating releases.

n The Installation and Administration Guide includes an overview of this release, installation instructions, and
contact information.

n TheRelease Notes provide details about new features, database changes, known issues, and fixes.

n TheGetting Started Guide provides an operational overview of the Sage Estimating software.

n TheOptions Guide provides installation, setup, and operating instructions for each of the available Sage
Estimating options, such as the OnScreen Takeoff Integrator or LicenseManager.

IMPORTANT: For current information about supported operating systems, Internet browsers,
Microsoft® SQL Server®, and other software, and about system requirements for servers and client
workstations, refer to our Knowledgebase article ID 76530, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=76530.

Chapter 1—Microsoft SQL Server and Sage Estimating
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Conventions Used in this Document
This document uses the following conventions:

n Information you type into the software is shown in bold font. For example: TypeMiscellaneous in the box.

n The names of screens, windows, fields, and other features displayed by the software are shown in bold
font.

n The names of buttons you can click are enclosed in brackets with bold font. For example: [OK] or [Post].

n Names of keys are shown in capital letters. For example: ENTER or TAB. A plus sign (+) between two key
names indicates you should press the keys simultaneously.

n Variable names or names that are specific to your installationmay appear in italics and brackets. For
example: [Drive]\\[Server].

Symbols

NOTE: This symbol is used when presenting information that is supplemental to the adjacent text.

TIP: This symbol is used when presenting helpful information for using the software.

CAUTION: This symbol is used when presenting important information to help you avoid a loss of
critical data.

IMPORTANT: This symbol is used when presenting information that is critical to understand or that
requires you to take action.

Menu Paths
In this document, menu paths show you the steps required to start a task. Menu paths appear in bold font with
angle brackets around buttons. For example:

"If the program does not automatically start, click [Start] > Run."

Online Help
The Sage Estimating software includes online Help, which provides answers to your questions about
procedures as well as items in the windows.

To access the online Help in the Sage Estimating software, click the Help button or icon, or press [F1] to
display the Help topic for that window.

To aid you in finding the information you need, the online Help for eachmodule includes the following panes:

n Contents pane containing links to the Help topics

Conventions Used in this Document
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n Index pane containing keywords that link to Help topics related to that keyword

n Search pane, where you can type text and click [Search] to locate that text in the Help topics

For more information about using the online Help, see the Sage Estimating Help.

Wewould like your feedback about the online Help so we canmake improvements. Each Help topic contains
an area where you can indicate whether the topic was helpful and provide additional comments. To protect
your privacy, all comments are anonymous.

Training
Sage University offers online and classroom training sessions to help you get themost out of your Sage
Estimating software. To access Sage University, visit www.sageu.com.

You can also get access to Sage University from the File menu by selectingHelp > Sage Estimating on the
Web > Sage University.

Technical Assistance
When you need assistance, refer to the Knowledgebase article How do I get technical support for Sage
Estimating? to determine which service works best for you.

Submitting Enhancement Requests
Wewant to hear your suggestions for improving the software. To send us your comments, click on the File
menu button and select Help > Sage Estimating on the Web > Submit Enhancement Requests.

Chapter 1—Microsoft SQL Server and Sage Estimating
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Chapter 2—Technical Information
Supported Editions of SQL Server
For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and
other software, and about system requirements for servers and client workstations, refer to our
Knowledgebase article ID 76530, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=76530.

A copy of SQL Server Express Edition is provided free of charge with Sage Estimating. This edition is
sufficient for most Sage Estimating customers. However, customers with large databases may need to
upgrade to the Standard Edition. For information onMicrosoft SQL Server editions, visit www.microsoft.com.

SQL Server Guide 11
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Chapter 3—Installation
Overview
Before installing Sage Estimating, you have two primary SQL Server scenarios to consider:

n SQL Server Express Installation. Installing Sage Estimating also installs SQL Server Express when you
select certain installation options. Follow this scenario for these conditions:

p You are installing Sage Estimating on a standalone workstation or a workgroup server.

p You are installing to a server on a domain and you want to use the copy of SQL Server Express that
comes with the Sage Estimating install package.

The Sage Estimating installation package installs and configures a new SQL Server instance of
SQL Server Express whenever you select the option to create a new instance. You can operate the new
SQL Server instance alongside an existing SQL Server instance.

n Modified Installation. You have already installed a supported version of SQL Server (or plan to install
one), and you want to manually create a new instance to use with that version.

Use theSecurity feature in the EstimatingManagement Console to assign database permissions to each
operator after installing your SQL Server instance.

For more information on setting up SQL Server security for Sage Estimating, see the Installation
and Administration Guide.

NOTE: You can install an approved instance of SQL Server side by side on a computer where
SQL Server 2012 is also installed. Be aware that installing Sage Estimatingmay then result in an "Install
completed with errors" message. However, the resulting Sage Estimating installation operates correctly.

SQL Server Express Installation
Microsoft SQL Server Express comes as an optional component with the Sage Estimating install package. It
installs automatically when you select certain Sage Estimating installation options.

NOTE: If you are operating in a workstation/server environment, you do not need to install SQL Server
on the workstations. However, you can install SQL Server locally if you want to maintain a copy of your
estimating data.

Follow the instructions below to install SQL Server Express from the install package.

1 Open theSelect Installation Options for Sage Estimatingwindow by double-clickingSetMeUp.exe in
your local install folder.

The install folder is created wherever you download the Sage Estimating install files. For example, if you
download the install files to C:\Users\Public\Public Documents, look in this folder for theSetMeUp.exe file.

SQL Server Guide 12
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Figure 3: The Select Installation Options for Sage EstimatingWindow

2 In theSelect installation options for Sage Estimating window, select Create a new local SQL Server
instance.

3 In theEnter new instance name box, type a name for the new SQL Server instance (database server) in
the box and click [OK].

The default name for the instance is SAGE_ESTIMATING. However, you can give the instance any name
you want, provided it is not the same as an existing SQL Server instance on the computer.

4 Click [Next], and then follow the on-screen instructions for installing Sage Estimating or Sage Estimating
server.

The software installer creates the new instance, and notifies you when the process is finished.

NOTE: Be sure to elevate your privileges at the prompt within twominutes of its appearance or the
installation will quit.

Installing SQL Server Express also installs SQL Server Management Studio Express, a tool for performing
database back up and restoration procedures and for assigning database permissions.

Modified Installation
Youmay use a version of SQL Server that already exists on your computer, but it must be a supported
versions. ( For current information about supported operating systems, Internet browsers, Microsoft®

SQL Server®, and other software, and about system requirements for servers and client workstations, refer to

Chapter 3—Installation
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our Knowledgebase article ID 76530, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=76530.)

If you want to use your existing installation of SQL Server, create a new instance to operate alongside your
existing SQL Server instances. You can give the new instance any name you want. However, Sage
recommends naming the new instance an easily identified name such as SAGE_ESTIMATING.

After creating your new instance, ensure you assign the appropriate database permissions as outlined in the
Installation and Administration Guide.

NOTES:

l If you plan tomigrate existing data from a Pervasive-based version of Sage Estimating, youmust
install SQL Server or SQL Server Express on the destination computer or server.

l Restart your server or workstation after creating the new instance

CAUTION: Do not change the owner of any databases in the Sage Estimating instance.

Modified Installation

SQL Server Guide 14
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Chapter 4—FAQs
I already use a version of Microsoft® SQL Server® on my computer. Can I use this version
with Sage Estimating?

Youmust use a version of SQL Server that Sage Estimating supports, and youmust create a new instance
for Sage Estimating that conforms to our recommended security settings. See “The SAGE_ESTIMATING
Instance” on page 6 for more information.

NOTE: You can install an approved instance of SQL Server side by side on a computer where
SQL Server 2012 is also installed. Be aware that installing Sage Estimatingmay then result in an "Install
completed with errors" message. However, the resulting Sage Estimating install operates correctly.

If I already have a version of SQL Server installed, does installing Sage Estimating
upgrade my existing SQL Server version?

No. However, you can install SQL Server Express from the Sage Estimating setup and installation files for
use with Sage Estimating. You can then use both SQL Server versions in a side-by-side configuration
(meaning both versions are installed).

What are the minimum system requirements to install SQL Server?

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and
other software, and about system requirements for servers and client workstations, refer to our
Knowledgebase article ID 76530, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=76530.

Which operating systems are supported with SQL Server?

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and
other software, and about system requirements for servers and client workstations, refer to our
Knowledgebase article ID 76530, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=76530.

Are 64-bit platforms supported?

Yes, you can install SQL Server Express on the several 64-bit Windows platforms.

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and
other software, and about system requirements for servers and client workstations, refer to our
Knowledgebase article ID 76530, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=76530.

Can SQL Server Express Edition installations be performed on substitute, mapped, or
compressed drives?

No, installations cannot be used on any of these configurations.

SQL Server Guide 15
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Can I use File Tools or other utilities to back up my SQL databases?

No. Youmust detach your databases and then back them up after the process is complete. File Tools and
other utilities do not perform this function.

Use SQL Server Management Studio or SQL Server Management Studio Express to back up your SQL data.
Microsoft SQL Server Management Studio Express attaches and detaches the database automatically during
back up and restore procedures. For more information, see “Backing Up SQL Server Databases” on page 33.

Will running a virus scanner on the SQL Server host machine affect performance?

For performance reasons, if you plan to run a virus scanner on themachine that hosts the SQL Server
instance, you should exclude files that haveMDF, LDF, NDF, BAK, TRN, and TRC extensions. You should
also exclude additional processes for the version of SQL Server that you are running. For more information
about the files and processes to exclude, seeMicrosoft Knowledgebase article 309422 at
http://support2.microsoft.com/kb/309422.

How can I test whether SQL Server is working in Sage Estimating?

The first time you start Sage Estimating or the EstimatingManagement Console after installing the Sage
Estimating software, you should be able to use the Configuration wizard to locate your SQL Server instance.
If you are able to use the Configuration wizard to successfully locate at least one SQL Server instance, your
installation of SQL Server is operating correctly.

If you are able to open or create estimates and databases in the Sage Estimating software, SQL Server is
operating correctly.

What do I need to be able to manage user access rights in SQL Server?

For Sage Estimating, security is managed entirely from within theSecurity feature of the Estimating
Management Console. You can create roles and their corresponding permissions to access various Sage
Estimating tasks and features.

Youmust be belong to the Sage Estimating administrator role to create roles and assign them to other
operators. For more information about creating roles and permissions, refer to the Sage Estimating Installation
& Administration Guide or the EstimatingManagement Console in-product Help.

I can connect to a SQL Server instance on my local computer but why can't I connect to a
SQL Server instance on a remote server?

Youmay need to reconfigure your firewall settings. See “Firewall settings” on page 19.

Chapter 4—FAQs
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Chapter 5—Troubleshooting SQL Server
This section provides additional information if you have any difficulty installing or connecting to a supported
version of Microsoft® SQL Server®.

Installation Issues
The following paragraphs provide troubleshooting tips for installation issues.

Collation
Sage Estimating requires a special collation setting. Collation settings in SQL Server must be set to:

n Latin1_General

n Case-sensitive

n Accent-sensitive

These settings are configured automatically when you create the SQL Server Express instance from the Sage
Estimating install. Youmay sometimes see this listed in SQL Server as SQL_Latin1_General_CS_AS.

NOTE: If you upgraded to SQL Server Express 2014, your collation settings may not correctly match
the settings required by Sage Estimating.

Compatibility
Sage Estimating requires SQL Server 2008 R2, or higher.

SQL Server is designed so that multiple instances may exist on a single computer. Each instance is
independent of the others, andmay use different versions or service packs.

Youmay need to remove the existing version to resolve any compatibility issues. However, be aware that
other softwaremay be using the incompatible version. Contact your system administrator before attempting
to remove any incompatible version.

If you determine that the version can be removed safely, useWindows' Add or Remove Programs to
remove it (note that youmay have to remove several entries to completely remove the version).

Connection Issues
The following paragraphs provide troubleshooting tips for connection issues.

Authentication mode
The authenticationmode for the SQL Server instance you create for Sage Estimatingmust be set to
Windows Authentication and SQL Server Authentication (also referred to as "MixedMode") to work with

SQL Server Guide 17

This
 ve

rsi
on

 of
 th

e s
oft

ware
 

ha
s b

ee
n r

eti
red



Sage Estimating. In this mode, SQL Server creates andmaintains your login information. See “Chapter 5—
Troubleshooting SQL Server” on page 17 for more information.

Changing the authentication mode

If the authenticationmode is not set correctly, you can resolve this issue in SQL Server Management Studio
Express, as follows:

1 Start Microsoft SQL Server Management Studio Express.

p In Windows 7:Click Start > All Programs > Microsoft SQL Server Express > SQL Server
Management Studio Express.

p In Windows 8.1 or Windows 10:Click Start > All apps > Microsoft SQL Server Express
> SQL Server Management Studio.

2 Confirm that the correct Server type, Server name, andAuthentication settings are correct, and then
click [Connect]. For example:

Server type: Database Engine

Server name:Machine_name\instance_name

Authentication: Windows Authentication

NOTE: If Windows Authentication does not work, try SQL Server Authentication. Youmust have
security permission in SQL Server to access the database using this authentication.

3 In theObject Explorer pane, right-click on the server name and select Properties.

4 Youmust select the server name, not the folders below it, in order to see theSecurity option in the next
step.

5 Select Security.

6 Select SQL Server and Windows Authentication.

7 Click [OK] twice.

If the authenticationmode is set correctly and you are still experiencing problems, contact your system
administrator to review your permission settings inWindows or SQL Server. See “Security Administration” on
page 23 for more information.

Database location
Your default database locationmay not be set correctly in the system registry. See “Appendix A—SQL Server
Instance Settings” on page 29 for verification instructions.

Chapter 5—Troubleshooting SQL Server
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Firewall settings
If you experience communication issues with a remote SQL Server instance, youmay be using a firewall that
is set up to block network traffic between your computer and the SQL Server instance. To allow
communication, you need to set two firewall exceptions:

n The SQL Server Database Engine service

n The SQL Server browser service

NOTES:l The following instructions are for use withWindows Firewall. If you are using another firewall for your
system, contact the firewall manufacturer for instructions on setting service exceptions.

l Sage recommends contacting your system administrator if you need to change firewall settings.

l This procedure does not cover setting firewall exceptions for installations on a workgroup. If you are
using SQL Server on a workgroup server, youmust set separate firewall exceptions to allow your
workstations to communicate with the SQL Server instance. Refer to the Installation & Administration
Guide for instructions.

Setting the SQL Server Database Engine exception

Set up a SQL Server Database Engine exception for each instance of SQL Server you use with Sage
Estimating.

1 Determine the path to your SQL Server computer.

a On the computer or server where SQL Server is installed, open the SQL Server ConfigurationManager.

2 Start the SQL Server ConfigurationManager.

p In Windows 7: Click Start > All Programs >Microsoft SQL Server > Configuration Tools
> SQL Server Configuration Manager.

p In Windows 8.1 or Windows 10: Click Start > All apps > Microsoft SQL Server >  SQL Server
Configuration Manager.

The SQL Server ConfigurationManager opens.

Connection Issues
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Figure 4: The SQL Server ConfigurationManager

b In the left-hand pane of the SQL Server ConfigurationManager, select SQL Server Services.

c In the right-hand pane, right-click onSQL Server (INSTANCE), where (INSTANCE) is the SQL Server
instance for which you are creating the firewall exception, and select Properties.

d In theSQL Server Propertieswindow, click on theService tab.

Chapter 5—Troubleshooting SQL Server
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Figure 5: SQL Server Properties Window—Service Tab

e In theBinary Path entry, note or record the path described within the quotationmarks. This is the file
path to the SQL Server instance binary files (the path is contained only within the quotationmarks—
ignore the text outside the quotes).

3 OpenWindows Firewall by selectingStart > Control Panel > System and Security > Administrative
Tools > Windows Firewall with Advanced Settings.

If you are usingWindows 8.1 orWindows 10, select Start > All apps > Windows System > Control
Panel > System and Security > Administrative Tools > Windows Firewall > Advanced Settings.

4 In the left-hand pane of theWindows Firewall with Advanced Securitywindow, right-click Inbound
Rules, and then select New Rule.

5 In theNew Inbound Rulewizard, select theProgram option, and then click [Next].

6 Select the This program path option.

7 Click [Browse] and locate the sqlservr.exe file at the binary file path you recorded in step 1, and then click
[Open].

8 Select theAllow the connection option, and then click [Next].

9 Select theDomain, Public, andPrivate check boxes, and then click [Next].

Connection Issues
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10 Type the name of your SQL Server instance in theName box.

11 Click [Finish] to create the firewall exception for the SQL Server Database Engine service.

TheWindows Firewall with Advanced Securitywindow opens.

Figure 6: Windows Firewall with Advanced Security Window

Setting the SQL Server browser service exception

1 OpenWindows Firewall by selectingStart > Control Panel > System and Security > Administrative
Tools > Windows Firewall with Advanced Settings.

If you are usingWindows 8.1 orWindows 10, select Start > All apps > Windows System > Control
Panel > System and Security > Administrative Tools > Windows Firewall > Advanced Settings.

2 In the left-hand pane of theWindows Firewall with Advanced Securitywindow, right-click Inbound
Rules, and then select New Rule.

3 In theNew Inbound Rulewizard, select thePort option and click [Next].

4 Select UDP as the protocol type.

5 Select theSpecific local ports option and type 1434 in the corresponding box.

6 Click [Next].

7 Select theAllow the connection option and click [Next].

8 Select theDomain, Public, andPrivate check boxes then click [Next].

9 Type SQL Server Browser Exception in theName box.

Chapter 5—Troubleshooting SQL Server
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10 Click [Finish] to create the firewall exception for the SQL Server browser service.

Network configuration
To connect with SQL Server, youmust have TCP/IP enabled.

Enable TCP/IP

If you are receiving network configuration errors, make sure that TCP/IP is enabled, as follows:

1 Select Start > Control Panel > Administrative Tools > Windows Firewall with Advanced Security.

2 Start the SQL Server ConfigurationManager.

p In Windows 7: Click Start > All Programs >Microsoft SQL Server > Configuration Tools
> SQL Server Configuration Manager.

p In Windows 8.1 or Windows 10: Click Start > All apps > Microsoft SQL Server >  SQL Server
Configuration Manager.

3 ExpandSQL Server Network Configuration.

4 Select Protocols for SAGE_ESTIMATING (or the name of your instance).

5 Right-click on TCP/IP and select Enable.

6 Click [OK].

NOTE: Youmust stop and restart the SQL Server services for this change to take effect. See “SQL
Server services” on page 24 for more information.

Running a virus scanner on the SQL Server host machine
For performance reasons, if you plan to run a virus scanner on themachine that hosts the SQL Server
instance, you should exclude files that haveMDF, LDF, NDF, BAK, TRN, and TRC extensions. You should
also exclude additional processes for the version of SQL Server that you are running. For more information
about the files and processes to exclude, seeMicrosoft Knowledgebase article 309422 at
http://support2.microsoft.com/kb/309422.

Security Administration
Operators using Sage Estimatingmust have SQL Server permissions to the databases they are expected to
use. You assign permissions using the Roles and Permissions features in the EstimatingManagement
Console. For more information, see the Installation & Administration Guide.

If an operator is experiencing connection issues with a database, verify the operator belongs to a role with the
appropriate permissions.

Connection Issues
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SQL Server services
Youmay have several SQL Server services or instances, depending on the version of SQL Server you are
using. For SQL Server Express, the following are used:

n SQLServer (the name you assigned to the SQL Server instance)

n SQLServer Browser

If the service is not running, you can start it using SQL Server ConfigurationManager.

To Start the SQL Server Engine Using SQL Server Configuration

1 Start the SQL Server ConfigurationManager.

2 Start the SQL Server ConfigurationManager.

p In Windows 7: Click Start > All Programs >Microsoft SQL Server > Configuration Tools
> SQL Server Configuration Manager.

p In Windows 8.1 or Windows 10: Click Start > All apps > Microsoft SQL Server >  SQL Server
Configuration Manager.

3 Select SQL Server Services.

4 Right-click the service (for example, SQL Server (<instance name>)), and then click Start.

To Stop the SQL Server Engine Using SQL Server Configuration

1 Start the SQL Server ConfigurationManager.

2 Start the SQL Server ConfigurationManager.

p In Windows 7: Click Start > All Programs >Microsoft SQL Server > Configuration Tools
> SQL Server Configuration Manager.

p In Windows 8.1 or Windows 10: Click Start > All apps > Microsoft SQL Server >  SQL Server
Configuration Manager.

3 Select SQL Server Services.

4 Right-click the service (for example, SQL Server (<instance name>)), and then click Stop.

Determining the path to the SQL Server program
If you havemultiple instances of SQL Server installed, each instance is independent of the others. To
determine the location of the SQL Server program for a particular instance, do the following:

1 Start Microsoft SQL Server Management Studio Express.

p In Windows 7:Click Start > All Programs > Microsoft SQL Server Express > SQL Server
Management Studio Express.

Chapter 5—Troubleshooting SQL Server
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p In Windows 8.1 or Windows 10:Click Start > All apps > Microsoft SQL Server Express
> SQL Server Management Studio.

2 In theConnect to Serverwindow, confirm that the correct Server type, Server name, and
Authentication are selected, and then click [Connect]. For example:

p Server type: Database Engine

p Server name: Computer_name\instance_name

p Authentication: Windows Authentication
If Windows Authentication does not work, try SQL Server Authentication. Youmust have security
permission in SQL Server to access the database using this authentication.

3 Right-click on the server name, and then select Properties.

The path is listed on theGeneral page next toRoot Directory. Make note of this path.

4 Click [Cancel] and then close theSQL Server Management Studio Express window to exit without
making any changes.

The program exists in the Binn directory, which is below the root directory you noted in step 4. For example:
C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\sqlservr.exe. The actual number in the path
may be different depending on how many instances you have installed on the computer.

Determining the path to the SQL Server program

SQLServer Guide 25

This
 ve

rsi
on

 of
 th

e s
oft

ware
 

ha
s b

ee
n r

eti
red



Chapter 6—Additional Information
The following is provided as additional resourcematerial. It is included for reference only and is not meant to
imply that Sage supports, controls, or endorses any of the content. Be aware that titles, links, and content can
change andmay not always be pertinent to your situation.

General Information
Instance Configuration:

http://msdn.microsoft.com/en-us/library/ms143531(v=SQL.100).aspx

Microsoft SQL Server Security Datasheet:

http://download.microsoft.com/download/D/1/B/D1B8D9AA-19E3-4DAB-AF9C-
05C9CCEDD85C/SQL%20Server%202008%20Security%20-%20Datasheet.pdf

Collation or Corruption
How to Rebuild theMaster Database for SQL Server:

http://msdn.microsoft.com/en-us/library/dd207003(v=SQL.100).aspx

Security
Password Policy:

http://msdn.microsoft.com/en-us/library/ms161959(v=SQL.100).aspx

SQL Server Security White Papers:

http://www.microsoft.com/sql/technologies/security/whitepapers.mspx
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Strong Passwords:

http://msdn.microsoft.com/en-us/library/ms161962(v=SQL.100).aspx

Services
How to Verify a Successful Installation of SQL Server Reporting Services:

http://msdn.microsoft.com/en-us/library/ms143773(v=SQL.100).aspx

Managing the Database Engine Services:

http://msdn.microsoft.com/en-us/library/ms189925(v=SQL.100).aspx

Managing Services Using SQL Server Management Studio:

http://msdn.microsoft.com/en-us/library/ms187478(v=SQL.100).aspx
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Chapter 7—Glossary
BOL/Books On Line
SQLServer Books On Line. These are resourcematerials for SQL Server provided by Microsoft. Books On
Line is automatically installed with the Sage Estimating installation of SQL Server Express Edition. You can
also download a current copy at www.microsoft.com.

Instance/Named Instance
A complete database environment, including the relational databasemanagement system software, table
structure, stored procedures, and other functionality.

Microsoft Desktop Engine (MSDE)
A database engine compatible with earlier versions of SQL Server.

sa
The system administrator for SQL Server.

SQL
Structured Query Language, the standardized language used in virtually all relational databases.

SQL Server Management Studio (SSMS)
The configuration tool used tomanage all aspects of the SQL server.

SQL Server Management Studio Express (SSMSE/SSMS Express)
A limited version of SQL Server Management Studio.

Stored Procedures
Database functions that allow advanced pre-compiled queries.

Transact-SQL
A robust scripting language supported by Microsoft SQL Server.

User Account Control (UAC)
A method of adding security toWindows by creating different access levels for administrators and standard
users. It also prevents standard users from changing system settings or affecting sensitive system
information.
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Appendix A—SQL Server Instance
Settings
If you have an existing instance of a supported version of Microsoft® SQL Server® installed, you can set up
another instance to work with Sage Estimating. (Options described in this sectionmay vary slightly depending
on the edition you are installing.)

NOTE: If you choose to uninstall your existing instance first, restart your server before reinstalling to
avoid problems with the new installation.

CAUTION: Do not change the owner of any databases in the Sage Estimating instance.

Set your new SQL Server instance to the settings outlined in the following sections.

SAGE_ESTIMATING Instance
Figure 7: Instance Configuration Settings

Youmust use a named instance. You can give the instance any name you want. However, Sage
recommends giving the instance a name that makes it easily identified (such as SAGE_ESTIMATING).
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Authentication Mode
Figure 8: AuthenticationMode Settings

The instancemust supportMixed Mode authentication (Windows Authentication and SQL Server
Authentication). This means eitherWindows authentication or SQL Server authentication can be used to
access the database information.

WhenWindows authentication is used, the operator must have permissions to use SQL Server or be a
member of a group that has those permissions. InWindows authenticationmode, SQL Server validates the
account name and password using information from theWindows operating system.

When SQL Server authentication is used, the operator must have system administrator (sysadmin) rights in
SQL Server. The SQL Server authentication is used for backward-compatibility and requires a strong
password.

Collation Settings
Collation settings must be Latin1_General, case-sensitive, and accent-sensitive (Latin1_General_CS_
AS).

You can customize the collation settings during the server configuration portion of the SQL Server install. In
the SQL Server collation customization window, make the following selections:
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n Select theWindows collation designator and sort order option (instead of SQL collation, which is the
default)

n Latin1_General (for the collation designator)

n Case-sensitive

n Accent-sensitive

n Clear all other options

Additional Recommendations
To ensure accurate performance, Sage strongly recommends making changes and verifications to the
following settings in SQL Server Management Studio and SQL Server ConfigurationManager. Failure tomake
these changes may result in poor Sage Estimating performance or communication issues.

Memory
Determine the amount of available memory on the server or workstation where SQL Server is installed. To
prevent SQL Server from consuming all available memory, use SQL Server Management Studio to set the
maximum amount of memory (in the instance properties) to a reasonable limit (such as 4GB ) as follows:

1 Right-click on the SQL Server instance and select Properties.

2 In the Server Properties window, click Memory (left-hand pane).

3 Set theMaximum server memory amount to 4000 (or whatever limit you determine).

Communication protocol
Set the communication protocol settings for the Sage Estimating SQL Server instance as follows:

1 Start the SQL Server ConfigurationManager by selectingStart > All Programs > SQL Server [your
version] > Configuration Tools > SQL Server Configuration Manager.

InWindows 8.1 andWindows 10, select Start > All apps > SQL Server [your version] > SQL Server
Configuration Manager.

2 In the left-hand pane of theSQL Server Configuration Manager window, click the arrow next to
SQL Server Network Configuration to display all local SQL Server instances.

3 Select the instance associated with Sage Estimating (SAGE_ESTIMATING, by default).

4 In the right-hand pane right-click on a communication protocol and select Disable.

5 Repeat step 4 for all communication protocols except TCP/IP. Leave this protocol Enabled.

Additional Recommendations
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6 In the left-hand pane of theSQL Server Configuration Managerwindow, click the arrow next to
SQL Native Client 10.0 Configuration orSQL Native Client 11.0 Configuration (depending on your
SQL Server instance).

7 Click Client Protocols (left-hand pane).

8 In the right-hand pane right-click on a communication protocol and select Disable.

9 Repeat step 8 for all communication protocols except TCP/IP. Leave this protocol Enabled.

10 Close the SQL Server ConfigurationManager and restart the service.

Appendix A—SQL Server Instance Settings

32 Sage Estimating (SQL)

This
 ve

rsi
on

 of
 th

e s
oft

ware
 

ha
s b

ee
n r

eti
red



Appendix B—Backing Up and Restoring
Using SQL Management Studio
Sage EstimatingManagement Console includes Backup and Restore tools that we recommend you use for
backing up and restoring your Sage Estimating data. They are very efficient processes that minimize the
possibility of error. In addition, the Restore process automatically upgrades databases to your current version
if you backed them up using an earlier version, which can save you time. For more information and step-by-
step instructions, see the EstimatingManagement Console help.

If you prefer to use SQL Server Management Studio or Management Studio Express to back up your
Microsoft® SQLServer® databases, follow the instructions in this appendix.

Backing Up SQL Server Databases
If you choose to back up and restore your Sage Estimating data using the SQL Server tools, make sure you
include all the necessary steps in your back up procedures.

Your SQL Server database backup copy is generated in two steps:

1 Use SQL Server Management Studio (or Management Studio Express) to make a backup copy of the
database into a file folder.

The default location for this folder is C:\Program Files\Microsoft SQL Server\MSSQL10_50.SAGE_
ESTIMATING\MSSQL\Backup. (The actual number and instance name that appears in the pathmay be
different if you havemultiple instances of SQL Server installed or if you named your instance a different
name.)

2 Make sure to include the SQL backup folder (referenced in step 1) when you perform your tape or third-party
backup.

NOTES:l Be sure to perform regular tests of your backups to ensure they are working properly.

l You can perform backup and restore functions using SQL Server Management Studio or Management
Studio Express. Installing SQL Server Express from the Sage Estimating setup and installation files
installs a copy of SQL Server Management Studio Express.

l SQLServer Management Studio Express automatically detaches and attaches the database when
you back up and restore.

CAUTION: The restore process overwrites any changes youmake to the database between creation of
backup copies.

Backing up the SQL Database
1 Start Microsoft SQL Server Management Studio Express.
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p In Windows 7:Click Start > All Programs > Microsoft SQL Server Express > SQL Server
Management Studio Express.

p In Windows 8.1 or Windows 10:Click Start > All apps > Microsoft SQL Server Express
> SQL Server Management Studio.

2 Select the database you want to back up from theObject Explorer pane.

Figure 9: Database List in the Object Explorer Pane

3 Right-click the database, and then select Tasks > Back Up to open theBack Up Databasewindow.
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Figure 10: The Back UpDatabaseWindow

4 Under Source (in the right-hand pane of theBack Up Databasewindow), select the database to be backed
up from theDatabase list.

p For the backup type, select Full.

p For the backup component, select Database.

5 UnderBackup Set, type a name for the database backup you are creating in theName box.

If desired, also type a description for the backup in theDescriptionbox.

6 Set the desired expiration criteria for the backup in theBackup set will expire section.

7 Select the backup destination from theDestination list.

This list displays previously defined backup file paths and file names. The backup utility selects the
Backup folder in your SQL Server instance folder by default but you can add a new file path as a destination
by clicking [Add].

8 Click [OK]. A Backup of database completed successfullymessage appears when the backup
operation is finished.

Youmay now perform your normal tape or third-party back up procedures.

Be sure to include the SQL back up folder (or the folder where your backup copy is stored if you selected
another location in step 7). The default location for this folder is C:\Program Files\Microsoft SQL

Backing up the SQLDatabase
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Server\MSSQL10_50.SAGE_ESTIMATING\MSSQL\Backup. (The actual number and the name that appears
in the pathmay be different if you havemultiple instances of SQL Server installed or if you named the instance
a different name.)

Restoring the SQL Database
CAUTION: The restore process overwrites any changes youmake to the database between creation of
backup copies.

1 Start Microsoft SQL Server Management Studio Express.

p In Windows 7:Click Start > All Programs > Microsoft SQL Server Express > SQL Server
Management Studio Express.

p In Windows 8.1 or Windows 10:Click Start > All apps > Microsoft SQL Server Express
> SQL Server Management Studio.

2 Select the database you want to restore from theObject Viewer pane.

Figure 11: Database List in the Object Viewer Pane

3 Right-click the database, and then select Tasks > Restore > Database to open theRestore Database
window.
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Figure 12: The Restore DatabaseWindow

4 Select the database you want to restore in the To databasebox.

If you want to create a new database, type the name of the database in the To database box.

5 UnderSource for restore, select From database then select the name of the backup database copy you
want to use for the restore operation.

6 In theSelect the backup sets to restore table, select the check box for the database you want to restore.

7 In theSelect a page pane (in the upper left-hand corner of the window), click Options.

8 In theRestore Options area, select theOverwrite the existing database check box.

9 Click [OK].

A Restore of database completed successfullymessage appears when the restoration operation is
finished.

NOTE: The restore process overwrites any changes youmade to the database since the last time you
created a backup.

10If you restored an Estimates database, youmust run the security.fix procedure as follows:

Restoring the SQLDatabase
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a In SQLManagement Studio, locate and then expand the folder for the estimates database that you
restored.

a Click Programmability -> Stored Procedures.

b Scroll to the security.fix stored procedure, right click the file, and then click Execute Stored
Procedure.

c Click [OK].
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