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Chapter 1—Release Overview
Sage welcomes you to Sage Estimating. Read this guide carefully to understand the installation and
configuration process.

Configuration Features in Sage Estimating
Youwill find the following configuration features in Sage Estimating:

n Estimating Management Console. The EstimatingManagement Console allows you to view andmanage
your databases, estimates, and roles and permissions. You can also use the EstimatingManagement
Console to perform datamigrations, share estimate layouts, view andmanage estimates, and set up
custom estimate reports.

n Configuration wizard. The Configuration wizard lets you designate a SQL Server instance to act as your
Sage Estimating server. Using the Configuration wizard, you can also create the estimate database,
upgrade existing data, and set up your software licensing and registration. For more information, see “D.
Run the ConfigurationWizard” on page 15.

Read the Supporting Documentation Before You Install
Be sure to read supporting documentation before you install Sage Estimating (SQL):

l This Installation and Administration Guide includes an overview of this release, installation
instructions, system requirements, and contact information.

l TheRelease Notes provide details about new features, database changes, known issues, and fixes.
This document is available in your Sage Estimating installation files in theDocuments folder.

l TheGetting Started Guide provides an operational overview of the Sage Estimating software. This
document is available in your Sage Estimating installation files in theDocuments folder.

l TheSQL Server Guide gives you an overview of the significant differences between the new
SQL Server databases and the Pervasive databases used in previous Sage Estimating releases. This
document is available on your Sage Estimating installation files in theDocuments folder.

l TheOptions Guide provides installation, setup, and operating instructions for each of the available
Sage Estimating options, such as the OnScreen Takeoff Integrator or LicenseManager. This
document is available in your Sage Estimating installation files in theDocuments folder.

Conventions Used in this Document
This document uses the following conventions:

n Information you type into the software is shown in bold font. For example: TypeMiscellaneous in the box.

n The names of screens, windows, fields, and other features displayed by the software are shown in bold
font.

n The names of buttons you can click are enclosed in brackets with bold font. For example: [OK] or [Post].

Installation and Administration Guide 1
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n Names of keys are shown in capital letters. For example: ENTER or TAB. A plus sign (+) between two key
names indicates you should press the keys simultaneously.

n Variable names or names that are specific to your installationmay appear in italics and brackets. For
example: [Drive]\\[Server].

Symbols

NOTE: This symbol is used when presenting information that is supplemental to the adjacent text.

TIP: This symbol is used when presenting helpful information for using the software.

CAUTION: This symbol is used when presenting important information to help you avoid a loss of
critical data.

IMPORTANT: This symbol is used when presenting information that is critical to understand or that
requires you to take action.

Menu Paths
In this document, menu paths show you the steps required to start a task. Menu paths appear in bold font with
square brackets around buttons. For example:

"If the program does not automatically start, click [Start] > Run."

Online Help
The Sage Estimating software includes online Help, which provides answers to your questions about
procedures as well as items in the windows.

To access the online Help in the Sage Estimating software, click the Help button or icon, or press [F1] to
display the help topic for that window.

To aid you in finding the information you need, the online Help for eachmodule includes the following panes:

n Contents pane containing links to the help topics

n Index pane containing keywords that link to help topics related to that keyword

n Search pane, where you can type text and click [Search] to locate that text in the help topics

For more information about using the online Help, see the Sage Estimating Help.

Wewould like your feedback about the online Help so we canmake improvements. Each Help topic contains
an area where you can indicate whether the topic was helpful and provide additional comments. To protect
your privacy, all comments are anonymous.

Chapter 1—ReleaseOverview
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Training
Sage University offers online and classroom training sessions to help you get themost out of your Sage
Estimating software. To access Sage University, visit www.sageu.com.

You can also get access to Sage University from the File menu by selectingHelp > Sage Estimating on the
Web > Sage University.

Technical Assistance
When you need assistance, refer to the Knowledgebase article How do I get technical support for Sage
Estimating? to determine which service works best for you.

Submitting Enhancement Requests
Wewant to hear your suggestions for improving the software. To send us your comments, click the File menu
button , and then select Help > Sage Estimating on the Web > Submit Enhancement Requests.

Training

Installation and Administration Guide 3
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Chapter 2—System Requirements
As with any software, as we continue to enhance Sage Estimating, you will realize optimal system
performance by using up-to-date computer hardware. This includes memory as well as overall hardware
specifications.

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and
other software, and about system requirements for servers and client workstations, refer to our
Knowledgebase article ID 71213, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=76530.

For help in selecting the right business-class computers for your business-class software, contact your
authorized business partner.

Access Rights
The following sections describe the access rights you need to successfully install and use Sage Estimating.

Elevate Permissions
Youmust elevate your permissions before installing Sage Estimating onWindows 7 andWindows 8.1. During
certain installation tasks, you will receive another prompt to elevate your privileges. If you do not acknowledge
each prompt within twominutes, the installation process will quit the task. If this occurs, youmay receive a
separate prompt asking you to retry the task. To retry the task, click [Retry] and then elevate your privileges
at the prompt.

SQL Server Permissions
Database permissions for SQL Server instances used with Sage Estimating are now set up using the
Security feature in the EstimatingManagement Console.

For more information on setting up SQL Server security for Sage Estimating, see “F. Set Up Roles and
Permissions” on page 17.

Full Control of Specific Files and Folders Required
To use Sage Estimating, youmust have full control of the following files and folders on your file server,
terminal server, and workstations that have Sage Estimating installed. Make sure that your system
administrator also gives you full control of all the subfolders and files.

CAUTION: Incorrectly modifyingMicrosoft Windows security may severely affect your system
operations. Sage is not responsible for operation problems caused by incorrectly modifying your
Microsoft Windows security settings. To set permissions on your network orWindows operating
system, youmust have advanced knowledge of your network. Contact your system administrator for
assistance.

NOTE: Some of these folders may be hidden. To view them:

Installation and Administration Guide 5
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p InWindows 7, openWindows Explorer, and then click Organize> Folder and Search Options> View
tab > Show hidden files and folders.

p InWindows 8.1 andWindows 10, openWindows Explorer, click theView tab, and then select the
Hidden items check box in theShow/hide group.

Table 1: Folders and Files Requiring Operator Control

Product Operating
Systems

Required Folders
and Files Location and Specifications

Sage
Estimating

64-bit Windows
systems

[Drive]:\Program
Files (x86)\Sage
Estimating

This folder is located on the file
server, terminal server, and
workstations where you installed
Sage Estimating. It is the default
installation location for Sage
Estimating. However, depending on
your system configuration, your
company may have renamed this
folder or installed it to a different
location.

Sage
Estimating

Windows 7,
Windows 8.1

[Drive]
:\Users\Public\Sage
Estimating

-and-

[Drive]
:\ProgramData\Sage
Estimating

These folders are located on the
workstation or terminal server where
you use Sage Estimating. Sage
Estimating installs necessary files to
these folders and requires that the
user has full control of them.

Full Control and Read Access to Specific Registry Keys Required
To use Sage Estimating, youmust have full control of the followingWindows registry key on your file server,
terminal server, and workstations that have Sage Estimating installed. Make sure that your system
administrator also gives you full control of all subkeys.

CAUTION: Incorrectly editing theMicrosoft Windows registry may severely damage your system.
Sage is not responsible for damage to your system caused by editing the registry. Beforemaking
changes to the registry, contact your system administrator for assistance andmake a backup copy of all
valued data. System administrators, seeMicrosoft Registry Editor Help topics for detailed instructions.

n HKEY_CURRENT_USER

You should also have read access to the following registry keys and associated subkeys:

n HKEY_Local_Machine\Software\ODBC

n HKEY_Local_Machine\Software\Wow6432Node\Sage

Chapter 2—System Requirements
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Supported Upgrade Paths
If you plan to use your estimate data from a release earlier than version 9.6, youmust upgrade your data to
Sage Estimating 9.6 or later prior to migrating your data. Refer to “Chapter 4—DataMigration” on page 23 for
datamigration instructions.

NOTE: Do not install previous releases of Sage 300 Construction and Real Estate (formerly Sage
Timberline Office) after installing Sage Estimating 16.11. The new Sentinel driver is incompatible with
previous releases.

You can upgrade any Windows-based Sage Estimating data (beginning with Sage Estimating 1.0) to Sage
Estimating 9.6.

If desired, you can install this version of Sage Estimating without uninstalling your previous Sage Estimating
installation. However, because the data format is different, you cannot migrate data to this release from
releases of Sage Estimating earlier than version 9.6 without upgrading your data first.

Supported Upgrade Paths

Installation and Administration Guide 7
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Chapter 3—Installation and
Configuration
Installation and Configuration Categories
Installation and configuration of Sage Estimating falls into one of three primary scenarios.

n Scenario 1: Set up in a server/workstation domain

n Scenario 2: Set up in a workgroup environment

n Scenario 3: Set up on a standalone computer

Use the following diagrams to plan the installation and configuration process for your setup scenario.

Installation and Administration Guide 9
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Figure 1: Scenario 1 (Domain server/workstation environment, databases installed on the server)

Chapter 3—Installation and Configuration
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Figure 2: Scenario 2 (Workgroup environment, estimating data shared from one workstation)

Installation and Configuration Categories

Installation and Administration Guide 11
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Figure 3: Scenario 3 (Standalone workstation environment, estimating data stored on the workstation)

A. Before You Install or Upgrade
Ensure you read through and understand the information in this installation guide.

1 If you are currently using a previously-released version of Sage Estimating, create a complete backup copy
of all Sage Estimating data and program files before installing this release.

2 Install the appropriate operating system service pack level, make sure that there is sufficient hard disk
space available, and ensure that your server and workstations meet all other hardware and software
requirements.

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®,
and other software, and about system requirements for servers and client workstations, refer to our
Knowledgebase article ID 71213, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=76530.

3 Make sure that you have full control of the necessary folders, files, and registry keys on your file server,
terminal server, and workstations that will have Sage Estimating installed. For a list of the required folders,
files, and registry keys for your operating system, see “Chapter 2—System Requirements” on page 5.

4 Close all programs and services for the duration of the installation. This includes programs that may be
running in the background such as antivirus, email, and backup programs.

5 If you do not have Sentinel protection devices attached to your computer, do not attach these devices until
after you install Sage Estimating. If you already have Sentinel protection devices attached, you can leave
these devices in place during the Sage Estimating installation.

Chapter 3—Installation and Configuration
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6 Decide which installation scenario to follow. See “Installation and Configuration Categories” in the previous
section.

7 Youmust have the appropriate permissions to perform certain tasks described in this chapter. Contact your
Sage Estimating administrator if you require additional permissions.

B. Install Sage Estimating
If you have not already done so, download the Sage Estimating installation files according to the instructions
provided in the software notice. If you are installing Sage Estimating on a server, ensure you save the
installation files in a location that all workstations can access. Then copy the installation files to each
workstation where you want to install Sage Estimating.

IMPORTANT:l Do not install Sage Estimating unless you have sufficient hard disk space available.

For current information about supported operating systems, Internet browsers, Microsoft®

SQL Server®, and other software, and about system requirements for servers and client workstations,
refer to our Knowledgebase article ID 71213, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=76530..

l Do not install previous releases of Sage 300 Construction and Real Estate after installing Sage
Estimating. The new Sentinel drive is incompatible with previous releases.

1 At the workstation or server, log on with full administrative rights.

Full administrative rights are defined as write access to theWindows registry and all folders on the
computer (including rights to the root of all hard drives). If you are unsure whether you have full
administrative rights, ask your network administrator for assistance.

2 Double-click theSetMeUp.exe file in your local Sage Estimating install folder.

The Sage Estimating install folder is at the location you specified during the Sage Estimating download
process. For example, if you downloaded the installation files to C:\Users\Public\Public Documents\Sage
Estimating, look in this folder for theSetMeUp.exe file.

3 When prompted by theUser Account Control dialog box, click [Yes] to allow the program tomake
changes to the computer.

4 Read the terms of the Sage License Agreement, and then click [Accept] to accept them.

5 On the Sage Estimating installation window that appears, select Sage Estimating.

B. Install Sage Estimating

Installation and Administration Guide 13
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Selecting this option alone installs the Sage Estimating software and support components, but does not
install a new instance of SQL Server Express. If you need to create a new SQLServer instance, follow the
instructions in the next section, “C. Install/Configure SQL Server ”.

6 Follow the remaining steps as prompted by the installation process, which guides you through the
installation of Sage Estimating products and required support software.

NOTES:
l The installation process may restart your computer during the installation. Ensure you close all
programs and applications before starting the installation to avoid losing any data. If your computer
restarts, log on to your computer again.

l If you choose to upgrade data from a previous version of Sage Estimating, the process may take up to
four hours, depending on the size of your database. Plan accordingly.

7 Repeat steps 1 through 6 for each workstation or server where you want to install Sage Estimating. (For
more detailed information, refer to scenarios 1, 2, and 3 on “Installation and Configuration Categories” on
page 9.)

C. Install/Configure SQL Server 
If you are installing Sage Estimating for the first time, or if you want to create a new SQLServer Instance,
install or configure a supported version of SQL Server on the server or workstation where you want to store
your Sage Estimating data.

Chapter 3—Installation and Configuration
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A copy of SQL Server Express is included with the Sage Estimating installation.

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and
other software, and about system requirements for servers and client workstations, refer to our
Knowledgebase article ID 71213, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=76530.

n If you want to use an existing installation of SQL Server, refer to “Chapter 5—Configuring SQL Server” on
page 27 for settings for creating and configuring a new instance.

n If Microsoft® SQL Server® is not already installed on the server or workstation where you plan to keep your
Sage Estimating databases, and you want to install the copy of SQL Server Express that comes with Sage
Estimating, select theCreate a new local SQL Server instance option during installation.

If you are operating in a workstation/server environment (see “Installation and Configuration Categories” on
page 9), you do not need to install SQL Server on the workstations.

NOTES:l At the instance name prompt, type a name for the new SQL Server instance (database server) in the
box, and then click [OK].

The default instance name is SAGE_ESTIMATING, but you can give the instance any name you
want provided you do not give it the same name as any existing SQL Server instance on the
computer.

l If you plan tomigrate existing data from Pervasive-based Sage Estimating (version 9.6 and later) to
version 16.11, youmust install SQL Server on the destination computer or server.

l The installation process may restart your computer. If your computer restarts, log back onto your
computer at the prompt.

l You can install an approved instance of SQL Server side by side on a computer where SQL Server
2008 R2 or SQL Server 2012 is also installed. Be aware that installing Sage Estimatingmay result in
an "Install completed with errors" message. However, the resulting Sage Estimating install operates
correctly.

l Sage recommends against installing SQL Server Express on a domain controller.

D. Run the Configuration Wizard
The Configuration wizard installs automatically as part of the Sage Estimating installation.

1 Start the Configuration wizard as follows, depending on your operating system:

p For Windows 7: Click Start > All Programs > Sage > Estimating 16.11 > Configuration Wizard.

p For Windows 8.1 or Windows 10: Click theConfiguration Wizard tile on the Start menu, or right-
click outside the tile area, and then click All apps > Sage > Configuration Wizard.

D. Run the ConfigurationWizard

Installation and Administration Guide 15
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NOTE: Depending on your version of Windows, youmay need to elevate your permissions before starting
the Configuration wizard by right-clicking Configuration Wizard (or the desktop icon), and then selecting
Run as administrator.

2 In theConfiguration Wizardwindow, register your software if prompted as follows:

a Locate your product's registration name from the packing slip enclosed with the original shipment.

b Type the registration name in theRegistration name box.

c Locate each product or feature in theAvailable Features list that you want to use (left-hand pane) and
double-click it to add it to the registration list (in the detail pane).

Figure 4: Selecting Features for Registration and Activation

d In theActivation Code box of the registration list, type the activation code from the original shipment's
packing slip.

Alternatively, you can type one of the following selections in the Activation Code box for some of the
product features:

p DEMO: Operates the software feature in demonstrationmode.

p LM: Registers the software feature separately using LicenseManager.

See “H. Set Up LicenseManager (optional)” on page 19 for more information about setting up License
Manager.

e Click [Save] to save your registration and activation selections.

3 Click Server in the left-hand pane of the Configuration wizard.

4 Select the SQL Server instance ("server") that you are using for your Sage Estimating server by clicking
[Select].

5 Follow the on-screen prompts to finish configuring your Sage Estimating software.

Chapter 3—Installation and Configuration
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The prompts you receive vary depending on your installation. Youmay be prompted to perform one or more
of the following actions:

p If the Configuration wizard does not find a preexisting estimate database in the specified SQL Server
instance, it prompts you to create one. Type a name for the new estimate database at the prompt.

p If you are storing existing Sage Estimating data from a previous release (version 11.1 or later) on the
selected instance, the EstimatingManagement Console identifies the data for upgrade. Click [Upgrade]
then follow the prompts to upgrade your data.

6 Click [Finish] to exit the Configuration wizard.

E. Migrate Your Data (optional)
If you have existing Pervasive-based estimate data, you canmigrate your data to the current Sage Estimating
version. You can perform this process from any computer that has access to the SQL Server instance or
instances where you plan to store your estimate data. See “Chapter 4—DataMigration” for instructions.

F. Set Up Roles and Permissions
Set up roles and permissions from aworkstation where Sage Estimating is installed. If you are setting up
Sage Estimating in a workstation/server or workgroup environment, you need to perform the roles and
permissions setup from only one computer.

NOTE: Youmust be a Sage Estimating administrator to set up roles and permissions. The person who
installs Sage Estimating is set up automatically as a Sage Estimating administrator.

Setting up roles and permissions involves three general steps:

n Create roles and assign permissions to them.

n Set up a list of authorized Sage Estimating operators.

n Assign operators to roles.

Set up a list of operators and task/feature permissions using theSecurity feature in the Estimating
Management Console.

Create roles and assign permissions to them
1 Start the EstimatingManagement Console.

p For Windows 7:Click Start > Programs > Sage > Estimating 16.11 > Estimating Management
Console.

p For Windows 8.1 or Windows 10:Click theEstimating Management Console tile from the Start
menu, or right-click outside the tile area, and then click All apps > Sage > Estimating Management
Console.

2 At the top of the EstimatingManagement Console, click [Security].

E. Migrate Your Data (optional)

Installation and Administration Guide 17
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3 From theSecuritywindow of the EstimatingManagement Console, click theRoles tab.

4 Click [Add] to open theAdd Rolewindow.

5 In theAdd Rolewindow, type a name for the new role in theName box and an extended description in the
Description box.

Use the extended description to provide helpful identification information later, such as the purpose of the
role.

6 Select the check box next to one or more tasks in the features list to provide operators and groups assigned
to the role with access to the tasks.

For example, selecting a check box labeledCreate Estimate gives operators and groups within the role the
ability to create new estimates.

7 Clear the check box next to a task to prevent operators and groups in the role from accessing it.

Set up an operator list
1 In the EstimatingManagement Console, click [Security] to open theSecuritywindow (if it is not already
open), and then click theUsers tab.

2 On theUsers tab, click [Add] (located to the right of theUsers grid) to open theAdd Userwindow.

3 In theAdd Userwindow, click [Select] to create a list of all operator user IDs and group IDs on the network
to which Sage Estimating is connected.

Alternatively, if you already know the user or group ID you want to add, you can type it directly in theUser
Id box or type the first few letters and click [Select].

4 Select a network user ID or group ID from the resulting list.

NOTE: If you select a group ID, Sage Estimating adds all operators associated with the group.

5 Click [OK] in the Add Userwindow.

The operator or operators associated with the selected user or group ID appear in theUsers grid of theUsers
tab.

Assign an operator to a role
1 From theSecuritywindow, click theUsers tab.

2 Select an operator from the list in theUsers grid.

3 Click a role in theRoles list to assign the selected operator to it.

4 Repeat steps 1-3 for each operator you want to set up in Sage Estimating.

Chapter 3—Installation and Configuration
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The Features list displays the corresponding tasks to which a selected role has permissions. You can assign
an operator to more than one role and the Features list displays the cumulative task and feature permissions.

IMPORTANT: At least one operator must be assigned to the administrator role at all times. Attempts to
remove the last operator from the role result in an error message.

G. Set Up Firewall Exceptions
If you are installing Sage Estimating on a workgroup server, youmust set certain firewall exceptions to allow
workstations to communicate with the Sage Estimating SQL Server instance.

For instructions on setting firewall exceptions, see “Setting the Firewall forWorkgroups”.

H. Set Up License Manager (optional)
If desired, you can install LicenseManager to track andmanage your Sage Estimating network licenses.
LicenseManager uses a server protection device and network licenses to track application uses on the
network.

Use the instructions in this section to install LicenseManager.

Guidelines
Note that:

n All license-managed servers and workstations must use the same network protocol (TCP/IP).

n You cannot install LicenseManager to a terminal server. If you have a terminal server, install to a
workstation.

n If you use firewall software on your license server, youmay not be able to use theWlmAdmin or
WCommute applications to view or check out licenses. To resolve this issue, discuss the server’s firewall
security with your network administrator. If you are willing to adjust your firewall security settings on the
licensemanager server, consider granting access to the lservnt.exe file.

n Check in any licenses before upgrading.

For more information about LicenseManager, seeSentinel LicenseManager System Administrator Online
Help (index.html). This file is in the \\AdditionalInstalls\LicenseManager\SysAdminHelp folder in your
Sage Estimating setup and installation files.

Install the Sentinel driver
The Sage Estimating installation program automatically installs a Sentinel driver if you do not have one.
However, if you need instructions to install the Sentinel driver manually, visit www.sagecre.com and click
[Customer Support]. After you have logged on, in theKnowledgebase Search box, type How do I install
the Sentinel driver? See "Technical Assistance" on page 3 for more information about using the Technical
Support Knowledgebase.

G. Set Up Firewall Exceptions
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IMPORTANT: Do not install previous releases of Sage 300 Construction and Real Estate after
installing Sage Estimating. The new Sentinel driver is incompatible with previous releases.

Attach a protection device to the computer that will have License
Manager
1 If you have a parallel port protection device, disconnect any hardware or peripheral devices attached to the
parallel port.

2 Plug the protection device into the parallel port or USB port.

3 If you disconnected devices in step 1, reconnect these devices.

Install License Manager
If you already have LicenseManager installed, start with “Upgrade LicenseManager” on page 21.

1 Log on with full administrative rights. Full administrative rights are defined as write access to theWindows
registry and all folders on the computer (including rights to the root of all hard drives).

If you are unsure whether you have full administrative rights, ask your network administrator for assistance.
Alternately, you can ask your network administrator to log on with the network administrator ID before you
start the installation.

2 Browse to your Sage Estimating installation and setup files and double-click
\\AdditionalInstalls\LicenseManager\Server\Setup\Setup.exe.

3 Click [Open] then click [OK] to start the installation.

4 Follow the on-screen prompts. The installation automatically installs the appropriate software for the
operating system.

NOTE: Be sure to accept the default installation path when you install LicenseManager. If you need to
change the default installation path, change it to a local drive. You cannot install LicenseManager to a
network drive.

Install license codes
The number of network licenses purchased for an application indicates the total number of concurrent network
uses allowed for that application.

To install license codes:

1 Check inWindows Services to ensure that the Sentinel LicenseManager service is running.

p In Windows 7: Click Start > Control Panel > System and Security > Administrative Tools
> Services.

p In Windows 8.1 or Windows 10:Click Start > All apps > Windows System > Control Panel
> System and Security > Administrative Tools > Services.

Chapter 3—Installation and Configuration
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Look forSentinel RMS License Manager in the list of services.

2 On the LicenseManager server:

p In Windows 7: Click Start] > All Programs > Accessories > Run.

p In Windows 8.1 and Windows 10:Click Start > All apps > Run.

3 In theRunwindow, browse to your Sage Estimating setup and installation files, and then double-click
\\AdditionalInstalls\License Manager\Admin.net\Win32\WlmAdmin.exe.

4 Install license codes using one of the followingmethods.

p To enter license codes from a file: In theWlmAdminwindow, right-click your server and select Add
Feature > From a File > To Server and Its File. In theOpenwindow, select your license file and click
[Open]. This installs all license codes in the file.

p To type license codes: In theWlmAdminwindow, right-click your server and select Add Feature >
From a String. In theAdd feature to serverwindow, type your license code exactly as it appears in the
license file or on the packing slip. (The code is not case sensitive.) Be sure to select theAdd feature to
server's file check box.

When you enter a license code, the software adds this code to a file named Lservrc (which has no file
extension) in the LicenseManager installation path.

Upgrade License Manager
To upgrade LicenseManager, youmust use the following steps to remove the previous version of License
Manager and then install the new version (version 8.3). Perform these steps at the computer where License
Manager is installed.

1 Check in any licenses before upgrading.

2 Run LoadLS.exe, located in the folder where you installed the previous version of LicenseManager
(typically, C:\Program Files\Rainbow Technologies\SentinelLM7x.x.xServer\English). Click [Remove],
and then click [OK] to remove the Sentinel LM licensemanager.

3 Remove the previous LicenseManager version:

p In Windows Windows 7:Click Start > Control Panel > Programs > Uninstall a Program.

p In Windows 8.1 or Windows 10:Click Start > All apps >  Windows System > Control Panel
> Programs > Uninstall a Program.

RemoveSentinel LM x.x.x.x. Server.

4 Install the new version of LicenseManager. See “Install LicenseManager”.

5 Copy the Lservrc file from the directory you identified in step 2 to the 8.3 directory of LicenseManager.
Typically, the 8.3 directory is C:\Program Files\Common Files\SafeNetSentinel\Sentinel RMS License
Manager\WinNT.

H. Set Up LicenseManager (optional)
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6 Click [Start] and then select Settings > Control Panel > Administrative Tools > Services. Find
Sentinel RMS License Managerin the list of services, right-click the service, and then select [Restart].

I. After You Complete Your Setup
1 Restart all programs and services that you shut down for the installation.

2 The Sage Estimating software performs a series of checks the first time you start it. If the Sage Estimating
software notifies you of any error conditions, correct the condition before continuing.

3 Sage Estimating provides supporting documents in theDocuments folder of the Sage Estimating
installation files. These documents are available in Adobe Acrobat (PDF) format only. If you do not already
have Adobe Acrobat or Acrobat Reader, you can download Adobe Acrobat from www.adobe.com.

IMPORTANT: For performance reasons, if you plan to run a virus scanner on themachine that hosts
the SQL Server instance, you should exclude files that haveMDF, LDF, NDF, BAK, TRN, and TRC
extensions. You should also exclude additional processes for the version of SQL Server that you are
running. For more information about the files and processes to exclude, seeMicrosoft Knowledgebase
article 309422 at http://support2.microsoft.com/kb/309422.

J. Other Installation Scenarios

Terminal Server
Follow the steps for “Scenario 2 (Workgroup environment, estimating data shared from one workstation)”, with
these exceptions:

n Always useAdd or Remove Programs to start an installation to a terminal server.

n If you use another server to host Sage Estimating databases, install only Sage Estimating products to the
terminal server.

Chapter 3—Installation and Configuration
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Chapter 4—Data Migration
If you have been using a Pervasive-based version of Sage Estimating, you canmigrate (transfer) your existing
Pervasive-based data to theMicrosoft® SQLServer® database platform if you want to use it with this release.

NOTE: Youmust be using Sage Estimating 9.6 or later to migrate your data.

Overview
The process of migrating or making your existing Sage Estimating data compatible for use with the new Sage
Estimating is performed using the datamigration feature of the EstimatingManagement Console. This feature
performs two functions when you select a Pervasive database for migration:

1 Validates your existing data for compatibility with Microsoft SQL Server.

2 Migrates or creates new SQL Server tables with your Sage Estimating data.

The EstimatingManagement Console performs these steps together when you start the datamigration
process. When youmigrate your Pervasive databases, the EstimatingManagement Console creates
corresponding .mdf and .ldf files in the specified SQL Server instance.

Changes in the Database Structure
Whereas Pervasive allows you to arrange your estimates in a hierarchical folder structure within each
database, Microsoft SQL Server stores all your estimates in just one estimate database. It also stores your
standard database and Address Book information separately.

Figure 5: Comparison of Pervasive and SQL Server
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If you have arranged your estimates in Pervasive folders and subfolders, the EstimatingManagement
Console attempts to re-create the arrangement using "branches" in place of folders. These branches are for
organizational display purposes only. They do not change the structure of your SQL Server database.

During themigration process, the EstimatingManagement Consolemay rename some of your database files
to comply with SQL Server requirements. For more information on renaming database files, refer to the
EstimatingManagement Console Help.

Migrating Your Data
Begin the process using the EstimatingManagement Console (select Start > All Programs > Sage > Sage
Estimating > Estimating Management Console).

1 From the EstimatingManagement Console, click [Data Migration].

2 Select step 2—Settings in the DataMigration window.

3 Click SQL Server (left-hand pane) then select a destinationAddress Book and Estimate database for
your migrated data.

Click [Select] next to theAddress Book Database orEstimate Database box to specify a database from
the current instance.

4 Click Pervasive (left-hand pane).

The EstimatingManagement Console performs an automatic check of your Pervasive databases and
verifies they meet datamigration prerequisites.

The EstimatingManagement Console displays one or more error messages if prerequisites are not met.
Correct each error condition then try the verification process again by clicking [Reverify].

5 Click [Options], and then:

p Select theEnable detailed logging check box if you want to generate detailed entries in themigration
event log.

Clear theEnable detailed logging check box to prevent detailedmigration event logging.

NOTE: Enabling detail loggingmay cause the datamigration process to perform slower.

p Select theAllow non-administrators to view and edit migrated estimates check box if you want to
makemigrated estimates available to all users.

Clear theAllow non-administrators to view and edit check box to prevent users other than
administrators from viewing and editing themigrated estimates.

NOTE: After migration, you can change which estimates users can view and edit in theSecurity section
of the EstimatingManagement Console.

6 Click step 3—Select Databases.

Chapter 4—DataMigration
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7 Click [Browse] and locate the path to the data folder where the Pervasive data you want to migrate is
located then click [OK].

TheData Migrationwindow displays the selected folder path in theStarting folder box.

The Sage Estimating scans the selected folder for all Pervasive databases that are available for migration
and displays them in a list below theStarting folder box. If desired, you can click the arrow key to the right
of the [Browse] button and perform one of the following actions:

p Cancel scanning. The scan process can be lengthy, depending on the number and size of the files
within the selected folder. Select this option to stop the scan at any time.

p Rescan. Select this option to scan the selected folder again.

NOTE: The EstimatingManagement Console does not scan backup data folders (PEBackup folders). If
the EstimatingManagement Console is unable to locate certain Pervasive databases, the databases may
be residing in a PEBackup folder. Try renaming the PEBackup folders and restart the scan.

8 Select the check box for each Pervasive database in the list that you want to migrate.

You can select estimate, Address Book, and standard databases for migration.

NOTE: To preserve links between estimates and standard databases, Sage recommends migrating your
estimates concurrently with (or after) your standard databases. Migrating estimates before or separately
from their standard databases breaks any links with their associated standard databases and disables
certain editing functions in the spreadsheet.

9 Click [Migrate] to begin themigration process.

Themigration process may take some time, depending on the size of the databases you aremigrating. You
can view the status of themigration from themigration event log by clicking step 4—Event log.

If desired, you can also select other Pervasive databases for migration by repeating steps 1-9. Any
additional migration jobs you schedule are placed in a queue and performed in order.

NOTES:
l Ensure you select theQueued check box at the top of themigration event log to see a list of pending
migration jobs in the queue.

l Do not attempt to access any of the databases you aremigrating until themigration process is
finished. You cannot access a database while it is migrating.

10 Repeat steps 1-9 as necessary tomigrate all Pervasive databases you want to use with Sage Estimating.

Migrating Your Data
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Chapter 5—Configuring SQL Server
If you are installing or upgrading Sage Estimating, and you already have a supportedMicrosoft® SQLServer®

installation on your computer or server, you can use the existing SQL Server installation by setting up another
instance (database server).

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and
other software, and about system requirements for servers and client workstations, refer to our
Knowledgebase article ID 71213, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=76530.

Setting Up a SQL Server Instance for Use with Sage
Estimating
If you have an existing instance of a supported version of Microsoft SQL Server installed, you can set up
another instance to work with Sage Estimating. (Options described in this sectionmay vary slightly depending
on the edition you are installing.)

NOTE: If you choose to uninstall your existing instance first, restart your server before reinstalling to
avoid problems with the new installation.

CAUTION: Do not change the owner of any databases in the Sage Estimating instance.

Set your new SQL Server instance to the settings as outlined in the following sections.

Named Instance
Figure 6: Instance Configuration Settings
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Youmust use a named instance. You can give the instance any name you want. However, if you have
installed a previous version of Sage Estimating (such as version 11.2), give the new instance a different name
that is easily recognizable (such as SAGE_EST_16_11).

Authentication Mode
Figure 7: AuthenticationMode Settings

The instancemust supportMixed Mode authentication (Windows Authentication and SQL Server
Authentication). This means eitherWindows authentication or SQL Server authentication can be used to
access the database information.

When you useWindows authentication, the operator requires permission to use SQL Server or be amember
of a group that has permission. InWindows authenticationmode, SQL Server validates the account name and
password using information from theWindows operating system.

When you use SQL Server authentication, the operator requires system administrator (sysadmin) rights in
SQL Server. SQL Server authentication is used for backwards compatibility and requires a strong password.

Collation Settings
Collation settings must be Latin1_General, case-sensitive, and accent-sensitive (Latin1_General_CS_
AS).

You can customize the collation settings during the server configuration portion of the SQL Server install. In
the SQL Server collation customization window, make the following selections:

n Select theWindows collation designator and sort order option (instead of SQL collation, which is the
default)

n Latin1_General (for the collation designator)

Chapter 5—Configuring SQL Server
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n Case-sensitive

n Accent-sensitive

n Clear all other options

Assigning Database Permissions
You use theSecurity feature in the EstimatingManagement Console to set up database permissions for
SQL Server instances used with Sage Estimating.

For more information on setting up SQL Server security for Sage Estimating, see “F. Set Up Roles and
Permissions” on page 17.

Setting the Firewall for Workgroups
If you are using SQL Server with a workgroup, youmust set the firewall on the workgroup server to allow
workstation computers to connect to the instance.

NOTE: If you are using SQL Server on a domain-based server, youmay still need to configure your
firewall to allow remote communication. Refer to theSQL Server Guide for instructions.

Firewall Settings (Windows 7, Windows 8.1, and Windows 10)
1 OpenWindows Firewall.

p In Windows 7:Click Start > Control Panel > System and Security > Windows Firewall
> Advanced Settings.

p Windows 8.1 or Windows 10:Click Start > Windows System > Control Panel > System and
Security > Windows Firewall > Advanced Settings.

2 Set rules for inbound and outbound TCP connections:

a Right-click Inbound Rules, and then select New Rule.

b In the Inbound Rulewizard, select Port, and then click [Next].

c Select TCP, and then select Specific local ports.

d In theSpecific local ports box, type 8005, 49385, and then click [Next].

e Select Allow the connection, and then click [Next].

f Select theDomain, Private, andPublic check boxes, and then click [Next].

g In theName box, typeSage Estimating Service (or other appropriate name), and then click [Finish].

h Repeat steps a through g for outbound TCP connections, selectingOutbound Rules in step a.

3 Set rules for inbound and outbound UDP connections:

Assigning Database Permissions
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a Right-click Inbound Rules, and then select New Rule.

b In the Inbound Rulewizard, select Port, and then click [Next].

c Select UDP, and then select Specific local ports.

d In theSpecific local ports box, type 1433, 1434, and then click [Next].

e Select Allow the connection, and then click [Next].

f Select theDomain, Private, andPublic check boxes, and then click [Next].

g In theName box, typeSage Estimating Service (or other appropriate name), and then click [Finish].

h Repeat steps a through g for outbound UDP connections, selectingOutbound Rules in step a.

Additional Recommendations
To ensure accurate performance, Sage strongly recommends making changes and verifications to the
following settings in SQL Server Management Studio and SQL Server ConfigurationManager. Failure tomake
these changes may result in poor Sage Estimating performance or communication difficulties between Sage
Estimating and your SQL Server instance.

Memory
Determine the amount of available memory on the server or workstation where SQL Server is installed. To
prevent SQL Server from consuming all available memory, use SQL Server Management Studio to set the
maximum amount of memory (in the instance properties) to a reasonable limit (such as 4GB ) as follows:

1 Right-click the SQL Server instance, and then select Properties.

2 In the Server Properties window, click Memory (left-hand pane).

3 Set theMaximum server memory amount to 4000 (or whatever limit you determine).

Communication Protocol
Set the communication protocol settings for the Sage Estimating SQL Server instance as follows:

1 Start the SQL Server ConfigurationManager.

p In Windows 7: Click Start > All Programs >Microsoft SQL Server > Configuration Tools
> SQL Server Configuration Manager.

p In Windows 8.1 or Windows 10: Click Start > All apps > Microsoft SQL Server >  SQL Server
Configuration Manager.

2 In the left-hand pane of theSQL Server Configuration Manager window, click the arrow next to
SQL Server Network Configuration to display all local SQL Server instances.

3 Select the instance associated with Sage Estimating (SAGE_ESTIMATING, by default).

Chapter 5—Configuring SQL Server
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4 In the right-hand pane right-click a communication protocol, and then select Disable.

5 Repeat step 4 for all communication protocols except TCP/IP. Leave this protocol Enabled.

6 In the left-hand pane of theSQL Server Configuration Managerwindow, click the arrow next to
SQL Native Client 10.0 Configuration.

7 Click Client Protocols (left-hand pane).

8 In the right-hand pane right-click a communication protocol, and then select Disable.

9 Repeat step 8 for all communication protocols except TCP/IP. Leave this protocol Enabled.

10 Close the SQL Server ConfigurationManager and restart the service.

Copying Databases from Other Instances
Sage Estimating allows the use of just one active SQL Server instance at a time. This instance is a "closed"
SQL Server instance. Sage Estimating does not recognize databases (Address Book or standard databases)
transferred or copied from other SQL Server instances unless they are added by way of theSearch For
feature in the EstimatingManagement Console.

For example, if you have two Sage Estimating installs, Install A and Install B, you cannot copy Address Book
databases by copying them from Install A's SQL Server instance to Install B's SQL Server instance alone
(using SQL Server Management Studio's built-in Copy Databases wizard, for example). Youmust also open
the EstimatingManagement Console and use theSearch For button in the Address Book
Companies/Contacts toolbar.

Figure 8: Copying Databases From One SQL Server Instance to Another

Copying Databases from Other Instances
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Any database you add to an instancemust have the same Sage Estimating version as the other operating
databases. For example, if you are using Sage Estimating 16.11, and you want to add a standard database
from a previous Sage Estimating installation, upgrade the standard database to version 16.11 before adding it
to the new instance. Refer to the EstimatingManagement Console in-product Help for instructions on using
theSearch For feature.

You can switch active SQL Server instances at any time for Sage Estimating by starting the Configuration
wizard, selectingServer from the left-hand pane, and clicking [Change] from the right-hand pane.
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