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Chapter 1—Microsoft SQL Server and
Sage Estimating

Sage is pleased to provide you with this guide to understanding Microsoft® SQL Server®. Read this guide
carefully to learn the basic principles of SQL Server and how it supports Sage Estimating operation.

Sage Estimating uses SQL Server as its database platform. Previous releases used Pervasive as the
database platform for storing Sage Estimating data. This database platform change is intended to offer you
increased security, performance, and flexibility for your reports, queries, and daily operations.

This document provides information on the impact of these changes. It is important to understand these
differences so that you can effectively manage and protect your Sage Estimating data. @
Although this document is current as of the time of its distribution, a newer version may b &1 e. For the
most recent version, log on to https://customers.sagenorthamerica.com/irj/portal/anon‘y@ gin and
search for this document in the Technical Support Knowledgebase.

Microsoft SQL Server and Pervasive ‘\

Microsoft SQL Server represents a change from the Pervasive databa @m used in previous Sage
Estimating releases. It is important to understand how the new SQL atabase platform is structured.
SQL Server stores database information in database (.mdf) an df) files. Previously, Sage Timberline
Office Estimating created separate estimate files that yqu caall in any desired Windows file structure.

With the new SQL Server database, Sage Estimating alfyour estimates in the same .mdf database file
on a single server known as an instance.

Figure 1: Comparison of Pervasive and SQL Se, E
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A Sage E%@tance (sometimes referred to as a "server") consists of three primary components:
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Chapter 1—Microsoft SQL Server and Sage Estimating

= An Address Book database
= An estimate database
= One or more standard databases

You configure security for the instance and apply it to all contents, including the Address Book, all standard
databases, and all estimates within the estimate database.

Estimates are stored entirely within the estimate database. With the new Sage Estimating, you can use the
Estimating Management Console feature to arrange your estimates in a hierarchy of tiers or "branches." The
branches you create in the Estimating Management Console are for organizational purposes only; they do not
change the structure of your database.

The location of your SQL Server database files (.mdf and .Idf files) depends in part on your o ystem.
See “SQL Server Express Installation” on page 14 for more information.

the database size is limited to 10 gigabytes (GB). Sage Estimating provides rning if your

y
database size nears the limit. %

During the Sage Estimating install, if you choose to install SQL Server 20 press from the Sage
Estimating installation and setup files, the installation process autom% eates a new instance for you.

The allowable database size in SQL Server is unlimited. However, if you are operatiﬁgF erver Express,

The default name for the instance is SAGE_ESTIMATING; however, ave the option of giving the
instance any name you want.

If you choose not to install SQL Server Express from th nstallation files but elect to create your
own instance using an existing SQL Server installationyi st meet certain requirements. See “Modified
Installation” on page 16” for more information.

The SAGE_ESTIMATING IfGdnce

Sage Estimating allows the use of just ogdle a&ive SQL Se @ance at atime. The active instance is a
"closed" SQL Serverinstance; Sage iMgting doest A%ﬁ ze databases (Address Book or standard
5r SQL Se%
€.

databases) transferred or copied ces unless they are added by way of the
Search For feature in the Estigmati

For example, if you have tw&: Estimating$gstaits, Install A and Install B, you cannot copy Address Book
databases by copyin f@ Install A SQL 8erver instance to Install B's SQL Serverinstance alone
(using SQL Server M ent StudioQin Copy Databases wizard, for example). You must also open
the Estimating Managesnent Con&@i e the Search For # button in the Address Book
Companigs/@cts toolbar. @
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Microsoft SQL Server Files

Figure 2: Copying Databases From One SQL Server Instance to Another

You must use the Search For
feature,® for instance B to
recognize databases copied

/ from instance A.

Sage Estimating
SQAL Server instance B

Datahases Sage Estimating @
S0QL Server instance A 2

Any database you add to an instance must have the same Sage Estimati I0n as the other operating
databases. For example, if you are using Sage Estimating 15.11, an to add a standard database
from a previous Sage Estimating installation, upgrade the standard da e to version 15.11 before adding it

to the new instance. Refer to the Estimating Management Con in-product Help for instructions on adding
databases using the Search For feature.

The allowable database size in SQL Serveris unlimite@r, if you are operating SQL Server Express,
the database size is limited to 10 gigabytes (GB). eE ating provides you with a warning if your
database size nears the limit.

During the Sage Estimating install, if you choosQnstall SQL 008 R2 Express from the Sage
Estimating installation and setup windowy installation p omatically configures a new Sage
Estimating-compatible instance fory fault nam nstance is SAGE_ESTIMATING; however,
you have the option of giving theuns a y name&
If you choose not toinstall S Express f@e etup and installation files but elect to create your
own instance using an exisgnhg Server ingfal , it must meet certain requirements. See “Modified
Installation” on page 164 e information.
Microsoft S&. Serv es
Every S@\ database h ast two files associated with it:

ol

res the awa (.mdf)
= A sactlon log @1
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Chapter 1—Microsoft SQL Server and Sage Estimating

SQL Server stores your Sage Estimating data in the database file (.mdf). For details, see “SQL Server
Express Installation” on page 14.

The transaction log (.Idf) records all changes to the data in the database. This log ensures data integrity by
keeping track of data that has changed and can be used to roll the data back to a previous state in the event of
a database failure.

It is important to make regular backups of these files. For more information, see “Backing Up SQL Server
Databases” on page 17.

Collation settings for use with Sage Estimating
Sage Estimating requires a special collation setting. Collation settings in SQL Server must be set to:

= Latin1_General @

= Case-sensitive

= Accent-sensitive $ E
See “Collation Settings,” on page 37 for more information. &\

SQL Database Permissions and Accesa
e ®St

You must give each Sage Estimating operator permissions to th
expected to use. Assign database and feature permissions usi
Management Console. For more information, see the Es§

- CAUTION Do not change the owner of any%&

ag imating features that he or she is
security feature of the Estimating
nagement Console in-product Help.

in the Sage Estimating instance.

Read the Supporting Docu tatloréfore You Begin

Be sure to read supporting documentatl bef®re you be

= This SQL Server Guide gives y erV|ew of |§cant differences between the new SQL Server
databases and the Perva3| ses used @ s Sage Estimating releases.
e

= The Installation and A on Guide m&r an overview of this release, installation instructions,
system requirement ntact inf |on his document is available in the Documents folder of your
Sage Estimating in on files.

= The Rele tes provide d ut new features, database changes, known issues, and fixes. This
docum |Iable inthe ents folder of your Sage Estimating installation files.

Started G V|des an operational overview of the Sage Estimating software. This
tis avall in th Documents folder of your Sage Estimating installation files.

‘(\
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Conventions Used in this Document

= The Options Guide provides installation, setup, and operating instructions for each of the available Sage
Estimating options, such as the OnScreen Takeoff Integrator or License Manager. This document is
available in the Documents folder of your Sage Estimating installation files.

These documents are current at the time of the release. To learn about issues that have arisen since this
document was published, go to www.sagecre.com.

Conventions Used in this Document

This document uses the following conventions:

= Information you type into the software is shown in bold font. For example: Type Miscellaneous in the box.

= The names of screens, windows, fields, and other features displayed by the software are {c@ bold
font.

= The names of buttons you can click are enclosed in brackets with bold font. For exalgp K] or [Post].

= Names of keys are shown in capital letters. For example: ENTER or TAB n(+) between two key
names indicates you should press the keys simultaneously.

Variable names or names that are specific to your installation may a @talics and brackets. For
example: [Drive]\\[Server]. %

Symbols

D NOTE: This symbol is used when presenting mf@wat is supplemental to the adjacent text.

F TIP: This symbol is used when presenting | informatign for using the software.
i" CAUTION: This symbol is used w pre ing impo ation to help you avoid a loss of
— critical data.

%]

¢
IMPORTANT: This symbB 'when pre&\&(ormation that is critical to understand or that
requires you to take actlc% @

Menu Paths
In this document, me @s show yo@eps required to start a task. Menu paths appear in bold font with

angle brackets arol uttons For @
"If the p s not autom tart, click [Starf] > Run."

h@Help \Q

The S&ge Estim are includes online Help, which provides answers to your questions about
procedures as tems in the windows.

A\
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Chapter 1—Microsoft SQL Server and Sage Estimating

To access the online Help in the Sage Estimating software, click the Help button oricon, or press [F1] to
display the Help topic for that window.

To aid you in finding the information you need, the online Help for each module includes the following panes:
= Contents pane containing links to the Help topics

= Index pane containing keywords that link to Help topics related to that keyword

= Search pane, where you can type text and click [Search] to locate that text in the Help topics

For more information about using the online Help, see the Sage Estimating Help.

We would like your feedback about the online Help so we can make improvements. Each Help topic contains
an area where you can indicate whether the topic was helpful and provide additional comments otect
your privacy, all comments are anonymous.

- N
Training ”&(b‘

Sage University offers online and classroom training sessions to help you g% out of your Sage

Estimating software. To access Sage University, visit www.sageu.com.

You can also get access to Sage University from the File menu by selggti Ip > Sage Estimating on the
Web > Sage University.

Technical Assistance @

When you need assistance, refer to the Knowledgebas@ow do | get technical support for Sage
Estimating? to determine which service works be r youe

Submitting Enhancement Requ@
We want to hear your suggestions for in@g the softwar end us your comments, click on the File

menu button and select Hel G
L

& &
E Q

& &

A RS

N

n Web > Submit Enhancement Requests.
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Chapter 2—Technical Information

Supported Editions of SQL Server

Sage Estimating is tested for use with only the following editions of Microsoft® SQL Server®:
= SQL Server 2008 Standard Edition, Service Pack 1 or greater

= SQL Server 2008 R2 Express Edition

= SQL Server 2008 R2 Standard Edition

= SQL Server 2012 (Sage Estimating version 13.2 and later) @

sufficient for most Sage Estimating customers. However, customers with large datab need to

SQL Server 2008 R2 Express Edition is provided free of charge with Sage Estimating. Th;(&ion IS
upgrade to the Standard Edition. For information on Microsoft SQL Server 2008 editi

wWww.microsoft.com.
The following table offers a brief comparison of the Express and Standard Vf&& SQL Server 2008 R2.

Table 1: Comparison of SQL Server Standard and Express Versions %

Feature Express @ Standard
Concurrent workload governor No No
(throttle) ! ®
Database size 10 GB? § Unlimited
RAM support 1GB Operating system maximum
CPUs supported 1 . 4
Windows Vista® and Windows” Y \& Yes
7/8 support
1 This governor limits t ance of applica¥pns to approximately 5 users.
2 This database si%ulles to only erver database files (.mdf) and not to log files (.Idf).
3Your ccxnp@an have multj , but only one is used by SQL Server.

\
L8 Q}c)‘Q
A\
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Chapter 2—Technical Information

Minimum Requirements to Install SQL Server 2008 R2
Express Edition

The following lists some of the minimum requirements for installing SQL Server 2008 R2 Express from the
Sage Estimating setup and installation files:

= Windows Installer 4.5 or later
= Internet Explorer 6.0 SP1 or later

= .Net Framework 3.5 Service Pack 1
= 1GBRAM @
= 1GB free disk space @K

1.4 GHz P-4 CPU

Setup must run under an account with administrative privileges on the comp@ SQL Server 2008 R2

installing (32-bit or 64-bit). For a complete list of the installation requireiegts, visit www.microsoft.com.

Express is being installed
The hardware requirements may vary, depending on the version of S(%Q%% R2 Express you are
r

Supported Operating Systems &
E

You can install SQL Server 2008 R2 and SQL Seryer 2&
XP or later operating systems.

xpress on any computer operating Windows

You do not need to install Microsoft SQL Serve e same co where you install Sage Estimating,
depending on your system configuration. Eor example, if yo Ing your databases on a separate
server, install SQL Server on that serveé

NOTE: If youplanto mlgra er) existin g’n a previous version of Sage Estimating, you

must install a supported QL Serve stlnat|on computer or server. Refer to the
Installation and Admu& Guideort igration Utility Help for more information about data
migration.

If you are installing or mstall SQ%r and Sage Estimating on the same computer, keep in mind
that the Sage Estim software i tible with the 32-bit and 64-bit versions of the following operating

systems %
\ Ulti
&i s Vista® B inessYSP2)

=« Windows 20(@ tandard Edition (SP2)
= Windo% rver Enterprise Edition (SP2)

12 Sage Estimating (SQL)
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Supported Operating Systems

= Windows 2008 Server Standard Edition R2 (SP1

= Windows 2008 Server Enterprise Edition R2 (SP1)
= Windows 2012 Server Standard Edition

= Windows 7 Ultimate (SP1)

= Windows 7 Professional (SP1)

= Windows 7 Enterprise (SP1)

= Windows 8 Pro

= Windows 8 Enterprise

= Windows 8.1 Pro

= Windows 8.1 Enterprise

SQL Server Guide 13



Chapter 3—Installation

Overview
Before installing Sage Estimating, you have two primary SQL Server scenarios to consider:

= SQL Server Express Installation. Installing Sage Estimating also installs SQL Server 2008 R2 Express
when you select certain installation options. Follow this scenario for these conditions:

o You are installing Sage Estimating on a standalone workstation or a workgroup server.

o You are installing to a server on a domain and you want to use the SQL Server 2008 R2 Express install

that comes with the Sage Estimating install package. @
The Sage Estimating install package installs and configures a new SQL Server instance erver
2008 R2 Express whenever you select one of these install options. You can operate t QL Server

instance alongside an existing SQL Server instance.

= Modified Installation. You have a supported version of SQL Server inst 0 have one installed)
and you want to manually create a new instance to use with that version.

operator after installing your SQL Server instance.

Use the Security feature in the Estimating Management Console to as:ibase permissions to each

For more information on setting up SQL Server security for Sawmating, see the Installation

SQL Server 2012 is also installed. Be aware installing Sage Estimating may then result in an "Install

& Administration Guide.
NOTE: You can install an approved nstanc%ﬁr side by side on a computer where
t

completed with errors" message; howevel

¢
Microsoft SQL Server 2008 R2 Bxpr@) es as &al component with the Sage Estimating install
package. It installs automaticalb‘:N ou select % ge Estimating installation options.
Follow the instructions bela to iggtall SQL 8@8 R2 Express from the install package.

1 Openthe Select | @on Optior@age Estimating window by double-clicking SetMeUp.exe in
I Er.

ulting Sagimating install operates correctly.
SQL Server Express Iqullation @

your local instalkfol
downlox tall files to rs\Public\Public Documents, look in this folder for the SetMeUp.exe file.

Thein tal% is created w, ou download the Sage Estimating install files. For example, if you

SQL Server Guide 14



Chapter 3—Installation

Figure 3: The Select Installation Options for Sage Estimating Window

Select installation op

Sage Estimating

What do you want to install?

* Complete Sage Estimating system
For workstations running standalone, offiine, or workgroup

" Sage Estimating
For workstations connecting to a network server

" Sage Estimating Server only
For network servers currently with SQL Server

" Sage Estimating Server and new instance
For network servers not currently with SQL Server

Enter new instance name:  SAGE_ESTIMATINGO

2 Inthe Select installation options for Sage Estimating window,% one of the following options:

o Complete Sage Estimating system. This option installs thing you need to operate Sage
Estimating on your local workgroup server, offline or standalone computer, including a new
instance of SQL Server 2008 R2 Express. Selec % if you are installing Sage Estimatingon a
standalone computer or a workgroup server.

NOTE: If you are operatingina workstatlo nvironmef§, you do not need to install SQL Server on
the workstations. However, you can |nstaII rver option ou want to maintain a local copy of

your estimating data.
o Sage Estimating Server and p @ tance. Sde@[ion if you are installing to a serveron a
l !t

domain and you want to use Server2 press copy that comes with the Sage
Estimating install. Selectj ion aut nstalls and configures a new instance of

SQL Server 2008 R2 s oryou. T o is unavailable if you already have installed Sage
Estimating compo ninhe worksta’u rver.
o Create new lo Server in e. This option appears only if you have already installed Sage
Estimating ¢ ents on th?@) ation or server. Select this option to install and configure a new
ress.

instance QL erver 2008
3 Inthe E instance r@)ox, type a name for the new SQL Server instance (database server) in
h\ﬁ‘&. ick [OK

ult mstan name’s SAGE ESTIMATING but you can give the instance any name you want
prowded you d: n it the same name as any existing SQL Server instance on the computer.

4 Click [%

ow the on-screen instructions for installing Sage Estimating or Sage Estimating server.
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Modified Installation

The software installer creates the new instance as part of the Sage Estimating installation and notifies you
when the process is finished.

NOTE: If you are installing SQL Server on a computer with Windows Vista®, Windows 2008 Server,
Windows 7, or Windows 8, ensure you elevate your privileges at the prompt within two minutes of its
appearance or the installation will quit.

Installing SQL Server 2008 R2 Express also installs SQL Server Management Studio Express, a tool for
performing database back up and restoration procedures and for assigning database permissions.

Modified Installation

You may want to use a version of SQL Server that already exists on your computer. It must be (@w‘the

supported versions listed in “Supported Editions of SQL Server’ on page 11.
If you want to use your existing installation of SQL Server, create a new instance to ope &gside your
existing SQL Serverinstances. You can give the new instance any name you want. H , Sage

recommends naming the new instance an easily identified name such as SAGE TING.

Refer to “Appendix—SQL Server Instance Settings” on page 36 for the insta& yngs.

Installation & Administration Guide.

NOTES: @

« If you plan to migrate existing data from a Perv, -bayed version of Sage Estimating, you must
install SQL Server or SQL Server Expressgn tHie\deSWination computer or server.
&t

After creating your new instance, ensure you assign the appropriate datiermissions as outlined in the

» Reboot your server or workstation after he new iqstance.

CAUTION: Do not change the ownegof any"databasesg ge Estimating instance.

TN

S @

¥ Q

0\6 @@

,QQ Q
,06

A\
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Chapter 4—Back Up and Restore
Procedures

Backing Up SQL Server Databases

Performing a complete backup of your Sage Estimating data requires using SQL Server Management Studio
or Management Studio Express to back up your Microsoft® SQL Server® databases. It is critical that you
modify your back up procedures to include all the necessary steps.

Your SQL Server database backup copy is generated in two steps:

1 Use SQL Server Management Studio (or Management Studio Express) to make a backup @he
database into a file folder. (

The default location for this folder is C:\Program Files\Microsoft SQL Server\MSS SAGE_
ESTIMATING\MSSQL\Backup. (The actual number and instance name that ap the path may be
jnstance a different

different if you have multiple instances of SQL Server installed or if you nx
name.)

2 Make sure to include the SQL backup folder (referenced in step 1)w§; erform your tape or third-party
backup.

@ N Besuire to perform regular tests of your backups to en ey are working properly.

« You can perform backup and restore functions SQ@. Server Management Studio or Management
Studio Express. Installing SQL Server 20 R&' s from the Sage Estimating setup and
installation files installs a copy of SQL Serg€r Management Studio Express.

« SQL Server 2008 R2 Management Stu@press autor@y detaches and attaches the database

when you back up and restore.

CAUTION: The restore proc Qes any‘t&&a@u make to the database between creation of

backup copies.

Backing up theﬂ@ Datal&
1 Start Microsoft S @r Manager@udm Express (Start > All Programs > Microsoft SQL Server
x& en

2008 Express Server M t Studio Express).

In Wlndo elect Start >® > Microsoft SQL Server 2008 Express > SQL Server

anage tud|o
&Q database you to back up from the Object Explorerpane.
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Chapter 4—Back Up and Restore Procedures

Figure 4: Database List in the Object Explorer Pane

Eile Edit View Debug Iools Window Community Help

{0 New Query | [0 |5 05 55 |0y |5 A 3 | B

Connect~ @3 @3 w T [7] B
= [ {5 ORB510451VM7\SAGEELD (SQL Server10.50.1¢
= [ Databases
[ System Databases
[T] Ext Commercial Con-Mas
| Ext Commercial GC
[ Ext Commercial Steel
| McKenzie Oaks
| Sample Address Book
[ Security
[ Server Objects
[ Replication
[ Management

4 n L3
TARegistered Servers | [ Object Explorer |
Ready

3 Right-click on the database and select Tasks > Back Up to opent p Database window.

Figure 5: The Back Up Database Window

‘Connection

Server:
ORB510451VM™SAGEETD

Connection:
BEST AGemmil

.!E View connection properties

ﬁw‘

&
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Restoring the SQL Database

4 Under Source (in the right-hand pane of the Back Up Database window), select the database to be backed
up from the Database list.

o Forthe backup type, select Full.
o Forthe backup component, select Database.

5 Under Backup Set, type a name for the database backup you are creating in the Name box.
If desired, also type a description for the backup in the Descriptionbox.

6 Set the desired expiration criteria for the backup in the Backup set will expire section.

7 Select the backup destination from the Destination list.

This list displays previously defined backup file paths and file names. The backup utility s t
Backup folderin your SQL Server instance folder by default but you can add a new file gatfas a destination
by clicking [Add]. @

8 Click [OK]. A Backup of database completed successfully message ap| a@the backup
operation is finished. K’&

You may now perform your normal tape or third-party back up procedures

Be sure to include the SQL back up folder (or the folder where your b%opy is stored if you selected
another location in step 7). The default location for this folder is C:\Prog Files\Microsoft SQL
ServenMSSQL10_50.SAGE_ESTIMATING\MSSQL\Backup. ctual number and the name that appears
in the path may be different if you have multiple instanc rver installed or if you named the instance
a different name.)

Restoring the SQL Databa
CAUTION: The restore process ov r|tes any chang ke to the database between creation of

backup copies.

1 Start Microsoft SQL Server Mana
Server 2008 Express > SQ

anage@ io Express.)
In Windows 8, select St& WM apps > SQL Server 2008 Express > SQL Server
Management Studi

2 Select the data ou want to @%’t the Object Viewer pane.

g tStudlo Start > All Programs > Microsoft SQL

SQL Server Guide 19



Chapter 4—Back Up and Restore Procedures

Figure 6: Database List in the Object Viewer Pane

File Edit View Debug Tools Window Community Help

P NewQuey |0y BB B O |5 WA 3 | )
(ObjectBplorer A x

Connect @3 @3 = T ] &
= [ ORB510451VMT\SAGEELD (SQL Server 10.50.1¢
= [3 Databases
[ System Databases
[F] E¢ Commercial Con-Mas
|1l Ext Commercial GC
|l Ext Commercial Steel
|1l McKenzie Oaks
| Sample Address Book
3 Security
[ Server Objects
3 Replication
3 Management

T — D
FARegistered Servers | [ Object Explorer

Ready

3 Right-click on the database and select Tasks > Restore > Datab%open the Restore Database
window.
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Restoring the SQL Database

Figure 7: The Restore Database Window

U Restore Database - Ext Cornmercial Con-Mas IEI
o Ssew - Do
ﬁ Options

Destination for restone

Select ortype the name of a new or existing database for your restore operation.

Ta database: Ext Commercial Con-Mas -

To a peint in time: Most recent possible E]

Source for restore

Specify the source and location of backup sets to restore.

@ From database: Ext Commercial Con-Mas -

() From device: @
Select the backup sets to restore:
Restore Mame Componemnt Type Server Database Postion  First LSM  Last LS
Connection

Server:
ORB510451VMASAGEETD

Connection:
BEST AGemmil
_‘!} View connection properties &
Progress O
%0)
< (1 +

4 Select the database you wish to restore in the Tg@ data 0X.

If you want to create a new database, type t f the dataase in the To database box.
5 Under Source for restore, select FrongdatabdSe then se ame of the backup database copy you
want to use for the restore operation.

table.

7 Click Options (from the% page pan@pper left-hand corner of the window).
8 Inthe Restore Op '@ea, select@erwrite the existing database check box.
9 Click [OK]. k @

<
A Resto\ tabase con@d successfully message appears when the restoration operation is

L 2
6 Select the check box of the dam\@)u wish to&k&om the Select the backup sets to restore

* The rest rocess overwrites any changes you made to the database since the last time you
credted the ba 0

A\
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Chapter 5—FAQs

| already use a version of Microsoft® SQL Server
with Sage Estimating?

® on my computer. Can | use this version

Sage Estimating requires SQL Server 2008 + SP1 or higher. You must create a new instance for Sage
Estimating and it must conform to our recommended security settings. See “The SAGE_ESTIMATING
Instance” on page 6 for more information.

@ NOTE: You can install an approved instance of SQL Server side by side on a computer where
SQL Server 2012 is also installed. Be aware that installing Sage Estimating may then result in an "Install
completed with errors" message; however, the resulting Sage Estimating install operates correctly.

If | already have a version of SQL Server installed, does installing Sage Estl
upgrade my existing SQL Server version?
@d installation

No. However, you can install SQL Server 2008 R2 Express from the Sage Estlmat|n§§

files for use with Sage Estimating. You can then use both SQL Server versmnsm\ -side configuration

(meaning both versions are installed).

What are the minimum system requirements to install SQL v 0087
()

See “Minimum Requirements to Install SQL Server 2008 R2 Express n page 12.

Which operating systems are supported with SQL wr 20087

See “Supported Operating Systems” on page 12.

Are 64-bit platforms supported? s ®

Yes, you caninstall SQL Server 2008 Express llowing 648git platforms:

= Windows Vista® x64 (Ultimate and Bt%ess ons) SP

= Windows 7 x64 (Ultimate and Busj ditions)

= Windows 2008 Server x64 S

= Windows 2008 Server R é @

= Windows 8 (Profe nd Ultimat t|§

= Windows 8.1 (P&wnal and L@ ditions)
di

Can S r 2008 Ex ition installations be performed on substitute, mapped,
d drlvm
&ms canngt b d on any of these configurations.

\((0
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Can | use File Tools or other utilities to back up my SQL databases?

No. You must detach your databases and then back them up after the process is complete. File Tools and
other utilities do not perform this function.

Use SQL Server 2008 R2 Management Studio or SQL Server 2008 R2 Management Studio Express to back
up your SQL data. Microsoft SQL Server 2008 R2 Management Studio Express attaches and detaches the
database automatically during back up and restore procedures. For more information, see “Backing Up SQL
Server Databases” on page 17.

If you are using Sage Estimating version 13.2 or later, you can use SQL Server 2012 Management Studio to
perform the backup.

Will running a virus scanner on the SQL Server host machine affect performa

instance, you should exclude files that have MDF, LDF, NDF, BAK, TRN, and TRC ext . You should
also exclude additional processes for the version of SQL Server that you are runnin e information
about the files and processes to exclude, see Microsoft Knowledgebase arti
http://support2.microsoft.com/kb/309422.

For performance reasons, if you plan to run a virus scanner on the machine that hosts th%& erver

How can | test whether SQL Server is working in Sage Estirr@ ¢

The first time you start Sage Estimating or the Estimating Managem%\sole after installing the Sage
Estimating software, you should be able to use the Configuratiogagizardto locate your SQL Server instance.
If you are able to use the Configuration wizard to successfully @at least one SQL Server instance, your
installation of SQL Server is operating correctly.

If you are able to open or create estimates and datgbase e Sage Estimating software, SQL Serveris
operating correctly.

What do | need to be able to manage u@ccess rig SQL Server?

For Sage Estimating, security is managgll eMirely from w %Securlty feature of the Estimating
Management Console. You can cre and the|rt Ing permissions to access various Sage
Estimating tasks and features. ’

operators. For more inform out creatin d permissions, refer to the Sage Estimating Installation
& Administration Guid stimatin nag ent Console in-product Help.

|l can connect QQL Serv ce on my local computer but why can't | connect to a
SQL Serv tance onar erver?

You @wall settings. See “Firewall settings” on page 26.

&%m\ econfigun
N4

You must be belong to the % |mat|ng ad @or role to create roles and assign them to other
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Chapter 6—Troubleshooting SQL Server

This section provides additional information if you have any difficulty installing or connecting to a supported
version of Microsoft® SQL Server®.

Installation Issues

The following paragraphs provide troubleshooting tips for installation issues.

Collation
Sage Estimating requires a special collation setting. Collation settings in SQL Server must be se?o:

= Latin1_General K
= Case-sensitive E@

= Accent-sensitive
These settings are configured automatically when you create the SQL Serve%;Z Express instance from

the Sage Estimating install. You may sometimes see this listed in SQL S QL_Latin1_General_CS_

&

NOTE: If you performed an upgrade to SQL Server 2008®0ur collation settings may not correctly

match the settings required by Sage Estimating. Q

Sage Estimating requires SQL Server 2008 + SP1&|gher. Howgver, SQL Server 2012 is only compatible
with Sage Estimating 13.2 and later.

Compatibility

SQL Server is designed so that muIt|pIe i ces may exis le computer. Each instance is
independent of the others, and may t vers n e packs. The following can be used
alongside the instance you creatg fo f st math

= MSDE 2000 + SP3 or highe%\ @
= SQL Server2000 + S igher &

@ NOTE: Mul e ersions of SP Qhe only compatible version of SQL Server 2000 is 8.00.760.0.

You mayae move the e ion to resolve the compatibility issue. However, be aware that other

software rx sing the i ble version. Contact your system administrator before attempting to
; ompatlbl%

f yOpydetermine tha ersion can be removed safely, use Windows' Add or Remove Programs to
remove it (note t ay have to remove several entries to completely remove the version).

A\
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Connection Issues

The following paragraphs provide troubleshooting tips for connection issues.

Authentication mode

The authentication mode for the SQL Server instance you create for Sage Estimating must be set to
Windows Authentication and SQL Server Authentication (also referred to as "Mixed Mode") to work with
Sage Estimating. In this mode, SQL Server creates and maintains your login information. See “Chapter 6—
Troubleshooting SQL Server” on page 24 for more information.

Changing the authentication mode

Express, as follows:

1 Start SQL Server Management Studio Express (Start > All Programs > Micr@@ewer 2008 R2

> SQL Server Management Studio Express). x

If the authentication mode is not set correctly, you can resolve this issue in SQL Server Mar@ Studio

In Windows 8, select Start > All apps > Microsoft SQL Server 2008
Studio Express.

Server Management

2 Confirm that the correct Server type, Server name, and Authenti% settings are correct, and then

click [Connect]. For example:
Server type: Database Engine @
Server name: Machine_name\instance_name ®
Authentication: Windows Authentication &
NOTE: If Windows Authentication S rgxk, try r Authentication. You must have
security permission in SQL Server4Q ac@ess the‘dai ing this authentication.
3 Inthe Object Explorer pane,?lm\@ onthe se&\ and select Properties.
4 You must select the ser\/{% not the fol w it, in order to see the Security option in the next
step.

5 Select Security. !@ Q

6 Select SQL Server and Windox@t entication.
A d

7 Click O\ ige.

|i€ne a8hertication mode | correctly and you are still experiencing problems, contact your system
adrWgistrator to revi ur permission settings in Windows or SQL Server. See “Security Administration” on
page 30 for morej on.

A\
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Database location

Your default database location may not be set correctly in the system registry. See “Appendix—SQL Server
Instance Settings” on page 36 for verification instructions.

Firewall settings

If you experience communication issues with a remote SQL Server instance, you may be using a firewall that
is set up to block network traffic between your computer and the SQL Server instance. To allow
communication, you need to set two firewall exceptions:

= The SQL Server Database Engine service

= The SQL Server browser service @
i

N dhedoellowing instructions are for use with Windows Firewall. If you are using an% wall for your
e

system, contact the firewall manufacturer for instructions on setting service e S.
« Sage recommends contacting your system administrator if you nee firewall settings.
« This procedure does not cover setting firewall exceptions for inst n a workgroup. If you are

workstations to communicate with the SQL Server instance. to the Installation & Administration

using SQL Server on a workgroup server, you must set separa);; | exceptions to allow your
Guide for instructions.

Setting the SQL Server Database Engine exce%@
i

Set up a SQL Server Database Engine exception for e ance of SQL Server you use with Sage
Estimating.
1 Determine the path to your SQL Server com
a On the computer or server where S rver is installe e SQL Server Configuration Manager by
selecting Start > All Programs 2 Icrdsoft SQL 08 R2 (or Microsoft SQL Server 2008) >
Configuration Tools > S@L onfiguggji nager (in Windows 8, select Start > All apps

> Microsoft SQL Server K SQL Se COnfiguration Manager).
The SQL Server Conf% anager {

\((0
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Figure 8: The SQL Server Configuration Manager

File Actien Yiew Help

LI AN RERERN ¢ JRCHORONC)

48 QL Server Configuration Manager (Local) || Name State Start Mode Log On As Process I
B :Qt :E"’E’ :IE"’“E‘k o W[ s server (sAGE ESTIVATING) Running Automatic NT AUTHORITYANE. ..
L 5QL server Network Configuration G2bit [2)5QL Server Agent (SAGE_ESTIMATING)  Stopped Other (Boot, Syste..  NT AUTHORITYANE... 0

» 2 5QL Native Client 10.0 Configuration (324

= SQL Server B R Automati NT AUTHORITWLO... 532
+ B 5L Sewer Network Configuration #SQL Server Browser unning utomatic RITY
» B 5QL Native Client 100 Configuration

n

b Inthe left-hand pane of the SQL Server Configuration Mar@select SQL Server Services.

¢ Inthe right-hand pane, right-click on SQL Server AINCE), where (INSTANCE) is the SQL Server
instance for which you are creating the firewal¢ exc , and select Properties.

d Inthe SQL Server Properties window, CIG e ServiceNgb.
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Figure 9: SQL Server Properties Window—Service Tab

SQL Server (SAGE_ESTIMATING) Properties 2 |

| Log On | Service | FILESTREAM | Advanced |

B General
Mrc \Program Files\Microsoft 5QL 9
Error Contral
Exit Code Ju]
[ Hast Mame ORB510451VMT
MName SQL Server (SAGE_ESTIMATING)
Process ID 1772
SQL Service Type SQL Server

Start Mode Automatic
State Running \

2>
S
&

Path to the executable file for this service,

ok [ Concel |[ ey |[ Heb | @
e Inthe Binary Path entry, note or record the p{%ﬁd within the quotation marks. This is the file
p

path to the SQL Server instance binary files ( ath ™ contained only within the quotation marks—

ignore the text outside the quotes). Q

rol Pane: @m and Services > Administrative

2 Open Windows Firewall by selecting Start >

Tools > Windows Firewall with A d Settings
If you are using Windows 8, Ie AII a dows System > Control Panel > System
and Services > Adm|n|st s > Win wall > Advanced Settings.

3 Inthe left-hand pane of t ows F|re i Advanced Security window, right-click on Inbound

Rules and select Ne@
4 Inthe New Inbgun e wizard
5 Select th program pa
and |
&t the Allow %:nnection option then click [Next].

8 Selec%@, Public, and Private check boxes then click [Next].

@e Program option and click [Next].

servr.exe file at the binary file path you recorded in step 1 then click
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9 Type the name of your SQL Server instance in the Name box.

10 Click [Finish] to create the firewall exception for the SQL Server Database Engine service.

The Windows Firewall with Advanced Security window opens.

Figure 10: Windows Firewall with Advanced Security Window

File Action View Help
«% 2@ =0
P Vindous Fieual uith Adhancy Actons
I dnbound Rules) Name Group = Profile + || Inbound Rules -
Outbound Rules -
%y Connection Security Rules .Windows Collaboration Computer Name... Windows Collaboration Co... Al W MNewRule..
1+ %] Monitaring .Wmdow; Collaboration Computer Name... Windows Collaboration Cow.. Al T Filter by Profile »
@Window; Communication Foundation N... Windows Communication F...  All
.Wmdow; Firewall Remote Management (.. Windows Firewall Remote...  Private.. W Filter by State '
.Window; Firewall Remote Management (... Windows Firewall Remote...  Domain 7 Filter by Group 4
.Windows Firewall Remote Management (... Windows Firewall Remote...  Domain Wiew »
.Wmdow; Firewall Remote Management (.. Windows Firewall Remote...  Private..
.Window; Management Instrumentation ... Windows Management Instr...  Private... G Refresh ®
@ Windows Management Instrumentation .. Windows Management Instr.. Domain = Export List...
.Window; Management Instrumentation ... Windows Management Instr... Domain E Help
.Windows Management Instrumentation ... Windows Management Instr...  Private...
.Wmdow; Management Instrumentation ... Windows Management Instr...  Private..
.Window; Management Instrumentation ... Windows Management Instr... Domain
.Wmdow; Media Player (UDP-In) Windows Media Player All
.Window; Media Player x86 (UDP-In) Windows Media Player All
.Windows Media Player Network Sharing ... Windows Media Player Net...  Domain |z
.Wmdow; Media Player Network Sharing ... Windows Media Player Net..  Private...
.Window; Media Player Network Sharing ... Windows Media Player Net...  Private...
.Windows Media Player Network Sharing .. Windows Media Player Net..  Domain
8 Windows Media Plaver Network Sharing ... Windows Media Plaver Net...  Private..,
] 1 (3 R T —|

Setting the SQL Server browser service

1 Open Windows Firewall by selecting Start
Tools > Windows Firewall with Advance"

If you are using Windows 8, select St

2 Inthe left-hand pane of the W|
Rules and select New RuI

and Services > Administrative T:ﬁ

3 Inthe Newlnboundg
4 Select UDP as the'growe€ol type.

5 elect the

Il apps > Wi
mdom e

6 Cljck
e Allow the conNg#Ction option and click [Next].

8 Selectthe Do

9 Type

ystem > Control Panel > System
Advanced Settings.

irewall w&' nced Security window, right-click on Inbound

|zard select th&)rt option and click [Next].

o

eC|f|c local po@ iog and type 1434 in the corresponding box.

blic, and Private check boxes then click [Next].

rowser Exception in the Name box.
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10 Click [Finish] to create the firewall exception for the SQL Server browser service.

Network configuration

To connect with SQL Server, you must have TCP/IP enabled.

Enable TCP/IP

If you are receiving network configuration errors, make sure that TCP/IP is enabled, as follows:

1 Select Start > Control Panel > Administrative Tools > Windows Firewall with Advanced Security.

2 Start SQL Server Configuration Manager (Start > All Programs > Microsoft SQL Server 2008 R2 >
Configuration Tools > SQL Server Configuration Manager).
In Windows 8, select Start > All apps > Microsoft SQL Server 2008 R2 > SQL Sewe&@uration
Manager.

3 Expand SQL Server 2008 Network Configuration.

4 Select Protocols for SAGE_ESTIMATING (or the name of your instanc&\
5 Right-click on TCP/IP and select Enable. O

6 Click [OK]. %

@ NOTE: You must stop and restart the SQL Server seng @this change to take effect. See “SQL
Server services” on page 30 for more information %

Running a virus scanner on the SRL Séfver host machine

For performance reasons, if you plantorun a vi@anner onth hine that hosts the SQL Server
instance, you should exclude files that have MDF=DF, NDF N, and TRC extensions. You should
also exclude additional processes for thgfvelgion of SQL SE t you are running. For more information

about the files and processes to exclys Ce Microso#t ebase article 309422 at
http://support2.microsoft.com/kB \\

Security Administ@ @

Operators using Sage @ g must hgye SQ®Server permissions to the databases they are expected to
use. You assign per using the%nd Permissions features in the Estimating Management
Console. For more ation, see llation & Administration Guide.

If an opei® o%periencing c@ I0n issues with a database, verify the operator belongs to a role with the
]

apprﬂ%& sionsQ
& rver sgavice

You may have %L Server services or instances, depending on the version of SQL Server you are
using. For S 2008 R2 Express, the following are used:
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= SQL Server (the name you assigned to the SQL Server instance)
= SQL Server Browser
If the service is not running, you can start it using SQL Server Configuration Manager.

To Start the SQL Server Engine Using SQL Server Configuration

1 Start SQL Server Configuration Manager (Start > All Programs > Microsoft SQL Server 2008 (or
Microsoft SQL Server 2008 R2) > Configuration Tools > SQL Server Configuration Manager).

If you are using Windows 8, select Start > All apps > Microsoft SQL Server 2008 R2 > SQL Server
Configuration Manager.

2 Select SQL Server Services. @
3 Right-click the service (for example, SQL Server (<instance name>)), and then click \

To Stop the SQL Server Engine Using SQL Server Configuration

1 Start SQL Server Configuration Manager (Start > All Programs > Micro Q[¥Server 2008 >
Configuration Tools > SQL Server Configuration Manager). O

er 2008 R2 > SQL Server

If you are using Windows 8, select Start > All apps > Microsoft
Configuration Manager.

2 Select SQL Server Services. @

3 Right-click the service (for example, SQL Server (%ameﬂ) and then click Stop.

Determining the path to th L Seryer program

If you have multiple instances of SQL Serverin d, eachi @ independent of the others. To
determine the location of the SQL Serveyprogram for a partir@ws ance, do the following:

¢
1 Start SQL Server Management S @ press ( | Programs > Microsoft SQL Server 2008 R2
> SQL Server Managemen (WOr SQL S agement Studio Express).

In Windows 8, select Stalt > apps > Migr SQL Server 2008 R2 > SQL Server Management

Studio. @
2 Inthe Connect%e r window &(it}[hat the correct Server type, Server name, and
Authentication are®elected, an@ ick [Connect]. For example:
o Sers\%Database E@
@ me; Coame\instance_name
utfenticatio i
If

%dows Authentication
indows isdition does not work, try SQL Server Authentication. You must have security
permission,i erver to access the database using this authentication.
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Determining the path to the SQL Server program

3 Right-click on the server name, and then select Properties.
The pathis listed on the General page next to Root Directory. Make note of this path.

4 Click [Cancel] and then close the SQL Server Management Studio Express window to exit without
making any changes.

The program exists in the Binn directory, which is below the root directory you noted in step 4. For example:
C:\Program Files\Microsoft SQL ServernMSSQL.1\MSSQL\Binn\sqlservr.exe. The actual number in the path
may be different depending on how many instances you have installed on the computer.
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Chapter 7—Additional Information

The following is provided as additional resource material. It is included for reference only and is not meant to
imply that Sage supports, controls, or endorses any of the content. Be aware that titles, links, and content can
change and may not always be pertinent to your situation.

General Information
Instance Configuration:

http://msdn.microsoft.com/en-us/library/ms143531(v=SQL.100).aspx

Microsoft SQL Server 2008 Security Datasheet: @

http://download.microsoft.com/download/D/1/B/D1B8D9AA-19E3-4DAB-AF9C- ®

05C9CCEDD85C/SQL%20Server%202008%20Security %20-%20Datasheet. pdf

How to Rebuild the Master Database for SQL Server 2008:

Collation or Corruption @

http://msdn.microsoft.com/en-us/library/dd207003(v=SQL.1 OO).a%

Security @
Password Policy: Q
asswort olicy &kl_

O

http://msdn.microsoft.com/en-us/library/ms16 .100).aspx

SQL Server 2008 Security White Papers:

http://www.microsoft.com/sql/technr@security/w it rs.mspx
L 2
2O

X
7%
17 O
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http://msdn.microsoft.com/en-us/library/dd207003(v=SQL.100).aspx
http://msdn.microsoft.com/en-us/library/ms161959(v=SQL.100).aspx
http://www.microsoft.com/sql/technologies/security/whitepapers.mspx

Chapter 7—Additional Information

Strong Passwords:

http://msdn.microsoft.com/en-us/library/ms161962(v=SQL.100).aspx

Services

How to Verify a Successful Installation of SQL Server 2008 Reporting Services:

http://msdn.microsoft.com/en-us/library/ms143773(v=SQL.100).aspx

Managing the Database Engine Services:

http://msdn.microsoft.com/en-us/library/ms189925(v=SQL.100).aspx
Managing Services Using SQL Server Management Studio: @
http://msdn.microsoft.com/en-us/library/ms187478(v=SQL.100).aspx ®
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Chapter 8—Glossary

BOL/Books On Line

SQL Server Books On Line. These are resource materials for SQL Server provided by Microsoft. Books On
Line is automatically installed with the Sage Estimating installation of SQL Server 2008 Express Edition. You
can also download a current copy at www.microsoft.com.

Instance/Named Instance

A complete database environment, including the relational database management system software, table
structure, stored procedures, and other functionality.

Microsoft Desktop Engine (MSDE) @

A database engine compatible with earlier versions of SQL Server. ®
" Q
The system administrator for SQL Server. O&

SQL
Structured Query Language, the standardized language used ir@ally all relational databases.

SQL Server Management Studio (SS%
The configuration tool used to manage all aspects% server.
SQL Server Management Studit@o ess (S&SE/SSMS Express)

A limited version of SQL Server Manage Studio.

9
Stored Procedures o O \§
Database functions that aIIow@ed pre-corr@

Transact-SQL @K
age supported k%soft SQL Server.
)

A robust scripting lan
ows by creating different access levels for administrators and standard
users from changing system settings or affecting sensitive system

ries.

User Ac t Contr
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Appendix—SQL Server Instance
Settings

If you have an existing instance of a supported version of Microsoft® SQL Server” installed, you can set up
another instance to work with Sage Estimating. (Options described in this section may vary slightly depending
on the edition you are installing.)

NOTE: If you choose to uninstall your existing instance first, reboot your server before reinstalling to
avoid problems with the new installation.

CAUTION: Do not change the owner of any databases in the Sage Estimating instance.
@limating

Set your new SQL Server 2008, SQL Server 2008 R2, SQL Server 2008 R2 Express, or (for,
13.2 and later) SQL Server 2012 instance to the settings as outlined in the following sectk@

SAGE_ESTIMATING Instance

Figure 11: Instance Configuration Settings \$
15 SQL Server 2008 R2 Setup : ?— S —— _- S =]y

Instance Configuration
Specify the name and instance ID for the instance of SQL Server. Instance ID becomes part of the ingtallation .

Setup Support Rules () Default instance @

Installation Type

@ Mamed instance: SAGE_ESTIMATING

Product Key

License Terms

SEpEE Instance [D: SAGE_ESTid

Feature Selection

Installation Rules Instance root directory:  C:\Prog eMMicrosoft SQL Servi

Instance Configuration

Disk Space Requirements SSQL10_50.SAGE_ESTIMATING
Server Configuration

Database Engine Configuration

Error Reporting Edition Version
Installation Configuration Rules Express with Adva... |10.50.1600.1
Ready to Install 10.50.1600.1

Installation Progress

Complete

ust use a na instance. You can give the instance any name you want. However, Sage
recommends givj iflstance a name that makes it easily identified (such as SAGE_ESTIMATING).

A\
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Authentication Mode

Figure 12: Authentication Mode Settings

%5 SQL Server 2008 R2 Setup = =[]
Database Engine Configuration

Specify Database Engine authentication security mode, administrators and data directories.

Setup Support Rules Account Provisioning | Data Directories | FILESTREAM
Installation Type
Product Key Specify the authentication mede and administraters for the Database Engine.

License Terms Authentication Mode

Setup Role (©) Windows authentication mode

Feature Selection : @
@ Mixed Mode (SQL Server authentication and Windows authentication)

Installation Rules

Instance Configuration Specify the password for the SQL Server system administrator (sa) account.

Disk Space Requirements Enter password: P — E

Server Configuration

e Engine Config . Confirm password: “"""“"l

Error Reporting Specify SQL Server administrators

Installation Configuration Rules =
Ready to Install @ rators have
Installation Progress leEE=siy

cratabase Engine.

Complete
Add Current User ] I Add... ] I Bemove ]
Next > ] I Cancel ] I Help ]
The instance must support Mixed Mode authe (Windo thentication and SQL Server
Authentication). This means either Windows a ntication rver authentication can be used to

access the database information.

*

operator%&e permissions to use SQL Server or be a

When Windows authentication i® usg

member of a group that has thogg [
account name and passwor%@

authentication mode, SQL Server validates the

nrormation indows operating system.

When SQL Server aut n is used, the op&ator must have system administrator (sysadmin) rights in
SQL Server. The SQ authenticgfioMis used for backward-compatibility and requires a strong

password. @
Collat v@ttings @
C 1 tigs must 1_General, case-sensitive, and accent-sensitive (Latin1_General_CS_

You can customj %IIation settings during the server configuration portion of the SQL Server install. In
the SQL Server n customization window, make the following selections:
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= Select the Windows collation designator and sort order option (instead of SQL collation, which is the
default)

= Latin1_General (for the collation designator)
= Case-sensitive
= Accent-sensitive

= Clear all other options

Additional Recommendations

following settings in SQL Server Management Studio and SQL Server Configuration Manag
these changes may result in poor Sage Estimating performance or communication issu%

Memory @

Determine the amount of available memory on the server or workstation whe&g erveris installed. To
prevent SQL Server from consuming all available memory, use SQL Serv ement Studio to set the
maximum amount of memory (in the instance properties) to a reasonal uch as 4 GB ) as follows:

To ensure accurate performance, Sage strongly recommends making changes and verificaji{@xe
Fateffe to make

1 Right-click on the SQL Server instance and select Properties.

2 Inthe Server Properties window, click Memory (left-han )

3 Set the Maximum server memory amount to 4 00\ tever limit you determine).
Communication protocol

Set the communication protocol settings for theQ Estimating

1 Start the SQL Server Configuration Magag

by selgcti
SQL Server 2008 R2) > Con§g @ ools >%
ps > SQL@

Berver instance as follows:

»

agy> All Programs > SQL Server 2008 (or
er Configuration Manager.

In Windows 8, select Start \7 008 > SQL Server Configuration Manager.

SQL Server Netw, |guratio@play all local SQL Server instances.
3 Select the instan sociated Estimating (SAGE_ESTIMATING, by default).

4 Inthe RX pane right-c@‘n a communication protocol and select Disable.

5 Jgefgat 4forall c@cation protocols except TCP/IP. Leave this protocol Enabled.

6 INYye left-hand p@the SQL Server Configuration Manager window, click the arrow next to
SQL Native ted#. 0 Configuration or SQL Native Client 11.0 Configuration (depending on your

sQL S% )-

2 Inthe left-hand pane @. QL Server Co&uration Manager window, click the arrow next to
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7 Click Client Protocols (left-hand pane).
8 In the right-hand pane right-click on a communication protocol and select Disable.
9 Repeat step 8 for all communication protocols except TCP/IP. Leave this protocol Enabled.

10 Close the SQL Server Configuration Manager and restart the service.
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