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Chapter 1—Release Overview

Sage welcomes you to Sage Estimating. Read this guide carefully to understand the installation and
configuration process.

Configuration Features in Sage Estimating
You will find the following configuration features in Sage Estimating:

= Estimating Management Console. The Estimating Management Console allows you to view and manage
your databases, estimates, and roles and permissions. You can also use the Estimating Management
Console to perform data migrations, share estimate layouts, view and manage estimates, and set up
custom estimate reports.

= Configuration wizard. The Configuration wizard lets you designate a SQL Server instance to act as your
Sage Estimating server. Using the Configuration wizard, you can also create the estimate database,
upgrade existing data, and set up your software licensing and registration. For more information, see “D.
Run the Configuration Wizard” on page 18.

Read the Supporting Documentation Before You Install

Be sure to read supporting documentation before you install:

« This Installation and Administration Guide includes an overview of this release, installation
instructions, system requirements, and contact information.

« The Release Notes provide details about new features, database changes, known issues, and fixes.
This document is available in your Sage Estimating installation files in the Documents folder.

« The Getting Started Guide provides an operational overview of the Sage Estimating software. This
document is available in your Sage Estimating installation files in the Documents folder.

« The SQL Server Guide gives you an overview of the significant differences between the new
SQL Server databases and the Pervasive databases used in previous Sage Estimating releases. This
document is available on your Sage Estimating installation files in the Documents folder.

« The Options Guide provides installation, setup, and operating instructions for each of the available
Sage Estimating options, such as the OnScreen Takeoff Integrator or License Manager. This
document is available in your Sage Estimating installation files in the Documents folder.

Conventions Used in this Document
This document uses the following conventions:
= Information you type into the software is shown in bold font. For example: Type Miscellaneous in the box.

= The names of screens, windows, fields, and other features displayed by the software are shown in bold
font.

= The names of buttons you can click are enclosed in brackets with bold font. For example: [OK] or [Post].
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Chapter 1—Release Overview

= Names of keys are shown in capital letters. For example: ENTER or TAB. A plus sign (+) between two key
names indicates you should press the keys simultaneously.

= Variable names or names that are specific to your installation may appear in italics and brackets. For
example: [Drive]\\[ Server].

Symbols

)

NOTE: This symbol is used when presenting information that is supplemental to the adjacent text.
TIP: This symbol is used when presenting helpful information for using the software.

? CAUTION: This symbol is used when presenting important information to help you avoid a loss of
—  critical data.
IMPORTANT: This symbol is used when presenting information that is critical to understand or that
— requires you to take action.

%]

Menu Paths

In this document, menu paths show you the steps required to start a task. Menu paths appear in bold font with
angle brackets around buttons. For example:

"If the program does not automatically start, click [Start] > Run."

Online Help

The Sage Estimating software includes online Help, which provides answers to your questions about
procedures as well as items in the windows.

To access the online Help in the Sage Estimating software, click the Help button oricon, or press [F1] to
display the help topic for that window.

To aid you in finding the information you need, the online Help for each module includes the following panes:
= Contents pane containing links to the help topics

= Index pane containing keywords that link to help topics related to that keyword

= Search pane, where you can type text and click [Search] to locate that text in the help topics

For more information about using the online Help, see the Sage Estimating Help.

We would like your feedback about the online Help so we can make improvements. Each Help topic contains
an area where you can indicate whether the topic was helpful and provide additional comments. To protect
your privacy, all comments are anonymous.
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Training

Training

Sage University offers online and classroom training sessions to help you get the most out of your Sage
Estimating software. To access Sage University, visit www.sageu.com.

You can also get access to Sage University from the File menu by selecting Help > Sage Estimating on the
Web > Sage University.

Technical Assistance

When you need assistance, refer to the Knowledgebase article How do | get technical support for Sage
Estimating? to determine which service works best for you.

Submitting Enhancement Requests

We want to hear your suggestions for improving the software. To send us your comments, click on the File
menu button and select Help > Sage Estimating on the Web > Submit Enhancement Requests.

Installation and Administration Guide 3
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Chapter 2—System Requirements

The following hardware and software requirements provide a guideline. As with any software, as we continue
to enhance Sage Estimating, you will realize optimal system performance by using up-to-date computer
hardware. This includes memory as well as overall hardware specifications. For help in selecting the right
business-class computers for your business-class software, contact your authorized business partner.

Sage Estimating supports the following and service packs. The listed service packs are minimum required

levels for installing Sage Estimating.

Table 1: Supported Operating Systems

Operating System

Minimum Service Pack

Windows 8.1 Pro

Windows 8.1 Enterprise

Windows 8 Pro

Windows 8 Enterprise

Windows 7 Business SP1
Windows 7 Professional SP1
Windows 2008 Server Enterprise Edition | SP2
Windows 2008 Server Standard Edition | SP2
Windows Server 2012 Standard Edition

Windows Vista® Business SP2
Windows Vista® Ultimate SP2

D NOTE: Sage Estimating also supports all 64-bit versions of these operating systems.

Supported Editions of SQL Server and Other Applications

Table 2: Compatible Third-Party Applications

Sage Estimating is tested for use with the following applications:
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Chapter 2—System Requirements

Interfacing Applications in the Interfacing Applications Not in the
Sage Estimating installation files Sage Estimating installation files
Sentinel Driver—7.6.1 On-Screen Takeoff—3.8 and 3.9

License Manager—38.3.0

Microsoft SQL Server 2008 R2 Express

m NOTE: You can install an approved instance of SQL Server side by side on a computer where
SQL Server 2012 is also installed. Be aware that installing Sage Estimating may then result in an "Install
completed with errors" message; however, the resulting Sage Estimating install operates correctly.

Recommended Minimum Processor

A Pentium 4 (P4) or later processor with a minimum of 2 gigahertz (GHz) processing speed is required for the
server that hosts Sage Estimating as well as workstations using Sage Estimating. Having a fast processor on
both the server and workstations will improve your performance.

Recommended Minimum Random Access Memory (RAM)

A minimum of 2 gigabytes (GB) of available, open RAM is required for the server that hosts Sage Estimating
and for the workstations using Sage Estimating. As a general rule, the more RAM you have on the server and
workstations, the better your performance will be.

Open RAM is unallocated random access memory that is available for Sage Estimating use.

Hard Disk Space Required for Installation

The following table lists the hard disk space necessary to install Sage Estimating on a server, stand-alone
computer, or workstation. Use this information to calculate your hard disk space requirements based on the
applications that you install. Having adequate free space on the hard disk, a fast processing speed, and
adequate RAM can improve your performance.

* IMPORTANT: Do not install Sage Estimating until you have sufficient hard disk space available.

Table 3: Hard Disk Space Usage

Product Available Hard Disk Space

Sage Estimating and SQL Server 2008 R2 Express | Upto 3 GB

Sage Estimating only Upto1.2GB
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Hardware Requirements

Hardware Requirements
Sage Estimating requires the following hardware.

Table 4: Hardware Requirements

Hardware Purpose and Specifications
DVD drive For Sage Estimating installation DVDs.
Network adapter Connects computer to a network.

Must be high quality.

Printer For Sage Estimating.

Super VGA monitor For high-resolution color display.

1280 pixels by 1024 pixels recommended.

SafeNet Sentinel SuperPro hardware key (dongle) [ For Sage Estimating license management.

Supported Protocols

Table 5: Supported Protocols

Protocol Purpose

Transmission Control Protocol/Internet Microsoft servers default to this protocol.
Protocol (TCP/IP)

Remote Display Protocol (RDP) 5 Microsoft remote protocol, which is used in its remote
connection applications.

Independent Computing Architecture (ICA) | Citrix remote protocol, which is used in its remote
connection application.

Access Rights

The following sections describe the access rights you need to successfully install and use Sage Estimating.

Elevate Permissions

You must elevate your permissions before installing Sage Estimating on Windows Vista, Windows Server
2008, Windows 7, and Windows 8 or Windows 8.1. During certain installation tasks, you will receive another
prompt to elevate your privileges. If you do not acknowledge each prompt within two minutes, the installation
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Chapter 2—System Requirements

process will quit the task. If this occurs, you may receive a separate prompt asking you to retry the task. To
retry the task, click [Retry] and then elevate your privileges at the prompt.

SQL Server Permissions

Database permissions for SQL Server instances used with Sage Estimating are now set up using the
Security feature in the Estimating Management Console.

For more information on setting up SQL Server security for Sage Estimating, see “F. Set Up Roles and
Permissions” on page 20.

Full Control of Specific Files and Folders Required

To use Sage Estimating, you must have full control of the following files and folders on your file server,
terminal server, and workstations that have Sage Estimating installed. Make sure that your system
administrator also gives you full control of all the subfolders and files.

CAUTION: Incorrectly modifying Microsoft Windows security may severely affect your system
operations. Sage is not responsible for operation problems caused by incorrectly modifying your
Microsoft Windows security settings. To set permissions on your network or Windows operating
system, you must have advanced knowledge of your network. Contact your system administrator for
assistance.

NOTE: Some of these folders may be hidden. To view them on Windows Vista, Windows 2008 Server,
and Windows 7, open Windows Explorer, select Organize > Folder and Search Options, and then
select Show hidden files and folders on the View tab. In Windows 8 or Windows 8.1, open Windows
Explorer, click on the View tab, and then select the Hidden items check box in the Show/hide group.

Table 6: Folders and Files Requiring Operator Control

Product Operating ReqUI.red Folders Location and Specifications
Systems and Files
Sage 32-bit Windows [Drive]:\Program This folder is located on the file
Estimating | systems Files \Sage server, terminal server, and
Estimating workstations where you installed
Sage Estimating. It is the default
installation location for Sage
Estimating. However, depending on
your system configuration, your
company may have renamed this
folder or installed it to a different
location.
Sage 64-bit Windows | [Drive]:\Program This folder is located on the file
Estimating | systems Files (x86)\Sage server, terminal server, and
Estimating workstations where you installed
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Supported Upgrade Paths

Product Operating Reqw.red Folders Location and Specifications
Systems and Files
Sage Estimating. It is the default
installation location for Sage
Estimating. However, depending on
your system configuration, your
company may have renamed this
folder or installed it to a different
location.
Sage Windows Vista®, | [Drive] These folders are located on the
Estimating | Windows 2008 :\Users\Public\Sage | workstation or terminal server where
Server, Estimating you use Sage Estimating. Sage
Windows 7, Estimating installs necessary files
Windows 8, and | -and- to these folders and requires that the
Windows 8.1 . user has full control of them.
[Drive]
:\ProgramData\Sage
Estimating

Full Control and Read Access to Specific Registry Keys Required

To use Sage Estimating, you must have full control of the following Windows registry key on your file server,
terminal server, and workstations that have Sage Estimating installed. Make sure that your system
administrator also gives you full control of all subkeys.

CAUTION: Incorrectly editing the Microsoft Windows registry may severely damage your system.
Sage is not responsible for damage to your system caused by editing the registry. Before making
changes to the registry, contact your system administrator for assistance and make a backup copy of all
valued data. System administrators, see Microsoft Registry Editor Help topics for detailed instructions.

= HKEY_CURRENT_USER
You should also have read access to the following registry keys and associated subkeys:
= HKEY_Local Machine\Software\ODBC

= HKEY_Local_Machine\Software\Wow6432Node\Sage

Supported Upgrade Paths

If you plan to use your estimate data from a release earlier than version 11.1, you must upgrade your data to
Sage Estimating 9.6 or later prior to migrating your data. Refer to “Chapter 4—Data Migration” on page 27 for
data migration instructions.
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NOTE: Do not install previous releases of Sage 300 Construction and Real Estate (formerly Sage
Timberline Office) after installing Sage Estimating 14.12. The new Sentinel driver is incompatible with
previous releases.

You can upgrade any Windows-based Sage Estimating data (beginning with Sage Estimating 1.0) to Sage
Estimating 9.6.

If desired, you can install this version of Sage Estimating without uninstalling your previous Sage Estimating
installation. However, because the data format is different, you cannot migrate data between this release and
releases of Sage Estimating earlier than version 11.1 without performing data migration.
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Chapter 3—Installation and
Configuration

Installation and Configuration Categories

Installation and configuration of Sage Estimating falls into one of three primary scenarios.
= Scenario 1: Set up in a server/workstation domain

= Scenario 2: Set up in a workgroup environment

= Scenario 3: Set up on a standalone computer

Use the following diagrams to plan the installation and configuration process for your setup scenario.
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Chapter 3—Installation and Configuration

Figure 1: Scenario 1 (Domain server/workstation environment, databases installed on the server)

At the Server:
1. Pre-installation checks—section A
2. Install/Configure SQL Server—section B

3. Install Sage Estimating “Server’—section C
4. Install/Upgrade License Manager (optional)}—section H

Server (Databases will reside here)

Workstation Workstation Workstation

At the Workstation:

5. Pre-installation checks—section A

6. Install/Configure SQL Server (optional)—section B
7. Install Sage Estimating—section C

8. Run the Configuration wizard—section D

9. Migrate your data (from 1st workstation only, optional}—section E
10. Set up roles and permissions (from 1st workstation only)—section F
11. After you complete your setup—section |
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Figure 2: Scenario 2 (Workgroup environment, estimating data shared from one workstation)

At

the Host:

1
2
3
4
5
6
7
8

. Pre-installation checks—section A

. Install/Configure SQL Server—section B

. Install Sage Estimating—section C

. Run the Configuration wizard—section D

. Migrate your data (optional)—section E

. Set up roles and permissions—section F

. Set up your firewall exceptions—section G

. Install/Upgrade License Manager (optional)—section H

Workstation

At the W

Host Workstation
(Databases will reside here)

Workstation

orkstations:

9. Pre-installation checks—section A

10. Install

11. Run th
12. After y

Sage Estimating—section C
e Configuration wizard—section D
ou complete your setup—section I

Workstation
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Figure 3: Scenario 3 (Standalone workstation environment, estimating data stored on the workstation)

Workstation

At the Workstation:

1. Pre-installation checks—section A

2. Install/Configure SQL Server—section B
3. Install Sage Estimating—section C

4. Run the Configuration wizard—section D
5. Migrate your data (optional)—section E

6. Set up roles and permissions—section F
7. After you complete your setup—section |

A. Before You Install or Upgrade

Ensure you read through and understand the information in this installation guide.

1

If you are currently using a previously-released version of Sage Estimating, create a complete backup copy
of all Sage Estimating data and program files before installing this release.

Install the appropriate operating system service pack level, make sure that there is sufficient hard disk
space available, and ensure that your server and workstations meet all other hardware and software
requirements. See “Chapter 2—System Requirements” on page 5 for more information.

Make sure that you have full control of the necessary folders, files, and registry keys on your file server,
terminal server, and workstations that will have Sage Estimating installed. For a list of the required folders,
files, and registry keys for your operating system, see “Chapter 2—System Requirements” on page 5.

Close all programs and services for the duration of the installation. This includes programs that may be
running in the background such as antivirus, email, and backup programs.

If you do not have Sentinel protection devices attached to your computer, do not attach these devices until
after you install Sage Estimating. If you already have Sentinel protection devices attached, you can leave
these devices in place during the Sage Estimating installation.

Decide which installation scenario to follow. See “Installation and Configuration Categories” in the previous
section.

You must have the appropriate permissions to perform certain tasks described in this chapter. Contact your
Sage Estimating administrator if you require additional permissions.
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B. Install/Configure SQL Server

B. Install/Configure SQL Server

Install or configure a supported version of SQL Server (SQL Server 2008 SP1, SQL Server 2008 R2,

SQL Server 2008 R2 Express, or SQL Server 2012 for Sage Estimating version 13.2 and later) on the server or
workstation where you want to store your Sage Estimating data. An optional copy of SQL Server 2008 R2
Express is included with the Sage Estimating installation.

NOTES:

If you want to use an existing installation of SQL Server 2008 or SQL Server 2008 R2, refer to “Chapter 5—
Configuring SQL Server,” on page 31 for settings for creating and configuring a new instance.

If you do not already have an installation of Microsoft® SQL Server® on the server or workstation where you
plan to keep your Sage Estimating databases, and you want to install the SQL Server 2008 R2 Express
copy that comes with Sage Estimating, follow the instructions for installing Sage Estimating found in “C.
Install Sage Estimating” on page 16 and select one of the following options during the install:

o Complete Sage Estimating System
o Sage Estimating Server and new instance (available only on new installations)
o Create new local SQL Server instance (available only when reinstalling)

If you are operating in a workstation/server environment (see “Installation and Configuration Categories” on
page 11), you do not need to install SQL Server on the workstations. However, you can install SQL Server
optionally if you want to maintain a local copy of your estimating data.

At the instance name prompt, type a name for the new SQL Server instance (database server) in the
box, and then click [OK].

The default instance name is SAGE_ESTIMATING , but you can give the instance any name you
want provided you do not give it the same name as any existing SQL Server instance on the
compulter.

» If you plan to migrate existing data from Pervasive-based Sage Estimating (versions 9.6 up to 13.1) to
version 14.12, you must install SQL Server on the destination computer or server.

» Theinstallation process may reboot your computer. If your computer reboots, log back onto your
computer at the prompt.

» You can install an approved instance of SQL Server side by side on a computer where SQL Server
2012is also installed. Be aware that installing Sage Estimating may then result in an "Install
completed with errors" message; however, the resulting Sage Estimating install operates correctly.

» Sage recommends against installing SQL Server 2008 R2 Express on a domain controller.
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Chapter 3—Installation and Configuration

C. Install Sage Estimating

IMPORTANT:

» Do not install Sage Estimating until you have sufficient hard disk space available. See “Hard Disk
Space Required for Installation” on page 6 for more information.

» Do not install previous releases of Sage 300 Construction and Real Estate after installing Sage
Estimating; the new Sentinel drive is incompatible with previous releases.

1 At the workstation or server, log on with full administrative rights.

Full administrative rights are defined as write access to the Windows registry and all folders on the
computer (including rights to the root of all hard drives). If you are unsure whether you have full
administrative rights, ask your network administrator for assistance.

2 Open the Sage Estimating installation window by double-clicking the SetMeUp.exe file found in your local
Sage Estimating install folder.

The Sage Estimating install folder is found in the location you specify during the Sage Estimating download
process. For example, if you download the install files to C:\Users\Public\Public Documents\Sage
Estimating, look in this folder for the SetMeU p.exe file.

NOTE: If you have not already done so, download the Sage Estimating install files in accordance with the
instructions provided in the software notice. If you are installing Sage Estimating on a server, ensure you
save the install files in a location that all workstations can access. Then copy the install files to each
workstation where you want to install Sage Estimating.

Clicking SetMeUp.exe opens the Sage Estimating installation window.

The Sage Estimating installation window
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C. Install Sage Estimating

[ Select installation optic

Sage Estimating

What do you want to install?

* Complete Sage Estimating system
For workstations running standalone, offline, or workgroup

" Sage Estimating
For workstations connecting to a network server

" Sage Estimating Server only
For network servers currently with SQL Server

" Sage Estimating Server and new instance
For network servers not currently with SQL Server

Enter new instance name:  SAGE_ESTIMATINGO

|T|s@

3 Follow the steps as prompted during the resulting installation and choose from one of the following
installation selections (refer to installation scenario 1, 2, and 3 on “Installation and Configuration
Categories” on page 11.

o Complete Sage Estimating system. This option installs everything you need to operate Sage
Estimating on your local workgroup server, offline workstation, or standalone computer, including a new
instance of SQL Server 2008 R2 Express. Select this option if you are installing Sage Estimatingon a
stand-alone workstation or a workgroup server.

o Sage Estimating. Select this option if you are installing Sage Estimating on a workstation that will
connect to a server on a domain or in a workgroup. Selecting this option installs the Sage Estimating
software and support components but does not install a new instance of SQL Server 2008 R2 Express.

o Sage Estimating Server only. Select this option if you are installing Sage Estimating to a serveron a
domain and you want to use an existing SQL Server install on the server. Selecting this option installs
certain Sage Estimating components that allow you to configure the server to support Sage Estimating
but does not install SQL Server 2008 R2 Express or Sage Estimating.

NOTE: You must install this option on the same server where your SQL Serverinstance is installed and
the existing SQL Server instance must meet the minimum supported requirements. For more information,
see “Supported Editions of SQL Server and Other Applications” on page 5.
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Chapter 3—Installation and Configuration

o Sage Estimating Server and a new instance. Select this option if you are installing to a serveron a
domain and you want to use the SQL Server 2008 R2 Express copy that comes with the Sage
Estimating install. Selecting this option automatically installs and configures a new instance of
SQL Server 2008 R2 Express for you. This option is unavailable if you already have installed Sage
Estimating components on the workstation or server.

o Create new local SQL Server instance. This option appears only if you have already installed Sage
Estimating components on the workstation or server. Select this option to install and configure a new
instance of SQL Server 2008 R2 Express.

The installation guides you through the process of installing Sage Estimating products and required support
software.

NOTES:

« The installation process may reboot your computer during the installation. Ensure you close all
programs and applications before starting the installation to avoid losing any data. If your computer
reboots, log on to your computer again.

« If you choose to upgrade data from a previous version of Sage Estimating, the process may take up to
four hours, depending on the size of your database. Plan accordingly.

4 Repeat steps 1-3 for each workstation or server where you want to install Sage Estimating.

D. Run the Configuration Wizard
The Configuration wizard installs automatically as part of the Sage Estimating installation.

1 Start the Configuration wizard by selecting Start > All Programs > Sage > Estimating 14.12
> Configuration Wizard or by clicking the desktop icon.

For Windows 8 and Windows 8.1, select the Configuration Wizard icon from the Tile Desktop, or right-
click outside the tile area, and then click All apps > Sage > Configuration Wizard.

NOTE: ForWindows Vista®, Windows 2008 Server, Windows 7, Windows 8, and Windows 8.1, you may
need to elevate your permissions level before starting the Configuration wizard by right clicking on
Configuration Wizard (or the desktop icon) and selecting Run as administrator.

2 Inthe Configuration Wizard window, register your software if prompted as follows:
a Locate your product's registration name from the packing slip enclosed with the original shipment.
b Type the registration name in the Registration name box.

¢ Locate each product or feature in the Available Features list that you want to use (left-hand pane) and
double-click on it to add it to the registration list (in the detail pane).
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D. Run the Configuration Wizard

Figure 4: Selecting Features for Registration and Activation

# | Available Features
— | Double-click any of these features
[E PWX-ENU - Estimating - Extended - ENU ™ 1 to add them to the registration list
EL' PWS-ENU - Estimating - Standard - ENU

Registration name: Default Registered User

Serial Number Description Achgfition Code | Status Expiration
F PWX-ENU Estimating - Extended - ENU Not Registered  No expiration.
PWS-ENU Estimating - Standard - ENU Not Registered  No expiration.

d Inthe Activation Code box of the registration list, type the activation code from the original shipment's
packing slip.

Alternatively, you can type one of the following selections in the Activation Code box for some of the
product features:
o DEMO: Operates the software feature in demonstration mode.

o LM: Registers the software feature separately using License Manager.

See “H. Set Up License Manager (optional)’ on page 22 for more information about setting up License
Manager.

e Click [Save] to save your registration and activation selections.
3 Click Server in the left-hand pane of the Configuration wizard.

4 Select the SQL Serverinstance ("server") that you are using for your Sage Estimating server by clicking
[Select].

5 Follow the on-screen prompts to finish configuring your Sage Estimating software.

The prompts you receive vary depending on your installation. You may be prompted to perform one or more
of the following actions:

o If the Configuration wizard does not find a preexisting estimate database in the specified SQL Server
instance, it prompts you to create one. Type a name for the new estimate database at the prompt.

o If you are storing existing Sage Estimating data from a previous release (version 11.1 or later) on the
selected instance, the Estimating Management Console identifies the data for upgrade. Click [Upgrade]
then follow the prompts to upgrade your data.

6 Click [Close] to exit the Configuration wizard.

Installation and Administration Guide 19



Chapter 3—Installation and Configuration

E. Migrate Your Data (optional)

If you have existing estimate data from a release prior to version 11.1, you can migrate your data to the current
Sage Estimating version. You can perform this process from any computer that has access to the SQL Server
instance or instances where you plan to store your estimate data. See “Chapter 4—Data Migration” on

page 27 for instructions.

F. Set Up Roles and Permissions

Set up roles and permissions from a workstation where Sage Estimating is installed. If you are setting up
Sage Estimating in a workstation/server or workgroup environment, you need to perform the roles and
permissions setup from only one computer.

NOTE: You must be a Sage Estimating administrator to set up roles and permissions. The person who
installs Sage Estimating is set up automatically as a Sage Estimating administrator.

Setting up roles and permissions involves three general steps:
= Create roles and assign permissions to them.

= Set up a list of authorized Sage Estimating operators.

= Assign operators to roles.

Set up a list of operators and task/feature permissions using the Security feature in the Estimating
Management Console.

Create roles and assign permissions to them

1 Start the Estimating Management Console by selecting Start > Programs > Sage > Estimating 14.1
> Estimating Management Console or by clicking on the desktop icon.

For Windows 8, select the Estimating Management Console icon from the Tile Desktop, or right-click
outside the tile area, and then click All apps > Sage > Estimating Management Console.

2 At the top of the Estimating Management Console, click [Security].
3 From the Security window of the Estimating Management Console, click on the Roles tab.
4 Click [Add] to open the Add Role window.

5 Inthe Add Role window, type a name for the new role in the Name box and an extended description in the
Description box.

Use the extended description to provide helpful identification information later, such as the purpose of the
role.
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6 Select the check box next to one or more tasks in the features list to provide operators and groups assigned
to the role with access to the tasks.

For example, selecting a check box labeled Create Estimate gives operators and groups within the role the
ability to create new estimates.

7 Clear the check box next to a task to prevent operators and groups in the role from accessing it.

Set up an operator list

1 Inthe Estimating Management Console, click [Security] to open the Security window (if it is not already
open) then click on the Users tab.

2 Onthe Users tab, click [Add] (located to the right of the Users grid) to open the Add User window.

3 Inthe Add User window, click [Select] to create a list of all operator user ID's and group ID's on the
network to which Sage Estimating is connected.

Alternatively, if you already know the user or group ID you want to add, you can type it directly in the User
Id box or type the first few letters and click [Select].

4 Select a network user ID or group ID from the resulting list.
NOTE: If you select a group ID, Sage Estimating adds all operators associated with the group.
5 Click [OK]inthe Add User window.

The operator or operators associated with the selected user or group ID appear in the Users grid of the Users
tab.

Assign an operator to a role

1 From the Security window, click on the Users tab.

2 Select an operator from the list in the Users grid.

3 Click on arole in the Roles list to assign the selected operator to it.

4 Repeat steps 1-3 for each operator you want to set up in Sage Estimating.

The Features list displays the corresponding tasks to which a selected role has permissions. You can assign
an operator to more than one role and the Features list displays the cumulative task and feature permissions.

IMPORTANT: At least one operator must be assigned to the administrator role at all times. Attempts to
remove the last operator from the role result in an error message.
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G. Set Up Firewall Exceptions

If you are installing Sage Estimating on a workgroup server, you must set certain firewall exceptions to allow
workstations to communicate with the Sage Estimating SQL Server instance.

For instructions on setting firewall exceptions, see “Setting the Firewall for Workgroups” on page 34.

H. Set Up License Manager (optional)

If desired, you can install License Manager to track and manage your Sage Estimating network licenses.
License Manager uses a server protection device and network licenses to track application uses on the
network.

Use the instructions in this section to install License Manager.

Guidelines
Please note the following:
= All license-managed servers and workstations must use the same network protocol (TCP/IP).

= You cannot install License Manager to a terminal server. If you have a terminal server, install to a
workstation.

= If you use firewall software on your license server, you may not be able to use the WimAdmin or
WCommute applications to view or check out licenses. To resolve this issue, discuss the server’s firewall
security with your network administrator. If you are willing to adjust your firewall security settings on the
license manager server, consider granting access to the Iservnt.exe file.

= Check in any licenses before upgrading.

For more information about License Manager, see Sentinel License Manager System Administrator Online
Help (index.html). This file is in the \Additionallnstalls\LicenseManager\SysAdminHelp folder in your
Sage Estimating setup and installation files.

Install the Sentinel driver

The Sage Estimating installation program automatically installs a Sentinel driver if you do not have one.
However, if you need instructions to install the Sentinel driver manually, visit www.sagecre.com and click
[Customer Support]. After you have logged on, in the Knowledgebase Search box, type How do | install
the Sentinel driver? See “Chapter 1—Release Overview” on page 1 for more information about using the
Technical Support Knowledgebase.

* IMPORTANT: Do not install previous releases of Sage 300 Construction and Real Estate after
installing Sage Estimating; the new Sentinel driver is incompatible with previous releases.
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H. Set Up License Manager (optional)

Attach a protection device to the computer that will have License
Manager

1 If you have a parallel port protection device, disconnect any hardware or peripheral devices attached to the
parallel port.

2 Plug the protection device into the parallel port or USB port.

3 If you disconnected devices in step 1, reconnect these devices.

Install License Manager
If you already have License Manager installed, start with“Upgrade License Manager” on page 24.

1 Log on with full administrative rights. Full administrative rights are defined as write access to the Windows
registry and all folders on the computer (including rights to the root of all hard drives).

If you are unsure whether you have full administrative rights, ask your network administrator for assistance.
Alternately, you can ask your network administrator to log on with the network administrator ID before you
start the installation.

2 Browse to your Sage Estimating installation and setup files and double-click
\\Additionallnstalls\LicenseManager\Server\Setup\Setup.exe.

3 Click [Open] then click [OK] to start the installation.

4 Follow the on-screen prompts. The installation automatically installs the appropriate software for the
operating system.

NOTE: Be sure to accept the default installation path when you install License Manager. If you need to
change the default installation path, change it to a local drive. You cannot install License Manager to a
network drive.

Install license codes

The number of network licenses purchased for an application indicates the total number of concurrent network
uses allowed for that application.

To install license codes:
1 Verify that the Sentinel License Manager service is running then select one of the following.

o Windows Vista and Windows 2008 Server: Start > Control Panel > System and Maintenance
> Administrative Tools > Services.

o Windows 7: Start > Control Panel > System and Security > Administrative Tools > Services.

o Windows 8 and Windows 8.1: Start > All apps > Windows System > Control Panel > System and
Security > Administrative Tools > Services.

2 Look for Sentinel RMS License Manager in the list of services.
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3 At the License Manager server, click Start] > All Programs > Accessories > Run (Windows Vista,
Windows 2008 Server, and Windows 7), or click Start > All apps > Run (Windows 8 and Windows 8.1).

4 Inthe Run window, browse to and double-click \\Additionallnstalls\License
Manager\Admin.net\Win32\WImAdmin.exe in your Sage Estimating setup and installation files.

5 Install license codes using one of the following methods.

o To enter license codes from a file: In the WimAdmin window, right-click your server and select Add
Feature > From a File > To Server and Its File. In the Open window, select your license file and click
[Open]. This installs all license codes in the file.

o To type license codes: In the WimAdmin window, right-click your server and select Add Feature >
From a String. In the Add feature to server window, type your license code exactly as it appears in
the license file or on the packing slip. (The code is not case sensitive.) Be sure to select the Add feature
to server's file check box.

When you enter a license code, the software adds this code to a file named Lservrc (which has no file
extension) in the License Manager installation path.

Upgrade License Manager

To upgrade License Manager, you must use the following steps to remove the previous version of License
Manager and then install the new version (version 8.3). Perform these steps at the computer where License
Manager is installed.

1 Check in any licenses before upgrading.

2 Run LoadLS.exe, located in the folder where you installed the previous version of License Manager
(typically, C:\Program Files\Rainbow Technologies\SentinelLM7x.x.xServer\English). Click [Remove],
and then click [OK] to remove the Sentinel LM license manager.

3 Remove the previous License Manager version:

o InWindows Vista, Windows 2008 Server, and Windows 7: Start > Control Panel > Programs
> Uninstall a Program.

o InWindows 8 and Windows 8.1: Start > All apps > Control Panel > Programs > Uninstall a
Program.

Remove Sentinel LM x.x.x.x. Server.
4 Install the new version of License Manager. See “Install License Manager” on page 23.

5 Copy the Lservrc file from the directory you identified in step 2 to the 8.3 directory of License Manager.
Typically, the 8.3 directory is C:\Program Files\Common Files\SafeNetSentine\Sentinel RMS License
ManagenWinNT.

6 Click [Start] and then select Settings > Control Panel > Administrative Tools > Services. Find
Sentinel RMS License Manager in the list of services, right-click the service, and then select [Restart].
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I. After You Complete Your Setup
1 Restart all programs and services that you shut down for the installation.

2 The Sage Estimating software performs a series of checks the first time you start it. If the Sage Estimating
software notifies you of any error conditions, correct the condition before continuing.

3 Sage Estimating provides supporting documents in the Documents folder of the Sage Estimating
installation files. These documents are available in Adobe Acrobat (PDF) format only. If you do not already
have Adobe Acrobat or Acrobat Reader, you can download Adobe Acrobat from www.adobe.com.

IMPORTANT: For performance reasons, if you plan to run a virus scanner on the machine that hosts
the SQL Server instance, you should exclude files that have MDF, LDF, NDF, BAK, TRN, and TRC
extensions. You should also exclude additional processes for the version of SQL Server that you are
running. For more information about the files and processes to exclude, see Microsoft Knowledgebase
article 309422 at http://support2.microsoft.com/kb/309422.

J. Other Installation Scenarios

Terminal Server

Follow the steps for “Scenario 2 (Workgroup environment, estimating data shared from one workstation)” on
page 13, with these exceptions:

= Always use Add or Remove Programs to start an installation to a terminal server.

= If youinstall Sage Estimating on a Windows 2008 Server terminal server, begin the installation by selecting
Control Panel > Install Application on Terminal Server. Follow the prompts and browse to the
install.exe file.

= If you use another server to host Sage Estimating databases, install only Sage Estimating products to the
terminal server.
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Chapter 4—Data Migration

If you have been using a Pervasive-based version of Sage Estimating, you can migrate (transfer) your existing
Pervasive-based data to the Microsoft® SQL Server® database platform if you want to use it with this release.

NOTES:

» You must be using Sage Estimating 9.6 or later to migrate your data.

« If you are currently using Sage Estimating 9.6, you cannot perform data migration from a computer
operating with Windows Vista®.

Overview

The process of migrating or making your existing Sage Estimating data compatible for use with the new Sage
Estimating is performed using the data migration feature of the Estimating Management Console. This feature
performs two functions when you select a Pervasive database for migration:

1 Validates your existing data for compatibility with Microsoft SQL Server.
2 Migrates or creates new SQL Server tables with your Sage Estimating data.

The Estimating Management Console performs these steps together when you start the data migration
process. When you migrate your Pervasive databases, the Estimating Management Console creates
corresponding .mdf and .Idf files in the specified SQL Server instance.

Changes in the Database Structure

Whereas Pervasive allows you to arrange your estimates in a hierarchical folder structure within each
database, Microsoft SQL Server stores all your estimates in just one estimate database. It also stores your
standard database and Address Book information separately.
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Figure 5: Compatrison of Pervasive and SQL Server
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If you have arranged your estimates in Pervasive folders and subfolders, the Estimating Management
Console attempts to re-create the arrangement using "branches" in place of folders. These branches are for
organizational display purposes only; they do not change the structure of your SQL Server database.

During the migration process, the Estimating Management Console may rename some of your database files
to comply with SQL Server requirements. For more information on renaming database files, refer to the
Estimating Management Console Help.

Migrating Your Data

Begin the process using the Estimating Management Console (select Start > All Programs > Sage > Sage
Estimating > Estimating Management Console).

IMPORTANT: You must have Sage 300 Construction and Real Estate version 9.6 or later installed on
the computer where your Pervasive SQL data is stored to perform data migration. You must also have a
copy of Sage 300 Construction and Real Estate version 9.6 or later installed on the local computer where
you are performing your data migration.

1 From the Estimating Management Console, click [Data Migration].
2 Select step 2—Settings in the Data Migration window.

3 Click SQL Server (left-hand pane) then select a destination Address Book and Estimate database for
your migrated data.

Click [Select] next to the Address Book Database or Estimate Database box to specify a database from
the current instance.
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Migrating Your Data

4 Click Pervasive (left-hand pane).

The Estimating Management Console performs an automatic check of your Pervasive databases and
verifies they meet data migration prerequisites.

The Estimating Management Console displays one or more error messages if prerequisites are not met.
Correct each error condition then try the verification process again by clicking [Reverify].

5 Click [Options] then select the Enable detailed logging check box if you want to generate detailed
entries in the migration event log.

Clear the Enable detailed logging check box to prevent detailed migration event logging.
NOTE: Enabling detail logging may cause the data migration process to perform slower.
6 Click step 3—Select Databases.

7 Click [Browse] and locate the path to the data folder where the Pervasive data you want to migrate is
located then click [OK].

The Data Migration window displays the selected folder path in the Starting folder box.

The Sage Estimating scans the selected folder for all Pervasive databases that are available for migration
and displays them in a list below the Starting folder box. If desired, you can click the arrow key to the right
of the [Browse] button and perform one of the following actions:

o Cancel scanning. The scan process can be lengthy, depending on the number and size of the files
within the selected folder. Select this option to stop the scan at any time.

o Rescan. Select this option to scan the selected folder again.

NOTE: The Estimating Management Console does not scan backup data folders (PEBackup folders). If
the Estimating Management Console is unable to locate certain Pervasive databases, the databases may
be residing in a PEBackup folder. Try renaming the PEBackup folders and restart the scan.

8 Select the check box for each Pervasive database in the list that you want to migrate.
You can select estimate, Address Book, and standard databases for migration.

NOTE: To preserve links between estimates and standard databases, Sage recommends migrating your
estimates concurrently with (or after) your standard databases. Migrating estimates before or separately
from their standard databases breaks any links with their associated standard databases and disables
certain editing functions in the spreadsheet.

9 Click [Migrate] to begin the migration process.

The migration process may take some time, depending on the size of the databases you are migrating. You
can view the status of the migration from the migration event log by clicking step 4—Event log.

If desired, you can also select other Pervasive databases for migration by repeating steps 1-9. Any
additional migration jobs you schedule are placed in a queue and performed in order.
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NOTES:

» Ensure you select the Queued check box at the top of the migration event log to see a list of pending
migration jobs in the queue.

« Do not attempt to access any of the databases you are migrating until the migration process is
finished; you cannot access a database while it is migrating.

10 Repeat steps 1-9 as necessary to migrate all Pervasive databases you want to use with Sage Estimating.
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If you are installing or upgrading Sage Estimating, and you already have a supported Microsoft® SQL Server®
installation on your computer or server, you can use the existing SQL Server install by setting up another
instance (database server).

For information about supported editions of Microsoft SQL Server, see “Supported Editions of SQL Server and
Other Applications” on page 5.

Setting Up a SQL Server Instance for Use With Sage
Estimating

If you have an existing instance of a supported version of Microsoft SQL Server installed, you can set up
another instance to work with Sage Estimating. (Options described in this section may vary slightly depending
on the edition you are installing.)

NOTE: If you choose to uninstall your existing instance first, reboot your server before reinstalling to
avoid problems with the new installation.

CAUTION: Do not change the owner of any databases in the Sage Estimating instance.

Set your new SQL Server instance to the settings as outlined in the following sections.
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Named Instance

Figure 6: Instance Configuration Settings
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You must use a named instance. You can give the instance any name you want; however, if you have
installed a previous version of Sage Estimating (such as version 11.2), give the new instance a different name
that is easily recognizable (such as SAGE_EST_14_11).

32 Sage Estimating



Setting Up a SQL Server Instance for Use With Sage Estimating

Authentication Mode

Figure 7: Authentication Mode Settings

% SQL Server 2008 R2 Setup = =[]
Database Engine Configuration

Specify Database Engine authentication security mode, administrators and data directories.

Setup Support Rules Account Provisioning | Data Directories | FILESTREAM

Installation Type

Product Key Specify the authentication mede and administraters for the Database Engine.
License Terms Authentication Mode

Setup Role () Windows authentication mode

Feature Selection B i . X o
. @ Mixed Mode (SQL Server authentication and Windows authentication)
Installation Rules

Instance Configuration Specify the password for the SQL Server system administrator (sa) account.

Disk Space Requirements Enter password: ssssssssnane

Server Configuration

1 . LLLLL I LI ]
Database Engine Configuration Cothimesiont |

Error Reporting Specify SQL Server administrators

Installation Confi tion Rul

nstallation Configuration Rules SQL Server
Ready to Install administrators have

unrestricted access to

Installation Progress :
the Database Engine.

Complete

Add Current User ] I Add... ] I Bemove ]

[ < Back ” Next > H G ” Help ]

The instance must support Mixed Mode authentication (Windows Authentication and SQL Server
Authentication). This means either Windows authentication or SQL Server authentication can be used to
access the database information.

When Windows authentication is used, the operator must have permissions to use SQL Server orbe a
member of a group that has those permissions. In Windows authentication mode, SQL Server validates the
account name and password using information from the Windows operating system.

When SQL Server authentication is used, the operator must have system administrator (sysadmin) rights in
SQL Server. SQL Server authentication is used for backwards compatibility and requires a strong password.

Collation Settings

Collation settings must be Latin1_General, case-sensitive, and accent-sensitive (Latin1_General_CS_
AS).

You can customize the collation settings during the server configuration portion of the SQL Server install. In
the SQL Server collation customization window, make the following selections:
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= Select the Windows collation designator and sort order option (instead of SQL collation, which is the
default)

= Latin1_General (for the collation designator)
= Case-sensitive
= Accent-sensitive

= Clear all other options

Assigning Database Permissions

Database permissions for SQL Server instances used with Sage Estimating are now set up using the
Security feature in the Estimating Management Console.

For more information on setting up SQL Server security for Sage Estimating, see “F. Set Up Roles and
Permissions” on page 20.
Setting the Firewall for Workgroups

If you are using SQL Server with a workgroup, you must set the firewall on the workgroup server to allow
workstation computers to connect to the instance.

NOTE: If you are using SQL Server on a domain-based server, you may still need to configure your
firewall to allow remote communication. Refer to the SQL Server Guide for instructions.

Firewall Settings (Windows Vista, Windows 2008 Server, Windows 7,
Windows 8, and Windows 8.1)

1 Open Windows Firewall (click Start > Control Panel > System and Security > Windows Firewall
> Advanced Settings, orin Windows 8 or Windows 8.1, click Start > Windows System > Control Panel
> System and Security > Windows Firewall > Advanced Settings).

2 Right-click on Inbound Rules and select New Rule.

3 Inthe Inbound Rule wizard, select Port and click [Next].

4 Select TCP and Specific local ports.

5 Inthe Specific local ports box, type 8005 then click [Next].

6 Select Allow the connection and click [Next].

7 Select the Domain, Private, and Public check boxes then click [Next].

8 Inthe Name box, type Sage Estimating Service (or other appropriate name) and click [Finish].

34 Sage Estimating



Additional Recommendations

Additional Recommendations

To ensure accurate performance, Sage strongly recommends making changes and verifications to the
following settings in SQL Server Management Studio and SQL Server Configuration Manager. Failure to make
these changes may result in poor Sage Estimating performance or communication difficulties between Sage
Estimating and your SQL Server instance.

Memory

Determine the amount of available memory on the server or workstation where SQL Server is installed. To
prevent SQL Server from consuming all available memory, use SQL Server Management Studio to set the
maximum amount of memory (in the instance properties) to a reasonable limit (such as 4 GB ) as follows:

1 Right-click on the SQL Server instance and select Properties.
2 Inthe Server Properties window, click Memory (left-hand pane).

3 Set the Maximum server memory amount to 4000 (or whatever limit you determine).

Communication Protocol
Set the communication protocol settings for the Sage Estimating SQL Server instance as follows:

1 Start the SQL Server Configuration Manager by selecting Start > All Programs > SQL Server 2008 (or
SQL Server 2008 R2) > Configuration Tools > SQL Server Configuration Manager.

In Windows 8, select Start > All apps > Microsoft SQL Server > SQL Server Management Studio.

2 Inthe left-hand pane of the SQL Server Configuration Manager window, click the arrow next to
SQL Server Network Configuration to display all local SQL Server instances.

3 Select the instance associated with Sage Estimating (SAGE_ESTIMATING, by default).
4 Inthe right-hand pane right-click on a communication protocol and select Disable.
5 Repeat step 4 for all communication protocols except TCP/IP. Leave this protocol Enabled.

6 Inthe left-hand pane of the SQL Server Configuration Manager window, click the arrow next to
SQL Native Client 10.0 Configuration.

7 Click Client Protocols (left-hand pane).
8 In the right-hand pane right-click on a communication protocol and select Disable.
9 Repeat step 8 for all communication protocols except TCP/IP. Leave this protocol Enabled.

10 Close the SQL Server Configuration Manager and restart the service.
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Copying Databases from Other Instances

Sage Estimating allows the use of just one active SQL Server instance at a time. This instance is a "closed"
SQL Server instance; Sage Estimating does not recognize databases (Address Book or standard databases)
transferred or copied from other SQL Server instances unless they are added by way of the Search For
feature in the Estimating Management Console.

For example, if you have two Sage Estimating installs, Install A and Install B, you cannot copy Address Book
databases by copying them from Install A's SQL Server instance to Install B's SQL Server instance alone
(using SQL Server Management Studio's built-in Copy Databases wizard, for example). You must also open

the Estimating Management Console and use the Search For # button in the Address Book
Companies/Contacts toolbar.

Figure 8: Copying Databases From One SQL Server Instance to Another
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Copying Databases from Other Instances

Any database you add to an instance must have the same Sage Estimating version as the other operating
databases. For example, if you are using Sage Estimating 14.12, and you want to add a standard database
from a previous Sage Estimating installation, upgrade the standard database to version 14.12 before adding it
to the new instance. Refer to the Estimating Management Console in-product Help for instructions on using
the Search For feature.

You can switch active SQL Server instances at any time for Sage Estimating by starting the Configuration
wizard, selecting Server from the left-hand pane, and clicking [Change] from the right-hand pane.
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