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Backup procedures 
Throughout this guide you are asked to back up and copy files. These copies are important: 

 To preserve an off-site copy in case of damage to your building. 

 To eliminate the need to re-key data in case of damage to your system. 

 To ensure that you have a copy of your files for reference before you close the current year. 
 

  
IMPORTANT! With any backup tool, we recommend that you validate and test the backup to 
ensure that the process is working properly. Environmental issues, data file sizes, and files in use 
can affect the integrity of a backup. Restoring your business data requires advanced knowledge 
of the Actian Pervasive, Microsoft SQL (if using), and Sage 300 Construction and Real Estate file 
systems. We strongly recommend you undertake this process with a knowledgeable professional, 
such as your business partner, certified consultant, or Sage Customer Service representative. 

Files to copy 
This section lists the file names to back up or copy in each application. 

 Be sure to show file extensions in Windows File Explorer to ensure proper operation. 

 These procedures use default file names (for example, Current.glt and History.glt). If you 
use named files, substitute your named files for the default names. 

 History files such as History.apt or History.glt are created when you select Tools > Move to 
move a file to history. For more information on moving files to history, see the topics on "File 
Maintenance" in each section of this book. 

 Be sure to include files in other locations as specified in Company Settings > File 
Locations. 

 Ensure your backups include the appropriate files for other applications and third-party 
software that interface with Sage 300 CRE. 

Refer to the Files to back up in each application list on the following pages when you are 
instructed to back up or copy files for a specific application. 
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NOTE:  The files in the Files to back up in each application list are the minimum required for 
reporting. However, additional files may be needed. When you back up your entire database, these 
files will be included. If you need to restore your Sage 300 Construction and Real Estate database, 
you should restore the backup of your entire database. 

Files to back up in each application 

  
NOTE: Files that can be named will have the same extension as those listed in the table above. For 
example, January.api would be a named Accounts Payable invoice file. To determine if named files 
are used, go to Company Settings > File Locations to look for file types where Ask Name is 
selected. 

 

Accounts Payable Accounts Receivable Billing 

Current.apt 

History.api 

History.apt 

Master.apm 

Master.txm (if using taxes) 

New.api 

Standard.aps 

Ts.ctl 

User.frm (in the Formula 
folder) 

Activity.ara 

Current.art 

History.ara 

History.art 

Master.arm 

Master.txm (if using taxes) 

New.art 

Standard.ars 

Ts.ctl 

User.frm (in the Formula 
folder) 

View.arv 

Billed.bli 

Billed.blw 

History.blt 

History.blw 

Master.blm 

Master.txm (if using taxes) 

New.blt 

Standard.bls 

Ts.ctl 

Unbilled.bli 

Unbilled.blw 

User.frm (in the Formula 
folder) 

 

Cash Management Contracts Equipment Cost 

History.cmt 

Master.cmm 

Master.txm (if using taxes) 

Register.cmt 

Ts.ctl 

User.frm (in the Formula 
folder) 

Contracts 

Active.cna 

Active.cnc 

Active.cnt 

Settings.cns 

Ts.ctl 

User.frm (in the Formula 
folder) 

Current.eqt 

History.eqt 

Master.eqm 

New.eqt 

Standard.eqs 

Ts.ctl 

User.frm (in the Formula 
folder) 

 

General Ledger Job Cost Payroll 

Current.glt 

History.glt 

Master.glm 

New.glt 

Ts.ctl 

Current.jct 

History.jct 

Master.jcm 

New.jct 

Ts.ctl 

Current.prt 

History.prt 

Master.prm 

New.prt 

Pr.frm (in the Formula folder) 
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User.frm (in the Formula 
folder) 

User.frm (in the Formula 
folder) 

System.prs 

Tax.prx 

Ts.ctl 

User.frm (in the Formula 
folder) 

 

Project Management Property Management 

Correspondence.pjc 

Document.pjd 

FieldReports.pjf 

Log.pjl 

Master.pjm 

View.pjv 

Accum.pma 

Current.pmt 

History.pmt 

Issue.pmz 

Lease.pml 

Master.txm (if using taxes) 

New.pmt 

Property.pmp 

Recovery.pmv 

Retail.pmr 

System.pms 

Tenant.pmn 

Ts.ctl 

User.frm (in the Formula 
folder) 

 

Data in other related data folders that you may want to back up include: 

 Purchasing and Inventory files, which are located in the POIVData folder under your company 
data folder. 

 Service Management files, which are located in the SMData folder under your company data 
folder. If you have SM files in a different location, note the location by selecting File > Data 
Folder Settings > File Locations > SM Data. 

 The files in these folders should not be backed up individually. It is necessary to include the 
entire folder when backing up Purchasing/Inventory and Service Management data files. 
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Backing up files using System Administrator 
We recommend that you use the backup operation in the System Administrator tool to back up your 
company data (including the Global, Service Management, Purchasing, and Inventory data) on a 
regular basis. See the Using System Administrator to back up and restore your data video for more 
information. 

 

  
NOTE: Although you can still use File Tools to back up and restore your company data stored in 
Pervasive, File Tools cannot back up and restore the SQL data.  

 

  
IMPORTANT! Perform the backup during off hours so that nobody is accessing or changing the 
data. If someone is using the software, some data files may be locked and the backup will fail. 

 To use System Administrator to back up data: 
1. On the server, access the tool by selecting the Sage Administration program group (from the 

Start menu) and then selecting System Administrator. 

2. Click the Backup tab. 

3. Your company folders are shown in a table. Select the Backup check box in front of the 
companies to include in the backup. 

If you have more than one company, we recommend that you back up all of them. 

4. In the Files column, select the type of files to back up: 

 All: Includes print files or other file types that were saved inside the company folder as well 
as the data files. 

 Data only: Only includes the Pervasive files and folders (not other file types such as .bmp 
and .txt files) inside the company's data folder. 

  
WARNING: The extended data files for large data files exceeding 2GB are not being included in 
the backup with the Data only option. Use the All files option instead. See the knowledgebase 
article titled System Administrator Backup tool excludes extended data files when the Data Only 
option is selected. 

 

  
NOTE: We recommend that you select All. The Sage\Timberline Office\9.5 folder is always 
included in the backup.  

5. If you need to add other folders or files to the backup, click [Add Folder] or [Add File] and 
then select the folder or file; it will be listed in the table. 

 

  
NOTE: You may want to include folders containing attachments that are not already in the data 
folders.  

6. Select the folder to store the backed-up data by either: 

 Typing the path. 

 Clicking [Browse] and selecting the folder. 

7. To schedule a time every day for an automatic backup, select the Automatically back up 
every day at check box, select the time, and click [Save]. 

https://support.na.sage.com/selfservice/viewdocument.do?externalID=85272
https://support.na.sage.com/selfservice/viewdocument.do?externalID=112037
https://support.na.sage.com/selfservice/viewdocument.do?externalID=112037
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TIP: The automatic backup selection creates a task in the Windows Task Scheduler. You may be 
able to use that tool to adjust the timing and days of the week to back up the data automatically. 

 

8. To back up your data immediately, click [Save] and then [Back Up Now]. 

When the backup runs, success and failure messages display on your screen. If there is a 
failure, click [View Log] to view the log file to determine the issue. 

The backup process creates a zip file named backup<DATE>_<TIME>.zip that contains: 

 The Pervasive data folders for the companies you selected in step 3 

 The SQL database (if your data was replicated) 

 The 9.5 folder (without Wininst) 

 Any additional folders or files that you selected in step 5 

 Log files with the backup information 

Backing up files using File Tools 
Although we recommend that you use the backup operation in the System Administrator, you can 
use File Tools to back up the entire Sage 300 Construction and Real Estate data folder or selected 
data files. 

Information about how to back up files using File Tools is also included in the knowledgebase 
article titled, How do I use File Tools to back up data files? 

 

  
NOTES: When you use File Tools, the folder options of Windows Explorer should be set to display 
file extensions.  

File Tools is not able to back up the extended data files for large data files exceeding 2GB.  Refer 
to the knowledgebase article titled, Error: "CP5 error Overflow for Zip.Add" (data file size exceeds 
2GB) for further information if you encounter this error. 

 To use File Tools to back up data: 
1. Open Sage Desktop and select Applications > Common Tools > Tools > File Tools. 

2. In the Operation Selection window, select Backup and click [Next]. 

3. In the Backup Operation window, select the folder or files you want to include. 

To back up an entire folder, click [Add Folder] and then select the folder that contains the 
files to be backed up. When you select a folder, all sub-folders are included. Use the down 
arrow at the right to open a list of available drives and folders. You can navigate to a higher 
folder on the same drive or change the search to another drive by selecting the applicable 
drive or folder. You can navigate one level upward by clicking the folder icon with the up 
arrow. Perform this step for each data folder you want included in the backup. 

To backup individual files, click [Add Files] and then select the files that you want to 
backup. Press and hold the CTRL key on your keyboard to select multiple files. To include 
Purchasing and Inventory and/or Service Management data after selecting the individual 
files, click [Add Folder] in the Backup Operations window, then browse to and select the 
POIVData and/or SMData folder that you want to backup. Each folder will need to be added 
separately. 
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NOTE: Purchasing and Inventory (POIVData) and Service Management (SMData) folders are 
automatically included in the company folder  backup if they are located inside the company data 
folder. However, if your SMData folder is in a different location, note the location by selecting File 
> Data Folder Settings > File Locations > SM Data. To back up the SMData folder when it is 
located outside your company data folder, click [Add folders] and choose the SMData folder 
located in the folder noted in File Locations 

To back up additional files (in folders that are not already selected), click [Add Files]. Select 
the files to be backed up by holding down the CTRL key and clicking each file to highlight it. 
You can highlight all files by pressing the CTRL + A keys. Click a file again to remove the 
selection highlight 

4. Click [Next]. 

5. For Destination, specify the name and location for the backup file or click [Browse] to locate 
the destination folder. 

6. For Archive Name, type the name of the new archive file you want to create. You can click 
[Append] to insert either a date and time stamp or to add a unique numeric value to the file. 
The .tsZip2 extension will be used if you do not enter an extension. 

 

  
NOTE: Be aware that if the .tsZip2 file you specify already exists, it will be overwritten by the new 
file.  

7. (Optional) For Comment, type a comment that will appear with this backup if the backup is 
restored. 

8. Click [Next] to begin the validation. 

9. When the Validation Summary window appears, click [Next]. 

10. When the Verify Files window appears, verify that the correct folders and files are included, 
and then click [Next]. 

11. When the Execution Summary window appears, verify that the process is correct, and then 
click [Next] to start the backup. 

12. When the Operation Journal window appears, review the processes that were performed, and 
then click [Save] to save the journal or click [Print] to print the journal. 

13. Click [Finish] to exit File Tools. 
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Copying files using File Tools 
You can also use File Tools to copy selected Sage 300 Construction and Real Estate data files to 
another location. These copies are meant to restore files immediately if a process does not finish 
successfully. They are not meant to replace your full backup. When you use File Tools, show file 
extensions to ensure proper operation. 

 To use File Tools to copy files: 
1. Open Sage Desktop and select Applications > Common Tools > Tools > File Tools. 

2. In the Operation Selection window, select Copy and click [Next]. 

3. To copy your entire data folder, click [Add Folder] then select the folder that contains the 
files to be copied. Use the down arrow at the right to open a list of available drives and folders. 
You can then navigate to a higher folder on the same drive or change the search to another 
drive by selecting the applicable drive or folder. You can navigate one level upward by 
clicking the folder icon with the up arrow. 

4. To copy individual files, click [Add Files] to open the list of files eligible for copying; then 
select the files to be copied by holding down the CTRL key and clicking each file to highlight 
it. To remove a highlight, click the file again. You can highlight all files by pressing the CTRL + 
A keys. 

5. For Destination, specify the full path where files will be copied or click [Browse] to locate the 
destination folder. If you are copying to a CD, choose the CD drive as the destination folder. 

6. Click [Next]. 

7. If any of the files being copied already exist in the destination location, a warning will appear 
for each one. Select one of the following options for each warning: 

 [Yes]: Overwrite the file named in the warning. 

 [Yes to All]: Overwrite this file and any additional files that already exist and have 
duplicate names of those being copied. No more warnings will appear. 

 [No]: Do not overwrite; remove this file from the list to be copied. 

 [No to All]: Do not overwrite this file or any additional files that already exist and have 
duplicate names of those being copied. No more warnings will appear. 

As the files are copied, the status is shown in the Progress window. If the validation process 
finds issues that need to be resolved, the wizard will instruct you how to fix them. 

 

  
NOTE: If you click [Back] before an operation is complete, the program returns to the previous 
window without completing the operation. If you click [Cancel], you cancel any further 
operations and exit File Tools; if any previous operations were already completed successfully, 
they are not canceled.  

When the copy operation is complete for all files, review the processes that were performed, 
and then click [Save] to save the journal or click [Print] to print the journal. 

8. Click [Finish] to exit File Tools. 
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