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Section 1

System Guidance

General

Thisdocument provides detail ed information about system and environment considerations
to ensure your network isready to install Residential Management. You will also find what
you need to prepare before you install. This document is specific to Residential

M anagement requirements. For information about environment and installation
considerations for Sage 300 Construction and Real Estate, refer to the Sage 300
Construction and Real Estate Installation Guide, available in your Accounting and
Management installation files at \Documents\InstallationGuide.pdf.

Develop a Plan to Back Up Files

We strongly recommend that you use third-party software to back up all Sage 300
Construction and Real Estate and Residential Management data files to external mediaon
adaily basis.

Consider the following as you develop your backup plan:
= Use third-party backup software for all backups.

= Verify that when afolder isincluded in a backup, the backup software also includes the
subfolders. In other words, the backup software should support recursive backups.

= Schedule backup during off-peak hours, since al users must close Residential
Management before you back up files.
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= Always back up both the .mdf and .Idf Residential Management database files.

= Review where you store the Residential Management data and back up all data, even if
it isoutside default folders.

= Store backup mediain a secure location outside your building.

= Test backups by restoring them to test folders. These tests are important because backup
media may have alimited life, backup devices may malfunction, and you may have
incorrect software settings in your backup software.

WARNING: When you test a backup, keep the restored data separate from your production data.

Creating a Backup of Residential Management data

We recommend two backup software packages that you can purchase to back up your
Residential Management data nightly:

= VERITAS® Backup Exec for Windows Servers
= Brightstor® ARCserve for Windows

You can purchase an add-on modulefor either of these backup applicationsto back up SQL
database files. The add-on module you purchase processes a batch file that stops the SQL
server, alows the backup system to back up the specified files, and starts the SQL server.
A low cost alternative to purchasing the add-on module is to write a batch file and allow
the backup application to run the batch file prior to backing up the Residential M anagement
database files.

Follow the steps below to create text files with instructions for stopping and starting the
SQL server:

1 Create two text files using a text editor such as Notepad or WordPad. For example, you
can name one file Stop.bat and name the other file Start.bat.

2 Add the following lines to the Stop.bat file:
Net stop mssgl$sagerm
net stop sglserveragent

3 Add thefollowing lines to the Start.bat file:
Net start mssgl$sager m

net start sglserveragent

4 Schedule your backup system to run the Stop.bat file, back up your Residential
Management datafiles, and then run the Start.bat file.
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NOTE: You can aso manually enter the commands in steps 2 and 3 above at acommand prompt
(from the Windows Start menu, select Run and enter cmd).

Assign Full-Control User Rightsto All Folders That Contain Sage 300
Construction and Real Estate Application Data Files and Sage 300
Construction and Real Estate Data Files

Assign full-control user rightsto all foldersthat contain Pervasive program files, Sage 300
Construction and Real Estate program files, Sage 300 Construction and Real Estate data
files, Residential Management program files, and Residential Management SQL database
files. To use Sage 300 Construction and Real Estate and Residential Management, users
must have full control of the following files and folders on the files server, terminal server,
and workstations that have Sage 300 Construction and Real Estate and Residential
Management installed.

WARNING: Incorrectly modifying Microsoft Windows security may severely affect your system
operations. Sage Softwareisnot responsiblefor operation problems caused by incorrectly modifying
your Microsoft Windows security settings. To set permissions on your network or Windows
operating system, you must have advanced knowledge of your network. Contact your system
administrator for assistance.

= [Drive]:\Program Files\Timberline Office folder: Thisfolder islocated on thefile
server, terminal server, and workstations where you installed Sage 300 Construction and
Real Edtate. It isthe default installation location for Sage 300 Construction and Real
Estate. However, depending on your system configuration, your company may have
renamed thisfolder or installed it to a different location.

= [Drive]:\Documentsand Settings\[username] folder (Windows XP, Windows Server
2003, and earlier): Thisfolder islocated on the workstation or terminal server where
you use Sage 300 Construction and Real Estate. Sage 300 Construction and Real Estate
installs necessary files to this folder and requires that the user has full control of it.
Typically, the user has full control of this folder by default.

= [Drive]:\Users\[User name] folder (Windows Vista, Windows 2008 Server, and
Windows 7): Thisfolder islocated on the workstation or terminal server where you use
Sage 300 Construction and Real Estate. Sage 300 Construction and Real Estate installs
necessary filesto thisfolder and requiresthat the user hasfull control of it. Typically, the
user has full control of thisfolder by default.
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= [Drive]:\Documents and Settings\All Users\Application Data\Sage\Timberline
Office (Windows XP, Windows Server 2003, and earlier): Thisfolder islocated onthe
server and on any workstations or terminal server where you install Sage 300
Construction and Real Estate Accounting & Management programs. Thisfolder must be
shared on the server. Sage 300 Construction and Real Estate installs necessary filesto
thisfolder and requiresthat all users have read/write permissions to the folder and all of
its subfolders. This folder may also be hidden. To view hidden folders, open Windows
Explorer, select Tools > Folder Options, and select the View hidden filesand folders
check box on the View tab.

= [Drive]:\ProgramData\Sage\Timberline Office (Windows Vista, Windows 2008
Server, and Windows 7): Thisfolder islocated on the workstation or terminal server
where you use Sage 300 Construction and Real Estate Accounting & Management
programs. If you are using aworkstation as a peer-to-peer server, the folder must also be
shared. Sage 300 Construction and Real Estate installs necessary files to this folder and
requiresthat all users have read/write permissionsto thisfolder and all of its subfolders.
Thisfolder may be hidden by default. To view hidden folders, open Windows Explorer,
select Tools> Folder Options, and select the View hidden filesand folder s check box
on the View tab.

= Company datafolder (Accounting): Typically, the data folder islocated on the file
server where you installed Accounting and Management Products.

= Database and estimates (Estimating): Typicaly, these files are located at both the file
server and the workstation where you installed Estimating Products.

= Pervasiveinstallation folder: By default, Pervasive installs to C:\Pvsw on the file
server, terminal server, and workstations where you installed Sage 300 Construction and
Real Estate.

= Windows system folder: Typically, the Windows system folder islocated at
C:\Windows or C:\Winnt on your workstation. If your system administrator does not
want to give you full control of the local Windows system folder, ask for full control of
just the Dbnames.cfg file and Pvsw.log file in the Windows system folder.

[Drive:]\RM: Thisfolder islocated on thefile server, terminal server, and workstations
where you installed Residential Management. It is the default installation location for
Residential Management. However, depending on your system configuration, your
company may have renamed this folder or installed it to a different location.

NOTE: Each Residential Management user must have at least power user rights on the network for
access to the Sage 300 Construction and Real Estate directory, including all subfoldersand all files,
on the server where Termina Servicesisinstalled and the file server.
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Comply With Windows User Account Control (UAC) Requirements

The critical program files are being installed in the normal installation location (the
Program Filesfolder by default), while dataand all other files are being installed to a
shared |ocation. For Sage 300 Construction and Real Estate applicationsto work correctly,
you must ensure you have read/write permissions to these files. For new installations of
Sage 300 Construction and Real Estate Accounting & Management on Windows Vista,
Windows 2008 Server, or Windows 7 operating systems, these datafilesare being installed
in the [Drive] :\ProgramData\Sage\Timberline Office folder. For new installations on
Windows XP or Windows Server 2003 and earlier operating systems, these files are being
installed in the [Drive]:\Documents and Settings\All Users\Application
Data\Sage\Timberline Office folder.

If you are upgrading Sage 300 Construction and Real Estate Accounting & Management
applications, your data folders will not be moved automatically. You do not need to move
your data; however, if you install Windows Vista, Windows 2008 Server, or Windows 7 and
your dataisnot in ashared location, you need to share the datafolders and assign read/write
permissions, or you must move the folders to a shared location and assign read/write
permissions. If you move your datafiles, ensureyou update their locations using File Tools.

NOTE: Some of these folders are hidden in their new location. To view them, open Windows
Explorer, select Tools > Folder Options, and select the View hidden files and folder s check box
on the View tab.

In compliance with UAC requirements, you cannot save afile to afolder to which you do
not have read/writer permissions assigned. If such an attempt is made, Windows security
diverts your datato acopy of the datafile or report and associates the copy with your user
profile, thereby possibly compromising the integrity of your application. To prevent this,
Sage 300 Construction and Real Estate applications present you with an error message if
you try to save afile to such alocation.
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Frequently Asked Questions

Overview

These are some of the frequently asked questions concerning Residential Management. For
more information on installing or upgrading Residential Management, refer to the
Installation Guide, available in your Residential Management installation files at
\Documents\I nstall ationGuideResM gmt.pdf .

What if noserversarelisted in the Select Server window when | start
Residential M anagement?

SQL Servicesare running on the local workstation

When you install Residential Management in aLoca AreaNetwork (LAN) environment,
you must also install SQL Services (SQL Server 2005 or SQL Server 2005 Express) and
Residential Management on the local workstations. To connect to the server’s SQL service,
the service must not be running on the workstation.

Verify that SQL Services on the workstation are stopped:

1 Ontheworkstation, select [Start] > All Programs > Microsoft SQL Server 2005 >
Configuration Tools> SQL Server Service Manager.

2 Inthe SQL Server Service Manager window, select SQL Server 2005 Services > SQL
Server (SAGECRE).



Frequently Asked Questions

8

3 Right-click SQL Server (SAGECRE) and select Stop.

4 Closethe SQL Server Service Manager window.

A port isblocked by thefirewall

By default, ports 1433 and 1434 are reserved for SQL Services. If either of these two ports
isblocked, the SQL Services (SQL Server 2005 or SQL Server 2005 Express) on the
workstation cannot communicate with SQL Services on the server. If you manually
assigned different ports for SQL Services, verify that those ports are not blocked or being
used by adifferent service.

Verify that the workstation is communicating with the server:
1 Ping the server from the workstation:

a From the Windows Start menu, select Run.

b Inthe Open box, type cmd.

¢ Click [OK].

d At the command prompt, type ping and the name of the server you want to
communicate with. Leave a space between the word ping and the computer name.

e PressENTER.

A successful ping returnsaset of four reply packetswith the | P address. An unsuccessful
ping will return a note that the host is unknown, or will hang followed by a message that
the connection timed out.

2 If theworkstation is communicating successfully with the server, the server IP addressis
returned. For example, the IP address might be 172.72.242.50.

3 If the test fails, the server is not configured correctly to alow workstations to
communicate with it. Contact your systems administrator.

For moreinformation about how to use static and dynamic port alocation with SQL Server,
refer to articles 823938, 287932, and 293107 in Microsoft's Knowledge Base.

1 Open http://support.microsoft.com in your browser.

2 Search for the article number.

3 Follow theinstructionsin Microsoft's Knowledge Base article.
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How do | troubleshoot problemsthat occur when | start Sage 300
Construction and Real Estate?

Search the Knowledgebase. To access the Knowledgebase, open the Sage Customer Portal
at https://customers.sagenorthamerica.com/irj/portal/anonymous/login. See” Online Help”
on page 20 for instructions for registering and logging on. After you log on to the Sage
Customer Portal, type a question for a specific issue in the Knowledgebase Search box.

How do | end a Terminal Services session that has stopped responding?

Use Terminal Services Manager on the server to end sessions

NOTES:

= This solution includes information or procedures for a non-Sage 300 Construction and
Real Estate product. Although we provide steps to solve the issue, we cannot guarantee
them. Please refer to the documentation you received with the software or technical
support for the product for detailed instructions.

= Contact your system administrator if you are not comfortable following the steps below.
If your Terminal Services session stops responding, end the session as follows:

1 Onthe server where Terminal Servicesisinstaled, click [Start] and then click Settings
> Control Panel.

2 Select Administrative Tools.
3 Select Terminal Services Manager.

4 Right-click the operator whose session stopped responding, and select Disconnect.

NOTE: Thisisequivalent to ending atask using CTRL+ALT+DEL.
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Prerequisite Software

Residential Management needs to have the following third-party componentsinstalled at
the beginning of the Residential Management installation.

Description of Third-Party Components

Microsoft SQL Server 2005 Express

Microsoft SQL Server 2005 Express provides access to Residential Management
databases. Thisversion is available in the Residential Management installation files.
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Compatibility Testing

Thefollowing tables list the software that Sage 300 Construction and Real Estate’s quality
assurance department tests with Sage 300 Construction and Real Estate.

For more information about Sage 300 Construction and Real Estate requirements, see the
Installation Guide. It islocated in your Accounting and Management installation files at
\Documents\I nstallationGuide.pdf.

Servers

We test Windows Server 2003 Standard Edition, Windows Server 2003 Enterprise Edition,
and Windows Small Business Server 2003 with Sage 300 Construction and Real Estate. In
this document, unless noted otherwise, the term “Windows Server 2003" refersto all three
editions of this operating system.

Microsoft Windows Server 2003 R2 has been tested for compatibility with Residential
Management and we are able to support its use.

Operating Systems Service Pack Other

Windows 2008 Server (withand | Service Pack 2
without Terminal Services. For
Standard, with Terminal Services
and Citrix XP)

T
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Operating Systems

Service Pack

Other

Windows Server 2003 (with and
without Terminal Services. For
Standard, with Terminal Services
and Citrix XP)

Service Pack 2

Peer to Peer

In addition, we test Palm OS versions 3.x, 4.0, and 4.1 with Accounting and Management

Products.

Workstations

We support workstation, stand-alone, and peer-to-peer operating systems.

Operating Systems Service Pack Other

Windows 7 Professional, Service Pack 1

Ultimate, and Enterprise

Windows Vista Business and Service Pack 2 Microsoft DirectX 9.0,

Ultimate Microsoft Windows Installer
31

Windows XP Professional Service Pack 3 Microsoft DirectX 9.0,

Microsoft Windows Installer
31

Other Software

We test the following additional software with Sage 300 Construction and Real Estate.

Other

Service Pack or Update

Crystal Reports® 11 for Sage

Asingtalled from Sage 300
Construction and Real Estate
installation files

Internet Explorer 6.0

Service Pack 1

Microsoft .NET Framework 2.0

Asinstalled from Sage 300
Construction and Real Estate
installation files

Microsoft Data Access Components (MDAC) 2.7

Asingtalled from Sage 300
Construction and Real Estate
installation files




Other

Service Pack or Update

Microsoft Office 2002, and 2003

For Office 2003, Service
Pack 2

Symantec® Winfax 10.03

For Windows XP with
Service Pack 2, 10.04 Update

UniMessage Pro 1.0

SQL Server 2005 Express and SQL Server 2005

For SQL Server 2005,
Service Pack 2

Section 4
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Migrating Residential M anagement

Microsoft Installer and Residential M anagement

Moving Residential Management to a New Server Location

WARNING: Incorrectly moving Residential Management databases may severely damage your
system. Sage Software isnot responsible for damageto your data caused by incorrectly moving your
Sage 300 Construction and Real Estate data folders or Residential Management databases. Before
making changes to your Sage 300 Construction and Real Estate or Residential Management data,
contact your system administrator for assistance and make a backup copy of all valued data.

The default location for the Residential Management database is the SQL directory. For
example, C:\MSSQL\Data. You can create a new data directory using Windows Explorer
and use the Database Installer in your Residential Management installation files to detach
and reattach the database to your SQL server.

NOTE: If you are moving the data to a different server, refer to the section “Moving Residential
Management datato a New Host or Server” on page 18.

Follow these steps to move your Residential Management database to a different location
on your server:

1 Haveall operators exit Residential Management.

16
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2 Back up your database files. For example, if your database is called SunriseProp, make
a backup of the SunriseProp.mdf and SunriseProp_log.Idf files.

3 UseWindowsExplorer to create anew datadirectory. For example, F\RMData\Data (F:\
represents the drive on your server).

4 Usethe Database Installer to detach your database:

a Inthefolder where your RM installation files are stored, browse to and double-click
RM Database.exe (\RM Database\RM Database.exe) to open the RM Data
Installation window.

b Inthe RM Data Installation window, type your Database Name in the box. For
example, SunriseProp.

¢ Click [Detach] to detach your database.
d Inthe Database I nstaller window, click [OK] to detach the database.

e IntheLogin Information window, in the L ogin field, type your SQL login ID and
password, and click [Accept]. A password is required only if you set one up for this
login ID.

f After the detach is complete, click [OK]. Minimize the RM Data I nstallation
window.

5 Use Windows Explorer to cut and paste your SunriseProp.mdf and SunriseProp_log.Idf
filesfrom C:\MSSQL\Datato F:\RMData\Data (F:\ represents the drive on your server).

6 Maximize the RM Data | nstallation window to attach your database:
a Fromthe Data Drivelist, select the F drive.

b Typethenew directory inthe Data Directory box. For example, if your new directory
is F\RMData\Data, type \RM Data.

c Click [Attach].
d Inthe Database I nstaller window, click [OK].

e IntheLogin Information window in the Login field, type your SQL login ID and
password and click [Accept].

f After the attach is complete, click [OK] and then click [Exit].

7 You should now be able to use Residential Management.



Migrating Residential Management

18

Moving Residential Management datato a New Host or Server

When you move Residential Management to a new server, you must move the Sage 300
Construction and Real Estate program folder and data folders. You will need the
Accounting and Management Products installation files that you are using currently to
install components, such asthe Pervasive database engine, at the new server. Do not install
anewer version of Accounting and Management Products until after you have moved and
tested Sage 300 Construction and Real Estate at the new server.

For information on how to move Accounting and Management products, refer to the Sage
300 Construction and Real Estate Installation Guide, available in your Accounting and
Management installation files at \Documents\installationGuide.pdf.

1 Verify that no operators are using Residential Management on the old server.
2 Onthe new server:

a Install the same version of Residential Management that is currently installed on the
old server.

b Download or copy the new Residential Management installation filesto the new server
in accordance with the instructions provided in the download software notice.

¢ Intheresulting RM installation folder, browse to and double-click RM Database.exe
(\RM Database\RM Database.exe) to open the RM Data I nstallation window.

d IntheRM Datalnstallation window, click [Creat€] to create the RM Demo database
as usual and prepare the database engine for your data from the old server.

3 Ontheold server:

a Click [Start] and select Settings > Control Panel > Administrative Tools >
Services.

b Right-click MSSQL or M SSQL Server and select Sop.

c Using Windows Explorer, browse to your SQL data directory (for example,
C:\MSSQL\Data) and copy the .mdf and .Idf files associated with your Residential
Management database to the SQL data directory on the new server. For example, if
your database is called SunriseProp, copy SunriseProp.mdf and SunriseProp_log.Idf
to the new server.

d Close the Services window.
4 Onthe new server:
a Click [Sart] and select Run.

b Click [Browse]. Browse to your RM installation folder and double-click
RM Database.exe (\RM Database\RM Database.exe) then click [Open].
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¢ Inthe RM Data I nstallation window, type your Database Name in the box. For
example, if your .mdf fileis called SunriseProp.mdf, your database nameis
SunriseProp.

d Click [Attach] to attach your database as usual.
e Click [Exit] to closethe RM Data I nstallation window.

f You should now be able to start Residential Management. Select the SQL Server
(usually (local)), and select your database.

You may need to run ResetRegistry.vbs (located in your RM folder) to view the new
server so that you can select it.

NOTE: If you have any custom Residential Management reports, copy them from the old server to
the same location on the new server.
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Further Assistance

Online Help

Each Sage 300 Construction and Real Estate module includes online help, which provides
answers to your questions about procedures as well asitemsin the windows.

To access the online help in the Sage 300 Construction and Real Estate software:

* Inawindow, click the Help button or icon, or press[F1] to display the help topic for that
window.

* In the Desktop, select Help > Search for help on, and then choose the desired module.

To aid you in finding the information you need, the online help for each module includes
the following panes:

o Contents pane containing links to the help topics
o |ndex pane containing keywords that link to help topics related to that keyword

o Search pane, where you can type text and click [Search] to locate that text in the help
topics

For more information about using the online help, see the Sage 300 Construction and Real
Estate Desktop help (in the Desktop, select Help > Sage 300 Construction and Real
Estate Desktop Help). Wewould like your feedback about the online help so we can make
improvements.

B2
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Each help topic contains an areawhere you can indicate whether the topic was helpful and
provide additional comments. To protect your privacy, al comments are anonymous.

Training

Sage University offers online and classroom training sessions to help you get the most out
of your Sage 300 Construction and Real Estate software. To access Sage University, from
the Sage 300 Construction and Real Estate Desktop, select visit www.sageu.com. You can
also get accessto Sage University from the Sage 300 Construction and Real Estate Desktop
from Help > Sage 300 Construction and Real Estate on the Web > Sage Software
University.

Contact Customer Support

Depending on your Sage Service Plan, you may be able to take advantage of the following
services:

Sage Customer Portal

You may log on to the Sage Customer Portal at https.//customers.sagenorthamerica.com/irj/
portal/anonymous/login to access any of the following services:

= Knowledgebase: Find answersto your guestions, access downloads, and subscribe to
your favorite articles. This serviceis available online 24/7.

= Live Chat: Chat online with a customer support analyst - a great option for quick
guestions. Chat hours are the same as our telephone support hours.

= Online Support Request: Submit an online support ticket when you have a non-urgent
guestion. One of our call center support analystswill assist you. Online support hoursare
the same as our customer support call center hours.

Sage Customer Support Call Center

Telephone Support: When you have a more urgent question or would prefer to speak to a
customer support analyst directly, call us at 800-551-8307. Telephone support is available
Monday through Friday from 6 am. to 5 p.m. Pacific time with the following exceptions:

= Every Thursday from 2 p.m. to 3 p.m. Pacific time (closed for customer support staff
meetings)

= Standard United States holidays



Further Assistance

22

= Quarterly company meetings

Upgrading Your Service Plan

If your service plan does not provide online or telephone customer support and you would
like to add or upgrade a service plan, please call 800-858-7098.
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