
Sage 100 2017
Upgrade Checklist

October 2016



© 2016 The Sage Group plc or its licensors. All rights reserved. Sage, Sage logos, and Sage product and 
service names mentioned herein are the trademarks of The Sage Group plc or its licensors. All other 
trademarks are the property of their respective owners. 

Business Objects® and the Business Objects logo, BusinessObjects®, and Crystal Reports® are 
trademarks or registered trademarks of Business Objects Software Ltd. in the United Sates and in other 
countries. Business Objects is an SAP company.

Microsoft® and Microsoft SQL Server® are either registered trademarks or trademarks of the Microsoft 
Corporation in the United States and/or in other countries.

The names of all other products and services are property of their respective owners.



2017 Upgrade Checklist
Checklists
Appendix A
Appendix B

The upgrade process consists of three steps:

1 Preparing your data for upgrading

2 Upgrading your data to version 2017

3 Converting your data to version 2017

This appendix contains the information you will need to upgrade and convert your 
data based on the version of your data. Proceed to the applicable section as follows:

 Upgrading from Version 2016 to Version 2017 on page 2

 Upgrading from Version 2015 to Version 2017 on page 8

 Upgrading from Version 2014 to Version 2017 on page 14

 Upgrading from Version 2013 to Version 2017 on page 20

 Upgrading from Version 4.50 to Version 2017 on page 26

 Upgrading from Version 4.45 to Sage 100 Premium Version 2017 on page 32

 Upgrading from Version 4.40 to Version 2017 on page 37

 Upgrading from Version 4.30 to Version 2017 on page 43

 Upgrading from Version 4.20 to Version 2017 on page 50

 Upgrading from Version 4.10 to Version 2017 on page 58

 Upgrading from Version 4.00 or 4.05 to Version 2017 on page 65
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Upgrading from Version 2016 to Version 2017
Upgrading from Version 2016 to Version 2017

When upgrading to version 2017, you must perform a parallel installation. Use the 
Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to 
upgrade your data. For more information, consult with your Sage business partner. 

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 2016 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ Create a backup of your version 2016 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

4____ If you use the Purchase Order module, you will have the option to start 
retaining purchase order history and to create history using records in your 
Purchase Order data entry files. 

If you plan to create history, consider running the following utilities to clear 
out records that you do not want to include:

 Purge Completed Purchase Orders

 Purge Obsolete Purchase Orders 

For more information on the utilities, see the help system.

5____ Rebuild all data files. 

 If you are upgrading from Sage 100 Standard or Advanced, use the 
Rebuild Key Files and Rebuild Sort File utilities.

 If you are upgrading from Sage 100 Premium, use the Rebuild Sort File 
utility.

You must answer Yes to all recalculation questions.

6____ Print all customized form definitions.

       NOTE  
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 
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Upgrading from Version 2016 to Version 2017
7____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

8____ If you are upgrading Sage 100 Premium, configure your firewall to allow 
access to port number 1433 on the server with your version 2016 
installation. Port 1433 is the default SQL Server port. 

Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 2, you are now ready to migrate 
your data to your version 2017 system.

1____ If you are upgrading Sage 100 Standard or Advanced, select Library Master 
Utilities menu > Parallel Migration. Follow the steps in the wizard to migrate 
your data. 

If you are upgrading Sage 100 Premium, start the Parallel Migration Wizard 
using one of the methods below, and follow the steps in the Wizard.

 If you are using Windows Server 2008, start the Parallel Migration 
Wizard from the Sage program group on the Start menu.

 If you are using Windows Server 2012, start the Parallel Migration 
Wizard from the Start window.

The Migration Wizard will back up the Sage 100 SQL databases for your 
prior version of Sage 100, copy the backup files to the server where the 
Sage 100 2017 SQL Server instance is installed, and then restore them in 
the new location. Administrative rights are required for both your prior 
version of Sage 100 and for version 2017. The person running the Migration 
Wizard must have rights to the following administrative share: 
\\{sourceserver-name}\c$ 

If local security settings prevent the wizard from migrating the databases, 
use SQL Server Management Studio to back up the MAS_System and 
company databases that you want to migrate. Then copy the .BAK files to 
the ..\MSSQL\Data folder on the server where the Sage 100 2017 SQL 
Server instance is installed.

2____ After the migration is complete, log into Sage 100 2017 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

3____ Review security tasks for new features in version 2017. Review ODBC 
security if it is used.

4____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

5____ If you customized your Desktop, review the customizations on the Custom 
toolbar. 

WARNING  
If you are 
migrating data for 
Sage 100 
Premium, you 
must have 
administrator 
rights for the 
server with the 
installation you are 
migrating from and 
the server with 
your version 2017 
installation.
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Upgrading from Version 2016 to Version 2017
Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 2 and the Upgrade 
Checklist on page 3, you are now ready to convert your data to version 2017.

1____ If your company data contains credit card information, verify that the 
workstation you are using has a working Internet connection to 
automatically install the Sage Exchange Desktop and transfer credit card 
records to a Sage Exchange Vault account during conversion. Credit card 
records must be transferred to a Sage Exchange Vault account before 
company data can be converted.

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2017. This must be done for each of your companies. 

If the Purchase Order module is set up for a company, a window with 
options for retaining purchase order history appears. You can set up the 
feature and create history during data conversion or you can do so at a later 
time.   

3____ If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

4____ If your system is integrated with Sage CRM, go into CRM Server Options, 
and update the following information as needed. 

 Integration server port ID

 Sage CRM SQL server name

 Sage CRM SQL database name

The server name and database name should reference the mirror 
installation that you created for integration with Sage 100 2017. For more 
information on this process, refer to the Installing Sage CRM chapter in the 
Sage 100 Installation and System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

5____ If you synchronize payroll data between Sage Payroll Services and your 
general ledger, contact Sage Payroll Services Support for assistance with 
resetting the link for your Sage 100 company. 

You must complete this step before you can synchronize payroll data. This 
applies only if Sage Payroll Services is selected in the Payroll Service field 
in Sage Payroll Services Options. 

6____  Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields.  
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Upgrading from Version 2016 to Version 2017
7____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.

8____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.

9____ Review your Payroll Tax Tables. Installing the Payroll Tax Table Update 
replaces all of your current state and federal tax tables with new tables 
unless you have specifically excluded a state tax table from the update by 
selecting the Exclude this Table from Tax Update check box in Tax Table 
Maintenance. Local tax information is not updated. 

10____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2017. 

To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

11____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

12____ If you use Sage Intelligence Reporting, create a new repository for use with 
Sage 100 2017 and import any custom reports into it. For detailed 
instructions, see Upgrading Sage Intelligence Reporting on page 72.

13____ If dictionary changes were made to any files used for import and export jobs 
created in the Visual Integrator module, those jobs will need to be manually 
updated for modules other than Job Cost, Payroll, Material Requirements 
Planning, TimeCard, and Work Order.

       NOTE  
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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Upgrading from Version 2016 to Version 2017
To determine if manual updates are required, review the associated file 
layout information using the File Layouts and Program Information link on 
the Resources page of the Desktop. If you are upgrading from 
Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary 
Listing accessed from the Visual Integrator Main menu. Verify that the 
imported field names are consistent with the new file layouts.

14____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

15____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

16____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

17____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.

18____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

19____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

20____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

21____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

22____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

23____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

24____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records.  To run the utility, select Library Master > Utilities > Build Search 
Index.
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Upgrading from Version 2016 to Version 2017
25____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

For information on what is new in this release, see the What’s New chapter in the 
Sage 100 2017 Customer Upgrade Guide. 
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Upgrading from Version 2015 to Version 2017
Upgrading from Version 2015 to Version 2017

When upgrading to version 2017, you must perform a parallel installation. Use the 
Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to 
upgrade your data. For more information, consult with your Sage business partner. 

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 2015 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ Create a backup of your version 2015 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

4____ If you use the Purchase Order module, you will have the option to start 
retaining purchase order history and to create history using records in your 
Purchase Order data entry files. 

If you plan to create history, consider running the following utilities to clear 
out records that you do not want to include:

 Purge Completed Purchase Orders

 Purge Obsolete Purchase Orders 

For more information on the utilities, see the help system.

5____ Rebuild all data files. 

 If you are upgrading from Sage 100 Standard or Advanced, use the 
Rebuild Key Files and Rebuild Sort File utilities.

 If you are upgrading from Sage 100 Premium, use the Rebuild Sort File 
utility.

You must answer Yes to all recalculation questions.

6____ Print all customized form definitions.

       NOTE  
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 
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Upgrading from Version 2015 to Version 2017
7____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

8____ If you are upgrading Sage 100 Premium, configure your firewall to allow 
access to port number 1433 on the server with your version 2015 
installation. Port 1433 is the default SQL Server port. 

Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 8, you are now ready to migrate 
your data to your version 2017 system.

1____ If you are upgrading Sage 100 Standard or Advanced, select Library Master 
Utilities menu > Parallel Migration. Follow the steps in the wizard to migrate 
your data. 

If you are upgrading Sage 100 Premium, start the Parallel Migration Wizard 
using one of the methods below, and follow the steps in the Wizard.

 If you are using Windows Server 2008, start the Parallel Migration 
Wizard from the Sage program group on the Start menu.

 If you are using Windows Server 2012, start the Parallel Migration 
Wizard from the Start window.

The Migration Wizard will back up the Sage 100 SQL databases for your 
prior version of Sage 100, copy the backup files to the server where the 
Sage 100 2017 SQL Server instance is installed, and then restore them in 
the new location. Administrative rights are required for both your prior 
version of Sage 100 and for version 2017. The person running the Migration 
Wizard must have rights to the following administrative share: 
\\{sourceserver-name}\c$ 

If local security settings prevent the wizard from migrating the databases, 
use SQL Server Management Studio to back up the MAS_System and 
company databases that you want to migrate. Then copy the .BAK files to 
the ..\MSSQL\Data folder on the server where the Sage 100 2017 SQL 
Server instance is installed.

2____ After the migration is complete, log into Sage 100 2017 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

3____ Review security tasks for new features in version 2017. Review ODBC 
security if it is used.

4____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

5____ If you customized your Desktop, review the customizations on the Custom 
toolbar. 

WARNING  
If you are 
migrating data for 
Sage 100 
Premium, you 
must have 
administrator 
rights for the 
server with the 
installation you are 
migrating from and 
the server with 
your version 2017 
installation.
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Upgrading from Version 2015 to Version 2017
Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 8 and the Upgrade 
Checklist on page 9, you are now ready to convert your data to version 2017.

1____ If your company data contains credit card information, verify that the 
workstation you are using has a working Internet connection to 
automatically install the Sage Exchange Desktop and transfer credit card 
records to a Sage Exchange Vault account during conversion. Credit card 
records must be transferred to a Sage Exchange Vault account before 
company data can be converted.

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2017. This must be done for each of your companies. 

If the Purchase Order module is set up for a company, a window with 
options for retaining purchase order history appears. You can set up the 
feature and create history during data conversion or you can do so at a later 
time.    

3____ If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

4____ If your system is integrated with Sage CRM, go into CRM Server Options, 
and update the following information as needed. 

 Integration server port ID

 Sage CRM SQL server name

 Sage CRM SQL database name

The server name and database name should reference the mirror 
installation that you created for integration with Sage 100 2017. For more 
information on this process, refer to the Installing Sage CRM chapter in the 
Sage 100 Installation and System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

5____ If you synchronize payroll data between Sage Payroll Services and your 
general ledger, contact Sage Payroll Services Support for assistance with 
resetting the link for your Sage 100 company. 

You must complete this step before you can synchronize payroll data. This 
applies only if Sage Payroll Services is selected in the Payroll Service field 
in Sage Payroll Services Options. 

6____  Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields.  
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Upgrading from Version 2015 to Version 2017
7____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.

8____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.

9____ Review your Payroll Tax Tables. Installing the Payroll Tax Table Update 
replaces all of your current state and federal tax tables with new tables 
unless you have specifically excluded a state tax table from the update by 
selecting the Exclude this Table from Tax Update check box in Tax Table 
Maintenance. Local tax information is not updated. 

10____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2017. 

To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

11____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

12____ If you use Sage Intelligence Reporting, create a new repository for use with 
Sage 100 2017 and import any custom reports into it. For detailed 
instructions, see Upgrading Sage Intelligence Reporting on page 72.

13____ If dictionary changes were made to any files used for import and export jobs 
created in the Visual Integrator module, those jobs will need to be manually 
updated for modules other than Job Cost, Payroll, Material Requirements 
Planning, TimeCard, and Work Order.

       NOTE  
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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Upgrading from Version 2015 to Version 2017
To determine if manual updates are required, review the associated file 
layout information using the File Layouts and Program Information link on 
the Resources page of the Desktop. If you are upgrading from 
Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary 
Listing accessed from the Visual Integrator Main menu. Verify that the 
imported field names are consistent with the new file layouts.

14____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

15____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

16____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

17____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.

18____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

19____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

20____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

21____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

22____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

23____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

24____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records. To run the utility, select Library Master > Utilities > Build Search 
Index.
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Upgrading from Version 2015 to Version 2017
25____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

For information on what is new in this release, see the What’s New chapter in the 
Sage 100 2017 Customer Upgrade Guide. 
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Upgrading from Version 2014 to Version 2017
Upgrading from Version 2014 to Version 2017

When upgrading to version 2017, you must perform a parallel installation. Use the 
Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to 
upgrade your data. For more information, consult with your Sage business partner. 

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 2014 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ Create a backup of your version 2014 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

4____ If you use the Purchase Order module, you will have the option to start 
retaining purchase order history and to create history using records in your 
Purchase Order data entry files. 

If you plan to create history, consider running the following utilities to clear 
out records that you do not want to include:

 Purge Completed Purchase Orders

 Purge Obsolete Purchase Orders 

For more information on the utilities, see the help system.

5____ Rebuild all data files. 

 If you are upgrading from Sage 100 Standard or Advanced, use the 
Rebuild Key Files and Rebuild Sort File utilities.

 If you are upgrading from Sage 100 Premium, use the Rebuild Sort File 
utility.

You must answer Yes to all recalculation questions.

6____ Print all customized form definitions.

       NOTE  
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 
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Upgrading from Version 2014 to Version 2017
7____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

8____ If you are upgrading Sage 100 Premium, configure your firewall to allow 
access to port number 1433 on the server with your version 2014 
installation. Port 1433 is the default SQL Server port. 

Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 14, you are now ready to 
migrate your data to your version 2017 system.

1____ If you are upgrading Sage 100 Standard or Advanced, select Library Master 
Utilities menu > Parallel Migration. Follow the steps in the wizard to migrate 
your data. 

If you are upgrading Sage 100 Premium, start the Parallel Migration Wizard 
using one of the methods below, and follow the steps in the Wizard.

 If you are using Windows Server 2008, start the Parallel Migration 
Wizard from the Sage program group on the Start menu.

 If you are using Windows Server 2012, start the Parallel Migration 
Wizard from the Start window.

The Migration Wizard will back up the Sage 100 SQL databases for your 
prior version of Sage 100, copy the backup files to the server where the 
Sage 100 2017 SQL Server instance is installed, and then restore them in 
the new location. Administrative rights are required for both your prior 
version of Sage 100 and for version 2017. The person running the Migration 
Wizard must have rights to the following administrative share: 
\\{sourceserver-name}\c$ 

If local security settings prevent the wizard from migrating the databases, 
use SQL Server Management Studio to back up the MAS_System and 
company databases that you want to migrate. Then copy the .BAK files to 
the ..\MSSQL\Data folder on the server where the Sage 100 2017 SQL 
Server instance is installed.

2____ After the migration is complete, log into Sage 100 2017 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

3____ Review security tasks for new features in version 2017. Review ODBC 
security if it is used.

4____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

5____ If you customized your Desktop, review the customizations on the Custom 
toolbar. 

WARNING  
If you are 
migrating data for 
Sage 100 
Premium, you 
must have 
administrator 
rights for the 
server with the 
installation you are 
migrating from and 
the server with 
your version 2017 
installation.
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Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 14 and the 
Upgrade Checklist on page 15, you are now ready to convert your data to version 
2017.

1____ If your company data contains credit card information, verify that the 
workstation you are using has a working Internet connection to 
automatically install the Sage Exchange Desktop and transfer credit card 
records to a Sage Exchange Vault account during conversion. Credit card 
records must be transferred to a Sage Exchange Vault account before 
company data can be converted.

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2017. This must be done for each of your companies. 

If the Purchase Order module is set up for a company, a window with 
options for retaining purchase order history appears. You can set up the 
feature and create history during data conversion or you can do so at a later 
time.   

3____ If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

4____ If your system is integrated with Sage CRM, go into CRM Server Options, 
and update the following information as needed. 

 Integration server port ID

 Sage CRM SQL server name

 Sage CRM SQL database name

The server name and database name should reference the mirror 
installation that you created for integration with Sage 100 2017. For more 
information on this process, refer to the Installing Sage CRM chapter in the 
Sage 100 Installation and System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

5____  Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields. 

6____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.
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7____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.

8____ Review your Payroll Tax Tables. Installing the Payroll Tax Table Update 
replaces all of your current state and federal tax tables with new tables 
unless you have specifically excluded a state tax table from the update by 
selecting the Exclude this Table from Tax Update check box in Tax Table 
Maintenance. Local tax information is not updated. 

9____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2017. 

To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

10____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

11____ If you use Sage Intelligence Reporting, create a new repository for use with 
Sage 100 2017 and import any custom reports into it. For detailed 
instructions, see Upgrading Sage Intelligence Reporting on page 72.

12____  If dictionary changes were made to any files used for import and export 
jobs created in the Visual Integrator module, those jobs will need to be 
manually updated for modules other than Job Cost, Payroll, Material 
Requirements Planning, TimeCard, and Work Order.

       NOTE  
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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To determine if manual updates are required, review the associated file 
layout information using the File Layouts and Program Information link on 
the Resources page of the Desktop. If you are upgrading from 
Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary 
Listing accessed from the Visual Integrator Main menu. Verify that the 
imported field names are consistent with the new file layouts.

13____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

14____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

15____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

16____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.

17____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

18____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

19____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

20____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

21____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

22____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

23____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records. To run the utility, select Library Master > Utilities > Build Search 
Index.
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24____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

For information on what is new in this release, see the What’s New chapter in the 
Sage 100 2017 Customer Upgrade Guide. 
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Upgrading from Version 2013 to Version 2017

When upgrading to version 2017, you must perform a parallel installation. Use the 
Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to 
upgrade your data. For more information, consult with your Sage business partner. 

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 2013 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ Create a backup of your version 2013 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

4____ Rebuild all data files. 

 If you are upgrading from Sage 100 Standard or Advanced, use the 
Rebuild Key Files and Rebuild Sort File utilities.

 If you are upgrading from Sage 100 Premium, use the Rebuild Sort File 
utility.

You must answer Yes to all recalculation questions.

5____ Print all customized form definitions.

6____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

7____ If you are upgrading Sage 100 Premium, configure your firewall to allow 
access to port number 1433 on the server with your version 2013 
installation. Port 1433 is the default SQL Server port. 

       NOTE  
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 
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Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 20, you are now ready to 
migrate your data to your version 2017 system.

1____ If you are upgrading Sage 100 Standard or Advanced, select Library Master 
Utilities menu > Parallel Migration. Follow the steps in the wizard to migrate 
your data. 

If you are upgrading Sage 100 Premium, start the Parallel Migration Wizard 
using one of the methods below, and follow the steps in the Wizard.

 If you are using Windows Server 2008, start the Parallel Migration 
Wizard from the Sage program group on the Start menu.

 If you are using Windows Server 2012, start the Parallel Migration 
Wizard from the Start window.

The Migration Wizard will back up the Sage 100 SQL databases for your 
prior version of Sage 100, copy the backup files to the server where the 
Sage 100 2017 SQL Server instance is installed, and then restore them in 
the new location. Administrative rights are required for both your prior 
version of Sage 100 and for version 2017. The person running the Migration 
Wizard must have rights to the following administrative share: 
\\{sourceserver-name}\c$ 

If local security settings prevent the wizard from migrating the databases, 
use SQL Server Management Studio to back up the MAS_System and 
company databases that you want to migrate. Then copy the .BAK files to 
the ..\MSSQL\Data folder on the server where the Sage 100 2017 SQL 
Server instance is installed.

2____ After the migration is complete, log into Sage 100 2017 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

3____ Review security tasks for new features in version 2017. Review ODBC 
security if it is used.

4____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

5____ If you customized your Desktop, review the customizations on the Custom 
toolbar. 

WARNING  
If you are 
migrating data for 
Sage 100 
Premium, you 
must have 
administrator 
rights for the 
server with the 
installation you are 
migrating from and 
the server with 
your version 2017 
installation.
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Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 20 and the 
Upgrade Checklist on page 21, you are now ready to convert your data to version 
2017.

1____ If your company data contains credit card information, verify that the 
workstation you are using has a working Internet connection to 
automatically install the Sage Exchange Desktop and transfer credit card 
records to a Sage Exchange Vault account during conversion. Credit card 
records must be transferred to a Sage Exchange Vault account before 
company data can be converted.

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2017. This must be done for each of your companies. 

3____ If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

4____ If your system is integrated with Sage CRM, go into CRM Server Options, 
and update the following information as needed. 

 Integration server port ID

 Sage CRM SQL server name

 Sage CRM SQL database name

The server name and database name should reference the mirror 
installation that you created for integration with Sage 100 2017. For more 
information on this process, refer to the Installing Sage CRM chapter in the 
Sage 100 Installation and System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

5____  Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields.  

6____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.

7____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.
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8____ Review your Payroll Tax Tables. Installing the Payroll Tax Table Update 
replaces all of your current state and federal tax tables with new tables 
unless you have specifically excluded a state tax table from the update by 
selecting the Exclude this Table from Tax Update check box in Tax Table 
Maintenance. Local tax information is not updated. 

9____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2017. 

To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

10____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

11____ If you use Sage Intelligence Reporting, create a new repository for use with 
Sage 100 2017 and import any custom reports into it. For detailed 
instructions, see Upgrading Sage Intelligence Reporting on page 72.

12____ If dictionary changes were made to any files used for import and export jobs 
created in the Visual Integrator module, those jobs will need to be manually 
updated for modules other than Job Cost, Payroll, Material Requirements 
Planning, TimeCard, and Work Order.

To determine if manual updates are required, review the associated file 
layout information using the File Layouts and Program Information link on 
the Resources page of the Desktop. If you are upgrading from 
Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary 
Listing accessed from the Visual Integrator Main menu. Verify that the 
imported field names are consistent with the new file layouts.

13____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

       NOTE  
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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14____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

15____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

16____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.

17____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

18____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

19____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

20____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

21____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

22____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

23____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records. To run the utility, select Library Master > Utilities > Build Search 
Index. 

24____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.
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b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

For information on what is new in this release, see the What’s New chapter in the 
Sage 100 2017 Customer Upgrade Guide. 
2017 Upgrade Checklist                                                                                                                                                25



_____________________________________________________________________________________________

Upgrading from Version 4.50 to Version 2017
Upgrading from Version 4.50 to Version 2017

When upgrading to version 2017, you must perform a parallel installation. Use the 
Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to 
upgrade your data. For more information, consult with your Sage business partner. 

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 4.50 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ Create a backup of your version 4.50 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

4____ If you use credit card processing, verify that you have a valid credit card 
encryption key in Company Maintenance for proper conversion of credit 
card data.

5____ Rebuild all data files. 

 If you are upgrading from Sage 100 Standard or Advanced, use the 
Rebuild Key Files and Rebuild Sort File utilities.

 If you are upgrading from Sage 100 Premium, use the Rebuild Sort File 
utility.

You must answer Yes to all recalculation questions.

6____ Print all customized form definitions.

7____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

8____ If you are upgrading Sage 100 Premium, configure your firewall to allow 
access to port number 1433 on the server with your version 4.50 
installation. Port 1433 is the default SQL Server port. 

       NOTE  
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 
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Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 26, you are now ready to 
migrate your data to your version 2017 system.

1____ If you are upgrading Sage 100 Standard or Advanced, select Library Master 
Utilities menu > Parallel Migration. Follow the steps in the wizard to migrate 
your data. 

If you are upgrading Sage 100 Premium, start the Parallel Migration Wizard 
using one of the methods below, and follow the steps in the Wizard.

 If you are using Windows Server 2008, start the Parallel Migration 
Wizard from the Sage program group on the Start menu.

 If you are using Windows Server 2012, start the Parallel Migration 
Wizard from the Start window.

The Migration Wizard will back up the Sage 100 SQL databases for your 
prior version of Sage 100, copy the backup files to the server where the 
Sage 100 2017 SQL Server instance is installed, and then restore them in 
the new location. Administrative rights are required for both your prior 
version of Sage 100 and for version 2017. The person running the Migration 
Wizard must have rights to the following administrative share: 
\\{sourceserver-name}\c$ 

If local security settings prevent the wizard from migrating the databases, 
use SQL Server Management Studio to back up the MAS_System and 
company databases that you want to migrate. Then copy the .BAK files to 
the ..\MSSQL\Data folder on the server where the Sage 100 2017 SQL 
Server instance is installed.

2____ After the migration is complete, log into Sage 100 2017 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

3____ Review security tasks for new features in version 2017. Review ODBC 
security if it is used.

4____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

5____ If you customized your Desktop, review the customizations on the Custom 
toolbar. 

WARNING  
If you are 
migrating data for 
Sage 100 
Premium, you 
must have 
administrator 
rights for the 
server with the 
installation you are 
migrating from and 
the server with 
your version 2017 
installation.
2017 Upgrade Checklist                                                                                                                                                27



_____________________________________________________________________________________________

Upgrading from Version 4.50 to Version 2017
Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 26 and the 
Upgrade Checklist on page 27, you are now ready to convert your data to version 
2017.

1____ If your company data contains credit card information, verify that the 
workstation you are using has a working Internet connection to 
automatically install the Sage Exchange Desktop and transfer credit card 
records to a Sage Exchange Vault account during conversion. Credit card 
records must be transferred to a Sage Exchange Vault account before 
company data can be converted.

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2017. This must be done for each of your companies.

If your data contains credit card records that will be transferred to a Sage 
Exchange Vault account, the Credit Card Conversion To Sage Exchange 
Vault Time Estimate window appears. This window provides an estimate of 
how long it will take to transfer the credit card data. This estimate is based 
on benchmark test results, but results will vary based on Internet 
connection speed, network traffic, and the number of customer credit card 
records stored in your system. 

You may be able to decrease the estimate by updating credit card 
transactions and purging credit card data. If this window appears, click Yes 
to proceed with data conversion or click No to stop the conversion process. 

Additional time is required to convert company data after the credit card 
records are transferred; that time is not included in the estimate shown on 
the window. 

3____ Verify that credit card processing is enabled for each company in Company 
Maintenance if credit cards were previously being processed using Sage 
Payment Solutions. For more information, see Set Up the Credit Card 
Processing Module in the Help system.

If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

4____ If your system is integrated with Sage CRM, go into CRM Server Options, 
and update the following information as needed. 

 Integration server port ID

 Sage CRM SQL server name

 Sage CRM SQL database name
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The server name and database name should reference the mirror 
installation that you created for integration with Sage 100 2017. For more 
information on this process, refer to the Installing Sage CRM chapter in the 
Sage 100 Installation and System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

5____  Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields. 

6____ If you have customers with national accounts and credit cards are assigned 
to the sold-to customers, review those records to determine whether the 
credit card information should be manually transferred to the bill-to 
customer.

7____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.

8____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.

9____ Review your Payroll Tax Tables. Installing the Payroll Tax Table Update 
replaces all of your current state and federal tax tables with new tables 
unless you have specifically excluded a state tax table from the update by 
selecting the Exclude this Table from Tax Update check box in Tax Table 
Maintenance. Local tax information is not updated. 

10____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2017. 

To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

       NOTE  
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

11____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

12____ If you use Sage Intelligence Reporting, create a new repository for use with 
Sage 100 2017 and import any custom reports into it. For detailed 
instructions, see Upgrading Sage Intelligence Reporting on page 72.

13____ If dictionary changes were made to any files used for import and export jobs 
created in the Visual Integrator module, those jobs will need to be manually 
updated for modules other than Job Cost, Payroll, Material Requirements 
Planning, TimeCard, and Work Order.

To determine if manual updates are required, review the associated file 
layout information using the File Layouts and Program Information link on 
the Resources page of the Desktop. If you are upgrading from 
Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary 
Listing accessed from the Visual Integrator Main menu. Verify that the 
imported field names are consistent with the new file layouts.

14____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

15____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

16____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

17____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.

18____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

19____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

20____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.
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21____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

22____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

23____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

24____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records. To run the utility, select Library Master > Utilities > Build Search 
Index. 

25____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

For information on what is new in this release, see the What’s New chapter in the 
Sage 100 2017 Customer Upgrade Guide. 
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Upgrading from Version 4.45 to Sage 100 Premium 
Version 2017

Before upgrading your data to version 2017, you must perform a parallel installation 
and run the Parallel Migration utility from the Windows Start menu > All Programs > 
Sage program group. For more information, consult with your Sage business 
partner.

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

Pre-Upgrade Checklist

You must prepare your version 4.45 data for upgrade. This should be done for each 
company you plan to upgrade. Several steps should be completed by a SQL 
Server® administrator.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ Create a backup of your version 4.45 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

4____ Rebuild all data files using the Rebuild Sort File utility. You must answer Yes 
to all recalculation questions.

5____ Print all customized form definitions.

6____ If you are upgrading Sage 100 Premium, configure your firewall to allow 
access to port number 1433 on the server with your version 4.45 
installation. Port 1433 is the default SQL Server port. 

Upgrade Checklist

After completing the Pre-Upgrade Checklist on this page, you are now ready to 
migrate your data to your version 2017 system.

1____ Start the Parallel Migration Wizard using one of the methods below, and 
follow the steps in the wizard to migrate your data.

 If you are using Windows Server 2008, start the Parallel Migration 
Wizard from the Sage program group on the Start menu.

 If you are using Windows Server 2012, start the Parallel Migration 
Wizard from the Start window. 

       NOTE  
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 

WARNING  
You must have 
administrator 
rights for the 
server with the 
installation you 
are migrating 
from and the 
server with your 
version 2017 
installation.
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The Migration Wizard will back up the Sage 100 SQL databases for your 
prior version of Sage 100, copy the backup files to the server where Sage 
100 2017 SQL Server instance is installed, and then restore them in the 
new location. Administrative rights are required for both your prior version 
of Sage 100 and for version 2017. The person running the Migration Wizard 
must have rights to the following administrative share: 
\\{sourceserver-name}\c$ 

If local security settings prevent the wizard from migrating the databases, 
use SQL Server Management Studio to back up the MAS_System and 
company databases that you want to migrate. Then copy the .BAK files to 
the ..\MSSQL\Data folder on the server where the Sage 100 2017 SQL 
Server instance is installed.

2____ After the migration is complete, log into Sage 100 2017 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

3____ Review security tasks for new features in version 2017.

4____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

5____ If you customized your Desktop, review the customizations on the Custom 
toolbar. 

Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 32 and the 
Upgrade Checklist on page 32, you are now ready to convert your data to version 
2017.

1____ If your company data contains credit card information, verify that the 
workstation you are using has a working Internet connection to 
automatically install the Sage Exchange Desktop and transfer credit card 
records to a Sage Exchange Vault account during conversion. Credit card 
records must be transferred to a Sage Exchange Vault account before 
company data can be converted.

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2017. This must be done for each of your companies.

If your data contains credit card records that will be transferred to a Sage 
Exchange Vault account, the Credit Card Conversion To Sage Exchange 
Vault Time Estimate window appears. This window provides an estimate of 
how long it will take to transfer the credit card data. This estimate is based 
on benchmark test results, but results will vary based on Internet 
connection speed, network traffic, and the number of customer credit card 
records stored in your system. 
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You may be able to decrease the estimate by updating credit card 
transactions and purging credit card data. If this window appears, click Yes 
to proceed with data conversion or click No to stop the conversion process. 

Additional time is required to convert company data after the credit card 
records are transferred; that time is not included in the estimate shown on 
the window. 

3____ Verify that credit card processing is enabled for each company in Company 
Maintenance if credit cards were previously being processed using Sage 
Payment Solutions. For more information, see Set Up the Credit Card 
Processing Module in the Help system.

If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

4____ Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields. 

5____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.

6____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.

7____ If you had the Extended Solution for customers with national accounts and 
the Populate Bill Address Block with ’Bill To’ Customer Block check box was 
selected in AR-1068 Setup Options, you must run the Sales Order Bill To 
Address Fix Utility (select File menu > Run, then type *Utl) to populate the 
sales order bill-to address information with the bill-to customer’s address 
information. 

8____ Test your modified SAP Crystal reports and forms. Use SAP Crystal Reports 
Designer to modify reports as needed. 

You must either be logged on using a Windows account that has read 
access to the applicable SQL Server database, or you must have a 
separate SQL Server authenticated logon ID and password. Integrated 
Security is used by default; if your Windows account does not have rights to 
the database, a logon dialog box appears, allowing you to enter a different 
logon ID and password for database access.

Before modifying forms or the standard Crystal reports found on the 
Custom Reports menu, you must be proficient in the use of SAP Crystal 
Reports.
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9____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

10____ If you use Sage Intelligence Reporting, create a new repository for use with 
Sage 100 2017 and import any custom reports into it. For detailed 
instructions, see Upgrading Sage Intelligence Reporting on page 72.

11____ If dictionary changes were made to any files used for import or export jobs 
created in the Visual Integrator module, those jobs will need to be manually 
updated.

To determine if manual updates are required, review the associated file 
layout information using the File Layouts and Program Information link on 
the Resources page of the Desktop. Verify that the imported field names 
are consistent with the new file layouts.

12____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

13____ If you do not use taxation for purchase orders, clear the Sales Tax Reporting 
check box in Accounts Payable Options.

14____ If you include sales tax on purchase orders and want to enter default tax 
schedules for vendors, use Accounts Payable Assign Vendor Tax 
Schedules to set up tax schedules.

15____ Confirm in Accounts Receivable Customer Maintenance that all customers 
that have exemption numbers still have the exemption number defined.

16____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.

17____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

18____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

19____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

20____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

21____ Test all printers, that you normally use for printing forms and reports. Each 
workstation must have a default printer defined.
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22____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records. To run the utility, select Library Master > Utilities > Build Search 
Index.

23____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

For information on what is new in this release, see the What’s New chapter in the 
Sage 100 2017 Customer Upgrade Guide. 
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Upgrading from Version 4.40 to Version 2017

When upgrading to version 2017, you must perform a parallel installation. Use the 
Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to 
upgrade your data. For more information, consult with your Sage business partner. 

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 4.40 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ Create a backup of your version 4.40 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

4____ If you are upgrading from version 4.40 Product Update 4 and higher, verify 
that you have a valid credit card encryption key in Company Maintenance 
for proper conversion of credit card data.

5____ Rebuild all data files using the Rebuild Key Files and Rebuild Sort File 
utilities. You must answer Yes to all recalculation questions.

6____ Print all customized form definitions.

7____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 37, you are now ready to 
migrate your data to your version 2017 system.

1____ From your version 2017 installation, select Library Master Utilities menu > 
Pre Migration, and then enter the source path and company code for your 
version 4.40 system. Run the reports and utilities that appear. 

It is critical that you address everything listed in the Pre Migration window 
before you proceed to the next step. If nothing appears, no action is 
required.

       NOTE  
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 

       NOTE  
The tasks that 
appear in the Pre 
Migration window 
are based on the 
version of your 
data.
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2____ Select Library Master Utilities menu > Parallel Migration. Follow the steps in 
the wizard to upgrade your data.

3____ After the migration is complete, log into Sage 100 2017 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

4____ Review security tasks for new features in version 2017. Review ODBC 
security if it is used.

5____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

6____ If you customized your Desktop, review the customizations on the Custom 
toolbar. 

Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 37 and the 
Upgrade Checklist on page 37, you are now ready to convert your data to version 
2017.

1____ If your company data contains credit card information, verify that the 
workstation you are using has a working Internet connection to 
automatically install the Sage Exchange Desktop and transfer credit card 
records to a Sage Exchange Vault account during conversion. Credit card 
records must be transferred to a Sage Exchange Vault account before 
company data can be converted.

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2017. This must be done for each of your companies.

If your data contains credit card records that will be transferred to a Sage 
Exchange Vault account, the Credit Card Conversion To Sage Exchange 
Vault Time Estimate window appears. This window provides an estimate of 
how long it will take to transfer the credit card data. This estimate is based 
on benchmark test results, but results will vary based on Internet 
connection speed, network traffic, and the number of customer credit card 
records stored in your system. 

You may be able to decrease the estimate by updating credit card 
transactions and purging credit card data. If this window appears, click Yes 
to proceed with data conversion or click No to stop the conversion process. 

Additional time is required to convert company data after the credit card 
records are transferred; that time is not included in the estimate shown on 
the window. 

3____ Verify that credit card processing is enabled for each company in Company 
Maintenance if credit cards were previously being processed using Sage 
Payment Solutions. For more information, see Set Up the Credit Card 
Processing Module in the Help system.
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If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

4____ If your system is integrated with Sage CRM, go into CRM Server Options, 
and update the following information as needed. 

 Integration server port ID

 Sage CRM SQL server name

 Sage CRM SQL database name

The server name and database name should reference the mirror 
installation that you created for integration with Sage 100 2017. For more 
information on this process, refer to the Installing Sage CRM chapter in the 
Sage 100 Installation and System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

5____ Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields.  

6____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.

7____ If you had the Extended Solution for customers with national accounts and 
the Populate Bill Address Block with ’Bill To’ Customer Block check box was 
selected in AR-1068 Setup Options, you must run the Sales Order Bill To 
Address Fix Utility (select File menu > Run, then type *Utl) to populate the 
sales order bill-to address information with the bill-to customer’s address 
information. 

8____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.

9____ Review your Payroll Tax Tables. Installing the Payroll Tax Table Update 
replaces all of your current state and federal tax tables with new tables 
unless you have specifically excluded a state tax table from the update by 
selecting the Exclude this Table from Tax Update check box in Tax Table 
Maintenance. Local tax information is not updated. 

10____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2017. 

       NOTE  
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

11____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

12____ If you use Sage Intelligence Reporting, create a new repository for use with 
Sage 100 2017 and import any custom reports into it. For detailed 
instructions, see Upgrading Sage Intelligence Reporting on page 72.

13____ If dictionary changes were made to any files used for import or export jobs 
created in the Visual Integrator module, those jobs will need to be manually 
updated for modules other than Job Cost, Payroll, Material Requirements 
Planning, TimeCard, and Work Order.

To determine if manual updates are required, review the associated file 
layout information using the File Layouts and Program Information link on 
the Resources page of the Desktop. If you are upgrading from 
Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary 
Listing accessed from the Visual Integrator Main menu. Verify that the 
imported field names are consistent with the new file layouts.

14____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

15____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

16____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

17____ If you do not use taxation for purchase orders, clear the Sales Tax Reporting 
check box in Accounts Payable Options.
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18____ If you include sales tax on purchase orders and want to enter default tax 
schedules for vendors, use Accounts Payable Assign Vendor Tax 
Schedules to set up tax schedules.

19____ Confirm in Accounts Receivable Customer Maintenance that all customers 
that have exemption numbers still have the exemption number defined.

20____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.

21____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

22____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

23____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

24____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

25____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

26____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

27____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records. To run the utility, select Library Master > Utilities > Build Search 
Index.

28____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.
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c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

For information on what is new in this release, see the What’s New chapter in the 
Sage 100 2017 Customer Upgrade Guide.
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Upgrading from Version 4.30 to Version 2017

When upgrading to version 2017, you must perform a parallel installation. Use the 
Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to 
upgrade your data. For more information, consult with your Sage business partner. 

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 4.30 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ Create a backup of your version 4.30 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

4____ If you use credit card processing and are upgrading from version 4.30 
Service Update 18 through 23, verify that you have a valid credit card 
encryption key in Company Maintenance for proper conversion of credit 
card data.

5____ Rebuild all data files using the Rebuild Key Files and Rebuild Sort File 
utilities. You must answer Yes to all recalculation questions.

6____ Print all customized form definitions.

7____ Correct and apply all negative tiers before upgrading. For more information, 
see Correct Negative Tiers in the Help system.

8____ If you had historical data prior to version 4.10, print the following Sales 
Order History reports: Customer Sales History Report, Monthly Recap by 
Product Line Report, Monthly Recap by Warehouse/Product Line Report, 
Monthly Recap by Warehouse Report, Monthly Recap by Division Report. 
These reports are no longer available beginning with version 4.10.

9____ If you created reports using Business Insights Reporter, review the report 
names in the Business Insights Reporter selection window. If there are 
multiple reports with similar names, copy the reports within Business 
Insights Reporter and rename each report.

       NOTE  
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 
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For example, if you have reports named CustomerSalesReport, 
CustomerSalesReport2, and CustomerSalesReport3, copy 
CustomerSalesReport2 as "SalesReportForCustomers" and 
CustomerSalesReport3 as "ReportForCustomerSales."

For more information, see Copy a Report in the Help system.

10____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 43, you are now ready to 
migrate your data to your version 2017 system.

1____ From your version 2017 installation, select Library Master Utilities menu > 
Pre Migration, and then enter the source path and company code for your 
version 4.30 system. Run the reports and utilities that appear.

a Select Item Code Validation Report to display missing item codes from 
your Warehouse Detail, Item Costing, and Transaction Detail files.

 To fix the files, in your version 4.30 data, use Inventory Management 
Main menu > Inventory Maintenance.

b Select Inventory File Comparison Report to compare the quantity in 
your warehouse, tier, and transaction inventory data files.

 Run this report by warehouse and save as an audit trail.

 To correct any quantities, run the Inventory Balancing Utility.

c Select Inventory Balancing Utility to balance your inventory quantities. 

 Run this utility for each warehouse.

 In the Action column, select the action to perform for each item, or 
apply a specific action based on valuation type.

 If the valuation is LIFO, FIFO, Lot, or Serial, in the Action column 
select Skip if the tier quantities are incorrect. You must perform a 
physical count to correct the tier quantity. After the tier quantity is 
correct, run this utility for these valuation methods.

 If the valuation is Average Cost or Standard Cost and the 
warehouse and transaction quantities are incorrect, you must 
perform a physical count to correct the warehouse quantity. After the 
warehouse quantity is correct, run this utility for those valuation 
methods. 

 For more information, see Balance Inventory Quantities in the Help 
system.

       NOTE  
The tasks that 
appear in the Pre 
Migration window 
are based on the 
version of your 
data.

       NOTE  
The quantities in 
your warehouse, 
tier, and 
transaction 
inventory data 
files must match 
before you can 
upgrade your 
data to version 
2017. 
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d Run all Inventory Pre Migration tasks again to ensure corrections were 
made. Keep all reports as an audit trail.

2____ Select Library Master Utilities menu > Parallel Migration. Follow the steps in 
the wizard to upgrade your data.

3____ After the migration is complete, log into Sage 100 2017 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

4____ Review security tasks for new features in version 2017. Review ODBC 
security if it is used.

5____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

6____ If you customized your Desktop, review the customizations on the Custom 
toolbar. 

Data Conversion Checklist

After completing the Pre-Upgrade Checklist on page 43 and the Upgrade Checklist 
on page 44, you are now ready to convert your data to version 2017.

1____ If your company data contains credit card information, verify that the 
workstation you are using has a working Internet connection to 
automatically install the Sage Exchange Desktop and transfer credit card 
records to a Sage Exchange Vault account during conversion. Credit card 
records must be transferred to a Sage Exchange Vault account before 
company data can be converted.

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2017. This must be done for each of your companies.

If your data contains credit card records that will be transferred to a Sage 
Exchange Vault account, the Credit Card Conversion To Sage Exchange 
Vault Time Estimate window appears. This window provides an estimate of 
how long it will take to transfer the credit card data. This estimate is based 
on benchmark test results, but results will vary based on Internet 
connection speed, network traffic, and the number of customer credit card 
records stored in your system. 

You may be able to decrease the estimate by updating credit card 
transactions and purging credit card data. If this window appears, click Yes 
to proceed with data conversion or click No to stop the conversion process. 

Additional time is required to convert company data after the credit card 
records are transferred; that time is not included in the estimate shown on 
the window. 
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3____ Verify that credit card processing is enabled for each company in Company 
Maintenance if credit cards were previously being processed using Sage 
Payment Solutions. For more information, see Set Up the Credit Card 
Processing Module in the Help system.

If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

4____ If your system is integrated with Sage CRM, go into CRM Server Options, 
and update the following information as needed. 

 Integration server port ID

 Sage CRM SQL server name

 Sage CRM SQL database name

The server name and database name should reference the mirror 
installation that you created for integration with Sage 100 2017. For more 
information on this process, refer to the Installing Sage CRM chapter in the 
Sage 100 Installation and System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

5____ Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields. 

Re-customize the customized libraries for the Bar Code, Bill of Materials, 
Inventory Management, and Purchase Order modules. 

6____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.

7____ If you had the Extended Solution for customers with national accounts and 
the Populate Bill Address Block with ’Bill To’ Customer Block check box was 
selected in AR-1068 Setup Options, you must run the Sales Order Bill To 
Address Fix Utility (select File menu > Run, then type *Utl) to populate the 
sales order bill-to address information with the bill-to customer’s address 
information. 

8____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.
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9____ Review your Payroll Tax Tables. Installing the Payroll Tax Table Update 
replaces all of your current state and federal tax tables with new tables 
unless you have specifically excluded a state tax table from the update by 
selecting the Exclude this Table from Tax Update check box in Tax Table 
Maintenance. Local tax information is not updated. 

10____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2017. 

To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

11____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

12____ If dictionary changes were made to any files used for import or export jobs 
created in the Visual Integrator module, those jobs will need to be manually 
updated for modules other than Job Cost, Payroll, Material Requirements 
Planning, TimeCard, and Work Order.

To determine if manual updates are required, review the associated file 
layout information using the File Layouts and Program Information link on 
the Resources page of the Desktop. If you are upgrading from 
Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary 
Listing accessed from the Visual Integrator Main menu. Verify that the 
imported field names are consistent with the new file layouts.

13____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

14____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

       NOTE  
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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15____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

16____ If you do not use taxation for purchase orders, clear the Sales Tax Reporting 
check box in Accounts Payable Options.

17____ If you include sales tax on purchase orders and want to enter default tax 
schedules for vendors, use Accounts Payable Assign Vendor Tax 
Schedules to set up tax schedules.

18____ Confirm in Accounts Receivable Customer Maintenance that all customers 
that have exemption numbers still have the exemption number defined.

19____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.

20____ If you had the Extended Solution for direct deposits, verify the bank ID (bank 
account) number for each bank code. During conversion, if there is a 
discrepancy between the bank ID number in Bank Code Maintenance and 
the bank account number in Direct Deposit Information for a bank code, the 
account number in Direct Deposit Information replaces the number in Bank 
Code Maintenance. If an account number is not entered in Direct Deposit 
Information, the number in Bank Code Maintenance is entered in Direct 
Deposit Information. Account number changes are noted in the conversion 
log.

21____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

22____ Compare the following version 4.30 and 2017 reports because sales tax 
may be recalculated during the conversion: Accounts Receivable Sales Tax 
Report, Accounts Receivable Repetitive Invoice Listing, Accounts Payable 
Repetitive Invoice Listing, Open Sales Order Report, and Open Purchase 
Order Report.

23____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

24____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

25____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.
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26____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

27____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

28____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records. To run the utility, select Library Master > Utilities > Build Search 
Index. 

29____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

For information on what is new in this release, see the What’s New chapter in the 
Sage 100 2017 Customer Upgrade Guide. 
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Upgrading from Version 4.20 to Version 2017

When upgrading to version 2017, you must perform a parallel installation. Use the 
Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to 
upgrade your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 4.20 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ Create a backup of your version 4.20 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

4____ If you plan to use Federal and State eFiling and Reporting for the 1099 
forms, W-2 forms, 941 forms, and governmental reports, perform the 
conversion to version 2015 after the quarter end and before the first payroll 
in the current quarter to avoid values being placed in the wrong boxes on 
some forms. If conversion is performed mid-quarter, some data may require 
editing.

5____ Rebuild all data files using the Rebuild Key Files and Rebuild Sort File 
utilities. You must answer Yes to all recalculation questions.

6____ Print all customized form definitions.

7____ Correct and apply all negative tiers before upgrading. For more information, 
see Correct Negative Tiers in the Help system.

8____ If you had historical data prior to version 4.10, print the following Sales 
Order History reports: Customer Sales History Report, Monthly Recap by 
Product Line Report, Monthly Recap by Warehouse/Product Line Report, 
Monthly Recap by Warehouse Report, Monthly Recap by Division Report. 
These reports are no longer available beginning with version 4.10.

       NOTE  
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 
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9____ If you created reports using Business Insights Reporter, review the report 
names in the Business Insights Reporter selection window. If there are 
multiple reports with similar names, copy the reports within Business 
Insights Reporter and rename each report.

For example, if you have reports named CustomerSalesReport, 
CustomerSalesReport2, and CustomerSalesReport3, copy 
CustomerSalesReport2 as "SalesReportForCustomers" and 
CustomerSalesReport3 as "ReportForCustomerSales."

For more information, see Copy a Report in the Help system.

10____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 50, you are now ready to 
migrate your data to your version 2017 system.

1____ From your version 2017 installation, select Library Master Utilities menu > 
Pre Migration, and then enter the source path and company code for your 
version 4.20 system. Run the reports and utilities that appear.

a Select Item Code Validation Report to display missing item codes from 
your Warehouse Detail, Item Costing, and Transaction Detail files.

 To fix the files, in your version 4.20 data, use Inventory Management 
Main menu > Inventory Maintenance.

b Select Inventory File Comparison Report to compare the quantity in 
your warehouse, tier, and transaction inventory data files.

 Run this report by warehouse and save as an audit trail.

 To correct any quantities, run the Inventory Balancing Utility.

c Select Inventory Balancing Utility to balance your inventory quantities. 

 Run this utility for each warehouse.

 At the Action column, select the action to perform for each item, or 
apply a specific action based on valuation type.

 If the valuation is LIFO, FIFO, Lot, or Serial, at the Action column 
select Skip if the tier quantities are incorrect. You must perform a 
physical count to correct the tier quantity. After the tier quantity is 
correct, run this utility for these valuation methods.

 If the valuation is Average Cost or Standard Cost and the 
warehouse and transaction quantities are incorrect, you must 
perform a physical count to correct the warehouse quantity. After the 
warehouse quantity is correct, run this utility for those valuation 
methods. 

       NOTE  
The tasks that 
appear in the Pre 
Migration window 
are based on the 
version of your 
data.

       NOTE  
The quantities in 
your warehouse, 
tier, and 
transaction 
inventory data 
files must match 
before you can 
upgrade your 
data to version 
2017. 
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 For more information, see Balance Inventory Quantities in the Help 
system.

d Run all Inventory Pre Migration tasks again to ensure corrections were 
made. Keep all reports as an audit trail.

2____ Select Library Master Utilities menu > Parallel Migration. Follow the steps in 
the wizard to upgrade your data.

3____ If you are printing bar codes, ensure that the Azalea fonts are installed on 
the workstation. The fonts can be installed from the WkSetup\Azalea folder 
where Sage 100 is installed on your server.

4____ After the migration is complete, log into Sage 100 2017 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

5____ Review security tasks for new features in version 2017. Review ODBC 
security if it is used.

6____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

7____ If you customized your Desktop, review the customizations on the Custom 
toolbar. 

Data Conversion Checklist

After completing the Pre-Upgrade Checklist on page 50 and the Upgrade Checklist 
on page 51, you are now ready to convert your data to version 2017.

1____ If your company data contains credit card information, verify that the 
workstation you are using has a working Internet connection to 
automatically install the Sage Exchange Desktop and transfer credit card 
records to a Sage Exchange Vault account during conversion. Credit card 
records must be transferred to a Sage Exchange Vault account before 
company data can be converted.

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2017. This must be done for each of your companies.

If your data contains credit card records that will be transferred to a Sage 
Exchange Vault account, the Credit Card Conversion To Sage Exchange 
Vault Time Estimate window appears. This window provides an estimate of 
how long it will take to transfer the credit card data. This estimate is based 
on benchmark test results, but results will vary based on Internet 
connection speed, network traffic, and the number of customer credit card 
records stored in your system. 

You may be able to decrease the estimate by updating credit card 
transactions and purging credit card data. If this window appears, click Yes 
to proceed with data conversion or click No to stop the conversion process. 
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Additional time is required to convert company data after the credit card 
records are transferred; that time is not included in the estimate shown on 
the window. 

3____ Verify that credit card processing is enabled for each company in Company 
Maintenance if credit cards were previously being processed using Sage 
Payment Solutions. For more information, see Set Up the Credit Card 
Processing Module in the Help system.

If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

4____ If your system is integrated with Sage CRM, go into CRM Server Options, 
and update the following information as needed. 

 Integration server port ID

 Sage CRM SQL server name

 Sage CRM SQL database name

The server name and database name should reference the mirror 
installation that you created for integration with Sage 100 2017. For more 
information on this process, refer to the Installing Sage CRM chapter in the 
Sage 100 Installation and System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

5____ Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields.  

Re-customize the customized libraries for all modules other than Accounts 
Payable, Accounts Receivable, Bank Reconciliation, eBusiness Manager, 
General Ledger, Job Cost, Material Requirements Planning, Payroll, Return 
Merchandise Authorization, Sales Order, TimeCard, and Work Order. 

6____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.

7____ If you had the Extended Solution for customers with national accounts and 
the Populate Bill Address Block with ’Bill To’ Customer Block check box was 
selected in AR-1068 Setup Options, you must run the Sales Order Bill To 
Address Fix Utility (select File menu > Run, then type *Utl) to populate the 
sales order bill-to address information with the bill-to customer’s address 
information. 
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8____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.

9____ Review your Payroll Tax Tables. Installing the Payroll Tax Table Update 
replaces all of your current state and federal tax tables with new tables 
unless you have specifically excluded a state tax table from the update by 
selecting the Exclude this Table from Tax Update check box in Tax Table 
Maintenance. Local tax information is not updated. 

10____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2017. 

To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

11____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

12____ If dictionary changes were made to any files used for import or export jobs 
created in the Visual Integrator module, those jobs will need to be manually 
updated for modules other than Job Cost, Payroll, Material Requirements 
Planning, TimeCard, and Work Order.

To determine if manual updates are required, review the associated file 
layout information using the File Layouts and Program Information link on 
the Resources page of the Desktop. If you are upgrading from 
Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary 
Listing accessed from the Visual Integrator Main menu. Verify that the 
imported field names are consistent with the new file layouts.

       NOTE  
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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13____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

14____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

15____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

16____ If you do not use taxation for purchase orders, clear the Sales Tax Reporting 
check box in Accounts Payable Options.

17____ If you include sales tax on purchase orders and want to enter default tax 
schedules for vendors, use Accounts Payable Assign Vendor Tax 
Schedules to set up tax schedules.

18____ Confirm in Accounts Receivable Customer Maintenance that all customers 
that have exemption numbers still have the exemption number defined.

19____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.

20____ If you had the Extended Solution for direct deposits, verify the bank ID (bank 
account) number for each bank code. During conversion, if there is a 
discrepancy between the bank ID number in Bank Code Maintenance and 
the bank account number in Direct Deposit Information for a bank code, the 
account number in Direct Deposit Information replaces the number in Bank 
Code Maintenance. If an account number is not entered in Direct Deposit 
Information, the number in Bank Code Maintenance is entered in Direct 
Deposit Information. Account number changes are noted in the conversion 
log.

21____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

22____ Compare the following version 4.20 and 2017 reports because sales tax 
may be recalculated during the conversion: Accounts Receivable Sales Tax 
Report, Accounts Receivable Repetitive Invoice Listing, Accounts Payable 
Repetitive Invoice Listing, Open Sales Order Report, and Open Purchase 
Order Report.

23____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.
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24____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

25____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

26____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

27____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

28____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records. To run the utility, select Library Master > Utilities > Build Search 
Index. 

29____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.
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For information on what is new in this release, see the What’s New chapter in the 
Sage 100 2017 Customer Upgrade Guide.
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Upgrading from Version 4.10 to Version 2017

Prior to upgrading your version 4.10 data to version 2017, you must perform a 
parallel installation. Use the Pre-Migration and Parallel Migration utilities from the 
Library Master Utilities menu to upgrade your data. For more information, consult 
with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

Pre-Upgrade Checklist

You must prepare your version 4.10 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ Create a copy of your version 4.10 MAS90 folder, which includes data for all 
of your companies. Perform this step following your usual backup process. 
For specific support on how to back up your data, refer to manuals for your 
backup software or contact the vendor from whom you purchased that 
product.

4____ If you plan to use Federal and State eFiling and Reporting for the 1099 
forms, W-2 forms, 941 forms, and governmental reports, perform the 
conversion to version 2015 after the quarter end and before the first payroll 
in the current quarter to avoid values being placed in the wrong boxes on 
some forms. If conversion is performed mid-quarter, some data may require 
editing.

5____ Rebuild all data files using the Rebuild Key Files and Rebuild Sort File 
utilities. You must answer Yes to all recalculation questions.

6____ Print all customized form definitions.

7____ Correct and apply all negative tiers before upgrading. For more information, 
see Correct Negative Tiers in the Help system.

8____ If you had historical data prior to version 4.10, print the following Sales 
Order History reports: Customer Sales History Report, Monthly Recap by 
Product Line Report, Monthly Recap by Warehouse/Product Line Report, 
Monthly Recap by Warehouse Report, Monthly Recap by Division Report. 
These reports are no longer available beginning with version 4.10.

9____ If you created reports using Business Insights Reporter, review the report 
names in the Business Insights Reporter selection window. If there are 
multiple reports with similar names, copy the reports within Business 
Insights Reporter and rename each report.

       NOTE  
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 
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For example, if you have reports named CustomerSalesReport, 
CustomerSalesReport2, and CustomerSalesReport3, copy 
CustomerSalesReport2 as "SalesReportForCustomers" and 
CustomerSalesReport3 as "ReportForCustomerSales."

For more information, see Copy a Report in the Help system.

10____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 58, you are now ready to 
migrate your data to your version 2017 system.

1____ From your version 2017 installation, select Library Master Utilities menu > 
Pre Migration, and then enter the source path and company code for your 
version 4.10 system. Run the reports and utilities that appear.

a Select Item Code Validation Report to display missing item codes from 
your Warehouse Detail, Item Costing, and Transaction Detail files.

 To fix the files, in your version 4.10 data, use Inventory Management 
Main menu > Inventory Maintenance.

b Select Inventory File Comparison Report to compare the quantity in 
your warehouse, tier, and transaction inventory data files.

 Run this report by warehouse and save as an audit trail.

 To correct any quantities, run the Inventory Balancing Utility.

c Select Inventory Balancing Utility to balance your inventory quantities. 

 Run this utility for each warehouse.

 At the Action column, select the action to perform for each item, or 
apply a specific action based on valuation type.

 If the valuation is LIFO, FIFO, Lot, or Serial, at the Action column 
select Skip if the tier quantities are incorrect. You must perform a 
physical count to correct the tier quantity. After the tier quantity is 
correct, run this utility for these valuation methods.

 If the valuation is Average Cost or Standard Cost and the 
warehouse and transaction quantities are incorrect, you must 
perform a physical count to correct the warehouse quantity. After the 
warehouse quantity is correct, run this utility for those valuation 
methods. 

 For more information, see Balance Inventory Quantities in the Help 
system.

       NOTE  
The tasks that 
appear in the Pre 
Migration window 
are based on the 
version of your 
data.

       NOTE  
The quantities in 
your warehouse, 
tier, and 
transaction 
inventory data 
files must match 
before you can 
upgrade your 
data to version 
2017. 
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d Run all Inventory Pre Migration tasks again to ensure corrections were 
made. Keep all reports as an audit trail.

2____ Select Library Master Utilities menu > Parallel Migration. Follow the steps in 
the wizard to upgrade your data.

3____ If you are printing bar codes, ensure that the Azalea fonts are installed on 
the workstation. The fonts can be installed from the WkSetup\Azalea folder 
where Sage 100 is installed on your server.

4____ After the migration is complete, log into Sage 100 2017 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

5____ Review security tasks for new features in version 2017. Review ODBC 
security if it is used.

6____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

7____ If you customized your Desktop, review the customizations on the Custom 
toolbar. 

Data Conversion Checklist

After completing the Pre-Upgrade Checklist on page 58 and the Upgrade Checklist 
on page 59, you are now ready to convert your data to version 2017.

1____ If your company data contains credit card information, verify that the 
workstation you are using has a working Internet connection to 
automatically install the Sage Exchange Desktop and transfer credit card 
records to a Sage Exchange Vault account during conversion. Credit card 
records must be transferred to a Sage Exchange Vault account before 
company data can be converted.

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2017. This must be done for each of your companies.

If your data contains credit card records that will be transferred to a Sage 
Exchange Vault account, the Credit Card Conversion To Sage Exchange 
Vault Time Estimate window appears. This window provides an estimate of 
how long it will take to transfer the credit card data. This estimate is based 
on benchmark test results, but results will vary based on Internet 
connection speed, network traffic, and the number of customer credit card 
records stored in your system. 

You may be able to decrease the estimate by updating credit card 
transactions and purging credit card data. If this window appears, click Yes 
to proceed with data conversion or click No to stop the conversion process. 
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Additional time is required to convert company data after the credit card 
records are transferred; that time is not included in the estimate shown on 
the window. 

3____ Update customized panels, by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields. 

Re-customize the customized libraries for all modules other than Accounts 
Payable, Accounts Receivable, Bank Reconciliation, eBusiness Manager, 
General Ledger, Job Cost, Material Requirements Planning, Payroll, Return 
Merchandise Authorization, Sales Order, TimeCard, and Work Order. 

4____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.

5____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.

6____ If you had the Extended Solution for customers with national accounts and 
the Populate Bill Address Block with ’Bill To’ Customer Block check box was 
selected in AR-1068 Setup Options, you must run the Sales Order Bill To 
Address Fix Utility (select File menu > Run, then type *Utl) to populate the 
sales order bill-to address information with the bill-to customer’s address 
information. 

7____ Review your Payroll Tax Tables. Installing the Payroll Tax Table Update 
replaces all of your current state and federal tax tables with new tables 
unless you have specifically excluded a state tax table from the update by 
selecting the Exclude this Table from Tax Update check box in Tax Table 
Maintenance. Local tax information is not updated. 

8____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2017. 

To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

       NOTE  
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

9____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

10____ If dictionary changes were made to any files used for import or export jobs 
created in the Visual Integrator module, those jobs will need to be manually 
updated for modules other than Job Cost, Payroll, Material Requirements 
Planning, TimeCard, and Work Order.

To determine if manual updates are required, review the associated file 
layout information using the File Layouts and Program Information link on 
the Resources page of the Desktop. If you are upgrading from 
Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary 
Listing accessed from the Visual Integrator Main menu. Verify that the 
imported field names are consistent with the new file layouts.

11____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

12____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

13____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

14____ If you do not use taxation for purchase orders, clear the Sales Tax Reporting 
check box in Accounts Payable Options.

15____ If you include sales tax on purchase orders and want to enter default tax 
schedules for vendors, use Accounts Payable Assign Vendor Tax 
Schedules to set up tax schedules.

16____ Confirm in Accounts Receivable Customer Maintenance that all customers 
that have exemption numbers still have the exemption number defined.

17____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.
2017 Upgrade Checklist                                                                                                                                                62



_____________________________________________________________________________________________

Upgrading from Version 4.10 to Version 2017
18____ If you had the Extended Solution for direct deposits, verify the bank ID (bank 
account) number for each bank code. During conversion, if there is a 
discrepancy between the bank ID number in Bank Code Maintenance and 
the bank account number in Direct Deposit Information for a bank code, the 
account number in Direct Deposit Information replaces the number in Bank 
Code Maintenance. If an account number is not entered in Direct Deposit 
Information, the number in Bank Code Maintenance is entered in Direct 
Deposit Information. Account number changes are noted in the conversion 
log.

19____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

20____ Compare the following version 4.10 and 2017 reports because sales tax 
may be recalculated during the conversion: Accounts Receivable Sales Tax 
Report, Accounts Receivable Repetitive Invoice Listing, Accounts Payable 
Repetitive Invoice Listing, Open Sales Order Report, and Open Purchase 
Order Report.

21____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

22____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

23____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

24____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

25____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

26____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records. To run the utility, select Library Master > Utilities > Build Search 
Index. 

27____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.
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If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

For information on what is new in this release, see the What’s New chapter in the 
Sage 100 2017 Customer Upgrade Guide.
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Upgrading from Version 4.00 or 4.05 to Version 2017

Prior to upgrading your version 4.00 or 4.05 data to version 2017, you must perform 
a parallel installation. Use the Pre-Migration and Parallel Migration utilities from the 
Library Master Utilities menu to upgrade your data. For more information, consult 
with your Sage business partner. 

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

Pre-Upgrade Checklist

You must prepare your version 4.00 or 4.05 data for upgrading. This should be done 
for each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ Create a copy of your version 4.x MAS90 folder, which includes data for all 
of your companies. Perform this step following your usual backup process. 
For specific support on how to back up your data, refer to manuals for your 
backup software or contact the vendor from whom you purchased that 
product.

4____ If you plan to use Federal and State eFiling and Reporting for the 1099 
forms, W-2 forms, 941 forms, and governmental reports, perform the 
conversion to version 2015 after the quarter end and before the first payroll 
in the current quarter to avoid values being placed in the wrong boxes on 
some forms. If conversion is performed mid-quarter, some data may require 
editing.

5____ Rebuild all data files using the Rebuild Key Files and Rebuild Sort File 
utilities. You must answer Yes to all recalculation questions.

6____ Print all customized form definitions.

7____ Correct and apply all negative tiers before upgrading. For more information, 
see Correct Negative Tiers in the Help system.

8____ Print the following Sales Order History reports: Customer Sales History 
Report, Monthly Recap by Product Line Report, Monthly Recap by 
Warehouse/Product Line Report, Monthly Recap by Warehouse Report, 
Monthly Recap by Division Report. These reports are no longer available 
beginning with version 4.10.

9____ If you created reports using Business Insights Reporter, review the report 
names in the Business Insights Reporter selection window. If there are 
multiple reports with similar names, copy the reports within Business 
Insights Reporter and rename each report.

       NOTE  
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 
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For example, if you have reports named CustomerSalesReport, 
CustomerSalesReport2, and CustomerSalesReport3, copy 
CustomerSalesReport2 as "SalesReportForCustomers" and 
CustomerSalesReport3 as "ReportForCustomerSales."

For more information, see Copy a Report in the Help system.

10____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 65, you are now ready to 
migrate your data to your version 2017 system.

1____ From your version 2017 installation, select Library Master Utilities menu > 
Pre Migration, and then enter the source path and company code for your 
version 4.00 or 4.05 system. Run the reports and utilities that appear.

a Select Item Code Validation Report to display missing item codes from 
your Warehouse Detail, Item Costing, and Transaction Detail files.

 To fix the files, in your version 4.00 or 4.05 data, use Inventory 
Management Main menu > Inventory Maintenance.

b Select Inventory File Comparison Report to compare the quantity in 
your warehouse, tier, and transaction inventory data files.

 Run this report by warehouse and save as an audit trail.

 To correct any quantities, run the Inventory Balancing Utility.

c Select Inventory Balancing Utility to balance your inventory quantities. 

 Run this utility for each warehouse.

 At the Action column, select the action to perform for each item, or 
apply a specific action based on valuation type.

 If the valuation is LIFO, FIFO, Lot, or Serial, at the Action column 
select Skip if the tier quantities are incorrect. You must perform a 
physical count to correct the tier quantity. After the tier quantity is 
correct, run this utility for these valuation methods.

 If the valuation is Average Cost or Standard Cost and the 
warehouse and transaction quantities are incorrect, you must 
perform a physical count to correct the warehouse quantity. After the 
warehouse quantity is correct, run this utility for those valuation 
methods. 

 For more information, see Balance Inventory Quantities in the Help 
system.

       NOTE  
The tasks that 
appear in the Pre 
Migration window 
are based on the 
version of your 
data.

       NOTE  
The quantities in 
your warehouse, 
tier, and 
transaction 
inventory data 
files must match 
before you can 
upgrade your 
data to version 
2017. 
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d Run all Inventory Pre Migration tasks again to ensure corrections were 
made. Keep all reports as an audit trail.

2____ Select Library Master Utilities menu > Parallel Migration. Follow the steps in 
the wizard to upgrade your data.

3____ If you are printing bar codes, ensure that the Azalea fonts are installed on 
the workstation. The fonts can be installed from the WkSetup\Azalea folder 
where Sage 100 is installed on your server.

4____ After the migration is complete, log into Sage 100 2017 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

5____ Review security tasks for new features in version 2017. Review ODBC 
security if it is used.

6____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

7____ If you customized your Desktop, review the customizations on the Custom 
toolbar. 

Data Conversion Checklist

After completing the Pre-Upgrade Checklist on page 65 and the Upgrade Checklist 
on page 66, you are now ready to convert your data to version 2017.

1____ If your company data contains credit card information, verify that the 
workstation you are using has a working Internet connection to 
automatically install the Sage Exchange Desktop and transfer credit card 
records to a Sage Exchange Vault account during conversion. Credit card 
records must be transferred to a Sage Exchange Vault account before 
company data can be converted.

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2017. This must be done for each of your companies.

If your data contains credit card records that will be transferred to a Sage 
Exchange Vault account, the Credit Card Conversion To Sage Exchange 
Vault Time Estimate window appears. This window provides an estimate of 
how long it will take to transfer the credit card data. This estimate is based 
on benchmark test results, but results will vary based on Internet 
connection speed, network traffic, and the number of customer credit card 
records stored in your system. 

You may be able to decrease the estimate by updating credit card 
transactions and purging credit card data. If this window appears, click Yes 
to proceed with data conversion or click No to stop the conversion process. 
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Additional time is required to convert company data after the credit card 
records are transferred; that time is not included in the estimate shown on 
the window. 

3____ Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields.  

Re-customize the customized libraries for all modules other than Accounts 
Payable, Accounts Receivable, Bank Reconciliation, eBusiness Manager, 
General Ledger, Job Cost, Material Requirements Planning, Payroll, Return 
Merchandise Authorization, Sales Order, TimeCard, and Work Order. 

4____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.

5____ If you had the Extended Solution for customers with national accounts and 
the Populate Bill Address Block with ’Bill To’ Customer Block check box was 
selected in AR-1068 Setup Options, you must run the Sales Order Bill To 
Address Fix Utility (select File menu > Run, then type *Utl) to populate the 
sales order bill-to address information with the bill-to customer’s address 
information. 

6____ Review your Payroll Tax Tables. Installing the Payroll Tax Table Update 
replaces all of your current state and federal tax tables with new tables 
unless you have specifically excluded a state tax table from the update by 
selecting the Exclude this Table from Tax Update check box in Tax Table 
Maintenance. Local tax information is not updated. 

7____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2017. 

To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

       NOTE  
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

8____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

9____ If dictionary changes were made to any files used for import or export jobs 
created in the Visual Integrator module, those jobs will need to be manually 
updated for modules other than Job Cost, Payroll, Material Requirements 
Planning, TimeCard, and Work Order.

To determine if manual updates are required, review the associated file 
layout information using the File Layouts and Program Information link on 
the Resources page of the Desktop. If you are upgrading from 
Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary 
Listing accessed from the Visual Integrator Main menu. Verify that the 
imported field names are consistent with the new file layouts.

10____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

11____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

12____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

13____ If you do not use taxation for purchase orders, clear the Sales Tax Reporting 
check box in Accounts Payable Options.

14____ If you include sales tax on purchase orders and want to enter default tax 
schedules for vendors, use Accounts Payable Assign Vendor Tax 
Schedules to set up tax schedules.

15____ Confirm in Accounts Receivable Customer Maintenance that all customers 
that have exemption numbers still have the exemption number defined.

16____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window. 

17____ If you had the Extended Solution for direct deposits, verify the bank ID (bank 
account) number for each bank code. During conversion, if there is a 
discrepancy between the bank ID number in Bank Code Maintenance and 
the bank account number in Direct Deposit Information for a bank code, the 
account number in Direct Deposit Information replaces the number in Bank 
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Code Maintenance. If an account number is not entered in Direct Deposit 
Information, the number in Bank Code Maintenance is entered in Direct 
Deposit Information. Account number changes are noted in the conversion 
log.

18____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

19____ Compare the following version 4.x and 2017 reports because sales tax may 
be recalculated during the conversion: Accounts Receivable Sales Tax 
Report, Accounts Receivable Repetitive Invoice Listing, Accounts Payable 
Repetitive Invoice Listing, Open Sales Order Report, and Open Purchase 
Order Report.If you purchased the Return Merchandise Authorization 
module, after setting up the data files for the first time, select Return 
Merchandise Authorization Setup menu > Create Customer Invoice Search 
Records to create customer invoice search records in RMA.

20____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

21____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

22____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

23____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

24____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records. To run the utility, select Library Master > Utilities > Build Search 
Index.

25____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.
2017 Upgrade Checklist                                                                                                                                                70



_____________________________________________________________________________________________

Upgrading from Version 4.00 or 4.05 to Version 2017
c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

For information on what is new in this release, see the What’s New chapter in the 
Sage 100 2017 Customer Upgrade Guide.
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Appendix A
If you use Sage Intelligence Reporting, follow the steps in this chapter to create a 
new repository for Sage 100 2017. If you have custom reports, follow the instructions 
to export custom reports from your prior version of the program and import them into 
the new repository. 

For detailed instructions on each step, see:

 Export Custom Reports on this page

 Create a New Repository on page 72

 Set Up Sage Intelligence Reporting in Sage 100 2017 on page 73

 Import Custom Reports on page 74

Report Compatibility

Reports can be imported only from an earlier version of the program or another 
instance of the same version. For example, you can import a report created in 
version 2013 into version 2017. You cannot import a report created in version 2017 
into version 2013.  

Reports created in Sage 100 Standard and Sage 100 Advanced are not compatible 
with Sage 100 Premium. Likewise, reports created in Sage 100 Premium are not 
compatible with  Sage 100 Standard and Sage 100 Advanced.

Export Custom Reports

In your prior version of Sage 100, export all of the custom reports that you want to 
use in version 2017.

To export custom reports

1 In your prior version of Sage 100, select Sage Intelligence Reporting Main menu 
> Report Manager. 

2 Right-click a report and then click Export Report. (Alternately, select a report and 
then, on the Tools menu, click Export Report.)

3 Select the location where you want to save the file and then click Save. A file 
with an AL_ extension is created.  

4 Repeat these steps for all custom reports that you want to use in version 2017.

Create a New Repository

Create a shared folder to use as the Sage Intelligence Reporting repository for 
Sage 100 2017. We recommend using a separate repository for each installation of 
Sage Intelligence Reporting. 

       NOTE  
These steps may 
vary depending 
on what version 
of Windows you 
are using. Check 
with your network 
administrator if 
you need 
assistance. 
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To create a repository 

1 Use Windows File Explorer to create a folder in the desired location.

2 Right-click the folder, point to "Share with," and click "Advanced sharing."

3 On the Sharing tab, select the "Share this folder" check box.

4 Enter a share name.

5 Click Permissions.  

6 For all applicable users, select the Full Control or Read and Write check boxes. 

7 Click OK. 

8 If you use reporting trees or distribution settings, copy the following folders from 
the old repository to the new one:

 Report Trees

 Distribution

Set Up Sage Intelligence Reporting in Sage 100 2017

After creating the shared folder, enter its location in Sage 100 2017. If you haven’t 
already registered your 2017 version of Sage Intelligence Reporting, you will be 
asked to do so. 

To set up Sage Intelligence Reporting

1 In Sage 100 2017, select Sage Intelligence Reporting Main menu > Report 
Manager.

2 Click File and then click Change. 

3 Click Yes in the message window.

4 In the Network Repository Path field, type the UNC path to the shared folder that 
you created. For example: \\ServerName\ReportRpository

5 Click OK.

6 If you receive a message asking you to register Sage Intelligence Reporting, 
click OK to open the License Manager window.

7 In the Account Number field, enter your Sage customer number.

8 In the Serial Number field, enter you unlocking key. This field is case-sensitive. 

9 Click Apply and then click Perform Registration. 
2017 Upgrade Checklist                                                                                                                                                73



_____________________________________________________________________________________________

Upgrading Sage Intelligence Reporting
Import Custom Reports

After creating the new repository and registering Sage Intelligence Reporting, import 
any custom report files.

To import custom reports

1 If you want to create folders to organize your reports, on the Home tab, click Add 
Folder. 

2 Right-click either the Home folder or any custom folder created in step 1, and 
click Import Report. (Alternately, you can click the Tools tab, and then click 
Import Report.) 

3 Select one of the custom reports that you exported from your prior version.

4 In the Import Report window, in the Target Connection field, select a connection. 

 For consolidated reports, select Sage MAS Consolidation. 

 For any other type of report, select Sage MAS (Auto Connect).  

5 In the Report Destination field, select the folder for the report. 

6 Click Import.

7 On the Home tab in the Actions group, click Refresh.

8 Repeat these steps for any other custom reports that you exported from your 
prior version of Sage Intelligence Reporting. 

       NOTE  
You must own the 
Sage 100 
Intelligence 
Connector 
module to 
generate 
consolidated 
reports. 
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